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PREFACE
About this Guide

This topic contains important information about the purpose, content, context, and intended
audience for this document.

Product Documentation

This document is part of the Niagara technical documentation library. Released versions of
Niagara software include a complete collection of technical information that is provided in
both online help and PDF format. The information in this document is written primarily for
Systems Integrators. In order to make the most of the information in this book, readers should
have some training or previous experience with Niagara 4 or NiagaraAX software.

Document Content

This document provides information about NiagaraAX Workbench and covers AX-3.8 and
AX-3.7 . Included are basic descriptions of the Workbench as well as reference information to
help Systems Integrators and Engineers.

Document change log

Updates (changes/additions) to this NiagaraAX User Guide document are listed below.
+ NiagaraAX-3.8 “Update 1” revision, May 26, 2016

A couple of document updates concurrent with the “update 1” release for AX-3.8 (in this
document denoted as “AX-3.8U1"). New features include Java Web Start, an alternative to
running the Wb Web applet in a browser (see the NiagaraAX Web Start Guide), and the
JACE-8000-AX license feature which allows the N4 controller to be converted to run AX-
3.8U1 (see the JACE-8000 Install and Startup Guide). Changes to this document are as
follows:

+ Added the Web Start Config property to the web-WebService component.
o Added an updated screen capture to the section, “Tour of the interface”.
+ NiagaraAX-3.8 release, November 4, 2013

Document updated to cover both the initial AX-3.8 release as well as AX-3.7 and AX-
3.7U1. A significant change was the removal of the prior main section “About Presentation
XML (Px)”, which explained graphics usage and related topics. This content was relocated
to a new standalone NiagaraAX Graphics Guide document, including updates to cover AX-
3.8 features and changes. Related to this, these following other sections were removed from
this document:

+ AX-3.7U1 “Update 1” revision, May 30, 2013

Various document updates concurrent with the “update 1” release for AX-3.7. Station se-
curity-related improvements are a main update focus.

A new section “About file naming” was added in the “About Niagara Framework” concepts
chapter. It explains the “approved set” of characters for naming files in a station’s file space.

In the main “About Security” section, the following subsections had changes:
o AX-3.7 release revision, August 29, 2012

Document was “version split” from the prior version describing AX-3.5 and AX-3.6, where
most mention of NiagaraAX release behavior prior to AX-3.6 was removed.
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Related documentation

The NiagaraAX User Guide has many related documents that are listed below.

Related documents
Document Title
NiagaraAX Platform Guide
NiagaraAX Provisioning Guide
NiagaraAX Lexicon Guide
NiagaraAX Data Recovery Service
JACE NiagaraAX Install & Startup Guide
AX to N4 Migration Guide
JACE-8000 Install and Startup Guide
NiagaraAX Web Start Guide
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CHAPTER 1 ABOUT THE FRAMEWORK

Well designed

Torics COVERED IN THIS CHAPTER

Well designed

The Niagara Framework solution
About Baja

About Niagara building blocks
About modules

About components

About presentation

About stations

About ORDs

About views

About lexicons

Software frameworks provide a platform to allow businesses to more easily build their end-
product offerings. The patented Niagara Framework® is targeted at solving the challenges asso-
ciated with managing diverse smart devices, unifying their data, and connecting them to enter-
prise applications. Examples of smart devices include: monitoring and control systems, sensors,
metering systems, and embedded controls on packaged equipment systems.

framework, n. something composed of parts fitted together and united; a structural frame; a ba-
sic structure (as of ideas); in object-oriented programming, a reusable basic design structure,
consisting of abstract and concrete classes, that assists in building applications.

Niagara Framework, n. a universal software infrastructure that allows companies to build cus-
tom, web-enabled applications for accessing, automating, and controlling smart devices in real
time over the Internet.

NiagaraAX is the third generation of the Niagara Framework. This Java-based software frame-
work provides an infrastructure to enable systems integrators and developers to build device-
to-enterprise solutions, and Internet—enabled control and monitoring products. The Frame-
work integrates diverse systems and devices (regardless of manufacturer or communication
protocol) into a unified platform that can be easily managed in real time over the Internet (or
intranet) using a standard web browser. The Framework also includes a comprehensive toolset
that enables non-programmers to build rich applications in a drag-and-drop environment.

NiagaraAX is fully scalable, meaning that it can be run on platforms spanning the range from
small, embedded devices to enterprise class servers. Niagara is being successfully applied in en-
ergy—services, building—automation, industrial-automation and M2M applications today.

The Niagara Framework addresses the challenges of automation, control and device to enter-
prise connectivity of real time systems. NiagaraAX, and its derivative products, offer compel-
ling value to both end users and partners. For OEM and reseller partners, the framework solves
several key challenges present in all control-related industries:

+ High development costs associated with the foundation or infrastructure layer of software
that communicates with devices and manipulates the data from them.

+ The need to transform information from real-time control processes into a homogeneous
structure enabling advanced product and service applications.

+ Integration of legacy systems to enable companies to easily migrate their existing customers
to new technologies and product offerings.

Partners who adopt the framework as their infrastructure eliminate substantial engineering ef-
fort and are able to focus on their core competencies of application development and
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marketing. These companies gain competitive advantage in their markets from lower develop-
ment costs and quicker time-to-market for their specific products, applications and value-add
services.

End users of Niagara benefit from:

.

Being able to preserve existing investments in control and monitoring devices as they move
to new, standards-based technologies.

Being able to access and control all of their diverse systems through a standard web
browser.

Combining information from different systems to support better overall management of
their enterprise assets.

Being able to specify interoperable systems and applications from multiple vendors, thereby
reducing the potential for vendor lock-in.

Niagara is designed to address the following specific technical challenges:

.

3

Platform independence - NiagaraAX works with a wide variety of operating systems and
hardware platforms.

Unification of diverse systems - NiagaraAX integrates heterogeneous systems, protocols,
and fieldbuses into normalized components.

Distributed architecture - NiagaraAX supports a highly distributed architecture. It success-
fully combines Internet/IT technology with the services necessary to implement real-time,
peer-to-peer automation applications.

Programming for non-programmers - NiagaraAX provides an environment and compre-
hensive toolset to enable domain experts to create sophisticated applications without writ-
ing code.

Extensibility - NiagaraAX provides an extensible component model and rich library of open
APIs to enable programmers to extend and enhance the framework and build their own
unique applications and products

Support for embedded systems - NiagaraAX can be embedded in small low cost devices

The Niagara Framework solution

The following topics describe how the framework addresses these challenges:

.

3

.

.

About control systems integration

About Java

About common networking and Internet protocols
About programming for non-programmers

About embedded systems capabilities

About distributed systems capabilities

About component software design

About control systems integration

In the context of the Niagara Framework, control systems integration means:

1.

connecting devices on a common communications media

2. modeling those devices in software

3. programming applications to use the information in those devices
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Before a device, such as a chiller, VAV box, or temperature sensor, can be used, information
from those devices must be pulled into the Niagara software.

Niagara then models those devices and their data types in software through the common object
model. This usually entails simplifying the device’s data types to make them easier to manipu-
late and control through the software.

The Niagara common object model is then used to build applications, with the goal being to
provide non-programmers a means to program the system easily without developing raw code.
The Niagara common object model is similar to a programming language in that there are a
few key concepts that are used, but the real power is in the reusable libraries of applications
and collections of objects that are available. Once you understand the key concepts and you
can put them to work, you can use Niagara objects to build control system solutions quickly
and efficiently.

The common object model, shown, allows the framework to:
+ provide two-way communication between devices and the Internet
+ send real-time device information across the Internet

« control devices in real-time across the Internet.

Figure 1. Niagara common object model
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About Java

All of the Niagarasoftware is written in Java, which means that it is platform independent. Prior
to Java, most software was written and compiled for a particular machine or operating system.
If that software needs to run on some other processor, the program has to be compiled again.
Java, on the other hand, compiles once. NiagaraAX software runs on embedded JACE control-
lers using the QNX operating system and the IBM J9 Java Virtual Machine (JVM), and runs on
Microsoft Windows desktop operating system platforms, as well as Linux and Solaris using the
HotSpot JVM.

About Virtual Machines

It is possible to compile code once and run it on any platform due to a layer of software that ex-
ists between the machine and the software called the Java virtual machine (JVM). The Niagara
Framework uses the Java VM as a common runtime environment across various operating sys-
tems and hardware platforms. The core framework scales from small embedded controllers to
high end servers. The framework runtime is targeted for J2ME compliant VMs. The user inter-
face toolkit and graphical programming tools are targeted for J2SE 1.4 VMs.
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There are a number of different virtual machines for different platforms on which the NRE is
running, but the NRE itself, and all of its modules, are the same regardless of platform. The
VM is responsible for defining how the software works with a given set of hardware-how it
talks to a LonWorks adapter, how it talks to the communications port, how it interacts with
the operating system, among other tasks.

About common networking and Internet protocols

Niagara is designed from the ground up to assume that there will never be any one “standard”
network protocol, distributed architecture, or fieldbus. Niagara’s design goal is to integrate
cleanly with all networks and protocols. The Niagara Framework standardizes what's inside the
box, not what the box talks to.

The Niagara software suite implements a highly efficient adaptation of the JavaBean compo-
nent software model and Internet technologies to provide true interoperability across a wide
range of automation products. The Niagara object model can be used to integrate a wide range
of physical devices, controllers, and primitive control applications including LonMark profiles,
BAChnet objects, and legacy control points. The architecture supports future enhancements by
allowing legacy systems to be brought forward, where they can readily adopt new standards,
solutions, and applications.

Enterprise-level software standards include Transmission Control Protocol/Internet Protocol
(TCP/IP), eXtensible Markup Language (XML), Hyper Text Transfer Protocol (HTTP), and
others. These standards provide the foundation on which to build solutions that allow informa-
tion to be shared between the control system and the enterprise information system.

About programming for non-programmers

Most features in the Niagara Framework are designed for dual use (for programmers as well as
non-programmers). These features are designed around a set of Java APIs to be accessed by de-
velopers writing Java code. At the same time, most features are also designed to be used
through high level graphical programming and configuration tools. This vastly increases the
number of users capable of building applications on the Niagara Framework platform.

About embedded systems capabilities

NiagaraAX is one of the only software stacks designed to run across the entire range of pro-
cessors from small embedded devices to server class machines. Niagara is targeted for em-
bedded systems capable of running a Java VM. This excludes some very low-end devices that
lack 32-bit processors or have only several megabytes of RAM, but opens up a wide range of
processor platforms.

The Niagara Processor Module (NPM) makes it possible to quickly develop NiagaraAX-based
products.

About distributed systems capabilities

The framework is designed to provide scalability to highly distributed systems composed of
tens of thousands of nodes running the Niagara Framework software. Systems of this size span
a wide range of network topologies and usually communicate over unreliable Internet connec-
tions. Niagara is designed to provide an infrastructure for managing systems of this scale.

About component software design

The Niagara uses an architecture centered around the concept of “Component Oriented Devel-
opment.” A component is a piece of self-describing software that can be assembled like build-
ing blocks to create new applications. A component—centric architecture solves many
problems in Niagara.

» Data normalization
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Components provide a model used to normalize the data and features of different types of
protocols and networks so that they can be integrated seamlessly.

+ Graphic development tools

Applications can be assembled with components using graphical tools in the Niagara
Workbench. This allows new applications to be built without requiring a Java developer.

+ Application visibility

Components provide unsurpassed visibility into applications. Since components are self-de-
scribing, it is very easy for tools to look at how an application is assembled, configured, and
to determine what is occurring at any point in time. This provides great value in debugging
and maintaining Niagara applications.

« Software reuse

Components enable software reuse. The AX supports custom development and extension
of the framework. The Niagara components are extensible and go beyond data and proto-
cols to unify the entire development environment.

About the software architecture

There are four layers to the Niagara software architecture. The bottom layer is the host plat-
form, either a JACE controller or a PC. The next layer is the Java virtual machine (JVM). The
JVM provides a layer between the hardware and its operating system and the Niagara software,
known as the Niagara run-time environment (NRE). On top of the NRE are the Niagara
modules.

NiagaraAX software subsystems are illustrated and the software processes and protocols are
shown.

Figure 2. Major software subsystems
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About Baja

NiagaraAX software processes and protocols

Supervisor

Workbench

b Web Browser

Fieldbus
xYZ

The core framework built is designed to be published as an open standard. This standard is
being developed through Sun's Java Community Process as JSR 60. This JSR is still an ongoing
effort, but it is important to understand the distinction between Baja and Niagara.

Fundamentally Baja is an open specification and the framework is an implementation of that
specification. As a specification, Baja is not a set of software, but rather purely a set of
documentation.

The Baja specification will include:

3

.

3

.

.

Standards for how Baja software modules are packaged
XML schema for the component model;

The component model and its APIs

Historical database components and APIs

Alarming components and APIs

Control logic components and APIs

Scheduling components and APIs

BACnet driver components and APIs

lonWorks driver components and APIs

Over time many more specifications for features will be added to Baja. But what is important
to remember is that Baja is only a specification. Niagara is an implementation of that specifica-
tion. Furthermore you will find a vast number of features in Niagara, that are not included
under the Baja umbrella. In this respect Niagara provides a superset of the Baja features.

NiagaraAX User Guide



About the Framework

May 26, 2016

About APIs

The API (Application Programming Interface) defines how software engineers access the capa-
bilities of software like the Niagara Framework. Workbench is the Niagara API — and using
the Workbench, you can create and edit the control logic for your job site.

Many features found in Niagara are exposed through a set of Java APIs. In the Java world, APIs
are grouped together into packages, which are scoped using DNS domain names. Software de-
veloped through the Java Community Process is usually scoped by packages starting with “java”
or “javax.” It is important to understand the two types of APIs related to the framework:

+ javax.baja

o com.tridium

javax.baja

The APIs developed for Baja (see “About Baja” for more about Baja) are all grouped under jav-
ax.baja.

These are APIs that will be part of the open Baja specification and may be implemented by ven-
dors other than the originating developer. Using these APIs guarantees a measure of vendor
neutrality and backward compatibility.

com.tridium

Software developed by Tridium which is proprietary and outside of the Baja specification is
grouped under the com.tridium packages. The com.tridium packages contain code specific to
how Niagara implements the Baja APIs. The com.tridium code may or may not be docu-
mented. If com.tridium APIs are publicly documented then Tridium encourages developers to
use them, but does not guarantee backward compatibility. Undocumented com.tridium APIs
should never be used by developers.

NOTE: Tridium has developed some APIs under javax.baja even though they are not currently
part of the Baja specification. These are APIs that Tridium feels may eventually be published
through Baja, but are currently in a development stage.

About Niagara building blocks

This section describes some of the fundamental building blocks of the framework. It is impor-
tant to understand these concepts and associated terminology in order to fully benefit from the
use of the NiagaraAX Workbench. Concepts discussed in this section include the following:

o Modules

Modules are the most basic unit of the software that comprises NiagaraAXNiagaraAX. For
more details about modules, see “About modules”.

+ Components

Components are the primary building blocks of the framework. For more details about
components, see “About components”.

« DPx

For more details about Px, see “About presentation xml (Px)”.
« stations

For more details about stations., see “About stations”.
+ ORDs

For more details about ORDs, see “About ORDs”.
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About modules

¢ Views

For more details about views, see “About views”.

Modules are the smallest units of software in the architecture.

Major releases of the Niagara software are distributed along with a set of release modules, but
as new modules are made available for that release, they may be distributed as independent re-
visions within that release.

NOTE: Beginning in AX-3.7, two types of modules are possible in the Niagara Framework:
“standard” Java archive (.jar) modules which make up the Niagara software, and “synthetic Java
archive” (.sjar) modules which allow for the creation of memory-resident modules and types
programmatically at run-time. Although they share many characteristics, the two types of mod-
ules are distinctly different. This section describes standard modules simply called “modules.”
For details on synthetic modules, refer to the “NiagaraAX Synthetic Modules” engineering
notes document.

Following, is a partial list of modules, as displayed in the nav side bar pane.

Figure 3. Module listing in the nav side bar tree

- &8 My Modules
+ (4 MySyntheticModule
+ (0) aaphp
+ (3) aapup
+ (0) adr
+ (0) ak2ss
+ () alarm
+ () alarmOrion
+ f_'] alarmRdb
+ C] andoverAC256
+ (7] andoverInfinity

NOTE: Don’t confuse modules with components. Components are used to build Niagara im-
plementations, while modules make up the Niagara software itself. Refer to “About compo-
nents” for more information about components.

The following topics are covered in this section:
+ About module characteristics

+ About benefits of modular software development

About module characteristics

All (;jar) modules:

» are composed of a single Java ARchive (JAR) file compliant with PKZIP compression
+ contain an XML manifest

+ are independently versioned and deployable

« state their dependencies on other modules and their versions
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About jar files

JAR files are the mechanism for distributing Java modules. JAR stands for “Java archive.” A JAR
file (.jar) is basically a compressed package whose components can be viewed with WinZip or
other archive viewing tool. Do not attempt to unzip a JAR file—it will not work. JAR files are
the add-ins that are plugged into the software to give additional functionality. Inside the JAR
file are the compressed software; its documentation; in some cases, examples or pre-canned ap-
plications; and libraries.

Some modules, such as the lonWorks module, are distributed as multiple JAR files because
there are so many different lonWorks devices. The core protocol is packaged in a JAR file called
lonWorks.jar. There are individual JAR files for each LON device manufacturer (for example,
lon_mfgName.jar). Every JAR file or module is versioned independently.

About module versions

Niagara’s versioning system allows you to check to make sure that you have the latest available
module for your system. Versions are specified as a series of whole numbers separated by a pe-
riod, for example “1.0.42”. To understand which version of a module is more recent, simply ob-
serve the module version number. For example, 3.7.42 is later than 3.7.35 because 3.7.42 >
3.7.35.

Following, shows modules listed, by name, with the version number and installation status, as
viewed in the software manager.

Figure 4. Module descriptions viewed in the software manager

File - | lled i |AvaiL i | B
aaphp - Tridium 3.7.38 Mot Installed -
aapup - Tridium 3.7.38 Mot Installed

adr Tridium 3.6.46 Tridium 3.6.46 Up to Date

ak255 = Tridium 3.7.33 Mot Installed

alarm Tridium 3.7.38 Tridium 3.7.38 Up to Date

alarmOrion = Tridium 3.7.33 Mot Installed ~|

Niagara versioning uses the following set of conventions:
+ Versions are specified using a base four-part version with optional patch versions.

+ The first number specifies the specification revision. This number starts at one and is incre-
mented each time the specification of the module is incremented. It is used with Baja mod-
ules to track the Baja specification version.

+ The next two numbers specify a major Niagara release.

+ The fourth number specifies a build number. A build number starts at zero for each major
release and increments each time all the software’s modules are built.

+ Additional numbers may be specified for code changes made off a branch of a specific build.
These are usually minor changes and bug fixes.

Every module has two versions. The first is the “bajaVersion” which maps the module to a Baja
specification version. If the module is not published under the Baja process then this value is
“0”. Secondly every module declares a “vendor” name and “vendorVersion”. The vendor name
is a case insensitive identifier for the company who developed the module and the vendorVer-
sion identifies the vendor's specific version of that module.

The vendorVersions are formatted as “major.minor.build[.patch]”:
+ Major and minor declare a feature release such as 3.8.

o The third number specifies a build number. A build number starts at zero for each feature
release and increments each time all the software modules are built.

+ Addition numbers may be specified for code changes made off a branch of a specific build.
These are usually patch builds for minor changes and bug fixes.
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So the vendorVersion “3.7.22” represents a module of build 22 in Niagara release 3.7. The ven-
dorVersion “3.7.45.2” is the second patch of build 45 in release 3.7.

About module directory structure

Every (,jar) module is managed in its own directory structure. The image below shows an ex-
ample of a directory for the alarm module.

Figure 5. Module directory structure

[alarm]
+- build.xml
+- module-include.xml
+- module.palette
+- [=rc]
| +- [Jawvax]
| | +- [baja]
| | +- [alarm]
| | +- TJawvaClassl.java
| | +- JawvaClassZ.java
| +- [com]
| | +- [tridium]
| | +- [alarm]
| | + JavaClass3.java
| | +- [ui]
| | + BilarmConsole. java
| +- [doc]
| +- AlarmConsole-guide.html
+- [libJar]

All of the source code that is used to build the module’s jar file is located under the “src” direc-
tory. During the build process the “libJar” directory is used to build up the image, which will be
zipped up for the module's jar file.

About benefits of modular software development

Modular software development provides several benefits, including the following:
+ Improves tracking deployment and versioning

Modular development assists in tracking the deployment and versioning of features and re-
leases. For example, if a new driver is available to be added to NiagaraAX, it can be pack-
aged, delivered, and added in as a single module or with multiple modules, using the
Software Manager. Refer to the NiagaraAX Platform Guide section “Software Manager” for
more information about managing modules.

Figure 6. Software Manager view

§ Current free space 9,550 KB To b free space after install

Type |Installed Versiod Avail. Version] File [
pidior Module - Tridun 3.0.85 () prEdtor Nt [nstalled
Madue - Tridum 3.0.86 () rdb Mot Irstalied
Modde - Tridum 3.0.85 () rdbOrade  Not Instaled
Module - Tridun 3.0.85  (0) rdbSal5erve Mot Installed
Modue Tridum 3.0.85  Tridum3.086 (0 sarm  UptoDate

Modue Tridum 3086  Tridum3.0.86 () bacup  UptoDate | |
itodde[Tridun 3.0.85 | Tridun 3.0.65_| M bacnet R Tnstal Tridum 3.0.66. =

Module Tridum 3.0.85__ Tridum 3.0.85 () baja Up to Date 5
|Uparade all out of Date| [import-] [Cancel Re-Install] (Uninstall| [Reset] [Commit]

DB

+ Requires less space on controller

This modular development allows you to save space on your JACE by only installing the
modules that you need and choose for that controller.

+ Requires less space on the workstation

When you install NiagaraAX, you can choose the modules that you want to install with
your application and omit any modules that you do not need. Later, if want to add addition-
al modules you can do so with the Software Manager (as shown).

+ Create new modules
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Software developers can use the tools in NiagaraAX to create new (.jar) modules and deploy
them using the New Module Wizard. Refer to “New Module wizard” for more details
about the New Module Wizard.

Figure 7. New module wizard

L2
New Module Wizard

Step 1 of 3
Create Module under Directary

|/D: /niagaras/Niagara-3.0.xk/modules | =

Madule Marme | |

Baja Wersion E’

Preferred Symbol | |

Description | |
Yendar | |

Madule is Embedded
Create Lexican
[ Create Palette

‘ Back || = Next I| Finish || ¥ Cancel |

NOTE: Starting in AX-3.7, you can also create “synthetic modules,” which does not require de-
veloper level knowledge. Refer to the engineering notes document NiagaraAX Synthetic Mod-
ules for details.

About components

A component is the primary building block that you use to engineer an application using
Workbench. As described in the “About component software design”, components provide
many advantages for the application developer.

Components differ from modules in that components compose a Niagara implementation
whereas modules compose the software itself.

The following sections describe characteristics of components:
+ About slots
+ About master/slave components

« About point components

About slots

Components are defined as a collection of “slots.” You can see all the slots that make up a com-
ponent by viewing the “slot sheet”. Slots have the following types of attributes:

+ Slot type

+ Slot name

+ Slot definition
» Flags

+ Facets
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Figure 8. Slot sheet for a single component

Slot I# IName IDispIay Name IDeﬁnitinn IFIags IType IFacets Il‘v‘
O Property 0 code Code Frozen program:ProgramCode
O action 1 execute Execute Frozen a woid {void)

O Property 2 EBooleanArg Booleanarg Crynarmic rs baja:Boolean

[ Property 3 Stringérg Skringdrg Crynamic rs baja:String

O Property 4 Mantharg Montharg Crynarmic rs baja:Month

[ Property 5 wsAnnotation  wsAnnotation Crynamic baja:WsAnnotation
O action 6 Active Ackive Crynarmic woid {void)

O action 7 Inactive Inactive Crynarmic woid {void)

O action 3 ChangeString  ChangesString Crynarmic void {baja: String)

O action 3 ChangeMonth  ChangeMonth Crynarmic void {baja:Month)
Slot type

There are three types of slots:
+ Property

Property slots represent a storage location of another Niagara object.
+ Action

An action is a slot that specifies behavior that may be invoked either through a user com-
mand or by an event. Actions provide the capability to provide direction to components.
They may be issued manually by the operator or automatically through links. Actions can
be issued by right—clicking on the component.

+ Topic

Topics represent the subject of an event. Topics contain neither a storage location, nor a
behavior. Rather a topic serves as a place holder for a event source.

Slot name

Every slot is identified by a name that is unique within its Type. Slot names must contain ASCII
letters or numbers.

Slot definition

Slots are either frozen or dynamic. A frozen slot is defined at compile time within a Type's Java
class. That means that frozen slots are consistent across all instances of a specified Type — they
don’t change. Dynamic slots may be added, removed, renamed, and reordered during runtime
— they can change. The power of the framework is in providing a consistent model for both fro-
zen (compile time) slots and dynamic (runtime) slots.

Flags

Slots have flags that allow modification of an object’s presentation or behavior. For example,

“read—only”, “operator allowed”, and “hidden”, are some of the slot flags that may be used to re-
strict the presentation or behavior of an object.

Facets

Facets contain meta data — or additional data about an object. For example, “units of measure-
ment” is a type of facet. Facets may be viewed in the slot sheet and edited from a component
property sheet.
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Figure 9. Editing facets from the property sheet

IJ (C) Facets min=0.0,units="%a, precision=0,max=100,0
— — e — Sp— w
. Edit Facets } x|
units Imisc 4] m Ipercent (%)
nax 100.00

About master/slave components

Master components can be defined so that persistent properties are copied to slave compo-
nents when they are changed. This allows you to change a property in one component that au-
tomatically updates the components that are linked to it as slaves. In this way a master
component can update slave components in all the other stations in a system.

About point components

In any NiagaraAX station, all real-time data is normalized within the station database as points,
a special group of components. The following image shows several types of control points, as
listed in the control module palette in Workbench.

Figure 10. Point types

= |[j control u
=] EI Paints

+ @ BooleanPaint

+ @ Boolean'Writable

+ @ MurmericPaint

+ @ MumericWritable

+ ) EnumPaint

=13 EnumWritable
+ 7 Procy Ext

+ {0 StringPoint

+ {0 StringWritable

Each type of point may be used for different purposes in Workbench. When you engineer a job
you may want to name a point, as shown below (a NumericWritable point named CondSet-
point). Points may be named and renamed but they retain their initial point type characteristics
and their characteristic icon color.

Figure 11. Numeric writable point named
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Points serve as a type of shell in NiagaraAX, to which you may add point extensions. These ex-
tensions allow you to select only those functions that you need and thereby limit your point
properties to just those that are necessary for your current application.

Figure 12. Adding point extensions

* ¥ Palette

= | (T alarm M
= Inl3 = fnull
= £ AlarmService - [ .
+ [ Default Alarm Class _| =2 Inl4 |- inull}
- [&] alarm Store | =2 1In15 |- inull}

+ @] History Config

=] E AlarmClass | M I_ {mall}
+ ConsoleRecipient _| = Fallback |- Inuall}

+ StationRecipient
=] EI Extensions
SWIFE CUEOFR.angedlarmEs:t

| O Cwerride Expiration
ﬂ =| £ outOfRangedlarmExt  Alarm Source Ext

= f&5] Fault Algarithm | = Alarm Inhibit Ifalse ok}

- @] offrormal slgarithm L
+ 7 BooleanChangeOfStateslarmExt O] Inkibit Tirne
+ 7 BooleanCommandFailureslarmEs:t | (3 Blarm State

+ 7 MultistateChangeOFStatedlarmEsxt
+ 77 MultistateCormmandFailuredlarmes:t
+ 77 FloatingLirnit&larmest

For detailed information about points and point extensions, refer to “Data and Control Model”.

About component naming

In a NiagaraAX station, components should be properly named using the following set of rules:

+ Only alphanumeric (A-Z, a-z, 0-9) and underscore (_) characters are used—spaces, hy-
phens, or other symbols characters (e.g: %, &, ., #, and so on) are illegal in component
names. For further details, see the next section “Escaped names”.

» The first character in the name must be a letter (not a numeral).

+ Name must be unique for every component within the same parent component. Work-
bench automatically enforces this rule, via a popup error dialog.

+ Naming is case-sensitive—for example, zone21 and Zone21 are unique names.

NOTE: Case differences among names affect “name sorts” in table-based views, which or-
der by ASCII code sequence, that is capital letters (A-Z) first, lower case (a-z) following.

To convey multiple-word names without using spaces, naming “conventions” such as “Camel-
Case” and/or underscores are often used, as needed. Examples of such component names are:

+ FloorlorFloor 1
+ ReturnAirTemp or Return Air Temp

+ Zone20l1 SATorZone 201 SAT

Escaped names

Workbench does allow you to name components “improperly,” such as with spaces or other
non-alphanumeric characters, without any warning. Further, various NiagaraAX drivers have
“learn” features to automate the creation of points, some of which (by default) may also have
such “improper” names—reflective of the “native name” of the source object. For example, a
BACnet proxy point might have the default name “Zone 6 RH%” that matches the actual (na-
tive) BACnet object’s name.

In any case, be aware that the “actual” component name has all illegal characters “escaped” us-
ing a “$” character, along with the ASCII code for that character, in hexadecimal. The proxy
point mentioned above, for example, will have the name “Zone$206RH$25”, where the $20
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escapes the space and the $25 escapes the %. You can see these escaped names in the slot sheet
of the component’s parent container. Or, with the component selected, look at its ord (shortcut
Ctrl + L) to see its actual name. Other examples include the dash character “-” which is “$2d”
and anytime you begin a name with a number, the “$3” is appended to the front of the name.

For the most part, this “escaped name” scheme is transparent to users. Whenever the name is
displayed to the user, say in the Nav side bar, property sheet, wire sheet, or a point manger, the
component’s name is “unescaped” by replacing the code (say, $20) with the actual ASCII char-
acter (say, a space). This way, the user sees “Zone 6 RH%” and so on. This is the component’s
“display name.”

In some cases, escaped names lead to confusion. You should avoid them if possible (rename us-
ing rules—see “About component naming”). For example, if you add history extensions to es-
caped-named points, you see those escape codes listed for source points when accessing the
History Ext Manager (although associated histories use the display names). Or, if you are build-
ing Px pages and manually typing in ords in Px widgets, you probably know source points by
“display names” only. If you manually type in an ord without the actual (escaped) name, the
widget binding fails with an error.

NOTE: If this sounds too complicated, remember that “drag and drop” operations resolve es-
caped names without problems—for example, drag any point onto a Px page to get its proper
ord.

About palettes

The palette provides a hierarchical view of available components. You may copy a component
from the palette and paste it where you need it — on a wire sheet, property sheet, Px View, or
in the palette nav side bar pane. You can also create custom palettes that you associate with a
module and use for holding frequently used components. For more information about using
the palette side bar, refer to “About the palette side bar”.

About presentation

The framework provides a powerful presentation architecture based on XML and the Niagara
component model.

Presentation is a term that is used to describe how Niagara provides visualization of informa-
tion across different types of media. The terms information, visualization, and media may com-
prise the following:

+ information
+ real-time data
+ historical data
+ configuration data
+ alarm data
+ scheduling data
+ graphical data
+ textual data
+ visualization
+ bitmap and vector graphics
+ text documents

« tables
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o charts

+ input controls (text fields, check boxes, trees)
media

+ desktop web browsers (HTML, CSS, JavaScript)
+  Workbench (Niagara stack)

o pdf

+ printed pages

o sVg

+ handhelds

« cell phones

About presentation modules

Niagara’s presentation architecture is based on many modules and their associated public APIs:

3

baja

The baja module defines the core component model upon which Niagara subsystems are
built. This document describes enhancements to the baja component model which will be
used by the presentation stack.

gx

The gx module provides an API for drawing 2D graphics to a device. The gx module deals
with drawing primitives: color, strokes, gradients, vector geometries (line, rectangle, ellipse,
paths), bitmap images, fonts, and transforms.

bajaui

The bajaui module provides the widget toolkit. Widgets are the basis for graphical composi-
tion, layout, user input, and data binding. The bajaui module builds upon gx to paint the
widgets.

PDF

The PDF implementation of the gx APIs.
HTML

The HTML rendering and data binding engine.

About presentation xml (Px)

An XML file format is used to define the Niagara presentation. This file format is called “Px”
for presentation XML and the term “Px” is commonly used to describe the presentation archi-
tecture. Presentation is a term that describes how Niagara visualizes information (text,
graphics, alarms, and so on) across heterogeneous media — such as: Workbench, browsers, mo-
bile devices, and so on. Niagara uses “presentation xml” (Px) to accomplish this. The following
image shows an example of a Px file in the Text Editor (Px source file), the Px Editor view, and
as displayed in the Px Viewer.
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Figure 13. Px file in Text Editor, Px Editor, and Px Viewer

<rxml wersion="1.0" enqgofddrmes TR 20 1
«<!-- Niagara Presentat | |
<px version="1.0">
<imports T
<module nawe="haja"/ [
<module name="hajaui
<module name="conver §
<module name="gx"/ >
</imports I
<Contents

T &
<CanvasPane viewdize=" i
........... : i

?

<Label layout="150,9 . |
<WalueBinding ord= 1
<INumericToSinpl

i

l‘-..

</WalueBinding-
</Label>

<Label layout="47,1C° ~°° 777 7
<ValueBinding ord=
<IBooleanToSinpl
<Image name="t
<Image name="f
</IBooleanToSiny
</WalueBinding-
</Label>

<Label layout="250,%
<ValueBinding ord=
<INumericToSinpl
</WalueBinding-
</Label>

< /CanvasPanex
</contents

<K L Bx source ﬁh

About presentation design philosophy

The presentation architecture is based on the following design principles:

.

Component model

The core philosophy of every subsystem in Niagara is to build atop the component model.
The presentation architecture is no exception. The design embraces a pure component
model solution. The component model is used for the normalized representation of presen-
tation - the “document object model” (DOM) of the Niagara presentation is always a
BComponent tree.

Unified visualization

Presentations include a unified approach to representing graphics, text, and input controls
all within a single component model. This allows all visualizations to share a common file
format as well as a rendering, layout, and input APIL

Unified media

The design goal of Px is to build a single presentation that can be used across multiple me-
dia. For example, given a Px file, it can be automatically rendered using the Workbench, as
an HTML web page, or as a PDF file. All presentations are stored in the normalized compo-
nent model as Px files.

About presentation media

There are four primary target medias that NiagaraAX supports.

.

.

Workbench

The Niagara stack must be available to take full advantage of the presentation architecture.
The desktop version of Workbench provides a stand alone application that can render pre-
sentations with their full power. With the WbProfile feature, new custom applications can
easily be built using Workbench framework and its presentation engine.

Workbench applet
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About stations

3

3

The applet allows the full Niagara stack to be downloaded to a client machine using a web
browser with the Java plug—in. Once loaded to the client, Workbench may be run as an
applet within an HTML page. In this scenario, the presentation engine will be available with
the full feature set. The WbProfile feature may be used to customize how Workbench is
decorated inside the HTML page.

PDF

Adobe's PDF format is the standard way to export a presentation to be printed to paper.
PDF provides explicit control for how a presentation is rendered on paper in various sizes.
It is also a convenient file format for access via HTTP or email. The presentation architec-
ture includes an engine for generating PDF files from Px files.

HTML

For the casual user where installing the Java plug—in or downloading Workbench is imprac-
tical, Niagara supports an engine for generating plain HTML pages from Px. A simple set of
HTML, CSS, and JavaScript provide a web interface using common standards. This inter-
face may also be used to support handheld devices and cell phones. Designers are limited to
a subset of widgets when creating HTML presentations (the Px tools provide this support).

Refer to the NiagaraAX Graphics Guide section “Types of Px target media options” for infor-
mation about presentation media technologies.

Figure 14. Presentation media options

Workbench Client

A station is the main unit of server processing in the Niagara architecture.

.

A station database is defined by a single .bog file, for example:
“file:!stations/{name}/config.bog”

Stations are booted from their config.bog file into a single Virtual Machine (VM), or proc-
ess, on the host machine.

There is usually a one—to—one correspondence between stations and host machines (Super-
visors or JACEs). However it is possible to run two stations on the same machine if they are
configured to use different IP ports.

A station runs the components of the Niagara Framework and provides the access for client
browsers to view and control these components. The primary parts of a station include compo-
nents and services. It is the combination of a database, a web server, and a control engine. The
station either runs on a Web Supervisor PC or a controller.
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About ORDs

Figure 15. Station in nav tree

]
= B My Host (FALCON)
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+ B3 My File System
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+ = Files
+ #4g History

A system can be a single station or multiple stations depending on the size of the project and it
is defined by a bog file. See “About BOG files”.

About BOG files

A bog file (baja object graph) contains Niagara components. It can be a complete database or
any collection of components. A bog file is a special file that describes the components in a da-
tabase. All views can be used on components in a bog file just as if they were in a station.

Figure 16. Sample bog file and nav tree presentation

L2xml version="1.07 encoding="TUTF-5" 7>
<hajalbjectGraph version="1.0">
<p h="1Za5%" m="h=baja" t="b:53tation">
<p n="stationMName” w="demo” />
<!-- /Home -->
<p n="Home"™ h="1" t="h:Page">
<p n="layout” v="file: wisp /Home.wisp
£!-- /Home/Graphics --»
<p n="Graphics"™ h="al0" t="h:Page™>
<p n="layout” v="file: wisp/Graphics
<!-- /Home/Graphics/Campus ---
<p n="Campus" h="£19" t="h:Page™>
<p n="layout” wv="file: wisp/Campus.
<!-- /Home/Graphics/Campus/Euilding
<p n="Building™ h="fla"™ t="h:Page™
<p n="layout” v="file: wisp/buildi
£!-- fHome/Graphics/CanpusBuildin
<p n="A4irHandler™ h="f£1b" t="h:Paq
<p n="layout” wv="file: wisp /build
<p n="0utsidedirTenp”™ t="bh:Tag">
<p n="ord" w="slot:/Logic/Housin * PracessiCantral
</p= —ﬁ Sameler
<p n="ReturniirTemp” t="h:Tag">
<p n="ord" w="slot:/Logic/Housinglmit/4irHandlf
</p>
<p n="MixediirTemp™ t="bh:Tag">
<p n="ord" w="slot:/Logic/Housinglmit/iirHandlf

= ﬁﬁ Station {dema)

An ORD is an “Object Resolution Descriptor”. The ORD is the Niagara universal identification
system and is used throughout the framework. The ORD unifies and standardizes access to all
information. It is designed to combine different naming systems into a single string and has the
advantage of being parsable by a host of public APIs.

An ORD is comprised of one or more queries where each query has a scheme that identifies
how to parse and resolve to an object. ORDs may be displayed visually, as with the Open Ord
locator or they may be entered in a text field, as shown in the Open ORD dialog box.

Figure 17. Open ORD and graphic locator system

. Open Ord |
|local: | spy: /sysManagers/registryManager /ordschenes| |
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ORDs can be relative or absolute. An absolute ORD usually takes the general format of “host|
session|space”, as illustrated below.

Figure 18. Absolute ORD typical structure

host | session | space
- ip:hestname fox:port
-dialup platform:

« host

The host query identifies a machine — usually by an IP address such as “ip:hostname”. For
example “fox:” indicates a fox session to the host.

+ session
The session is used to identify a protocol being used to communicate with the host.
+ space

The space query is used to identify a particular type of object. Common spaces are “mod-

” o«

ule:”, “file:”, “station:”, “view:”, “spy:”, or “history:”.

The local VM is a special case identified by “local:” which always resolves to BLocalHost.IN-
STANCE. The local host is both a host and a session (since no communication protocols are
required for access).

Both a slot path and a handle scheme can name components within a ComponentSpace. So the
ORD for a component usually involves both a space query and a path/handle.

Examples of ORDs:

o ip:somehost|fox:|station:|slot:/MyService

e 1ip:somehost|fox:|station:|h:/42

o 1ip:somehost|fox:|file:/C:/dir/file.txt

o local:|file:!lib/log.properties

e local:|module://icons/x16/cloud.png

o local:|spy:/

In Niagara you may view the complete list of installed ORD schemes at “spy:/sysManagers/
registryManager/ordSchemes” (“local:|fox:|spy:/sysManagers/registryManager/ordSchemes”).

About schemes

An ORD is a list of one or more queries separated by the
CII string formatted as “<scheme>:<body>".

uln

pipe symbol. Each query is an AS-

Figure 19. Example ORD scheme and body

ip:10.10.8.78|fox:|station:|slot:/Samples/NumericWritable2

scheme body scheme body
Query Query Query Query

« scheme
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The scheme name is a globally unique identifier which specifies, in Niagara, how to find a
piece of code to lookup an object from the body string. Refer to “Types of schemes” for a
listing of different types of schemes.

body

The body string is formatted differently, according to the requirements of the scheme. The
only rule is that it cannot contain a pipe symbol. Queries can be piped together to let each
scheme focus on how to lookup a specific type of object. In general, absolute ords are in the
following format: host | session | space.

Some examples follow:
o ip:somehost|fox:|file:/dir/somefile.txt

In this example, the “ip” scheme is used to identify a host machine. The “fox” scheme
specifies a session to that machine usually on a specific IP port number. Finally, the
“file” scheme identifies an instance of a file within the “somehost” file system.

e 1p:somehost|fox:1912|station:|slot:/Graphics/Home

In this example, the “ip” scheme is used to identify a host machine using an IP address.
The “fox” scheme specifies a session to that machine usually on a specific IP port num-
ber. Finally, the “station” and “slot” schemes identify a specific component in the station
database.

¢ local:|module://icons/x16/cut.png

This example illustrates a special case. The scheme “local” which always resolves to
BLocalHost.INSTANCE is both a host scheme and a session scheme. It represents ob-
jects found within the local VM.

Types of schemes

3

ip:
The “ip” scheme is used to identify an Ip Host instance. Ords starting with “ip” are always

absolute and ignore any base that may be specified. The body of a “ip” query is a DNS host-
name or an IP address of the format “dd.dd.dd.dd”.

fox:

The “fox” scheme is used to establish a Fox session. Fox is the primary protocol used by Ni-
agara for IP communication. A “fox” query is formatted as “fox:” or “fox:<port>”. If port is
unspecified then the default 1911 port is assumed.

file:

The “file” scheme is used to identify files on the file system. All file ords resolve to instances
of javax.baja.file.BIFile. File queries always parse into a FilePath. File ords include the fol-
lowing examples:

+ Authority Absolute: “//hostname/dir1/dir2”
+ Local Absolute: “/dirl/dir2”
+ Sys Absolute: “llib/system.properties”

Sys absolute paths indicate files rooted under the Niagara installation directory identi-
fied via Sys.getBajaHome().

+ User Absolute: “*config.bog”

User absolute paths are rooted under the user home directory identified via Sys.getUser-
Home(). In the case of station VMs, user home is the directory of the station database.

+ Relative: “myfile.txt”

NiagaraAX User Guide
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+ Relative with Backup: “../myfile.txt”
module

The “module” scheme is used to access BlFiles inside the module jar files. The module
scheme uses the “file:” scheme's formatting where the authority name is the module name.
Module queries can be relative also. If the query is local absolute then it is assumed to be
relative to the current module. Module queries always parse into a FilePath:

+ module://icons/x16/file.png

+ module://baja/javax/baja/sys/BObject.bajadoc

+ module:/doc/index.html

station:

The “station” scheme is used to resolve the BComponentSpace of a station database.
slot:

The “slot” scheme is used to resolve a BValue within a BComplex by walking down a path
of slot names. Slot queries always parse into a SlotPath.

h:

The “h” scheme is used to resolve a BComponent by its handle. Handles are unique String

identifiers for BComponents within a BComponentSpace. Handles provide a way to persis-
tently identify a component independent of any renames which modify a component's slot
path.

service:

The “service” scheme is used to resolve a BComponent by its service type. The body of the
query should be a type spec.

spy:

The “spy” scheme is used to navigate spy pages. The javax.baja.spy APIs provide a frame-
work for making diagnostics information easily available.

bql:
The “bql” scheme is used to encapsulate a BQL query.

Types of space

Space defines a group of objects that share common strategies for loading, caching, lifecycle,
naming, and navigation. Following, is a list of some of the different types of space:

*

.

3

.

3

*

3

component
file

history
module
orion
station

view

Types of files

In the file system, you may create and edit various types of files. Following, is a list of some of
the different types of files that reside in the file space:

22
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Figure 20. Types of files available from the new file menu

@ BogFile.bog

") HemiFile. html
JavaFile.java

3, MavFile.nav

@ PaletteFile, palette

@ PxFile.pix

[ TextFile txt

+ BogFile.bog

bog files are database files. Refer to “About BOG files” for more information about this type
of file.

+ HtmlFile.html

Html files are edited in the Text File Editor view and viewed in the Html View.
+ JavaFilejava

Java files are edited in the Text File Editor view.
+ DPaletteFile.palette

These files are custom collections of components that you create and save for viewing in
the palette side bar. Refer to “To create a palette” for information about creating custom
palettes.

» DPxFile.px

Px files are edited in the Px view and are used to store graphic presentations that are avail-
able for viewing in the Px viewer and in a browser. Refer to “About presentation xml (Px)”
for more information about Px files.

» TextFile.txt
Text files are edited and viewed in the text file editor.
+ NavFile.nav

Nav files are edited in the nav file editor and viewed in the nav tree. Refer the NiagaraAX
Graphics Guide section “About the Nav file” for more information about nav files.

NOTE: Also see “About file naming”.

About file naming

When working in a station, you often create files of various types in its file space—for example,
a Px file if adding a new view, if creating a new Nav file, whenever exporting a view to pdf/txt/
csv file, or if making a station backup .dist file. In addition, you often create new station file
folders, and also copy graphic image files over to the station’s file space.

Regardless of file types, whenever saving files (or before copying files to the station), we
strongly recommend that you restrict all characters in file and folder names to ones in the
“original” set of ASCII characters in the BNF for Niagara file paths, namely:

a-z | A-Z | 0-9 specials
specials=space | . | : [ = [$I+] (1) l&l 1 M1@J[]]

Otherwise, use of other characters, for example, a tilde ( ~ ) in file or folder names may result
in obscure problems—particularly on controller platforms (QNX-based hosts). Note that
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About views

About lexicons

earlier revisions of NiagaraAX automatically restricted file names in dialogs to only the original
set of characters above. However, starting in NiagaraAX-3.6.47 and later, these file naming
rules were “relaxed” to deal with other issues relating to Web Workbench and locally cached
files.

There are many ways to visualize your system and its components. A “view” is a “visualization”
of a component. One way to view a component is directly in the side bar nav tree. In addition,
you can right-click on an item and select one of its views to display in the view pane. You can
see many different views of components. For example, a component that appears in the nav
side bar tree may have a wire sheet view, a property sheet view, and a slot sheet view, that all
display in the view pane. Each component has a default view that appears whenever you acti-
vate a component (double-clicking, for example) without specifying a particular view.

Figure 21. Views
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See “About the view pane” for more information on the view pane. Refer to the “Plugin Guides”
for a comprehensive list of views.

NiagaraAX provides non-English language support by use of lexicons. Lexicons are identified
by Java locale codes, such as “fr” (French) or “de” (German). Starting in Workbench 3.7, all of
the lexicons are distributed as modules (niagaralexiconXx.jar) included in the
installation.

Each lexicon module contains one or more lexicon files (moduleName.lexicon). Lexicon files
are simple text files that map various entity “keys” (such as interface names or error and status
values) to localized language character values.

NOTE: Although module-based lexicons are introduced in Workbench 3.7, file-based lexicons
continue to be supported. If you have used file-based custom lexicons in a prior release, you
can continue to use those. In Workbench 3.7, you can deploy custom lexicons in any file-
based/module-based combination.

To edit lexicons, you typically use the Workbench lexicon tool (Tools > Lexicon Tool). Lexi-
con Report, the default view, lists all lexicons installed on your PC and specifies details about a
selected lexicon and its contained files. The Lexicon Editor view provides edit features and
shows the default (English) value for each line entry. The Lexicon Module Builder view lets
you bundle multiple lexicon files in a module for ease of distribution.

NOTE: In some cases, lexicon editing provides utility even in English language scenarios. For
more details, see the NiagaraAX Lexicon Guide section on “Notes on English (en) lexicon
usage”.

24
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After editing a lexicon file, you can then install the file in a remote platform using the platform
Lexicon Installer view. An alternative is to create (or update) a lexicon module with the edited
lexicon file, using the new Lexicon Module Builder view. Install the new (or updated) module
in a remote platform using the platform Software Manager view.

For detailed information on using the Lexicon Tool, see the NiagaraAX Lexicon Guide.
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CHAPTER 2 ABOUT THE USER INTERFACE

Torics COVERED IN THIS CHAPTER

Tour of the interface
Customizing the environment

Workbench is the term for the Niagara graphic user interface. The following sections describe
the general layout and many of the features of the Workbench user interface.

o Tour of the Workbench GUI

+ Customizing the Workbench environment

Tour of the interface

When you start Workbench, you will

Figure 22. Workbench

see the screen shown below.

ki Miagara Workbench E@
G—— File Edit Search Bookmarks Tools Window Help
o— P - D-Bz - 2o D 2 %
©&—1] |d |
- Naw =
9 i 2 My Network - 1
18 0 [@whewox [ Niagara Workbench
b My Host :192.168,1.1 Licensed to Technical Publications, Claire Newman
= My File System
My Modules
e Platform
: Station (Station_101)
'_;—"_ 192,158.201.60 (Ins_201_50)
Getting Started | Help Contents
sPoweced by
@iagdra |
t‘:\Nlagara\Nlagara—S‘S‘111> H
1 Menu Bar Side Bar Pane
2 Tool Bar 6 View Pane
3 Locator Bar Console
4 View Selector

The primary window of the interface

«+ Side bar pane

is divided into three main areas:
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Top-left area displays one or more side bars that you may choose from the Windows menu.
For details, see “About the side bar panes”.

View pane
Top-right area displays the currently selected view. For details, see “About the view pane”.
Console

Bottom area displays a command line that allows you to issue certain commands directly to
the system. For details, see “About the console”.

About Workbench window controls

The Workbench window provides typical Windows-type controls plus other unique features,
as shown below.

You may create additional windows after starting Workbench—all have the following basic
features:

.

Title bar

Has standard Windows title bar features, including windows name and icons to minimize,
maximize, and close. Double-click the title bar to toggle between maximized and a sizable
window.

Border Controls

As needed, drag any outside border to resize the entire window. Drag the inside border be-
tween the side bar and view areas, or (if shown) the console area to change their relative
sizes.

Scroll bars

Scroll bars appear in window areas when some content portions are not visible. They are
along the right and/or bottom portions of a window area (side bar, view, or console).

Simply drag a scroll slider (highlighted area) to scroll quickly. Or, click an ending scroll ar-
row to move in small increments.

Status bar
At the bottom left of the Workbench window is a status bar.

The status bar displays meanings of toolbar buttons. When working in a Wire Sheet view,
other details are revealed in the status line.

About the side bar panes

Side bar panes are normally visible only if a side bar is open.

When you close all side bars, the side bar pane will collapse and the view pane and console
pane (if open) will expand to fill the window. Two types of side bar panes are:

.

Primary side bar pane
The primary side bar pane is the first area on the left, below the locator baras shown below.
Px Editor side bar pane

This side bar pane appears on the right side of Workbench and is only available when the
Px Editor is active.

28
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Figure 23. Side bar pane
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You use a popup menu to perform all operations that are available from inside the side bars
(such as cutting or pasting). You use the title bar to open, close, and resize the side bars.

+ For more information about the side bar title bar, see “About the side bar title bar”.

+ For more information about types of side bars see “Types of side bars”.

About side bars

All side bars display in the side bar pane and have some common features, such as the side bar
title bar. The following sections describe characteristics of each type of side bar:

« About the side bar title bar

» Types of side bars

About the side bar title bar

All side bars have a title bar across the top. You can click and drag on the title bar to vertically
resize the side bar or you can click on a minimized side bar to restore it to the previous size.

In addition, all side bars have the following controls:
+ Close menu
Drop down control used to close the side bar pane.
+ DPanetitle
Icon and text that identifies the side bar.
+ Maximize button

When more than one side bar is open, this button appears on the right side of any non-
maximized side bar. Clicking on the maximize button will expand the side bar to fill the
side bar pane and the restore button will change to the maximize button.

+ Restore button

If the side bar pane is at maximum size, the restore button appears on the top right corner
of the title bar. Clicking on this button will restore the side bar pane to its previous size and
the maximize button will change to the restore button.

To find out more about specific side bar panes and their controls see “Types of side bars”.
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Types of side bars

The Workbench interface may be customized by adding unique side bars that are designed to
fit particular applications. The following side bars may be displayed in the side bar pane by
default:

.

Bookmarks side bar
Displays a list of bookmarks. For details, see “About the bookmark side bar”.
Help side bar

Provides a tree view of available help documentation. For details, see “About the help side
bar”.

Jobs side bar
Provides a tree view of available help documentation. For details, see “About Jobs side bar”.
Navigator side bar

Provides a tree view of the system. For details, see “About the nav side bar”. For more infor-
mation about the nav side bar, see “Types of nodes in the nav side bar tree”, and “About the
nav side bar toolbar”.

Palette side bar

Provides a tree view of components that are available in specific palettes. For details, see
“About the palette side bar” and “About the palette side bar toolbar”.

Todo side bar
Provides a customizable list of tasks or notes. For details, see “About the Todo list sidebar”.
Bound ords side bar

Provides a listing of all bound ords used in a Px file. For details, see “About the bound ords
side bar”.

Widget tree side bar

Provides a tree view of all widgets used in a Px file. For details, see “About the widget tree
side bar”.

Px Properties side bar

Provides a listing of all Px Properties that are defined for the viewed Px page. For details,
see “About the Px properties side bar”.

Properties side bar

Provides a listing of all properties for a component that is selected in the Px Editor. For de-
tails, see “About the properties side bar”.

About the bookmark side bar

When you open the bookmark side bar, it appears in the side bar paneas shown below.
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Figure 24. Bookmark side bar
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From the bookmark side bar, you can double click on bookmark nodes or use popup menus to
perform all operations that are available from the side bar (for example, go directly to a book-
marked location, manage bookmarks, edit bookmarks, and more). The quick access provided
here is very helpful for changing screens without having to go through multiple selections using
other menus or submenus.

For more details about the bookmark side bar, refer to the following:

+ To find out how to add or remove bookmarks in the bookmark side bar, see “To add a
bookmark”.

+ For details about managing bookmarks, see “T'o manage bookmarks”

+ For details about editing bookmarks, see “To edit a bookmark”
About the help side bar
When you open the help side bar, it appears in the side bar paneas shown below.

Figure 25. Help side bar
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The help side bar has three tabs that you may select by clicking on the tab. The three help tabs
are listed and briefly described, as follows:

+ Table of Contents

Contains a tree view of help topics, listed in alphabetical order by topic.
+ API

Contains a tree view of help topics, listed in alphabetical order by module.
+ Search

Contains a Find: text entry field and Search button. For details on using the Search, see
“Using the help side bar”.

About Jobs side bar

When you open the Jobs side bar, it appears in the side bar pane. The Jobs side bar contains a
list of jobs that have been performed or that are currently being performed.

Figure 26. Jobs side bar
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The following icons on the Jobs side bar indicate job status:
«  © Running
Indicates that the job is currently running.
o @ Success
Indicates that the job has completed without error.
o @ Failed
Indicates that the job did not complete.
+ @ Unknown
Indicates that the job status is not available.

From the Jobs side bar, you can click on the arrow icon >> to open the Job Log dialog box. The
Job Log dialog box displays a listing of the actions performed as part of the job. Each entry in
this log contains a detailed description that you can view by double-clicking on the entry to
open the Log Details dialog boxas shown below.

Figure 27. Log Details dialog box
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About the nav side bar

When you open the nav side bar, it appears in the side bar pane, as shown below. The nav side
bar contains the tree view that provides a hierarchical view of the whole system. From the nav
side bar, you can double click on nodes in the nav tree or use popup menus to perform all oper-
ations that are available from the nav side bar (for example, connect or disconnect to a station,
refresh a tree node, and more). The expandable tree provided here is very useful for performing
actions on nodes and for navigating through various screens and views in the Workbench.
Items are displayed in the tree with an icon that represents the associated function or file type.

Items are displayed in the tree with a symbol based on type. If the item is a file, it will be based
on file type. Refer to “Types of nodes in the nav side bar tree” for more details about file types.
Refer to “About the nav side bar popup menu items” for more details about the nav side bar
popup menu.

Figure 28. Nav side bar
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At the highest level, the nav side bar tree may include the following (when working from a
localhost):

+ My Host (local system)
+ My Modules
« Platform

» Stations (connected or disconnected)

Types of nodes in the nav side bar tree

The nav side bar tree may include the following types of nodes and their child nodes:
+ Host node

Represents a physical computer (hardware) that the rest of the nodes (subnodes) reside on.
For more details about how the host fits into the Niagara architecture, see “About Niagara
software architecture”.

« Module node

When expanded, displays a tree view of available modules, listed in alphabetical order by
module. For more details on modules, see “About modules”.

+ File system node
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Represents the top level of a tree view of the host file system. File system subnodes repre-
sent drives and locations on the host system. It is important to understand that the file sys-
tem provides access to files that are outside of the station database.

Station node

Represents a station (connected or disconnected). When expanded, the station node dis-
plays the station contents in a hierarchical tree. For more details on stations, see “About
stations”.

Platform

When expanded, displays a hierarchical view of the Niagara host platform. You can double-
click on the platform node and sub-nodes, or use a right-click shortcut menu to perform all
operations that are available on or under this node (connecting, disconnecting, refreshing,
and more). For details on the platform node and its subnodes, refer to “About a platform
connection” in the Platform Guide for more details.

Station

When connected and expanded, displays a hierarchical view of the Niagara station. You can
double-click on the station node and sub-nodes, or use a right-click shortcut menu to per-
form all operations that are available on or under this node (connecting, disconnecting, se-
lecting views, and more). For details on the station node, refer to “About stations”.

Config node

When expanded, displays a tree view of the station contents or “configuration”.
The config node usually contains one or more of the following types of nodes:
+ Component

When expanded, components (as containers) display a tree view of the sub-components
that they contain. Various component types may be displayed either in containers or at
the root of the component node. For more details on components, see “About
components”.

« Control

Control points may be displayed directly in the root of the Config node. For more infor-
mation about Control points, see “About point components” and “Data and Control
Model”.

o Drivers

Provides a place to store driver modules (such as the Niagara Network, BACnet drivers,
Modbus, and more). When expanded, displays a tree view of loaded driver modules. For
more details, refer to the “About Network architecture” section in the Drivers Guide.

« Services

Component for storing services, such as alarm service, history service, program service,
and more.

About the nav side bar toolbar

In addition to the standard side bar title bar (see “About the side bar title bar” for more details)
the nav side bar has a toolbar, located just below the title bar.

The nav side bar toolbar includes the following:

3

New tree button

When clicked, creates a new tree in the nav side bar. When you have more than one tree
node, you can select one to activate from the Drop-down tree selector.

Close tree button
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When clicked, closes the currently displayed side bar.
+ Drop-down tree selector

When more than one nav side bar is open, this selector allows you to choose which one to
display

About the palette side bar

When you open the palette side bar, it appears on the left side of the Workbench in the side
bar pane as shown below. The palette side bar provides a place to open and view sets of mod-
ules or custom palettes that you build for yourself. From the palette side bar, you can open
multiple palettes (displaying them one at a time), close palettes and view modules within pa-
lettes. You may also double-click or use popup menus to perform all operations that are avail-
able from the palette side bar (for example, copy modules, select a module view, refresh the
tree node, and more). The expandable tree provided in the palette allows you to perform ac-
tions on nodes within the palette and to navigate through the palette sub-directories. Items are
displayed in the tree with an icon that represents an associated function or file type.

The palette side bar also has a component preview pane that displays an image (when available)
of the selected component (shown below).

Figure 29. Palette side bar with preview pane
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Palette previews display in the palette when components have images configured either as the
default image property or as the image assigned to the comPreviewWidget property. If no pre-
view is associated with a component, in AX-3.5 and later, you can add a compPreviewWidget
property to a widget in order to display an image in the preview pane of the palette side bar.
See “To add a side bar preview using the compPreviewWidget property”.

For more details about the palette side bar, refer to the following:
+ To find out how to use the palette side bar, see “Using the palette side bar”.
For details about adding palettes to the palette side bar, see “To open a palette”

About the palette side bar toolbar

In addition to the standard side bar title bar (see “About the side bar title bar” for more details)
the palette side bar has a toolbar, located just below the title bar.

The palette toolbar includes the following:
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Open palette button

When clicked, opens the Open Palette dialog box. Refer to “To open a palette” for informa-
tion about opening palettes.

Close palette button
When clicked, closes the currently displayed palette.
Drop-down palette selector

When palettes are open in the palette side bar, this selector allows you to choose which pa-
lette to display.

Open preview pane button (AX-3.5 and later)

This control button toggles the preview pane on and off. Previews are available on some
components.

About the Open Palette dialog box

The Open Palette dialog box displays a tabular list of available palettes. If there are palettes lo-
cated in locations other than the My Modules directory, you can use the browse button to find
them.

Figure 30. Open Palette dialog box
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The Open Palette dialog box is shown above and has the following features:

.

Filter field

This is a text field that allows you to type the beginning letters of the desired palette name
to filter out palettes from the view. For example, typing in the letters “mo” removes palettes
that do not begin with the letters “mo”. You may use the * (asterisk) character as a “wild
card” entry in this field. All palettes are listed in the table if no text is entered in this field.

Browse button

This button opens the File Chooser dialog box to allow you to select palettes that are lo-
cated in alternate locations.

Table of palettes
The table of palettes has the following columns
+  Module
This is the name of the palette’s parent module
+ Description

This is a short title or name of the palette’s parent module
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About the Todo list sidebar

The Todo list sidebar is a convenient way to create and access Todo List items from a palette.
Click the + button on the toolbar to open the Add dialog box. The Add dialog box provides a
text field for adding and categorizing Todo list items. For more details about the Todo List see
“Todo List”.

Figure 31. Todo bar
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About the jobs side bar

The Jobs side bar shows all the current jobs in all the stations with which you have a
connection.

The current status of each job is shown as: running, canceling, canceled, success, or failed. If
the job is running then a progress bar displays estimated progress. You may cancel a running
job by pressing the Cancel button. Normally, once a job has completed you are notified via the
async notification feature. You may then dismiss the job by pressing the Close button. The de-
tails of the job may be accessed using the “>>” button to display the Job Log dialog box. For de-
tails about using the job side bar, refer to “Using the jobs side bar”.

About the bound ords side bar

The bound ords side bar, below, is available when the Px editor view is active. It displays a list-
ing of all the bound ords in the current Px view. Double click on any ORD in the list to display
the ORD in the ORD editor dialog box.

Figure 32. Bound ords side bar
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About the widget tree side bar

The widget tree, below, displays a tree hierarchy of the widgets (panes, labels, graphic elements,
and so on) that are in the current Px view.
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Figure 33. Widget tree side bar
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NOTE: It is often easier to use the Widget Tree to select objects when you have a lot of objects
on a view—especially when there are several layers of objects. When you select an object in the
tree view it is selected in the Px view as well and displays the selection borders and handles.

About the Px properties side bar

The Px properties side bar, shown below, is available when the Px editor view is active. It dis-
plays a listing of all the Px properties that are defined in the currently active Px file. Use the
menu bar icons to add, define, assign, and delete Px properties. For more information about Px
Properties, see the NiagaraAX Graphics Guide section “About Px Properties”.

Figure 34. Px properties side bar
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About the properties side bar

The properties side bar, shown below, is available when the Px editor view is active. It displays
a listing of all the properties that are in the currently selected object in the Px view. Double
click on any object in the widget tree or in the in the Px viewer to display the properties dialog
box (same information as the properties side bar).
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Figure 35. Properties side bar
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About the view pane

The View pane is the largest window area and is located on the right side, below the locator
bar, as shown below. Features of the view pane include tabbed views and a thumbnail view.

Figure 36. View pane
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Multiple tabbed views may be added to the view pane by using the tab feature. You can add,
close, and select tabs in the view window. The view area displays the currently selected view for
the active tab. You can change the selected view by doing any of the following:

+ double-click on an item in the nav palette tree

+ select a view or action from the nav palette popup menu
+ select a command from a menu or submenu

+ select a command from the locator bar

select a view from the view selector or from the view popup menu
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The thumbnail view, when active, appears in the top right corner of the window to help you
find your way around the wire sheet. For more details about the thumbnail view, refer to “Show
Thumbnail”.

For more details about using tabs, refer to “Creating tabs in the view pane”.
About the console

The console, see the following image, is located along the bottom of the Workbench interface
and may be alternatively hidden or shown by selecting Window > Hide Console or Window >
Console from the menu bar.

Figure 37. AX console
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The console has scroll bars on the right side and the window size may be adjusted by dragging
the top border bar. The console provides you with access to a command line prompt without
leaving the Workbench environment. From the console you may type in commands directly,
including the help command for additional help. The following lines are some console level
commands, parameters, and options:

>wb -help
usage:
wb [options] <ord>
parameters:
ord initial ord to display
options:

-profile:<type> ec-netax pro:WbProfile to use
-locale:<x> set the default locale (en_ US)
—-@<option> pass option to Java VM

About the menu bar

The menu bar is the row of pulldown menus located along the very top of the Workbench GUI
as shown below. You may use these menus to perform operations throughout the Workbench
GUI. Many of the menus on the menu bar are context-sensitive and only appear when certain
views are active.
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Figure 38. Menu bar
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For detailed information about the menus, refer to “Types of menu bar items”.

About the toolbar

The toolbar is the row of icons, just below the menu bar as shown below. The toolbar provides
menu choices for objects that appear in the view pane. Usually, toolbar icons provide single—
click access to many of the most commonly used features of the Workbench.

Figure 39. Toolbar
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In addition to the primary (always visible) toolbar, additional sets of toolbar icons are added to
the toolbar when different views are active. For example, when the Wire Sheet view is active,
the Delete Links icon and Zoom icons are available. When an icon is dimmed, it is unavailable.
For more information about specific toolbar icons, refer to “Types of toolbar icons”.
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About the locator bar

The locator bar is the area just below the toolbar that spans horizontally from the left edge of
the Workbench GUI all the way to the right side, including the view selector on the right side
as shown below. The part of the locator bar that shows your current path (not including the
view selector) is referred to as the PathBar.

Figure 40. Locator bar
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The purpose of the locator bar is to provide a graphical navigation field for selecting and dis-
playing destination references. The locator serves two functions.

« First, it is automatically updated each time a new view is selected - so that it shows you the
Ord of each view.

+ Second, since the Ord is displayed in a graphical row of icons, you may click on any icon
along that Ord or any child node from the Ord graphical drop-down menu.

Find the Open Ord command by selecting File > Open from the menu bar.
About the view selector

The view selector appears on the right side of the locator bar, just below the tool bar as shown
below.
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The view selector provides a context sensitive menu with commands that allow you to quickly
display different views of the information that is currently in the view pane. The commands in
the view selector differ, depending on the current view pane contents. For example, the view
selector commands that are available when you are viewing the platform in the view pane are
different from the commands that are available when you are displaying the driver manager
view.

Types of popup menus

Workbench provides view—specific, or context—specific commands for editing components in
many of the views. Following, is a list of the standard Workbench popup (right—click) menus.

+ Nav side bar

For an overview of the popup menus in the nav side bar, refer to “About the nav side bar
popup menus”.

For an overview of the nav side bar, refer to “About the nav side bar”.
«  Wire sheet

For an overview of the popup menus in the wire sheet, refer to “About the wire sheet popup
menu”.

+ Property sheet

For an overview of the popup menus in the property sheet, refer to “About the property
sheet popup menu”.

For descriptions of the property sheet popup menu items, refer to “About the property
sheet popup menu items”.

« Px Editor

For an overview of the popup menus in the Px Editor, refer to “Px Editor popup menu”.

About the nav side bar popup menus

The nav side bar menu is the popup menu that displays command options when you right—
click on a component item in the nav side bar. The nav side bar popup menu is context-sensi-
tive and displays items that relate to the object that is currently selected. For example, the pop-
up menu for a station is different from a popup menu for a folder or a point. The following
image shows a popup menu for a selected node in the nav side bar.
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Figure 42. Nav side bar popup menu
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If you right-click in a blank area of the pane (not selecting any items any the tree), the nav side
bar pane will display the Refresh Tree Node and Sync Tree commands. For descriptions of nav
side bar popup menu items, refer to “About the nav side bar popup menu items”.

About the wire sheet popup menu

The following image shows the wire sheet popup menu with a wire sheet object selected. The
menu displays different items depending on whether you right-click on an item or on a blank
area of the wire sheet. For descriptions of wire sheet popup menu items, refer to “About the
wire sheet popup menu items”.

Figure 43. Wire sheet popup menu
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For a description of the wire sheet, refer to “wiresheet-WireSheet”.

About the property sheet popup menu

The following image shows the property sheet popup menu. For descriptions of wire sheet pop-

up menu items, refer to “About the property sheet popup menu items”.

Figure 44. Property sheet popup menu
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For a description of the property sheet refer to “EC-NetAX pro — PropertySheet”.

Px Editor popup menu

The Px Editor popup menu appears when you right-click on an object in the Px Editor view.
The menu commands are context-sensitive and are dimmed or available, depending on the

type of object that you select.

The following image shows the Px Editor popup menu. For descriptions of the Px Editor popup
menu items, refer to “About the Px Editor popup menu items”.
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Figure 45. Px editor popup menu
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For a description of the Px Editor view, refer to “EC-NetAX pro - WbPxView”.

Types of data-presentation controls and options

Workbench views often present information in text fields, charts, or tabular layouts. Similar
views share many of the same types of controls and options features. Those common features
are described, by category, in the following lists:

+ Table controls and options

These controls affect the display of information in a table view. For details see “Table con-
trols and options”.

+ Batch editing

Batch editing is available in many table views. For details see “Batch editing (or batch
processing)”.

+ Chart controls and options

These controls affect the display chart views. For details see “Chart controls and options”.

Table controls and options

Many views that present information in a table have one or more of the following display fea-
tures and use one or more of the controls and options described in the following list:

+ On Demand History

This “play” button icon is available for the History Table view. Click the button to start On
Demand History updating. The button changes to a “pause” button icon while On Demand
History is active. See also, “About On Demand history views”.

« Data parameters
These controls include Delta (for history logging) and Time Range settings.

+ Delta reporting option
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This option is useful for history logging, when you want to display value changes (delta)
in your report. Refer to “About delta logging” for information about delta logging.

+ Time range option list

This list has a variety of predefined time range options, including an option that allows
you to restrict your data presentation to a particular date and time range that you

specify.
Title bar

This area of the table displays the name of the data collection on the left side of the title bar
and in some tables (collection table, history table, alarm extension manager, and others)
displays the total number of records in the table on the right side of the title bar.

Column headings
Each column of data has a title that indicates the data type.
Column boundaries

Each column has a movable column boundary that can be used to re-size the column using
the mouse control. Stretch or shrink column width by dragging the column boundary, as
desired. Use the Reset column widths menu item to reset all column widths to their default
size.

Table Options menu

This menu is located in the top right corner of the table and provides one or more of the
following controls and options. The standard table options menu includes the following
items:

+ Reset column widths

This menu item sets all columns in the table to their default widths. This is useful if you
manually changed widths of columns, and now some contents are hidden (even after
scrolling).

+ Export

This menu item opens the Export dialog box where you can choose to export the table
to PDF, text, HTML, or CSV (comma separated variable).

+ Context-sensitive menu items

Additional context-sensitive menu items appear in the table options menu, depending
on the component that you are viewing. These additional menu items allow you to se-
lect or deselect the item in order to display or hide the column data in the table.

Batch editing (or batch processing)

Batch editing is available in many of the table views in Workbench. This is a process of editing
or processing more than one record at a time and typically includes the following general steps:

.

Select multiple rows in a table by pressing the Ctrl or Shift key while clicking the desired
rows.

Use the popup (right-click, context-sensitive) menu or a toolbar icon to select an editing
command that performs an action or opens a dialog box editor that is appropriate for the
view.

Edit appropriate fields if a dialog box is used and click the OK button to process the edits.
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NOTE: Some actions, such as moving rows, or editing certain types of fields, are not appro-
priate for batch editing. In these cases — even though you can select multiple rows in the ta-
ble, the action will be performed on only one (usually the top, or highest) selected record in
the table.

The following image shows an example of batch processing three alarms by selecting three
rows in a table view and using the popup menu. In this case all three alarms are acknowledged
when the Acknowledge command is selected.

Figure 46. Batch processing (acknowledging) multiple alarms
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Chart controls and options

Many views that present information in a chart have one or more of the following display fea-
tures and use one or more of the controls and options described in the following list:
Figure 47. Chart view controls and options

Data Parameters
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« Data parameters
These controls include Delta (for history logging) and Time Range settings.
+ Delta reporting option

This option is useful for history logging, when you want to display value changes (delta)
in your report. Refer to “About delta logging” for information about delta logging.

+ Time range option list

This list has a variety of predefined time range options, including an option that allows
you to restrict your data presentation to a particular date and time range that you
specify.

+ On Demand History

This “play” button icon is available for the History Chart view. Click the button to start On
Demand History plotting. The button changes to a “pause” button icon while On Demand
History plotting is active. See also, “About On Demand history views”.
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Chart Title

This area of the chart displays the name of the chart. This title is editable in the chart build-
er view.

Y Axis

Displays units for the y axis.
X Axis

Displays units for the x axis.
Zoom Controls

Zoom controls appear when you drag the mouse cursor left-to-right or top-to-bottom in
order to zoom into the plotted data area. Use the zoom control to reduce the magnification
amount, or to move the chart left, right, up, or down. You can reduce the zoom level in in-
crements by using the “decrease zoom” icon . You can restore normal view (no zoom) in

one click by clicking the “normal view” icon [&l. Zoom Controls in Hx Web profile view are
available from a popup menu, shown below, that is activated after you click once on the
chart area.

Figure 48. Hx chart popup menu (for zoom controls)
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The popup menu includes the following control-related menu items:

3

.

.

Zoom In—zooms in one increment each time you select this menu item.

Zoom Out—zooms out one increment each time you select this menu item.

Original View—returns to the non-zoomed display (only available if you have zoomed in).
Higher Quality—toggles between higher and lower quality graphic display for the chart.
Charted Values

The color of the line and type of line is editable in the Chart Builder view.

Popup menu (Export)

The popup menu displays the PDF Export menu item. This menu item opens the Export
dialog box where you can choose to export the chart to PDF, text, HTML, or CSV (comma
separated variable).

NOTE: This export function works only with charts that are using a single history. Multiple
histories do not export in a usable format.

Tool Tip

When you “hover” the mouse pointer over the chart, a “tool tip” displays the date, time, and
value of that location in the chart. The values are defined by chart axes and not the values
of the actual data points.

Customizing the environment

You can customize your Workbench GUI as well as many of the settings in the Workbench en-
vironment. Some settings require an acknowledgement via the OK button on a dialog box,
while others are invoked immediately and saved automatically on exit from Workbench. For
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example, when you exit Workbench with four tabbed windows in your view pane, those same
four windows will be displayed the next time you open Workbench.

You can customize the Workbench environment in the following ways.
+ Creating Additional Windows

+ Editing popup menu “new” item

+ Creating tabs in the view pane

+  Working with the Wire Sheet view

+ Types of Workbench options

Creating Additional Windows

The Workbench allows you to create multiple fully functioning Workbench windows. Choos-
ing File: > New Window from the menu bar, creates a duplicate of your current Workbench
window.

After you create multiple windows, you can then customize each individual window, as needed,
to access different information, allowing you to see multiple concurrent views. You can also
copy and paste items from one window into another window.

Editing popup menu “new” item

You can change the menu items that display on the context-sensitive popup menu by editing
the files under the Workbench subfolder. For example, the following image shows the “new-
Widgets.bog” file that has been edited so that a “boundLabel” widget appears in the popup
menu under the New submenu.

Figure 49. Customizing the popup menu

Adding a widget to "newWidgets.bog” file
adds the menu item to the popup menu.

i [A] Label
ez S Vo -
Fe e Oy Copy S+ | 6] BarderPane
—+Dleorderbare || paste cutvy
Duclicate Chel+D

Creating tabs in the view pane

The Workbench allows you to create multiple tabbed views within the view pane of Work-
bench window, as shown below, by doing one of the following.

« From the menu bar, select File: > New Tab.
« If tabs already exist, right-click on a tab and select New Tab from the popup menu.

The new tab has a view identical to the previous one.
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Figure 50. Tabs in view
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As needed, you can use each tab to display a different view, component, or even host, all within
the same Workbench window. When you select a tab (make it active), the locator bar shows
the current path and view. Also, the menu and tool bars update to show appropriate options
for the current view.

From the view of the active tab, you can copy items, select another tab, and then paste them in-
to that view. You can also drag items into an active view from the (Nav or Palette) side bar.

In the Workbench view pane you can use tabs to help organize and selectively display
information.

Only one tab may be active at a time. In addition to simply clicking on a tab to make it active,
you can select File: > Next Tab from the menu bar to move to the next tab, moving left to
right, or you can move to the last tab by choosing File: > Last Tab from menu bar.

To close a tab, do any of the following:

+ Right-click a tab and choose Close Tab to close that tab, or

» Right-click a tab and choose Close Other Tabs to close all tabs except that tab.
+ From the menu bar, choose File: > Close Tab.

The currently active tab is closed.

Working with the Wire Sheet view

The Wire Sheet view has the following unique controls and features.
+ Zoom controls

Zoom controls appear on the Workbench toolbar when the Wire Sheet view is active. Click
the Zoom In, Zoom Out, and Zoom Reset buttons, as needed to adjust the size of objects
in the view.

Figure 51. Zoom controls in the Wire Sheet view
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Wire Sheet maximum size limits

Starting in AX-3.6, you can limit the size of the wire sheet by setting size of the wire sheet
in the Options dialog box. From the Workbench main menu, select Tools > Options to
open the dialog box. Then select the Wire Sheet option and enter a desired maximum value
in the Max Width and Max Height fields, as shown, below. Click the OK button to com-
plete the setting change. If you decrease the maximum wire sheet size, objects are reposi-

tioned to stay within the view, after the size change.

NOTE: You may need to refresh the wire sheet view to see the changes in wire sheet size
and object repositioning. Also, the wire sheet borders may not be visible until you zoom

out in the wire sheet view.

(O ptio|
Jptions

Figure 52. Setting maximum wire sheet size
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+ Object linking
Following are methods for performing object linking.

+ Drag wire

Move the mouse over the In or Out node of a wire sheet object (glyph) until the area is
highlighted and the mouse pointer changes to a white arrow. Click and drag from the
point of origin to the desired In or Out node of the target object and release the mouse

button to complete the link. See the following image.

Figure 53. Basic object linking
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Dragging a “wire” to a vacant slot on a wire sheet object causes the Link dialog box to open, as

shown below.
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Link dialog box
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Select the desired slots in the Link dialog box and click the OK button to create the link.

You cannot select invalid (dimmed) slots in the dialog box.

Slot selection is indicated by a red rectangle surrounding the selection.

Object names are listed at the top of their respective columns to identify them and to indicate
which object is the “Source” and “Target” object.

A summary of the currently selected slots displays above the OK and Cancel buttons.

.

Multi-linking (continuous link state)

You can maintain a continuous “link state” as you drag connection wires to link to mul-
tiple target objects from a single source object. This allows you to link from a single
source to as many targets as you want without having to click on the source object to
re-initiate each link. To do this, hold down the Shift key any time you release the mouse
button. If the mouse pointer is over a valid object node, a link is established or the Link
dialog box opens to complete the link. This continued link state is indicated by the tar-
get end of the wire “sticking” to and moving with the mouse pointer. Release the Shift
key and click anywhere or touch any key to deactivate the link state.

Link Mark

» o«

Link Mark is a feature that allows you to perform “one to many”, “many to one”, or
“many to many” linking in a single operation. Use the following three menu item com-
mands to create many links in at the same time.

Link Mark

Select the Link Mark command to define one or more selected objects as a link source
or link target. This command specifies that the selected objects are to be one side of the
link operation. The names of the “marked” objects display as part of the Link Mark or
Link From command in the popup menu.
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Figure 54. Using Link Mark
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Select the Link From command to define one or more selected objects as a link source or link
target. This command opens the Link dialog box with the “marked” object as the source object.

You can still change source and target roles in the dialog box using the Reverse button [l
Link To

Select the Link To command to define one or more selected objects as a link source or link tar-
get. This command opens the Link dialog box with the “marked” object as the target object.

You can still change source and target roles in the dialog box using the Reverse button [l
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+ Link Highlighting (AX-3.6)

Starting in AX-3.6, a link highlighting option (enabled by default) is available on the wire
sheet. Link highlighting makes it easier to distinguish links on a crowded wire sheet. Link
highlighting is comprised of the following features:

Link MumericSource, out - = MumericTarget3 (4).in10
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Figure 55. Link highlighting on the wire sheet
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Colored link highlights

When you select a component on the wire sheet, all links associated with the selected object
display with a colored outline around them.

NOTE: Highlighted links do not mean that the LINK is selected.

Distinct coloring

Selecting additional components causes subsequent link highlights to display a different
color highlighting (up to 20 colors before repeating).

Custom colors

You can customize the colors by editing the “system.properties” file (in the nav tree “lib”
folder, under MyFiles > Sys Home) as follows:

niagara.wiresheet.linkHighlightColor1=#00FF00
...and following, to...
niagara.wiresheet.linkHighlightColor20=#00FFFF

Each color is specified using the standard hexadecimal notation used for HTML color
display.

Off-view link navigation
Link “knob” indicators (used for off-view or crowded view links) have additional properties.
+ Off-view linking

Double-clicking on the knob hyperlinks to the component on the opposite end of the
link, displaying the wiresheet view with the linked knob highlighted.

+ Goto Link command

Right-clicking on the knob displays a GoToLink command on the popup menu. Select-
ing this command hyperlinks to the component on the opposite end of the link, display-
ing that component’s wiresheet view with the linked knob highlighted.

« Delete Links command

When one or more off-view links (or knobs) are selected, the Delete Links command
(available on the popup menu) deletes all selected links and their associated off-view
references. This is effective for multiple selected in-view and off-view (knob) links.

« Link selection

A Link Selection command is available from the popup menu when multiple links over-
lap on the wire sheet. Right-click on a link knob on the active wire sheet to select this
command, then choose the desired link from the secondary popup menu.
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Figure 56. Link Selection menu
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Starting in AX-3.6, you can edit a link directly from the wire sheet view using an Edit Link
dialog box - instead of the source component’s Link Sheet view. To open the dialog box,
right-click a single link (not multiple links or knob links) and select Edit Link from the pop-
up menu. The Edit Link dialog box displays, as shown below.

Figure 57. Edit Link dialog box
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Use the property fields to change any of the following link property values: Source Ord, Source
Slot Name, Target Slot Name, or Enabled. Click the OK button to commit and save the link

changes.

Types of options

Use the Workbench options dialog box to customize your Workbench GUI and to set other
preferences. Open this dialog box by selecting Tools > Options from the menu bar.

Figure 58. Options dialog box
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The following options are available in the options dialog box:

+ General options

+ Alarm Console options

+ Alarm Portal options
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+ Text Editor options
+ Lexicon Editor options
+ Bajadoc options
+ Station Copier options
+ R2 Platform Tool options
« DPx Editor options
Wire Sheet options

General options include the active Workbench “Theme”. See “About Workbench themes”.

General options

General Workbench options include settings for a variety of Workbench display and behavior
options.

Figure 59. General options
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NOTE: The Time Format and Unit Conversion parameters affect values that are displayed
when connected to a station using Workbench—regardless of the User preferences (set under
User Manager). The User preferences that are set under the User Manager are in effect when
connected to a station by a browser.

3

Time Format

Choose from a format option to set the way that Workbench time values are displayed by
default.

Unit Conversion

Choosing the English or Metric option converts values that are displayed in Workbench to
the chosen unit type. Selecting None leaves units in the state that is assigned at the point
facet.

AutoLogoff Enabled

Setting this parameter to True will activate the AutoLogoff feature. When activated, the
AutoLogoff feature will automatically log off a user from a platform when there is no activ-
ity detected in Workbench for the period specified in the AutoLogoff Period field. Setting
this parameter to False will disable the AutoLogoff feature.

AutoLogoff Period
Time until Workbench logs off a user when AutoLogoffEnable is set to True.
Prompt For Name On Insert

When set to True, Workbench will display a Name dialog box, when a new item is added
to the workspace.

Font Size
Choose between Normal and Large font options for Workbench display.
Active Theme

Choose between Frost, Lucid or Palladium “built-in” theme options for Workbench display.
See “About Workbench themes”.

Allow User Credential Caching

(AX-3.7 and later) If set to true (default), client access of a host (platform) or station allows
a checkbox option to “Remember these credentials” in the popup Authentication
dialog. If selected, the connection credentials are then cached and available in the “Creden-
tials Manager” (Tools > ManageCredentials).

This is a “convenience” mechanism. However, for best security it is recommended to glob-
ally disable user credential caching by setting this property to false. This way that option is
unavailable in the Authentication dialog. For related details, see “Credentials manager”.

Locale

(AX-3.8 only) Specifies the locale used by the Workbench VM, typically with a two-digit
(ISO 639) code. Formerly, the Workbench locale had to be specified in the !lib/system.prop-
erties file.

Alarm Console options

Alarm Console options allow you to customize both the appearance and behavior of the alarm
console.
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Figure 60. Alarm console options
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Alarm console options include the following:

3

Notes Required on Ack

This option, when set to true, causes the Notes dialog box to open whenever you initiate an
alarm acknowledgement from the alarm console.

Sounds Enabled

When set to true — causes a sound to accompany an alarm. You can also set this value
under the Alarms menu in the Workbench main menu when the Alarm Console view is
active.

Default Sound File
Sets the path to the default sound file.
Continuous Alarm

When set to true, causes an alarm to repeat continually, until it is acknowledged or cleared.
This option works together with the Continuous Alarm Delay property. You can also set
this value under the Alarms menu in the Workbench main menu when the Alarm Console
view is active

Continuous Alarm Delay

When Continuous Alarm is enabled, this property causes a “pause” time between in the
continuous alarm sound. The continuous alarm is interrupted for a time equal to the value
of this property.

Alarm priority coloring

The following properties work together in combination to produce a range of colors that
are assigned to the possible range of alarm priorities (1 - 255).

+ Low Priority Color

Choose a color to designate a low priority alarm.
+ Mid Priority Color

Choose a color to designate a mid priority alarm.
+ High Priority Color

Choose a color to designate a high priority alarm.

The highest priority (priority 1) is assigned the color of the High Priority Color setting.
The Mid-Priority and Low Priority colors are assigned likewise, to Mid and Low Priority
alarms. Alarm priorities that fall between these priority levels are assigned colors on a
color-scale along a path defined by the three assigned colors.
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+ Time Zone Display

This property allows you to choose to display alarm record timestamp values in the time
zone of the alarm console view (Console) or in the time zone of the alarm source (Source).

+ Alarm Class Mapping
Provides a way for you to create alarm classes and map specific alarms to classes.
+ Alarm Ack Responses

Use this property to create one or more text entries that you can use to populate the Notes
dialog box when acknowledging an alarm. When the Notes Required on Ack is set to true,
the Notes dialog box displays an additional option list containing any entries you create
with this property. Use the button to open the associated Edit dialog box and add, edit, or
remove response options, as desired. When the Notes Required on Ack is set to false, these
Alarm Ack responses are not visible.

+ View Instructions

When set to true, this property causes the alarm Instructions pane to display across the bot-
tom of the Alarm Console. Instructions display in the pane for any single selected alarm
that has associated instructions.

Alarm Portal options

Alarm Portal options allow you to customize both the appearance and behavior of the alarm
console.

Figure 61. Alarm portal options
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Alarm Portal options include the following:
+ Tray Icon Enabled
When set to True, displays an alarm icon in the system tray when the alarm portal is active.
+ Alarm Popup Enabled
When set to True, displays an alarm popup window when the alarm portal is active.
+ Alarm Popup Always On Top

When set to True, causes the alarm popup window to stay on top of other windows when
the alarm portal is active.

+ Alarm Popup Uncloseable

When set to True, makes the alarm popup window uncloseable when the alarm portal is
active.

+  Kiosk Mode

When set to True, the alarm portal opens in Kiosk Mode the next time it is started. For re-
lated information, refer to “ec-netax pro - KioskService”, the AX Graphics Guide section
“About Kiosk Profiles”, and the engineering notes document AX Kiosk Mode.

» Reconnect Interval
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The alarm portal checks for “disconnected” alarm consoles. If a console is disconnected, a
reconnect is attempted within the Reconnect Interval time.

Text Editor options

These options offer a whole range of ways to customize the presentation and behavior charac-
teristics of the text editor tool. Settings include text and symbol color coding options, as well as
key bindings for shortcut keys. The text editor options properties are shown .

Figure 62. Text editor options
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Lexicon Editor options

These options offer ways to customize the default settings of the lexicon editor. The lexicon ed-
itor options properties are shown and described in “Lexicon Editor view”. All of these proper-
ties may be overridden using the options that are available in the Lexicon Editor.

Figure 63. Lexicon editor options
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Bajadoc options

Baja reference documentation includes both Java API details as well as Baja slot
documentation.

+ Show Baja Only

When set to True displays only the reference documentation for slots (Properties, Actions,
and Topics). When set to False, documentation on the Java constructors, methods and
fields is also displayed.

« Flatten Inheritance

This option allows you to flatten the inheritance hierarchy into a single set of documenta-
tion. When set to False only the Java members and Baja slots declared in the specified class
are displayed.
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When set to True all Java members and Baja slots inherited from super classes are also
shown.

Station Copier options

This feature allows you to easily ignore critical data when copying stations to and from a plat-
form. These properties allow you to configure station transfer options from the Workbench
view. The properties include options to specify which directories and files to ignore when copy-
ing a station (by use of space delimited pattern filters). You can also use the property options to
set default values for copying station alarm, history, job and critical data directories (hidden).

Figure 64. Station copier options
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» File Pattern Exclude List

Use this option to set a pattern filter that excludes any specified file types from being copied
with the station.

+ Directory Pattern Exclude List

Use this option to set a pattern filter that excludes any specified directories from being cop-
ied with the station. For example, if you wanted to exclude copying all directories in the sta-
tion that begin with the letters “lighting”, then you could type “lighting*” in this field.

+ Copy options: (Station Alarm Data, Station History Data, Station Jobs Data)
These properties allow you to choose to copy (true) or not copy (false) certain station data.
Niagara R2 Platform Tool options

These options apply when platform connected to a JACE-603 or JACE-645 (or RB-603/RB-645
“retrofit board” JACE) being configured for Niagara R2.

Figure 65. Niagara R2 Platform Tool Options
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+ Local Niagara R2 Installation

Specifies the local file path to the Niagara R2 installation directory. The default value of the
installation folder (') is typically inappropriate. However, you can alternatively specify the
source Niagara R2 installation folder when running the Installation Wizard, launched from
the Platform Administration view of the JACE-603 or JACE-645.

» File Pattern Exclude List

Use this option to set a pattern filter that excludes any specified file types from being copied
with the station, when using the Station Copier.

+ Directory Pattern Exclude List
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Use this option to set a pattern filter that excludes any specified directories from being cop-
ied with the station, when using the Station Copier. For example, if you wanted to exclude
copying all directories in the station that begin with the letters “lighting”, then you could
type “lighting*” in this field.

For related details, refer to the Retrofit Board Niagara R2 Install & Startup Guide.

Px Editor options

These options offer ways to customize the presentation and behavior characteristics of the Px
editor view. The Px editor options properties are shown and described in the following list:

Figure 66. Px editor options

g P Edibar
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| ) Animate Bindings ﬂ
+ Show Grid

This property sets the default condition of the Px editor grid. Select true to make the grid
visible by default or select false to make the grid hidden by default. Either setting may be
changed at any time using the Px Editor menu.

+ Grid Size
This property sets the size of the grid in the Px editor.
+ Grid Color

This property sets the color of the grid in the Px editor. Click in the color field to display
the Color Choose dialog box. Use the Color Chooser to set the color that you want to assign
to the grid.

o Use Snap

This property sets the default condition of the Snap feature in the Px editor. Select true to
make objects snap to locations when they are at a distance equal to the Snap Size. Select
false to disable the snap feature. Either setting may be changed at any time from the Px Edi-
tor menu.

+ Snap Size
Set an integer value in this field to define the interval between successive snaps.
+ Show Hatch

This property sets the default condition of the Px editor hatching that displays on objects
on the Px editor canvas. Select true to make the hatching visible by default or select false to
make the hatching hidden by default. Either setting may be changed at any time using the
Px Editor menu.

« Hatch Color
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This property sets the color of the hatching in the Px editor. Click in the color field to dis-
play the Color Choose dialog box. Use the Color Chooser to set the color that you want to

assign to the Px editor hatching.
+ Preserve Identities

When set to true, this property allows you to explicitly turn on support for encoding all
names and handles on a Px page.

+ Animate Bindings

This option, true by default, allows the Px Editor to display live binding data for widgets in
Px Edit mode. If you set this option to false, then no data animation occurs in the Edit
mode, although animation does occur, as expected, in View mode.

Wire Sheet options
Wire sheet options allow you to customize the appearance of the wire sheet.

Figure 67. Wire sheet options
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Wire sheet options include the following:
+ Show Grid

When set to True displays a grid background on the Wire Sheet view.
+ Show Status Colors

When set to True, will display a different color for each status when it appears in the wire
sheet.

+ Show Thumbnail

When set to True — provides a small “thumbnail” view of the whole Wire Sheet for orienta-
tion and navigation purposes.

o Thumbnail X
A field is provided here for setting the X axis for the default position of the thumbnail view.
o Thumbnail Y
A field is provided here for setting the Y axis for the default position of the thumbnail view.
+ Link Highlighting (AX-3.6 and later)

When set to True — turns on link highlighting. See also, “Working with the Wire Sheet
view”.

+ Max Width (AX-3.6 and later)

Use this property to specify a maximum size for the wiresheet width. See also, “Working
with the Wire Sheet view”.

+ Max Height (AX-3.6 and later)
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Use this property to specify a maximum size for the wiresheet height. See also, “Working
with the Wire Sheet view”.

About themes

The Workbench themes options allow you to customize the appearance of the Workbench dis-
play. Generally speaking, a theme is a predefined collection of design elements that determine
the way an application appears to the user. Within the Niagara Framework, a theme is a mod-
ule that controls the appearance of Workbench on the local computer by defining fonts and
colors, as well as the icons, used in the Workbench display. Choosing a different theme affects
only the Workbench appearance, there is no other impact.

You can customize your Workbench display by selecting the theme that you prefer. In addition
to permitting you to customize your Workbench display, themes can also be used to give
Workbench a “branded” appearance.

Types of themes

Within Workbench, there are standard “built-in” themes that you can use. You can also create
and use custom themes. The built-in themes are installed as part of the Workbench applica-
tion. Starting in AX-3.7, there are three built-in themes available for use, as shown below.

+ Frost

Displays a medium-blue color scheme with many custom icons.
+ Lucid

Displays a blue and gray color scheme. This is the theme applied to Workbench by default.
+ Palladium

Displays a gray color scheme.

Figure 68. Workbench Built-in Themes
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To change the theme, click Tools > Options to see the active theme in the General tab. Click
the Active theme drop-down arrow and click on a different theme option to select it as shown
below. In order for the theme change to take effect, you must exit Workbench and restart it.
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Figure 69. Active Theme drop-down in General settings
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NOTE: To save changes made in Workbench Options, such as a theme change, you must
close/exit Workbench using File menu options or click the window’s close box. Closing Work-
bench in the console will not cause those changes to be saved.

Define a default custom theme for your brand

You can do this by creating a new custom theme module that specifies colors (such as, corpo-
rate colors), fonts, and icons to be used in the Workbench display and designating this as the
default theme. The Workbench automatically selects this theme if the user does not make an-
other selection. You can also “force” the use of the default theme, effectively locking Work-
bench into using the default theme.

Designate a default theme

This procedure explains how to designate a default theme and lock it.

Step 1 Open the brand.properties file in the /lib folder and add the following two lines of text,
replacing “themeName” with your custom theme name, as shown below.

workbench.theme.default=themeName

workbench.theme.locked=true

15 | workbench.theme.default=Citrus
14 | workbench.theme.locked=true

Step 2 Click File > Save to save your changes in the brand.properties file.

Step 3 Restart the Workbench for this change to take affect.

NOTE: Locking the theme hides the Active theme drop-down, normally visible in
Options, so that no other theme can be selected.

About theme modules

As with all Workbench modules, a theme module contains the build.xml and module-include.
xml files. A module is identified as a theme module by adding a <defs> tag with a themeName
definition within module-include.xml, as shown below.

Figure 70. <defs> tag within module-include.xml file.

1 <!-- Module Include File —->
<!-— Defs —->

<defs>
<def name="themeName" wvalue="themeCitrus"/>
</defs>

Mo s L
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Also required in a theme module, is at least one text file with the extension .nss located in /src/
nss. A Niagara Style Sheets (NSS) file is used to enable styling of fonts, colors, and other attrib-
utes of the Workbench display using syntax and keywords similar to those used in HTML Cas-
cading Style Sheets (CSS).

NOTE: Although NSS shares some syntax and keywords with CSS, the languages are not the
same. NSS performs cascading like CSS, however the syntax is different. Also, NSS has no posi-
tioning selectors while CSS has many. Refer to the “AX Developers Guide” for more details.

All of the resources files (NSS files, .PNG, etc.) for you theme module must be located under
the /src folder and must be specified within build.xml with the standard <resources> tag:

<resources name="nss/**" />

NOTE: With all resources tags, you must omit the “/src” directory from the value provided for
the “name” attribute.

You can override any Workbench icons with custom icons in your theme module. Your custom
icon image files (*.PNG) must be located in the /src/imageOverrides folder within your theme
module. Subfolders within /imageOverrides correspond to the name of the module containing
the icons you wish to override. For example, to override Workbench icon located in the icons
module your .PNG file must be located in /imageOverrides/icons/x16 in your theme module
and that exact path must be specified in a resources tag within the build.xml file for your theme
module:

<resources name="imageOverrides/icons/x16/**" />

NOTE: When overriding icons your must duplicate the original filenames and folder structure
exactly. Otherwise, the path to the icons will be incorrect and the custom icons will not display.
You can determine the correct path and filenames to use by examining the feature whose icons
you want to override and look inside the corresponding module for the path to those icon files.

For example, if overriding the alarm icon in the alarm module, first examine the contents of
the alarm module and note the filename and path to that icon (alarm/com/tridium/alarm/
icons/alarm.png), as shown below. Next, duplicate that path under the /imageOverrides folder
in your theme module, placing your image file named alarm.png in: /imageOverrides/alarm/
com/tridium/alarm/icons. Next, specify the exact path in a resources tag within the build.xml
file for your theme module:

<resources name="imageOverrides/alarm/com/tridium/alarm/icons/alarm.png" />

Figure 71. Determine filename and path to icon for override
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Also, you can have several themes sharing the same set of custom icons by placing multiple
NSS files inside the /src/nss folder. Each of the NSS files will be individually selectable as a
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separate theme in the Active Theme drop-down. Doing this eliminates the need to have dupli-
cate sets of icons in separate theme modules.

The following procedures describe how to:

+ Create a new theme module.

+ Copy resources from a built-in theme module.

+ Modify design elements in the NSS file.

+ Build ajar file for the theme module.

» Activate the new theme module.

Create a new theme module

This procedure describes the steps used to create a new theme module.

Step 1

In the Workbench Nav pane, under My File System, navigate to AX-3.7.x and expand

it. Create a new /themes subfolder there to store your custom themes. This is where
the new theme module that you create will be located.

Step 2
shown below.

Click Tools > New Module and fill-in the fields in the New Module dialog box, as

+ Enter the path to the /themes folder created above (for example: C:/niagara/EC-

Net-3.7.x/themes).

+ Enter a name for the theme using this naming convention, themeName (for exam-
ple: themeCitrus).

+ Enter a Preferred Symbol (four-letter abbreviation) for the new theme name (for
example: thci).

+ Enter a Description (for example: EC-NetAX Pro theme module).

« Enter a Vendor (for example: Distech).

o Clear the checked check box for Create Lexicon and click the Next button to ad-
vance to the next screen.

Figure 72. New Module dialog box

Step 3
Step 4

Remove any Dependencies listed in the dialog box and click the Next button.

No Packages are required. Click the Finish button to create the new module.

The new module contains the two required XML files: build.xml and module-include.
xmlas shown below.

Figure 73. New module
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Step 5 Using a text editor, open module-include.xml and add the <defs> tag to identify this
module as a theme module, as shown :

Figure 74. Add <defs> tag in module-include.xml

1 <!—— Module Include File ——>
<!-— Defs —->

4 <defs>
= <def name="themeName" wvalue="themeCitrus"/>
6 </defs>

8 <!—— Types —-->
g |%|<t,ype5>
10 </types>

Copy resources from a built-in theme module

This procedure describes how to obtain resources from another theme module and add appro-
priate resources tags to the build.xml file in the new theme module.

Prerequisites:

In addition to the .xml files mentioned earlier, the theme module requires that at least
one Niagara Style Sheet (NSS) file be located in: /src/nss. Copying an existing NSS file,
along with other resources, from one of the built-in themes will save time and reduce the
chance of introducing errors.

Step 1 In the Nav pane under My File System, navigate to your new theme module in the
/themes folder. Create a new subfolder there named /src (for example: /themes/theme-
Citrus/src). This is where all resources must be located.

Step 2 In the Nav pane under My Modules, scroll down to locate the built-in theme modules
(themeFrost.jar, themeLucid.jar, themePalladium.jar).

Double-click themeLucid.jar to display its resources. Select all the resource folders and
copy them.

Step 3 Under My File System, navigate to your new theme module in the /themes folder, and
paste the copied resource folders into the /src subfolder.

Step 4 Using a text editor, open the build.xml file in your theme module and add a <resour-
ces> tag for each folder copied from the built-in theme module , as shown :

Figure 75. Specify resources in build.xml

<module

name = "themeCitrus"

bajaVersion = "0O"

preferredSymbol = "thei”

dezcription = "Custom theme module"
8 vendor = "MyCompany"

11 <!-- Resources —->

12 E} <resources name="imageOverrides/icons/x16/% %" />
13 <resources name="nss/ /% %" />

14 <!-—<resources name="doc/*.*" />—->

15 </module

At this point, your new theme module has everything needed to build a .jar file. How-
ever, since the NSS file was copied from another theme, your new theme will have an
identical appearance. To make your new theme distinguishable from the other, you
must change design elements within the NSS file.
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Modify design elements in the NSS file

This procedure briefly describes an approach to modifying design elements in an NSS file to
give Workbench a unique appearance.

Step 1 In the Nav pane under My File System, navigate to your theme module and expand it
to access the NSS file in /src/nss. Using a text editor, open the NSS file and scroll to
the Define statements (#define...) located at the top of the NSS file. These statements
define certain font and color styles that typically are applied repeatedly throughout the
NSS file. Modifying a few color definitions in the #define statements will have the most
noticeable impact on the Workbench display.

Colors may be specified as RGB colors in hexadecimal format (for example: #000,
#fttfff ); or in many cases, colors may be specified according to their common English
names, such as gray, white, blue, etc.

NOTE: Refer to the AX Developer Guide section on HX Theming for more informa-
tion on NSS file properties. Also, an Internet search for “html color codes” will result
in many color code examples.

Step 2 After completing modifications, save the NSS file.
Build a .jar file for the theme module

This procedure describes building a .jar file for a new theme module so that the module can be
deployed in Workbench.

Step 1 Open the Niagara Console and run the following build command, as shown :

build -p [path to build.xml file] jar

Figure 76. Enter command in Niagara Console to build .jar file
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Step 2 Confirm that the .jar file (for example: themeCitrus.jar) was created in the /modules
folder.

Step 3  Exit and restart Workbench to load the jar file.
Activate the new theme module
This procedure covers activating a new theme module.

Step 1 Select the new theme module in Tools > Options under the Active Theme drop-
downas shown below.
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Figure 77. New theme is selectable in the Active Theme drop-down
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Step 2 Click File > Close and restart Workbench, the new theme will be active.

NOTE: To save changes made in Workbench Options, such as a theme change, you
must close/exit Workbench using File menu options or click the window’s close box.
Closing Workbench in the console will not cause those changes to be saved.
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CHAPTER 3 DAT1A AND CONTROL MODEL

Torics COVERED IN THIS CHAPTER

About control points
About point extensions
About control triggers
About point status
About writable points
About composites

This chapter provides details about the Niagara data control model.

In any station, all real-time data is normalized within the station database as points, which are
a special group of components. Each point represents one data item.

NOTE: This applies to a Supervisor station as well as a remote controller station. Proxy points
under a NiagaraNetwork, for example, are used for communication between remote controller
and supervisor. For more details, refer to the NiagaraAX Drivers Guide section “About the Ni-
agara Network”.

About control points
In the most simple form, points are control points. Find them in palette control: Points.

Figure 78. Control points
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Control points are the foundation for all points in the station, including all proxy points.
+ Types of control points

+ Other control components

+ About data value categories

+ About point types

+ About point Out

+ About point inputs

+ About point actions

+ About point facets
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Types of control points

As shown in Table 3-1 there are 8 different simple control points. Each type reflects a combina-
tion of a data (value) category and a point type.

Control point types

Boolean Category Numeric Category Enum Category String Category
BooleanPoint NumericPoint EnumPoint StringPoint
BooleanWritable NumericWritable EnumWritable StringWritable

See “About data value categories” and “About point types”.

Other control components

Apart from the 8 simple points, many other components are found in both the control palette
and the kitControl palette. Briefly, these components include:

» Extensions

To “extend” point functionality. See “About point extensions”.
» Triggers

To provide periodic “actions.” See “About control triggers”.
+ Other control objects

Found in various folders in the kitControl palette. Use these to provide station control logic
based on data obtained from points. Example objects include (numeric) math types, (Boo-
lean) logic types, and a PID loop, among others. Also, a few point extensions are in kitCon-
trol. See the section “Application for kitControl components” in the kitControl Guide.

About data value categories

There are four distinct data value categories for points, as well as for other components (for ex-
ample, weekly schedules). These value types are:

+ Boolean
Represents a binary value with only two states, such as “Off” or “On.”
+ Numeric

Represents an analog value such as a temperature, level, rate or similar floating point num-
ber, or a varying count (integer). Double-precision (64 bit) values are used.

« Enum

Represents an enumerated state (more than two), such as a multi-speed fan with states
“Oft,” “Slow,” and “Fast.” Enums are often called multi-states or discretes. States typically
derive from established integer value/state name pairs.

» String

A string of one or more ASCII characters (and if alpha-numeric), often with some literal
meaning.

Among the four categories, numeric and boolean points are the most common, as data usually
falls into these two categories.
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About point types

Within each of the four point data categories, there are two point types:
+ (read-only) e.g. BooleanPoint or NumericPoint

Represents a read-only data item. Unlike with the writable point type, there are no “input”
type properties.

NOTE: As copied directly from the control palette, there is no application for read-only
points. However, proxy points based upon read-only points, identical except for a non-null
proxy extension and manner of creation, are both common and useful. For more details,
see “About the proxy extension”, or refer to “About proxy points” in the Drivers Guide.

o Writable

Represents a data item that can be written, as well as read by the station (typically). An ar-
ray of 16 “InN” inputs, each with a different priority level, is available to write the value. By
default, the point’s value can also be set with an operator-issued action (right-click com-
mand), available at priority levels 8 (override) and 1 (emergency). For more details, see
“About point actions”. Writable points also have other features. See, “About writable
points”.

About point Out

Each point has a property “Out” that provides real-time information as shown below.

Figure 79. point Out provides real-time information
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At a minimum, the Out property provides:
+ value

Current value of the data item, within one of four possible data categories. See “About data
value categories”.

o facets

Items affecting the display of the value, such as decimal places, engineering units, or text
descriptors for Boolean/enum states. See “About point facets”.

+ status

Current status of the data, meaning the health and validity of the associated value. Status is
specified by a combination of status flags, such as “fault,” “overridden,” “alarm,” and so on.
If no status flag is set, status is considered normal and appears by default as “{ok}.”

Status flags are set in a number of ways. See “About point status”.

» priority
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Currently active Niagara priority level (from a 16-level priority scheme), for writable con-
trol points only. For more details on priority, see “About the priority scheme”.

NOTE: All writable control points include priority in status, including writable proxy
points.Priority appears at the end of the Out value, by default formatted as “@ n”, where n is
1 to 16, or if the fallback value is in effect, formatted as “@ de £”. For example: “Of f {ok}
@ 1”‘

About point inputs

Writable points have 16 input properties: “Inl” to “In16,” corresponding to priority levels. As
needed, you can link up to 14 of these inputs to another component in the station. The follow-
ing image shows a BooleanWTritable with links made to 3 inputs.

NOTE: Read-only (plain) points do not have any input properties.

Figure 80. Example links made to priority inputs
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By default, a writable point’s glyph (shape on wire sheet) shows only inputs In10 and In16
“pinned” for linking. However, when linking to a writable point, the Link editor shows all avail-
able priority inputs. For more details, see “About the priority scheme”.

About point actions

Writable points have actions—by default, these appear in a right-click menu when you select a
point in Workbench view or in the Nav tree.

Figure 81. Actions available on right-click menu
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An action is a slot that defines a behavior. Some other control objects and extensions also have
actions.

In the case of the 4 writable control points, default actions include the ability to:
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+ Override the point at priority levels 8 (override) and 1 (emergency override), where control
can be independently set or “auto’ed” at either level. A level 8 override can be for a defined
(or custom) length duration, as specified in the action’s popup dialog. See “About override
actions”.

+ Set the value of the point’s “Fallback” property. See “About set (Fallback) action”.

Often, you modify a writable point’s default actions—see “Modifying default actions”.

About override actions

Whenever a writable point is controlled from an action issued at either override level, it has an
“override” status. By default, override status color is magenta as shown below. For more point
status details, see “How status flags are set”.

A manual (level 8) override action to a point (not “auto”) prompts for an override duration, see
the following image.

NOTE: Emergency overrides (level 1) do not have durations—these overrides are “permanent”
(until auto’ed).

Figure 82. Override action duration (“argument”) dialog
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By default, a “Permanent” override is the first choice in the drop-down list—the override val-
ue will remain effective until the next time this action is auto’ed. Other timed durations are
available, including a “Custom” selection in which a user specifies a duration in hours, mi-
nutes, and seconds.

If needed, you can limit the maximum duration of manual override using facets—see “Maxi-
mum override duration facet”.

After clicking OK, the override action is issued to the point—if this is the highest effective pri-
ority level, the writable point operates under this control. If this is a timed override, the action
is automatically auto’ed upon expiration of the override period.

About set (Fallback) action

Whenever a writable point has a “null” or “invalid” value at inputs In1—In16 (note this means
that both override levels are currently “auto’ed”), the Out slot is set to the value of the Fallback
property. For more details, see “About the priority scheme”.

By default, an operator-level user can change the Fallback property, using the “set” action. This
produces a popup dialog that displays the current Fallback value.
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Figure 83. Set action prompt to change writable point’s Fallback property
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From the set action prompt, a “Cancel” leaves the current Fallback property unchanged. Other-
wise, the Fallback property is set to the value entered (or currently displayed value).

NOTE: The set action prompt does not display (or accept) a “null” value for Fallback. However,
a Fallback of null can be entered from the point’s property sheet.

A common application for this feature is with NumericWritables used as setpoints, particularly
under a NiagaraNetwork. As Niagara proxy points are always read-only points (not writable
types), yet inherit any actions of the source point, this feature provides user access to setpoints
via px graphics without creating additional proxy points. In particular, this “set” action is de-
signed to work well with “SetPoint” type widgets (found in the kitPx palette). For related de-
tails, see the NiagaraAX Graphics Guide section “About Widgets”.

NOTE: Each of the four “constant” kitControl components also provides a “set” action that
works in a similar manner, including with kitPx widgets. However, a constant object (Numeric-
Const, BooleanConst, etc.), has no priority inputs or Fallback property—the set action simply
writes directly to the component’s current Out slot. For details, see the “About Constant com-
ponents” section in the NiagaraAX KitControl Guide.

Modifying default actions

Unless all the “defaults” for actions of a writable point are acceptable (display names, all actions
available, default user access), you may wish to modify action defaults. You can do this selec-
tively from the slot sheet of the writable point. For general information, see “About slots”, and
“Using the slot sheet”.

Or, using facets you can limit the duration of manual overrides—see “Maximum override dura-
tion facet”.

The following sections provide more details on slot sheet techniques:
« Display names — Change how the point’s popup action menu lists available actions

+ Action access — Limit the actions that are made available, either by user level or for all
users
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NOTE: As a “global” alternative to editing display names on slot sheets, you can edit the de-
fault values of lexicon keys, in this case for the control module for action type slots. For
details, see “Notes on English (en) lexicon usage” in the Niagara 4 Lexicon Guide. You can
also modify the display name of the same action in multiple points in a single operation, us-
ing the (default) “Batch Editor” view of the station’s ProgramService (Config > Services >
ProgramService). This is one of many examples of using the Batch Editor.Also, you can use
the Batch Editor to modify a config flag of the same slot on multiple components in a sin-
gle operation.

Display names

By default, action display names are generic (“Emergency Inactive” and so on). You can change
the display name for any action. From the slot sheet, click on an action’s Display Name for an
editor. When you change a display name from defaults, it appears in listed in bold.

Figure 84. Editing action display names from slot sheet
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When a user invokes an action, the popup menu lists possible actions by more meaningful de-
scriptors. For example, you could change the “set” action display name from “Set” to “Set
Fallback.”

Action access

By default, for any writable point, all actions are available to any admin-level user, and all ac-
tions except emergency-level ones are available to an operator-level user. As needed, you can
selectively “hide” actions (from any level user), or change default permissions for actions.

NOTE: From a Px widget, you can also disable Px access to a bound writable point’s actions, by
setting the “popupEnabled” binding property of the widget to false. In this case, access to the
point’s actions would still be available from the point’s property sheet or in the wire sheet, un-
less otherwise changed from its slot sheet. For related Px details, NiagaraAX Graphics Guide,
“Types of binding properties” section.

From the slot sheet, do this by editing the action’s config flags (right-click the action and select
Config Flags as shown below.
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Figure 85. Editing config flags of action to “hide” or change permission level
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In the Config Flags editor, you click to assign or remove config flags. As pertains to action
slots, the following flags are most often changed:

+ Operator

If checked, only operator-level access is needed to invoke the action. If cleared, admin-level
access is needed. For details on permission levels, see “About permission levels”.

+ Confirm Required

If checked, a second (confirmation) dialog appears after the action is invoked, before the ac-
tion executes. An example confirmation dialog is shown below. By default, this flag is
cleared.

Figure 86. Action confirmation dialog (from “Confirm Required” config flag)
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« Hidden

If checked, the action does not appear (is hidden) from the action popup menu—for any
user. You may wish to do this selectively for some actions, for example, the “set” action for
Fallback access. (Note that a user with admin-level rights to the point may still access the
point’s slot sheet.)

About point facets

Primarily, facets determine how the point’s value displays in the station. Examples include engi-
neering units and decimal precision for numeric types, and descriptive value (state) text for
boolean and enum types.

With the exception of proxy points (with possible defined device facets), point facets do not af-
fect how the point’s value is processed. Refer to the Drivers Guide section “Effect of facets on
proxy points” for related details.

NOTE: Besides control points, various other components have facets too. For example, many
kitControl and schedule components have facets. Details about point facets apply to these com-
ponents too, unless especially noted.

Topics about facets include:
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+ Accessing and editing facets
+ Facets importance for Enum points
«+ Effect of facets on point actions

« Maximum override duration facet

Accessing and editing facets

Facets is a frozen slot in all control points and objects in the kitControl module. As shown ,
you modify facet values in a point’s property sheet, using the Config Facets dialog.

Figure 87. Point facets and edit dialog (AX-3.3 and later shown)
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In this case a BooleanWritable’s default t rueText facet is “true”—to modify you simply click
to select, then type over with whatever text is needed. For example, change “true” to “On” and
“false” to “Off”. When done click OK and then Save to make the actual point change.

Optionally, in addition to modifying existing facets, you can add or remove facet values in a
point. On many points you may only modify or provide new values for default facets. In the
case of writable points, you can add a facet to limit override duration (see “Maximum override
duration facet”).

NOTE: For string-type points (StringPoint, StringWritable), facets typically have little practical
application. By default, the Facets slot is empty for string-type points.

Facets importance for Enum points

Facets for enum-type components (EnumPoint, EnumWTritable, EnumSchedule, etc.) define the
operating range of the component, meaning its different possible enumerated states. Each state
is defined by a pairing of an integer value-to-text, also known as ordinal-tag. Each ordinal must
be a unique integer, and each tag must be unique text. By default, the point’s value displays us-

ing tag text.

If you add an enum point from the control palette, its Facets slot has a blank range entry. Until
you edit this facet and supply the ordinal-tag values, it can display only integer values. As
shown , a special Enum dialog appears when you edit range facets.
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Figure 88. Producing Enum dialog for enum point “range” facets

(0} Enumritable (Enum Writable)

1 ) Facets = % - 1. Edit Facets
+ 7 Bk L
= Config Facets x|
= | [Key [Type [value IE J
EnumR F2—Edit-Range
o |pange ‘ numR.ange ‘{} % ng
= ¥ ‘
- BN x|
=
_ 3. Get Enum dialag
= In7 [ il [Toc ][ cancel |
= Ind |; =
e | IR E U il x|
Tl l: [[]iUse Frozen Enum in R.ange {module:name):
= Inil [ | |
. B Ordinal [Tag [Display #
o Ini3 [
= Int4 =
= Inis [
11 j |
| Add ‘ | Modify | ‘ Remoye |

In the Enum dialog when adding an entry, the Add button becomes available after you enter
an integer value in the left side Ordinal box as shown below. Type in the associated text in the
right side Tag box, then click Add to add to the facet’s range. Click OK when done, also OK on
any remaining pop-ups.

Figure 89. Type unique integer value in Ordinal box and associated text in Tag box
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If using lexicons, in the “Lexicon Module Name” field you can enter the module name of a con-
figured lexicon (for example, control or kitControl) if Tag strings match lexicon “keys”
in that lexicon file. In this case, enumerations will display the lexicon strings (values) for those
ordinals instead of the tag text.

When defining range enumerations, instead of defining a custom one with your supplied ordi-
nals and tags text, you can also select from well known “frozen” enumerations, as defined in
various installed modules. A checkbox enables this and provides a drop-down list for you to se-
lect by module and enumeration type.
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Figure 90. Frozen enum selection in Enum dialog
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Depending on the driver/network type, the Point Manager under a device may automate this
facets range configuration when you add enum-type proxy points. For example, under a Lon-
works device, if you add a EnumPoint for a Lonworks NVO that uses an enumerated SNVT,
that point’s facets will automatically be configured with the correct range values.

NOTE: If an enum-type point receives an input value not included in its defined facets range,
it displays the ordinal integer value for that input. This varies from the multistate objects used
in r2 Niagara, which would display “Error” for any value not defined in its “stateText” entries.

Effect of facets on point actions

For some points with actions (see “About point actions”), facets also affect availability in the
point’s action (command) menu, as follows:

o EnumWritable

Upon an override or emergency action, a secondary drop-down selection dialog lists the
possible enum values (in its range), using display tag text. This list appears ordered top-to-

bottom by the tag associated with each ordinal, lowest-to-highest.

o NumericWritable

Upon an override or emergency action, an entry dialog permits a value only between the
facets “min” and “max” values, inclusive. By default, these facets values for numeric-type
points are min= -inf and max= +inf (no effective range checking for an action).

For example, you could use this facet’s feature with a NumericWritable that sets a tempera-
ture control setpoint, by setting its facets min= 65 and max=85. After saving this change,
any override or emergency action issued to that NumericWritable would need to fall within
this range. Otherwise, a user would see a message showing the acceptable range, and be

prompted to try again.

NOTE: Facets “min” and “max” values do not affect any received input values or proxied
data, only what can be issued via an action.

Maximum override duration (for any writable point type)

Using facets you can also limit the maximum override duration of manual (level 8) override
action invoked on writable control points. By default, the manual override of a writable
point has no duration limits. For more details, see “Maximum override duration facet”.
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Maximum override duration facet

Available for some time (but undocumented before), is the ability to limit the maximum over-
ride duration of an action invoked on a control point. By default, a manual (level 8) override of
a writable point is unlimited in duration, thus the default “Permanent” label in the action
menu.

Figure 91. Default override action menu for writable control point

Active ==
Override Duration |Permanent || [00000h 00m 00.000s
fancel

1 Minute
15 Minutes
30 Minutes
1 Hour

2 Hours
3 Hours
Custom

If needed, change this by adding a “maxOverrideDuration” facet (choosing type baja:Re-
1Time), with specified duration time, to either or both:

+ Config, Sys Info property

+ Any writable control point

NOTE: Override limits affects operator overrides (level 8) only, as emergency level over-
rides (level 1) are always unlimited in duration. In other words, an emergency level override
lasts until an emergency level “auto”.

Figure 92. Config Facets editor when picking maxOverrideDuration
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When a writable point is limited by a maxOverrideDuration facet, its action menu adjusts to
show the allowable range. See “Action menu examples”.

For details about editing facets, see “Accessing and editing facets”.
Config, Sys Info property

The “Sys Info” property of the station’s root Config component has a facets control, shown in
the Config component’s property sheet.
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Figure 93. Global maxOverrideDuration facet added to Sys Info property of station’s
Config component
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Adding this facet on the Sys Info property acts a global limit (station-wide) to a manual over-
ride action to all control points that do not have their own “maxOverrideDuration” facet.

Any writable control point

Each writable control point in the station can have a separately specified maximum override
duration. If this facet is present, it overrides any global (Sys Info) maxOverrideDuration
value.

Figure 94. Added maxOverrideDuration facet added at point level (overrides global
setting)
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As shown, this maxOverrideDuration facet can be added along with any other facets in
use by the control point. The example BooleanWritable point above already had configured
facets for trueText and falseText.

Action menu examples

Example action menus from writable points with a maxOverrideDuration facet in effect
are shown .
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Figure 95. Example override action menus affected by maxOverrideDuration facet
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Note if a system user attempts to invoke a “Custom” override over the specified maxOverri-

deDuration limit, an error popup appears that shows the override duration range as shown
below.
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Figure 96. Custom override attempt over maxOverrideDuration limit produces error
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As shown above, the allowable duration range appears in [brackets], in this case [1ms -
lhour].

About point extensions
As needed, you can add one or more extensions to a point, each as a child of that point. Exten-
sions are a way to add functionality to a point (or extend it) in a modular fashion.
The following topics provide more details on extensions:
+ Extension process overview
+ Types of point extensions
» About the proxy extension
+ About control extensions
+ About alarm extensions

+ About history extensions

NOTE: Extensions also apply to most kitControl objects. See the kitControl Guide section
“Extensions and kitControl components” for more details.

Extension process overview

Extensions are found in several palettes, including alarm, control, history, and kitControl.

You typically add an extension by either:
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+ dragging it into the property sheet of the point, or
+ dropping it on the point’s icon in the Nav tree.

A point’s property sheet lists extensions below its normal (frozen) properties. You can expand
each extension to view and modify its properties as shown below.

Figure 97. Extension expanded in a point’s property sheet
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If a point has multiple extensions, they are processed in the same top-to-bottom order that
they appear listed in that point’s property sheet. You can re-order extensions in a point—from
the top of the point’s property sheet, or on the point’s icon in the Nav sidebar, right-click and
select Reorder.

NOTE: If needed, you can also select and expose extension properties (for linking convenience)
on the point’s glyph by using the Composite editor of the parent point. For more details, see
“About composites”.

Types of point extensions

Point extensions include the standard proxy extension (one for each point, see “About the
proxy extension”) and also optional extensions.

Optional extensions are in three main categories:
+ control extensions
from control palette. See “About control extensions”.
+ alarm extensions
from alarm and kitControl palette. See “About alarm extensions”.
+ history extensions

from history palette. See “About history extensions”.

About the proxy extension

Each point has a proxy extension (Proxy Ext), a frozen property.
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The proxy extension is important—it indicates how the point’s data originates, including de-
tails specific to the parentage of the point’s network and communications (driver).

A point’s proxy extension is either:

.

Null

For any point that you copy from the control palette (or add using the right-click menu),
the proxy extension is simply null (NullProxyExt)—an empty placeholder. The station itself
originates the point's default Out value.

Also, many kitControl components also have a NullProxyExt, as they are based upon Con-
trolPoints. For details, see “Extensions and kitControl components” in the NiagaraAX Kit-
Control Guide.

<DriverType>

For any proxy point, meaning any of the 8 point types you create using the Points extension
under a device represented in any of the network types, the proxy extension is <DriverTy-
pe>ProxyExt. For example, a BooleanWritable proxy point under the Points container of a
Bacnet Device has a proxy extension of “BacnetBooleanProxyExt.”

For any proxy point, its proxy extension contains information organized in child properties.
Some properties may be unique to that specific driver type.

The following image compares property sheet views of the proxy extension properties for
two BooleanWritable points, on the left a control point, on the right a BACnet proxy point.

Proxy extension for control point (null) and a Bacnet proxy point.

| | 7 Prosy Ext rul =| 7 Proxy Ext binaryOutputd3al iPresent Yalue:-1:ENUMERATED
1 © sta
| & Fault Cause |
| Enabled
_| 2 Device Facets trueText=Fan On,falseText=Fan OFf 3 =
_| {2 Conwetsion
| 2 Tuning Palicy Hame  [Default Policy [~
| = Read Value |Fan On {ok} bac=16
| E= ik value [Fan on {oky @ 16
| O Object Id |b|nary0utput M 1 |
| € Property Id |Present Talue u
| 3 Property Array Index
| {3 Data Type |EN‘U‘IIERATED
| 2 Read Status |Polled
| {2 Write Status Jok

About control extensions

Control extensions are found in palette control: Extensions.

You can add control extensions, as needed, to points along with alarm and history extensions.
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Figure 98. Control extensions
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Control extensions perform additional processing on a point’s received value. There are rela-

tively few types of control extensions. See “Types of control extensions”.

Types of control extensions

There are a variety of control extension types located under their applicable point parents.

The following table lists all available control extension types and the applicable point parents.

Table 3.1. Control extension types

Control extension

Applies to point types

(control:Extensions)

any object with sin-

gle Numeric Out, e.g.

kitControl: Math ob-
ject “Add”

type (palette:Folder) | (read-only) Writable What it does
DiscreteTotalizerExt | BooleanPoint BooleanWritable Accumulates run-
(control:Extensions) time and change of
EnumPoint EnumWTritable state (COS) count.
Extension actions
- any object with sin- | permit resetting
gle Boolean Out, e.g. | (zeroing) the run-
kitControl: Logic ob- | time and COS count.
ject “And”
NumericTotalizerExt | NumericPoint NumericWritable Accumulates nu-

meric total using
hourly or minutely
totalization. Exten-
sion has action to re-
set (zero) total.

ProxyExt
(control:Extensions)

(standard for any point, see ““About the

proxy extension”)

Provides methods to
driver
communications.

About alarm extensions

Use an alarm extension for any point you wish to monitor for offnormal values, and show alarm
indication when a limit or value is met or exceeded. In an alarm extension, you also specify
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whether an alarm annunciation should occur upon alarm transitions, plus many other

parameters.

Find the alarm extensions in palettes alarm: Extensions and kitControl:Alarm.

Figure 99. Alarm extensions
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Alarm extension properties define items such as alarm enable (annunciation) transition types,
alarm delay times, associated alarm class, and alarm display text for different transition types.

You define the actual alarm limits or state(s) in properties in the extension’s “Offnormal Algo-
rithm” slot. For more details, see “About alarm extension properties”.

Types of alarm extensions

This topic lists alarm extension types and the applicable point parents.

Table 3.2. Alarm extension types

Applies to point types

Alarm extension type

(alarm:Extensions)

(palette:Folder) (read-only) Writable General description
OutOfRangeAlar- NumericPoint NumericWritable Provides alarming
mExt based upon numeric
(alarm:Extensions) — any object with sin- alarm high and low
gle numeric Out, e.g. | limits. Includes con-
kitControl: Math ob- | figurable deadband.
ject “Add”
StringChangeOfVa- | StringPoint StringWritable Provides alarming
lueAlarmExt based upon either in-
(alarm:Extensions) _ any object with sin- clusion or exclusi.on
gle String Out, e.g. of the entered string
NOTE: AX-3.6 or kitControl: String Value.(or”“regular ex-
later required object pression”, as
“StringSubString” needed).
BooleanChangeOf- BooleanPoint BooleanWritable Provides alarming
StateAlarmExt based upon one of

any object with sin-
gle Boolean Out, e.g.
kitControl: Logic ob-
ject “And”

two possible values
(state) as an alarm
condition.
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Alarm extension type

Applies to point types

(palette:Folder) (read-only) Writable General description
BooleanCommand- | — BooleanWritable Provides alarming
FailureAlarmExt based upon mis-
(alarm:Extensions) match between com-
manded value and
actual (sensed) value.
Extension has feed-
backValue input
property for linking.
EnumChangeOfSta- | EnumPoint EnumWritable Provides alarming
teAlarmExt based upon one of
(alarm:Extensions) multiple possible val-
ues (state) as an
alarm condition.
EnumCommandFai- | — EnumWritable Provides alarming
lureAlarmExt based upon mis-

(alarm:Extensions)

match between com-
manded value and
actual (sensed) value.
Extension has feed-
backValue input
property for linking.

StatusAlarmExt any type that accepts | any type that accepts | Provides alarming
(alarm:Extensions) extensions extensions based upon any com-
bination of status
flags, including over-
ridden, null, etc.
LoopAlarmExt — LoopPoint Sliding alarm limit
(kitControl:Alarm) for LoopPoint based

upon controlled
process deviation
from setpoint.
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Alarm extension type

Applies to point types

(palette:Folder) (read-only) Writable General description
ElapsedActiveTi- BooleanPoint with BooleanWritable Provides alarming
meAlarmExt DiscreteTotalizerExt | with based upon accumu-
(kitControl:Alarm) DiscreteTotalizerExt [ lated runtime
(elapsed active time).
— any object with sin- References a specific
gle Boolean Out (also | DiscreteTotalizerExt
with a DiscreteTota- | under same parent
lizerExt), e.g. kitCon- | point.
trol: Logic object
“And”
ChangeOfState- BooleanPoint with BooleanWTritable Provides alarming
CountAlarmExt DiscreteTotalizerExt | with based upon accumu-
(kitControl:Alarm) DiscreteTotalizerExt | lated COS (change of

any object with sin-
gle Boolean Out (also
with a DiscreteTota-
lizerExt), e.g. kitCon-
trol: Logic object
“And”

states). References a
specific DiscreteTo-
talizerExt under
same parent point.

About history extensions

Add a history extension to any point for which you want to log historical data, that is collect a

history.

In a point history, each collected sample of slot “Out” has a date-timestamp, point status and
value. Point history data is viewable in both a table and chart format.

Find the history extensions in palette history: Extensions.

Figure 100. History extensions
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Each history extension has various properties in two major groups:

+ Collector

Determines how or when data is collected, such as active time, and (if applicable) either
change tolerance or the collection interval time.
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+ History Config

Determines how the data is stored and accessed in the system, such as history name, ca-
pacity, and full policy.

For more details, see “Configure history extensions”.

Types of history extensions

The following lists all history extension types and the applicable point parents.

History extension types

History extension

Applies to point types

type (read-only) Writable General description

BooleanChangeOf- BooleanPoint BooleanWritable Collects upon each

Value change of Boolean

- any object with sin- | value (state) or
gle Boolean Out, e.g. | status.
kitControl: Logic ob-
ject type “And”

BooleanInterval as above as above Collects upon a re-
peating time interval,
as configured.

NumericChangeOf- | NumericPoint NumericWritable Collects upon each

Value change of value (out-

— any object with sin- side a specified toler-
gle Numeric Out, e.g. | ance) or change of
kitControl: Math ob- | status.
ject type “Add”

NumericInterval as above as above Collects upon a re-
peating time interval,
as configured.

EnumChangeOfVal- | EnumPoint EnumWritable Collects upon each

ue change of enumer-

— any object with sin- ated state or status.
gle Enum Out

Enumlnterval as above as above Collects upon a re-
peating time interval,
as configured.

StringChangeOfVal- | StringPoint StringWritable Collects upon each

ue change of string val-

— any object with sin- | 1€ or status.
gle String Out

StringInterval as above as above Collects upon a re-

peating time interval,
as configured.
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About the Update History Id action

All history extensions have an Update History action available. This popup menu item provides
a way to refresh the History Id after a rename. It applies the formatting property (as designated
by enclosing % signs) of the Name Format field to the Id of the History Config Id. For example,
if the History Name property under a history extension is set to $parent .name%, then the
History Config Id is initially named based on this parent display name. However, if you rename
the parent component, the History Config Id property does not automatically or immediately
change. The Update History Id action invokes a renaming of the History Config Id based on
the formatting property, so if the parent component (in this example case) is changed, the Up-
date History Id action changes the Id property and, if different from the history name, it results
in a change in the history name as well. See “About history names” for more information about
history naming.

About control triggers

There are two “time triggers” in the palette control:Trigger. These objects do not represent
data, but instead regularly fire a topic.

Figure 101. Control triggers
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Int I
e T?m:;’:er E
1
= |[j control u
+ £ Points ; Toenigger O
+ 7 Extensions 1
-
+ Interval
+ (E Daily
<1

The two control trigger types are:
+ Interval

Fires at a regular, repeating intervals specified in its Trigger Mode property.
For example, every n minutes, n hours, or whatever combination needed.

+ Daily

Fires once a day at a specific time and day of week, as specified in its Trigger Mode prop-
erty. For example, at 00:00:00 (midnight) all days of week except Sunday.

Each type has even more configuration capabilities to further define the fire time.

How triggers are used

To use a trigger, you typically link it to a selected action of a point extension (e.g. control,
alarm, and history) to automate an action. Often, you use a trigger as a child of a particular
point (sibling to the linked extension). Or, you can have a trigger in the same container as mul-
tiple points, and link it to more than one point or point extension.

For example, a Daily trigger (defined for midnight) can be linked to the ResetElapsedActive-
Time action of a DiscreteTotalizerExt extension of a BooleanWTritable point. In this case, that
point’s DiscreteTotalizerExt would only show runtime accumulated during the current day.

About related objects

Other objects with trigger functions are found in various palettes. The most closely related is
the TriggerSchedule object, found in the Schedule palette. See “About trigger schedules”.
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About point status

Along with point value, point status is available at point Out. Status reflects status flags, which
may get set singly, or in combinations. Status flags are typed by a unique text string (for exam-
ple: “alarm” or “down”), and many have associated status colors (a background and a fore-
ground). For example, the default status colors for alarm is white text on red background.

Status without any flags set is considered normal (text “ok”), and is without color indication.

NOTE: For each installed lexicon, text strings for status flags (plus associated colors), are indi-
vidually adjustable by editing default values in that host’s baja lexicon, using Workbench’s
Lexicon Editor. For a default English installation, to change default status appearance settings,
edit the en: baja lexicon. For more details, see “About lexicons” and “Lexicon Editor view”.

The following topics explain further details about point status:
+ Types of status flags

+ Priority of status indication

+ How status flags are set

« About “isValid” status check

Types of status flags
Status flag types are listed in Table 3-5, along with associated default colors (if any).
Status flag types
Type Default Colors, Example Meaning
alarm white text, Point currently has a value in
red background an alarm range, as defined by
g property in its alarm
28U extension.
fault black text, Originates from a proxy
orange background point only. Typically indi-
cates a configuration or li-
208.8 °F censing error. If it occurs
after normal operation, it
may indicate a “native fault”
in device, or the point’s pa-
rent device has a fault status.
overridden black text, Current point control is
magenta background from an action, meaning a
user-invoked command at ei-
f2.00F ther priority level 8 (over-
ride) or priority 1
(emergency).
disabled gray text, Originates from a proxy
light gray background point only. Point (or its pa-
rent device or network) has
7a.0°F been manually disabled
(property enabled = false).
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Type

Default Colors, Example

Meaning

down

black text,
yellow background

a3, °F

Originates from a proxy
point only. Driver communi-
cations to the parent device
are currently lost, based
upon the device status (Mon-
itor) configuration for that
network.

stale

black text,
tan background

734 5F

Originates from a proxy
point only. Driver communi-
cations have not received a
requested response for this
data item within the config-
ured times (Tuning period).

null

(no color indication)

Current point control has
entered a null state, vs. a spe-
cific value and priority level.
Typical to fallback operation
for a writable point.

NOTE: If linking a null sta-
tus Out to a “simple data”
slot, the point’s “null value”
is processed. See the Niagar-
aAX KitControl Guide sec-
tion “Status value to simple
value” for more details, in-
cluding its “About null val-
ues” section.

unackedAlarm

(no color indication)

Last point alarm event has
not yet received user ac-
knowledgment. Point’s alarm
extension uses alarm class
requiring acknowledgment.

Priority of status indication

Since status flags for a point or object can get set in combinations, status color indication uses
a priority method. Among those 6 status flags with associated colors, priorities (and default col-

ors) are:

1. disabled (dark gray)

Proxy point origination only. Point may have other status flags set. Typically, you manually
set and clear this status (unlike others). After disabled is set for a proxy point, it is no longer
polled. Further status changes do not occur until disabled is cleared.

2. fault (orange)

Typically proxy point origination only.

3. down (yellow)

Proxy point origination only.
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4. alarm (red)

Point may have other status flags set.
5. stale (tan)

Proxy point origination only.
6. overridden (magenta)

Point may have other status flags set.

NOTE: Status types unackedAlarm and null do not affect the indicated status color. For
more details on proxy point status, refer to “Proxy point status” in the Drivers Guide.

How status flags are set

Status flags are set differently depending on the type of point or control object. The following
sections explain:

+ Simple control point status

+ Propagate Flags status option (linked Math and Logic objects)

NOTE: Refer also to the Drivers Guide section “Proxy point status” for further details.

Simple control point status

For simple control points (NullProxyExt) the following status flags are the only ones set and
cleared:

+ alarm
Point is currently in an alarm condition as defined in its alarm extension.
+ unackedAlarm

Point has alarm extension assigned to an alarm class requiring acknowledgment, but the
last alarm event has not yet been acknowledged. Point may/may not be in alarm.

» override

Writable points only, during a user-initiated action at priority levels 8 (override) or 1 (emer-
gency). The override flag clears when the action “times out,” or when a user issues an “auto”
action at that same priority level.

o null

Writable point has “null” or otherwise “invalid” value at In1—In16, plus “null” configured
as “Fallback” value. See “About “isValid” status check”.

See the following image for examples of override and alarm status in simple control points.
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Figure 102. Status with simple control points
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Propagate Flags status option (linked Math and Logic objects)

By default, kitControl objects maintain independent status flags from input-linked points.
However, as a configuration option in each math or logic-type kitControl object (kitControl pa-
lette folders “Math” and “Logic”), you can specify “out” status to propagate from input status.

The object’s Propagate Flags property allows you to select any combination of the following
status types for propagation:

+ disabled
o fault

+ down

o alarm

+ overridden

NOTE: If the math or logic object has multiple inputs, and you set the propagateFlags
property to select one or more of the statuses above, simple “OR” logic is used across all in-
puts for the propagation of each selected status.

Depending on usage, status propagation may be extensive. Note that four of the five status
types (all except alarm and overridden) are “invalid status,” meaning they cause the output of
the object (if linked) to be considered invalid at its destination target. See “About “isValid” sta-
tus check”.

As an example of status propagation, some number of NumericWritable points are used to es-
tablish setpoints, and you link them all to a Math: Average object for downstream zone control.
In turn, the Average object feeds a Math: Reset object. Both math objects have “override” en-
abled in their “propagateFlags” property. A user issues an override (action) to one of the Nu-
mericWritable points, to override a setpoint.

98

NiagaraAX User Guide



Data and Control Model May 26, 2016

Figure 103. Status propagation in linked writable points, kitControl objects
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For the duration of the override, the linked Average object will also have an overridden status,
as will the Reset object, and so on. However, note that the linked writable point (NWcombined)
in this example does not have overridden status—status never propagates to any point.

NOTE: Before using this feature in an actual job, you should test and evaluate results to be sure
it has the desired effect. For example, if a Logic or Math object is exposed in a graphic and ap-
pears overridden, a user may (incorrectly) assume that they can right-click command (perform
an action) on that kitControl object, based on status color indication.

About “isValid” status check

When linking an input-type slot of a writable point or kitControl object, the value received at
the input is processed (evaluated) by that point or object only if it is valid.

NOTE: A valid input is one with none of the following status flags set:

+ down

o fault

+ disabled
+ null

+ stale

If any of the above status bits are set at an input, that input value is not used.

« IfakitControl object with a single input, by default that object uses the last known valid re-
ceived (at least until the input becomes valid again).

+ IfakitControl object with a multiple inputs, only the valid inputs are evaluated.

« If a writable point, the priority scan continues. See “About the priority scheme”.

About writable points

All writable points provide right-click actions. Override actions are evaluated within the prior-
ity scheme used by any writable point. In the case of the “set” action, the point’s “Fallback”
property is modified (see “About point actions”). BooleanWritable points also offer built-in
“minimum on/off” timers.
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+ About the priority scheme

« About minimum On and Off times

About the priority scheme

Each writable point uses a 16-level priority scheme, with corresponding inputs In1—In16, plus
a “Fallback” property. Level 1 is the highest priority, and level 16 is the lowest.

The following topics further describe the priority scheme:
+ Priority input scan
« Priority linking rules

+ Priority level conventions
Priority input scan

For any writable point, the effective input value is determined by a priority scan, looking for a
“non-auto” action at level 1 (emergency), then the value at the highest valid input, going from
level 2, to 3, and so on to level 16. (At level 8, any “non-auto” action is evaluated as valid).

Like almost all control execution, this priority scan is event-driven, meaning it occurs when
any input value changes. An input’s value typically comes from a link—however, note that for
most inputs, you may enter a value directly in the point’s property sheet (as an alternative
source).

NOTE: A valid input is one with none of the following status bits set:

+ down

o fault

+ disabled
o null

+ stale

If all 16 priority levels are evaluated without a valid input (and without an action at levels 1 and
8), then the fallback value is used.

NOTE: You can configure the writable point’s “Fallback” property to be “null,” so that the
point’s Out has a null status in this condition. Depending on the specific control sequence and
usage of the writable point, this may be an effective solution.However, note that by default, a
“set” action exists on any writable point, which writes directly to the Fallback value. See “About
set (Fallback) action”. If you want a writable point to always have a Fallback of “null,” go to its
slot sheet and set the “Hidden” config flag on the “set” slot. Otherwise, a user can invoke a
right-click command to set Fallback to any value. For more details, see “Modifying default
actions”.

Priority linking rules
When linking to the priority inputs of a writable object, you may notice these default rules:
+ Only one link per input (level).

« Levels 1 and 8 are unavailable for links. If a BooleanWTritable, level 6 is also unavailable.
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Priority levels 1 and 8 are reserved for actions (emergency and override). See “About point
actions”. Priority level 6 in a BooleanWritable is reserved for minimum on/off times. See
“About minimum On and Off times”.

NOTE: Both rules vary from the r2 Niagara priority input scheme, where a single priori-
tyArray input was used for a writable object (AnalogOutput, BinaryOutput, and so forth).
That input could be linked to multiple priority type outputs, including those with duplicate
priority levels and/or levels also used for object commands (emergency and manual).

Priority level conventions

The 16 priority levels used by writable points are modeled after corresponding BACnet priority
levels, using the following conventions, from highest to lowest:

1. Emergency (Manual Life Safety)—Unlinkable input, but available as action (command).
Automatic Life Safety

User Defined

User Defined

Critical Equipment Control

A A T

Minimum On/Off (BooleanWTritable meaning only, see “About minimum On and Off
times”)

User Defined

N

8. Override (Manual Operator)—Unlinkable input, but available as action (command).
9. Demand Limiting

10. User Defined

11. Temperature Override

12. Stop Optimization

13. Start Optimization

14. Duty Cycling

15. Outside Air Optimization

16. Schedule

NOTE: Although priority levels are patterned after BACnet, there is no direct linkage to
BACnet priorities, even with BACnet writable proxy points. Priority inputs of all writable
points are strictly a station-centric implementation.

About minimum On and Off times

Each BooleanWritable point has built-in timers to specify minimum on and/or minimum off
times. The respective point properties are “Min Active Time” and “Min Inactive Time.” Usage
is optional, and both properties work independently. Typical usage is to prevent short-cycling
of equipment controlled by the point.

Default property times for a BooleanWritable are all zeros (“00000h 00m 00s”), which effec-
tively disables a timer. In either property, you can specify any value needed using of a mix of
hours (h), minutes (m), and seconds (s) to enable that timer.

A minimum timer is triggered by a state change transition to active or inactive. This results in
the new state value being stored in the point’s priority array (at priority level 6) for the duration
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of that timer. While a minimum timer is in effect, only input changes at a higher priority (5 or
above) or an emergency action can affect the Out value.

For example, a BooleanWTritable point controls a fan, with related properties set as follows:
+ Min Active Time: 00000h 01m 30s

Specifies that once started, the fan must run at least 90 seconds.
+ Min Inactive Time: 00000h 03m 5s

Specifies that once stopped, the fan must remain stopped at 3 minutes, 5 seconds.

Starting with the fan stopped at schedule level (priority 16), if a user gives it a manual override
on (priority level 8), the fan will run for 90 seconds at priority level 6 (a higher level). After this
period, the fan continues running at the override 8 level for the duration of the override.

During the initial 90 seconds, a different override action (off or auto) will be ineffective—as the
higher priority level 6 remains in control. See “Priority level conventions”.

Once stopped, the point’s minimum off time will keep the fan off at priority level 6 for the
specified duration (in this example, 3 minutes and 5 seconds). During this period, only an
emergency command or input change at In2—In5 can effect further change.

About composites

Currently, a composite is something that Workbench allows you do to virtually any component
in a station, notably control points and objects, and even folders that contain control logic.
When you make a composite, you expose slots of child components in the glyph (object shape)
of that parent (composited) component. This can simplify linking and promote reuse of control
logic.

CAUTION: Although composites can simplify linking and make understanding logic flow eas-
ier, they always introduce performance issues. Perhaps the biggest issue is that once you link a
dynamic value to a composite, for example the “out” of a proxy point, it essentially “pinned” in-
to the “subscribed” state. This means that proxy point will always be polling (regardless of any
other usage).You should avoid making folder composites in your control logic, and instead use
the composite feature only at the point/object level to expose extension slots (if necessary). See
example “Point-level composite”.

When you composite a component (say a control point, meaning its contents), you select spe-
cific slots in child components (say, properties and/or actions of its extensions) to be “exposed”
in the “shape” of that point. Then, when looking at that point in the wire sheet view of its pa-
rent folder, you can see exposed properties of children as linkable slots (and/or available
actions).

Some composite examples

A few simple examples of composites are included here, as follows:
+ Point-level composite

+ Folder-level composite

Point-level composite

The following image shows a proxy NumericPoint representing a space temperature value that
has two extensions:

+ an alarm extension (OutOfRangeAlarmExt)

+ ahistory extension (NumericInterval)
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Figure 104. Property sheet of proxy point with two extensions
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In this example, when another system-related BooleanWritable (representing the system fan)
has a false (Off) status, it is desired that this temperature point be:

+ disabled from alarming, and
+ disabled from continued history collection

To achieve these “disable” functions, you must link the controlling source fan out to a slot of
each extension (visible in point’s wire sheet view, but not in the parent wire sheet for the point
itself). Furthermore, other kitControl objects needed. Without making a composite, the neces-
sary objects and links may appear.

Figure 105. Proxy point example without composite
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Notice that when looking at the proxy NumericPoint in the wire sheet of its parent folder, it is
not apparent that this point has linked extensions.

By making a composite of the NumericPoint (acting as the container for both the extensions
plus the additional kitControl objects) you can simplify reuse and clarify available links. The

following image shows the now-composited NumericWritable linked to the controlling Boo-
leanWritable, and the wire sheet view of the NumericWritable that contains the needed kit-

Control objects.
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Figure 106. Proxy point as composited container
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In this example, the exposed input slots in the composite were renamed from “In” to “almlIn-
hib” and “histStop” respectively, to clarify what each does. When looking at the Composite Edi-

tor for this example NumericPoint, it appears.

Figure 107. Composite Editor for example NumericPoint
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Folder-level composite

NOTE: Please see the related Caution

The following image shows a simple example of three Math objects chained together, located
in a “LogicA” folder. Together, they perform a “Celsius to Fahrenheit” conversion. A Numeric-

Writable is also shown linked to the first Math object to test.
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Figure 108. Simple example of folder before compositing
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If this application was needed later, you could copy all 3 linked objects again and insert in an-
other (perhaps already crowded) wire sheet. However, the middle “Multiply” object reveals an
intermediary result that is distracting. Or, you could just create a new subfolder with only the 3
linked objects and then link directly to the child objects as needed (however, it would not be
obvious from the parent’s wire sheet that links to children in that folder were established).

It would be better to “encapsulate” this into a single object with only a single “input” (degrees
F) and single “output” (degrees C). You can do something like this by compositing the parent
container, in this example folder “FolderA.”

In this case, you would want to delete the link from the test NumericWritable first, then open
the Composite Editor for the parent component FolderA. The Composite Editor lets you ex-
pand the tree of all contained components and “expose” those items of interest.

Figure 109. Launching and using the Composite Editor
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In this example, only the “In A” of the first math object and the “Out” of the third math object
is selected to be exposed. The Composite Editor provides a tree pane showing slots of points
and objects (by clicking the expand controls), and a slot is exposed by simply double-clicking it.
Other controls in the editor are available to rename, remove, reorder and reverse exposed
items, but are not used here. (For more details, see Making a composite.)

After clicking OK to perform the composite, the item composited (in this example, “LogicA”)
shows exposed slots when viewed in its parent’s wire sheet. The following image shows the test
NumericWritable now linked to the composited LogicA folder.
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Figure 110. Example LogicA folder showing exposed input and output
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You could later reopen this folder’s Composite Editor and rename the exposed properties dif-
ferently, perhaps “inDegF” and “outDegC” (to make the purpose of the composited folder
clearer). This would not affect the three (child) math objects in any way.
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CHAPTER 4 ABOUT STANDARD TOOLS

Torics COVERED IN THIS CHAPTER

Types of Tools

Alarm portal

Bacnet Service

Lexicon Tool

Local License Database
Lon Xml Tool

Lonworks Service
Credentials manager

New Driver wizard

New Module wizard

New Station wizard
Request License

Resource Estimator

Time Zone Database Tool
Todo List

Workbench Job Service
Workbench Service Manager

This section describes some of the standard “tools” available in Workbench. These tools pro-
vide Workbench interfaces to facilitate specific tasks — from managing credentials to monitor-
ing alarms. All of the tools described in this section are available from the Tools menu.
However, navigational links to some of the tools also appear in the nav side bar and in the nav
container views.

NOTE: The nav side bar and nav container views do not display the tool icons until you ini-
tially open them using the Tools menu.

Figure 111. Workbench tools
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Some, but not all of the tools that are available under the Tools menu appear in the nav side
bar when you select them. When you first open Workbench, the “My Tools” node will not be
present in the nav tree. Therefore, if you configure a tool, such as the BACnet service tool, all
the configuration data will be lost when you close the current session of Workbench. Tools,
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Types of Tools

such as the Alarm Portal, BACnet service, Lonworks service, and the Workbench Job Service
are available in Workbench when you do not have a station open. This is provided as a conven-
ience and may only be useful in a limited number of situations. For example, you would prob-
ably more typically use the Job Service, BACnet service, and Lonworks Service under the
“Services” node of a specific station.

Refer to “Types of Workbench Tools” for a list of the tools that are available from the Tools
menu.

The following tools are available in Workbench.
+ Alarm portal
Explains the options that appear in the alarm portal. Refer to “Alarm portal”.
+ Bacnet Service
Explains the options that appear in the Bacnet service. Refer to “Bacnet Service”.
+ Certificate Management

Explains the Certificate Management view of the SSL Toolset. You use this view to create
PKI (Public Key Infrastructure) digital certificates; to create Certificate Signing Requests
(CSRs); and to import and export keys and certificates to and from the Workbench key
stores. This view appears only if the platform-connected host is licensed for the SSL Toolset
and has the necessary modules installed. Refer to the document "NiagaraAX SSL Connectiv-
ity Guide" for complete details.

+ Certificate Signer Tool

Explains the options in the Certificate Signer Tool. You use this tool to sign intermediate
digital certificates. This tool appears only if the platform-connected host is licensed for the
SSL Toolset and has the necessary modules installed. Refer to the document "NiagaraAX
SSL Connectivity Guide" for complete details.

+ Driver Upgrade Tool

(Appears if the driverUpgrade module is in the local Imodules folder). Provides a wizard
to upgrade driver modules in a remote controller JACE host, including making any neces-
sary changes in the installed station’s database (config.bog file) that may be required by the
upgraded modules. Usage requires entering valid platform credentials and station creden-
tials for the remote JACE.

Currently, this tool applies if upgrading from the previous Video Driver to the newer Vid-

“w_»

eo Framework driver (older modules at “dev” prefix, new modules with “n” prefix). For
more details, refer to the section “Upgrading to Video Framework” in the Video Framework
Guide.

+ Lexicon Tool

Explains the options that appear in the lexicon tool. For general information, see “Lexicon
Tool”. For detailed information, see the NiagaraAX Lexicon Guide. For information about
the lexicon installer, refer to the “Lexicon Installer” section of the NiagaraAX Platform
Guide.

+ Local License Database
Explains the Workbench License Manager view. Refer to “Local License Database”.
+ Lonworks Service

Explains the options that appear in the lonworks service manager. Refer to “Lonworks
Service”.

« Lon Xml Tool
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Describes the Lon Xml Create view. Refer to “Lon Xml Tool”.
Manage Credentials

Explains the options that appear in the credentials manager. Refer to “Credentials
manager”.

New Driver wizard

Explains the options that appear in the new driver wizard. Refer to “New Driver wizard”.
New Module wizard

Explains how to modify the attributes of a new module. Refer to “New Module wizard”.
New Station wizard

Explains the options in the new station wizard how to change the default attributes of a
new station. Refer to “New Station wizard”.

Request License

Explains the options that appear in the license request dialog box. Refer to “Request
License”.

Resource Estimator

Explains the options that appear in the resource estimator dialog box. Refer to “Resource
Estimator”.

Sedona Installer

Provides a wizard to install a “Sedona Framework TXS bundle” distribution, which enables
Workbench to work with Sedona powered devices, including integration into NiagaraAX
stations.

NOTE: If a Sedona bundle is installed, additional Workbench tools (views) related to Sedo-
na will also be available. These tools include a Sedona - New App tool, Sedona Device
Simulator, Sedona Jennic - New Wireless Adapter tool, Sedona Jennic - Serial Port
Tool, and Sedona Manifest Manager. These tools are covered in Sedona-related docu-
ments, including online Workbench help jars that are installed with the Sedona Framework
TXS bundle.For more details, see the NiagaraAX Sedona Framework TXS-1.2 Installer
Guide.

Time Zone Database Tool

Provides ways to explore the contents of the local timezones.jar available to Workbench (if
a station is running locally, say on a Supervisor, it uses these time zone definitions as well).
Refer to “Time Zone Database Tool”.

Todo List
Explains the options that appear in the todo list dialog box. Refer to “Todo List”.
Workbench Job Service

Explains the options that appear in the Workbench job service view. Refer to “Workbench
Job Service”.

Workbench Service Manager

Explains the options that appear in the service manager screen. Refer to “Workbench Serv-
ice Manager”.
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Alarm portal

The alarm portal tool allows you to view and acknowledge alarms from many different stations
using a single viewer (portal). The alarm portal, shown, is divided into two resizable panes, and
a set of buttons along the bottom of the alarm portal window: You can add alarm consoles from
different stations by right-clicking in the Alarm Console Monitor (top pane) and choosing the
Add Alarm Console menu selection to initiate the Add Alarm Console wizard.

From the Alarm Portal, double click on any alarm listed in the Open Alarm Sources pane to
see the Alarm Details dialog box and the alarm record dialog box, as described in “About the
alarm console”.

Figure 112. Alarm portal
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« Alarm Console Monitor

This pane displays information about the consoles that are being monitored and contains
the following information areas:

« Title bar

Displays “Alarm Console Monitor” title on the left and the number of consoles that are
connected to the alarm portal on the right side of the title bar.

+ Column headings

Displays the title of each of the columns that are displayed in the alarm console
monitor.

« Alarm console list

Each row in the alarm console listing contains information about alarm consoles that
are currently listed as available to monitor from the alarm console. Station identity in-
formation is displayed, as well connection status (connected or disconnected) and con-
nect and disconnect times.

+ Open Alarm Sources

This pane displays information about individual alarm sources, as described below. If you
double- click on a single alarm source, the Open Alarm Sources view opens. This view is
described in “About the alarm console”.

o Title bar
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Displays “Open Alarm Sources” title on the left and the total number of points that are
displayed in the list on the right side of the title bar.

Column headings (click column heads to sort)

Displays the title of each of the columns in the open alarm sources list, as follows:
Timestamp

displays the latest time that the point generated an alarm.

Source State

displays the current state of the point (for example, Normal or Offnormal).

Ack State

displays how many alarms have been generated at the point and how many of those
alarms have been acknowledged.

Ack Required

displays “true” or “false” indicating that an acknowledgement is or is not required for
that alarm.

Source

displays the path to the point that is generating the alarm.

Alarm portal buttons

.

0 Acked /1 Unacked Alarms

Acknowledge

Acknowledges all alarms at the selected source when an alarm is selected in the alarm
source pane.

Hyperlink

is active when an alarm extension property (refer to “About alarm extension properties”.
When clicked, displays the alarm source.

Notes

displays a dialog box that allows you to add notes to an alarm record (see “About the
console recipient”.

Silence
when clicked, this button quiets the alarm sound for the selected point.
Filter

displays the alarm filter dialog box for limiting the alarms that are displayed. See “About
the alarm console”.

The alarm portal tool, when enabled, also places the alarm icon in your system tray and an
alarm popup window.

You can set options for the alarm portal in the Tools Options menu, as described in “Alarm
Portal options”.

Figure 113. Alarm portal popup window
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Bacnet Service

Lexicon Tool

Following is an example of the Bacnet Service property sheet. Select Tools > BACnet Service
from the Workbench main menu to add this service to the “My Tools” node of the nav tree.
The default view is the property sheet view.

Figure 114. Bacnet service property sheet view
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NOTE: You can use this Workbench Tools service to configure a local Bacnet device in the
same way as a you would under a station, as described in the Bacnet Guide. However, any con-
figuration that you do using the Workbench Bacnet Service (under the “My Tools” node) will
be lost when you close Workbench. Use Bacnet Service under a station to save your Bacnet
Service settings to a database.

Refer to the Bacnet Guide for a detailed description of the Bacnet service.

For general information on lexicons, see “About lexicons”. For detailed information on using
the Lexicon Tool, see the NiagaraAX Lexicon Guide. For details on installing (edited) file-based
lexicons in remote controller platforms, see the NiagaraAX Platform Guide section “Lexicon
Installer”. For details on installing (new/edited) module-based lexicons in remote controller
platforms, see the NiagaraAX Platform Guide section “Software Manager”.

For an overview of the Lexicon Tool views, see the following sections:
+ Lexicon Report view
+ Lexicon Editor view

« Lexicon Module Builder view

Lexicon Report view

The “Lexicon Report” view is available via the Workbench Tools menu, by selecting Lexicon
Tool. On the left side of this view, the Lexicon box shows a list of all module-based and file-
based lexicon locales installed on your Workbench PC. As needed, you click one of these lexi-
cons to select it. Selecting a lexicon shows various status parameters about each lexicon (bro-
ken down by module) in the table columns on the right side.
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Figure 115. Lexicon report view
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Check boxes at the top of report view allow you to “hide” values that could affect “missing” sta-
tus counts, as described in the NiagaraAX Lexicon Guide section “Lexicon components”.

This view lets you add (new) lexicons, delete unwanted lexicons, or search all available lexicon
property values that contain a given text. Additionally, you can double-click any module row in
the table to launch the Lexicon Editor view, which shows the contents of that lexicon file.

For detailed information using the lexicon report view, see the NiagaraAX Lexicon Guide sec-
tion “Lexicon Report View”.

Lexicon Editor view

The Lexicon Editor view (shown) lets you view and edit the contents of lexicon files installed
on your Workbench PC. Typically, you access the editor from the Lexicon Report view with a
lexicon selected on the left side, by double-clicking a module in the table on the right side. The
lexicon editor displays a table listing the defined keys for that module, with columns for map-
ping to a localized value override for the default value.

Figure 116. Lexicon editor view
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@ discovaryupdats 5t discovering points. Estimatad time remaining = {0) =
@ examinePointDiscovery.compare prompl Fiease specy file from 2 previously saved discovery. |
@ examinePolntDiscuvery.comparing Here Iz @ Text Comparison of the Two Discovery Bog Files =]
4 il I S|
Kep [ I"a'ueil Update Value
Dafauit l [0 Add hew Key
Color Chooser I Ord Chooser I
Al [ T

At the top of this view, you can search for specified text on either the lexicon property Key, the
property Default, or the custom Value. Clicking any row in the table populates the Key field.
At the bottom of the view, clicking the Add New Key button enables the Key field, as well. The
Value text field allows you to modify the value of the selected key (or add a value for a new
key). Starting in Workbench 3.7 the Value field has associated Color Chooser and Ord
Chooser buttons. These options allow you to browse for a specific color or ORD element. Up-
date the table with the Value field entry by clicking the Update Value button. Write changes
to the lexicon file by you clicking the Save button in the Workbench toolbar.

For detailed information on using the lexicon editor view, see the NiagaraAX Lexicon Guide.

Lexicon Module Builder view

Starting in Workbench 3.7, a Lexicon Module Builder view (shown) is available. The lexicon
module builder allows you to bundle multiple lexicon files into a module for ease of distribu-
tion. The lexicons available for use are those lexicon files (modulename.lexicon) located in the !
lexicon folder. You can build new lexicon modules or replace existing ones.
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Figure 117. Lexicon module builder view

Lexicon Tool

|, Lexicon Module Builder ~

=~ = Nav
Module Name | |
3] My Netwark
R e ek Tl s [

- B lexicon =] Module Description: | |
- Een Vendor Name: [ |
[3 controt.lexicon :
e version 1
[ bajauilexicon a Brand Pattern: | |
+ 4 lib [] Delete lexicon files after build
- Ml licenses [Source [Lexicon [File
E2 F modules [ file en control lexicon -
+ B8 registry S O file fr bajaui lexicon *
+ B security |
+ B station (=] Build Module
il T Ir]

In this view there are text fields for defining module information, a Browse button that allows
you to locate existing lexicon modules, a selection table of available lexicon files that can be se-
lected for inclusion, a check box to delete source files after the build is completed, and a Build
Module button to initiate the build.

On completion of the build, you will see a confirmation message indicating that the module
was constructed and placed in the 'modules folder.

For detailed information on using the lexicon module builder view, see the NiagaraAX Lexicon
Guide section “Lexicon Module Builder View”.

Local License Database

The Workbench License Manager view is available via the Workbench Tools menu, by select-
ing Local License Database.

Figure 118. Workbench License Manager

L] &

Nav

18 [@]

=52 My Host : sc-400 (i
== My File System

= <license wversion="3.8" vendor="Tridium™ generated="
"= Qnuc-NPM2-0000-0856-6C20 <feature name="brand" accept.station.in="*" accept.
Qnx-NPM2-0000-12C5-DD2C <feature name="gbout” project="Tridium-Training™ o
Qnx-NPM3-0000-1490-5349 <feature name="appFramework™ expiration="never" apj

<feature name="axvelocity" expiration="never™ part

- M <feature name="bacnet™ expiration="never™ schedule.
Qnx-NPME-0D00-1343-0D EEIEEEE 0OTE

"box" expiration="never™ gession.limi

«<feature name="crypto” expiration="never"” 3sl="tru
Win-90F 7-F 7BF-7970-3A86 <feature name="dataRecovery" expiration="never" pa
H & Tridium. license (Tridium 3.8 <feature name="email" expiration="never" parts="T-
<feature name="eventService™ expiration="never" pa

H g Platform <feature name="jen€élp” expiration="never™ schedule.
H w Station {dema)) <feature name="jennic” expiration="never" parts="DI
<feature name="lonworks" expiration="newver™ schedu
<feature name="maxHeap™ expiration="never" parta="
<feature name="mobile™ expiration="never" history="
<feature name="modbuslisync” expiration="never™ schi
<feature name="modbusSlave"” expiration="never"™ schi
<feature name="modbusTcp™ expiration="newver™ sched

", T 1 = ", n

. | [x] [« \ -]

£ My Modules

E‘ﬁ; My Tools

<| ‘ |> | Import File || Export File H Delete H Sync Online |

As shown, this view lets you browse and manage the contents of your “local license database.”

This view provides a two-pane window into all the license files and parent “host ID” folders,
where:

+ Left pane provides tree navigation, where you can expand folders and click (to select) li-
cense files.

+ Right pane shows the text contents of any selected license file.

Buttons at the bottom of this view provide a way to manage the contents of your local license
database, and are described as follows:

+ Import File
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Lon Xml Tool

Always available, this allows you to add license file(s) from a local license file or license ar-
chive (.lar) file.

Export File

Always available, this allows you to save all licenses (or any selected licenses) locally, as a li-
cense archive file.

Delete
This allows you to delete licenses from your Workbench local license database.
Sync Online

Typically available if you have Internet connectivity. This lets you update all licenses (or
any selected licenses) in your local license database with the most current versions, via the
online licensing server.

NOTE: For more complete details about the license database, see “Workbench license
manager” in the NiagaraAX Platform Guide.

The Lon Xml Tool is available from the Tools menu. The Lon Xml Create view helps you
make your own Lon Xml (.Inml) file for a device, using the source .xif file and (if necessary) oth-
er resource files, as available from the device’s manufacturer. The tool’s dialog provides the
necessary input fields.

Figure 119. Lon Xml Create tool view

TE T am el Tram
ﬂ Lon ¥l Toal

Sz =

%if File | | =

]
= My Host {dellxp)

] ﬁ My Modules Resource Dir |

+ B3 My File System 3
4t G? My Tools : “Q Compile

Refer to the Lonworks Guide for details about using this view and about the following:

.
.
.
.

3

Lonworks Service

Need for custom Lon Xml files
Lon Xml file overview

Lon Xml creation

Storing .Inml files

Differential temperatures and Inml file edits

The Lonworks Service is applicable if your Workbench PC has a Lonworks adapter. You can
view it by selecting Lonworks Service from the Tools menu. It provides the identical “LonNet-
work” access as if you had a local (PC) station running.
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Figure 120. Lonworks Service tool in Workbench

m (7} Lonwaorks Service (Lonworks Service)
] & My Network n +| €@ Lon Metwark  Lon Network

= My Host {dellxp) 1=
+ & My Modules
+ B3 My File System

111

Eenl ce
- 3 Lon Metwork

=&l Local Lon Device

+ 0 alarm Source

+ Device Data

+ @) Paints 5 .

4] [iii 0| | Refresh || Save |

For example, you can use the Lon Device Manager to discover, add, and upload Lon devices,
examine nvs and ncis as LonComponents, and even perform writes and do other configuration
(make bindings between devices, commission devices, etc.).

CAUTION: Any configuration you perform is not stored (persisted) in a station database, as
this is “station-less” access (modeled completely in RAM). When you close Workbench, all
modeling is lost—consider the Lonworks Service like a “hand held device” in this respect.
For this reason, do not use this tool to access a Lonworks network already managed by a sta-
tion, but instead open that station, and access its LonNetwork.

Refer to the Lonworks Guide for more details.

Credentials manager
The Manage Credentials tool, or “Credentials Manager” provides a dialog box to access and
open any previously “remembered” (cached) connections from your Workbench, including

both platform and station connections.

Figure 121. Manage Credentials dialog (credentials manager)

MName | Credentials |Type | ®B Reset
~ OFTIPLEX380 niagara baja:Username AndPassword
' ip1192.168. 1. 123 [fox: FacMan baja:UsernameAndPassword
7 ip:192.168. 1. 123 |patform:  myPlatAcct baja:Username AndPassword
F ip: 192. 168, 1. 33|fox: baja:Username AndPassword
2 i 192,168, 1, 33|pleLlonm: Higyar o baja:UsernameandPasswor d
2 local: [fox: myNewAdminSU  baja:UsernameAndPassword

You can also remove or reset any cached credentials. Note that your credentials cache is popu-
lated whenever you have the login (Authentication) dialog option “Remember these cre-
dentials” (check box) enabled. Starting in AX-3.7, any initial platform or station
connection, this option is disabled (unchecked) by default.
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Figure 122. Authentication (Remember credentials)

/’ | Authentication
_,"’J Logon required for access
Realm
MName ips Iplatform:
Scheme  HTTP-Digest

Credentials
Username myFlatloct
assuord

The available caching of credentials is a convenience feature, such that you can simply open
the platform or station later by entering only the IP address, or simply clicking on that host’s
dimmed platform or station in the Nav tree of Workbench, or going to the credentials manag-
er. Then, the login authentication dialog has the cached credentials already entered, and you
simply click OK.

If you want tighter security for any platform or station connection from your Workbench PC,
you should clear this check box whenever opening (logging on) a platform or station. Further-
more, you should remove any related entries using the credentials manager. This way, that plat-
form or station connection always requires full entry of both user name and password.

NOTE: Starting in AX-3.7, you can globally disable user credentials caching in Workbench, via
Tools > Options, in the General menu. When “Allow User Credentials Caching” is set to false,
the “Remember these credentials” checkbox remains unavailable (dimmed) in any Authentica-

Credentials

Password

Unavailable . .
: T For related details, see “General options”.

tion dialog.

New Driver wizard

The New Driver Module Wizard is available when you select Tools > New Driver from the
main menu. The first of four wizard dialog boxes is shown below.

Figure 123. New driver wizard

New Driver Module Wizard

Step 1 of 4
Create Module under Directory
@ | =
Module Name
Preferted Symbol
Description | |
Yendar |acme |
Author |anonymous |
Base Package |c:om. acme. foo |

| Back || = Next I| Finish || ¥ Cancel |

This wizard is provided as a convenient way to perform some of the steps necessary for creat-
ing a driver module. The four wizard dialog boxes allow driver developers to specify some basic
driver module options and finish with the wizard creating a set of folders and files under a sta-
tion directory that you assign during the wizard process. Also see the Niagara Developer Guide
for more detailed information about building modules.

NiagaraAX User Guide

117



About standard tools May 26, 2016

New Module wizard

The New Module Wizard is available when you select it from the Tools > New Module from

the main menu. The wizard presents a series of dialog boxes that help you create and save a
new module.

Figure 124. New module wizard creates folders under working directory

===

New Module Wizard 5

New Module Wizard
Step 10f 3

Create Module under Directory
[/c:/niagara/EC-NetAX-3.8.xx.xx/themes | &z

Module Name themeCitrus
prefered ymbol

Description [My custom theme medule ]

‘endor [Distech cantrals ]

[iCreate Lexicon:
[] Create Palette

| Back “ P Hext ” Finish ” .@Camel‘

This wizard creates a set of folders and files under a station directory that you assign during
the wizard process. After creating these files, you need to finish the process, as described in

“Working with modules”. Also see the Niagara Developer Guide for more detailed information
about building modules.

New Station wizard

The New Station wizard is available by selecting Tools > New Station from the main menu.
The wizard provides two dialogs to help you create and save a new station.

Figure 125. |Initial New Station Wizard dialog

Mew Station Wizard @ [EHS2 My Host
5 EHS My File System
E New Station Wizard i ’
=} ﬂ Sys Home
Station Mame . b on
R rertificates

Station Directory
[C:\nizgara\EC-NetAX-3.8.xx. xx\stations\MyNewStation

b demoAppliance

Et @ config.bog
s“é’%‘g Services
' “@ Drivers
BHED Apos

| Back || Dllext || Finish || .Q)Canoel|

In the first dialog, you enter the name of the station. When the wizard completes, the station

folder will have this name, as shown above in below. Fields in this first New Station wizard dia-
log are:

+ Station Name

The case-sensitive station name, which must begin with a letter. It is best to keep station

name short, and use a station “display name” if a longer name with spaces and/or other
characters are needed.

+ Station Directory

Read-only field specifies the location where the station folder is created (under the “Sta-
tions” folder).
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Click Next to continue to the next/final wizard dialog, shown in below.

Figure 126. Second (final) New Station Wizard dialog (AX-3.8 and AX-3.7)

AX-3.8 AX-3.7 and AX-3.7

g New Station Wizard Mew Station Wizard @
g New Station Wizard

Admin Password

I

Admin Password Confirm iy @ fkn: Bosshosd
l:l Your password must contain: l:l
-atleast 10 character(s) Admin Password Confirm
-atleast 1 digit(s)
-atleast 1 lower case character(s) l—

Error |
Bf FoxsPort  [4911 -atleast 1 case character(s) Fox Port

HTTPS Port 443 1911 @ Password must have at least 8 characters
HTTP Port
Open Station BOG on Finish
| 4 Back || Mexck || </ Finish || (&) Cancel | Open Station BOG on Finish
| | Back || Nexct | «/ Finish || & cancel |

In AX-3.8, Admin Password (user “ad- In AX-3.7, Admin Password (user “ad-

min”) must meet minimum “default min”) has lessor “default strong pass-
strong password” requirements, as words” needs. Cannot be either all letters
shown above. or all digits.

4

By default, the “Use secure connections” | By default, the station is created with

checkbox is enabled. “Foxs Only” and standard (non-SSL) configuration of the
“Https Only” will be enabled in the sta- | FoxService and Webservice. Ports shown
tion’s FoxService and WebService, re- are default Fox and Http ports.

spectively (for SSL). Ports shown are
default Foxs and Https ports. If needed
you can uncheck (clear) to create the sta-
tion with standard (non-SSL) settings.

Wizard differences between AX-3.8 and AX-3.7 are summarized above, with more details as
follows:

+ In order to complete the wizard (and create the station), you must enter a password for the
“admin” user that meets “default strong password” requirements, differing between AX-3.8
and AX-3.7. If needed you can change this later in the station (regardless if AX-3.8 or AX-
3.7).

+ In AX-3.8, the New Station wizard defaults to “Use secure connections (recommended)”,
such that any station created with the New Station Wizard is pre-configured for “SSL only”
Fox client access and Web (HTTP) access. This is different that when using the New Sta-
tion wizard in AX-3.7ul or earlier, where after creating the new station you must enable

SSL access.
= =] |
Connected to localhost
MName |Type |Stalm |Detai|s |Aum-start |Resd B
demo station |Idle fox=1911,foxs=4911,http=80,https =443 false true
demosppliance station Idle fox=n/a,foxs=nfahttp=n/a,https=nja  false true

rox:nra.fomzmmznra.w:m H

When you start a new AX-3.8 station created with the New Station wizard defaults, you
can see this in the “station status” area of the Application Director, as shown above.

Fields in this second New Station Wizard dialog are:
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Request License

Admin Password

The password for the “built-in” station user named admin. Must meet minimum “strong
password” requirements for AX-3.8 or AX-3.7, which differ.

Admin Password Confirm
Re-enter the same password again (must match).
Foxs Port (AX-3.8 default) or Fox Port (AX-3.7, or AX-3.8 option)

Lets you assign the port to be used for Foxs (Fox SSL) or Fox communications. Default
ports are:

+ Foxs Port: 4911
+« Fox Port: 1911

After new station creation, this can be changed (if needed) from the station’s Config,
Drivers, NiagaraNetwork, FoxService component’s property sheet.

HTTPS Port (AX-3.8 default) or HTTP Port (AX-3.7, or AX-3.8 option)

Lets you assign the port to be monitored by the station’s WebService for HTTP connec-
tions. Default ports are:

« HTTPS Port: 443
+ HTTP Port: 80

After new station creation, this can be changed (if needed) from the station’s Config,
Services, WebService component’s property sheet.

For related topics, see the following:

.

3

.

.

“About built-in users”, including “User admin”.
“web-WebService”.

“About the FoxService” in the NiagaraAX Drivers Guide.
NiagaraAX SSL Connectivity Guide

The “Request License” item on the Workbench Tools menu simply opens a “Bind License
form” in your Workbench PC'’s default browser. By default, the only pre-filled field in this form
is the host ID of your Workbench PC. See below.
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Figure 127. License request form in browser (from Workbench, Tools > Request License)

&« C | [ axlicensing tridium.com/license/request?params=YnJhbnT1 Q 35 =

niagara

licensing

-

Reguest/Bind License

License Details

Host 1d- © WIn-BBE1-B094-FC24-3440

License Key*

Requester Details

Name*

m

Company”

E-mail

4 ] +

Typically, your Workbench PC is already licensed. Otherwise, you would not be able to suc-
cessfully start Workbench, and then select Request License from the “Tools” menu.

However, you could use this as quick method to request a license for another PC on which you
have installed AX. In that case, you could substitute (type in) the host ID for the other PC in
this form, along with other pertinent information.

NOTE: For more information about the licensing, see “Appendix A. License Tools and Files”
in the NiagaraAX Platform Guide.

Resource Estimator

The Resource Estimator tool is available from the Tools menu. Use it as a worksheet to help
you estimate the total number of station resources that you will use in a projected station im-
plementation. The resource estimator view is, as shown below.
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Figure 128. Resource estimator view

additional Multipher  [Medium (30%) | 7]

Device Netwarks C{ % 100,000 + Multiplier
Devices I:I % 5000 + Multiplier
Proxy Poinks I:I % 250 + Multiplier
Program Components I:I % 3000 + Multiplier
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Config. 1 Count I:I
Config, 2 Count I:I
Config. 3 Count I:I
Config. 4 Count I:I
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Time Zone Database Tool
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0.000 kRU
0.000 kRU
0.000 kRU

0.000 kRU

Calculate

The Time Zone Database Tool, available since AX-3.5, provides several ways to explore the lo-
cal timezones.jar on the Workbench host. This jar file is the “historical time zone database”.

If the Workbench host is running a station (e.g. is a Supervisor), this is also the time zone data-
base used by that station. Using this tool, you can see what time zones are available, see the past
and current behaviors for any time zone, and in some cases the future behaviors as well.

NOTE: For additional time zone details, refer to the NiagaraAX Platform Guide appendix

“Time Zones and AX”.

Figure 129. Time Zone Database Tool in Workbench AX-3.5 or later

[ Manifest Information r% Time Zone Database rﬁ Daylight Saving Time Calculator r@ Time Zone Calculakor |

¥Yersion 2010.13

Source tzdataz010m.kar.gz
Min Year 1995

Max Year 2015

Zones Provided

AFricalAmericas rAntarctica Asia | Atlantic rAustraIia rCanada rEurope Etc | Indian | Other [Pacific [US

America/shdak

Admerica/dnchorage
America/fdnguilla
Americasintigua
Americasiraquaina
America/irgentina/Buenos_hires
Anericasirgentina/Catamarca
Admericasdrgentina/ConodRivadavia
Anericasirgentina/Cordoba
America/drgentina/Jujuy

[T

As shown, the Time Zone Database Tool has four available tabs.

« Manifest Info

« Time Zone Database

+ Daylight Savings Time Calculator

« Time Zone Calculator
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Manifest Info

This tab in the Time Zone Database Tool shows you the timezone.jar file version, and which
“Olsen Time Zone DB” version the file is based upon. The “Min Year” says how far back histor-
ically time zones are guaranteed to behave correctly. Conversely, “Max Year” is how far forward
behavior should be correct.

The main view is a tabbed breakdown of all time zone definitions by world region, where the
list of time zones in each region is listed alphabetically.

Time Zone Database
This tab in the Time Zone Database Tool lets you see how any selected time zone behaves.

Figure 130. Time Zone Database tab in Workbench Time Zone Database Tool

33 Manifest Information r% Time Zone Database rﬁ Daylight Saving Time Calculator r@ Time Zone Calculakor |

Time Zone IAmerica,l’New_\"ork (-5f-4) Iﬂ

Current Time |29—Har—2011 01:57 PN EDT |

Historical Zone ‘Yes

Historical Time Zone Eras

ID

January, 1900-lanuary, 2007 |/January, 2007-December, 10000 |

Era Active From January 1, 1900 at 00:00:00,000 Coordinated Universal Time

Era Active Until January 1, 2007 at 04:59:59,999 Coordinated Universal Time

Standard UTC Dffset -5 =
DObserves Daylight Saving es

Daylight Saving Begins Annually on the First Sunday on or after 1 in April at 02:00:00,000 Wall 1)
Daylight Saving Ends Annually on the Last Sunday in October at 02:00:00,000 Wall Time

For example, what is the current time? (note that a refresh is required for update)

Is this a “historical zone”? (meaning have time zone “rules” changed for this zone at some
point?)

Note that if “Yes”, there will be multiple “era” tabs in the lower definition area, each with the
parameters for things like UTC offset, DST (daylight savings time) changeover, and so on—spe-
cific to that time era.

Daylight Savings Time Calculator

This tab in the Time Zone Database Tool shows when the DST changeover occurs for any
year.

Figure 131. Daylight Savings Time Calculator tab in Workbench Time Zone Database Tool

33 Manifest Information r% Time Zone Database rﬁ Daylight Saving Time Calculator r@ Time Zone Calculakor |

Time Zone IAmerica,l’New_\"ork (-5f-4) Iﬂ
Year 2012] |[1900 - 9939]

DST Starts Sunday March 11 at 2:00 Al Wall Time

DST Ends Sunday Movember 4 at 2:00 AWM Wall Time

In Daylight Now Yes

To use, select a time zone and type in a year in the Year field.

Press Enter to update the “DST Starts” and “DST Ends” time fields.
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Todo List

Time Zone Calculator

This tab in the Time Zone Database Tool lets you compare the time between any two time
Zones.

Figure 132. Time Zone Calculator tab in Workbench Time Zone Database Tool

33 Manifest Information r% Time Zone Database rﬂ Daylight Saving Time Calculator r Time Zone Calculakor |

Time Zone IAmerica,l’New_\"ork (-5f-4) Iﬂ
Year 2012] |[1900 - 9939]

DST Starts Sunday March 11 at 2:00 Al Wall Time

DST Ends Sunday Movember 4 at 2:00 AWM Wall Time

In Daylight Now Yes

To use, select a source time zone and a target time zone, and specify a source time (initial de-
fault is the current time).

The Todo List is available when you select it from the Tools menu. This tool is provided to
help you with organizing, prioritizing and tracking tasks in Workbench. The Todo list view is
shown.

Figure 133. Todo list view

P | E & v = | »  Summary | =] Group| =

Summary Group |Priority |Date i
Commission Jace xkra 0 17-Aug-05 11:46 AM EDT

Create Mew Sation General 1 17-Aug-05 11:46 AM EDT

Set up Alarm Portal Extra z 17-Aug-05 11:46 AM EDT

Reschedule Energy Slowdown  General 3 17-Aug-05 11:46 AM EDT

The Todo list is a tabular view with standard table controls and options, as described in “Table
controls and options”. You can use this tabular list to create new lists or edit, group and rear-
range existing lists and items in your lists. In addition, you can use the filter fields at the top of
the display to filter what you see in the table, based on your summary description or group.

Workbench Job Service

The Workbench Job Service view, shown below, is available when you select it from the Tools
menu.

This job service tool keeps track of all jobs that are not initiated under a specific station, but in-
itiated by the Workbench environment.

Figure 134. Job service nav tree and property sheet view

= My Tools “Q ‘Workbench Job Service (Workbench Job Service)
= Workbench Service Manager | %, BacnetDiscoverDeviceslob  Bacnet Discover Devices Job
= Waorkbench Job Service
+ 9, BacnetDiscoverDevicesJob 0t el Stz
+ %, LonDiscoverJob | {3 Progress
| ) Start Time |30-&ug-z005 02:14 PM EDT |
| {0 Heartbest Time  [30-Aug-2005 02:14 M EDT |
| O End Time |30-Aug-2005 02:14 FM EDT |
+| %, LonDiscoverJob Lon Discaver Job
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NOTE: “Workbench jobs” are those that are initiated and run under Workbench - not under a
station. Jobs that run under a station are monitored and displayed in the Station Job Service
(under the station Services node in the nav side bar).

Workbench Service Manager

The service manager view is available when you select it from the Tools menu. The service
manager view, shown below, is used to manage the life cycle and configuration of all services.

Figure 135. Workbench service manager view

Workbench Service Manager

& larm:AlarmPortalTool

@ bacnet:BacnetwhbService  true false false
E lorworks:LonwhService  true false false
“Q workbench:WhlobService  true false false

| Stark || M Stop | [ Auta Start

The Workbench service manager is a tabular view with standard table controls and options, as
described in “Table controls and options”. From this view you can Start, Stop, or configure any
of the listed services to Auto-Start.
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CHAPTER 5 PERFORMING TASKS

Torics COVERED IN THIS CHAPTER

Starting and exiting

Getting started with stations
Using the side bar pane
Using bookmarks

Using the help side bar
Using the nav side bar (tree)
Using the jobs side bar
Using the palette side bar
Using the view pane

Editing components

Using alarms

Creating a Live History Chart
Working with modules

This chapter provides topics that cover some of the common Workbench tasks.

Workbench provides a complete user interface to the Niagara Framework. It can directly access
a station and perform any action that the system supports. You can view and control any com-

ponent using any of the supported views.

Starting and exiting

Tasks involved with starting and exiting Workbench, include the following.

« To start Workbench
+ To close the Workbench window

« To exit the Workbench

NOTE: Start procedures given here are for the “typical” usage of Workbench. You may
have other Windows Start menu shortcuts, Desktop shortcuts, or Windows 8 “Start Tiles’

”

installed for other Niagara applications not mentioned here. Refer to the AX-3.8 Windows

Installation document for summary information.

To start Workbench

To start Workbench do one of the following.

Prerequisites:

¢ From the Windows Start menu, choose either:
o Programs > NiagaraAX-3.8.xxx > Workbench 3.x.xxx
The Workbench GUI window appears.
o Programs > NiagaraAX-3.8.xxx > Workbench (Console)> Niagara 3.x.xx

The Niagara (Console) window appears, after which a separate Workbench GUI
window appears. The console window can be useful to capture debug messages
from the client Workbench application, or to exit in the case of a “hung client

connection”.
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NOTE: If you close the Workbench console window, Workbench also immediately
closes—any unsaved changes are lost. Be sure to save changes before closing the as-
sociated console window.

« From the Niagara Console window (Programs > Niagara 3.x.xx > Console), at the com-
mand prompt, enter either:

e wb w

The Niagara Workbench GUI window appears. The console window and Work-
bench window are independent, meaning if you close or exit one, the other remains
open.

e whb

The Workbench (Console) window appears, after which a separate Niagara Work-
bench GUI window appears. The console window can be useful to capture debug
messages from the client Workbench application, or to exit in the case of a “hung
client connection”.

NOTE: If you close the Workbench console window, Workbench also immediately
closes—any unsaved changes are lost. Be sure to save changes before closing the as-
sociated console window.Note you can also open a console within the Workbench
(GUI) window. See “About the console”.

o If Desktop Shortcuts were installed (and/or if AX-3.8 with Windows 8 Start Screen Tiles
were installed), double-click the following shortcut, or click the following tile:

¢ Workbench 3.x.xx

The Niagara Workbench GUI window appears.

To close a user interface window

Prerequisites:

NOTE: Closing all Workbench windows will exit the Niagara GUI.

To close the Workbench window do one of the following:
¢ From the File menu, select the Close command.The Workbench window will close.

o From the Niagara Workbench menu (located in the top left corner of the window title
bar), select the Close command.The Workbench window will close.

o Click the close icon (located in the top right corner of the window title bar).The Work-
bench window will close.

To exit a user interface

You can exit Workbench by using the Exit command (which will close all Workbench win-
dows) or by closing all Workbench windows.

Prerequisites:
To exit Workbench, do one of the following:
¢ From the File menu, select the Exit command.The Workbench GUI will close.

¢ Close all Workbench windows.The Workbench GUI will close when the final Workbench
window is closed.
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Getting started with stations

In order to communicate with a station, the station must be running and accessible. The fol-
lowing procedures provide information about basic tasks that are required to start, stop, and
communicate with stations:

+ To open a platform using user interface GUI

+ To connect to a platform using user interface GUI

+ To close a platform using Workbench

+ To disconnect from a platform using Workbench

» To start a station using Workbench

+ To stop a station using Workbench

+ To open a station

+ To close a station using Workbench

+ To connect to a station using Workbench

« To disconnect from a station

To open a platform using user interface GUI

To open a platform, do the following.

Step 1 From the menu bar, select File > Open > Open Platform.

Step 2

Step 3

The popup Open Platform dialog appears, or if AX-3.8, the Open Platform with SSL
dialog.

NOTE: The default in AX-3.8 has changed to Open Platform with SSL.

Complete the fields in the Open Platform or Open Platform with SSL dialog box as
follows:

*

Type

Select either & Platform SSL Connection or & Platform Connection, as appro-
priate. If you change, the default Port changes between 5011 (SSL) to 3011 (non-
SSL).

Host

Select the IP option and type in the IPv4 address of the host platform that you wish
to access.

Port

Verify the port shown, with the default as either 3011 (non-SSL) or 5011 (SSL). If
you know the remote host is using a different (non-default) platform daemon port,
enter it here.

Click the OK button. If you chose Open Platform (non-SSL), go to Step 4.

If you chose Open Platform with SSL, different results are possible:

*

If the Niagara platform is not enabled for SSL, an error results with “Cannot con-
nect. Ensure server is running on specified port”. Retry from Step 1, changing the
Type to Platform Connection.

If the Niagara platform is enabled for SSL, but you have not yet installed a certifi-
cate for that host, a popup Identity Verification dialog with certificate details ap-
pears. In most cases, you click Accept to proceed to the next step.
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Step 4

Step 5

+ An Authentication popup dialog appears. Go to the next step.

In the popup Authentication dialog, enter platform credentials

NOTE: Be sure to use the platform username and password — not credentials for any
station user.

+ Username
Enter the username for the platform.
« Password

Enter the password for the platform.

If the “Remember these credentials option” is available, you can select it, so that Work-
bench “remembers” these platform credentials. However, this can pose a future secur-
ity risk; thus this option may be disabled.

Click OK after entering credentials.

If the platform credentials were correct, the platform is connected, and the platform
icon appears in the side bar pane and the default Nav Container View appears in the
view pane. Where platform icons are:

+ B Platform or
+ & Platform SSL
If the platform credentials were not correct, you are prompted to enter them again.

For related details, refer to “Platform overview” in the NiagaraAX Platform Guide.

To connect to a platform using user interface GUI

Prerequisites:

NOTE: You cannot connect to a platform unless it is “open”. An open platform may be
visible in your Workbench nav side bar, but appear dimmed (be disconnected). If there is
no platform icon in the nav side bar, you need to open the platform before connecting
(see “To open a platform using Workbench GUI”.

To connect to a disconnected platform, do the following:

Step 1

Step 2

In the nav side bar (refer to “Using the nav side bar (tree)”) right—click on platform
icon and select the Connect command from the popup menu. Or, simply double-click
the platform icon.

The Authentication popup dialog appears.

Enter the credentials information as follows:
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Step 3

NOTE: Be sure to use the platform username and password — not credentials for any
station user.

+ Username
Enter the username for the platform.
« Password

Enter the password for the platform.

If the “Remember these credentials option” is available, you can select it, so that Work-
bench “remembers” these platform credentials. However, this can pose a future secur-
ity risk; thus this option may be disabled.

Click OK after entering credentials.

If the platform credentials were correct, the platform is connected, and the platform
icon appears in the side bar pane and the default Nav Container View appears in the
view pane. Where platform icons are:

+ B Platform or
+ & Platform SSL
If the platform credentials were not correct, you are prompted to enter them again.

For related details, refer to “Platform overview” in the NiagaraAX Platform Guide.

To close a platform using user interface

To close a platform, do the following:

Step 1

Step 2

In the nav side bar (refer to “Using the nav side bar (tree)”, if necessary) right—click on
the platform icon and select the Close command from the popup menu.

The Close dialog box appears.
In the Close dialog box, click OK to close the platform.

The platform is closed and the platform icon is removed from the nav side bar.

To disconnect from a platform using user interface

To disconnect from a platform, do the following:

Step 1

Step 2

»

In the nav side bar (refer to “Using the nav side bar (tree)”) right—click on platform
icon and select the Disconnect command from the popup menu.

The popup Disconnect confirmation dialog box appears.
In the Disconnect dialog box, click OK to disconnect.

The platform is disconnected and the platform icon is dimmed.

To start a station using user interface

Prerequisites:

NOTE: Most station—platform functions can be performed from the Application Director
platform view of a host; however, you must connect to the platform where a station is
hosted before you can perform these tasks.
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To start a station using Workbench, do the following:
Step 1 Connect to the station’s platform.

Step 2 In the nav side bar, expand the platform node in the nav tree by clicking on the plus
sign (+) next to the platform icon in the tree.

The contents of the platform node displays in the tree.
Step 3 In the nav side bar, double click the ® Application Director.

Step 4 In the Application Director view, select the desired station. It becomes highlighted in
the table.

Step 5 In the right-side area of this view, select the following options, as desired:

+ Select the Auto-Start option if you want the station to automatically start any time
the station host computer is re—booted. Clear the Auto-Start option to disable au-
to—start.

+ Select the Restart on Failure option if you want the station to automatically attempt
a restart any time it fails. Clear the Restart option to disable automatic restart.

Step 6 In the Application Director view, do one of the following:
« Select the desired station in the station table and click Start.

+ Right click the desired station in the station table and select Start from the popup
menu.

The station starts.

For details on this platform view, refer to “Application Director” in the NiagaraAX
Platform Guide.

To stop a station

Prerequisites:

NOTE: Most station—platform functions can be performed from the Application Director
platform view of a host; however, you must connect to the platform where a station is
hosted before you can perform these tasks.

To stop a station using Workbench, do the following:
Step 1 Connect to the station’s platform.

Step 2 In the nav side bar, expand the platform node in the nav tree by clicking on the plus
sign (+) next to the platform icon in the tree.

The contents of the platform node displays in the tree.
Step 3 In the nav side bar, double click the ® Application Director.

Step 4 In the Application Director view, select the desired station. It becomes highlighted in
the table.

Step 5 Do one of the following:
+  With the desired station selected station table, click Stop.
« Right click the desired station and select Stop from the popup menu.
The station stops.

To open a station

To open a station, do the following.
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Step 1

Step 2

Step 3

Step 4

Step 5

From the File menu, select Open > Open Station (Fox)

The popup Open Station dialog appears, or if AX-3.8, the Open Station with SSL
dialog.

NOTE: The default in AX-3.8 has changed to Open Station with SSL.

Complete the fields in the Open Station or Open Station with SSL dialog box as
follows:

+ Type

Select either % Station SSL Connection or ¥ Station Connection, as appropriate.
If you change, the default Port changes between 4911 (SSL) to 1911 (non-SSL).

+« Host

Select the IP option and type in the IPv4 address of the host platform that you wish
to access.

+ Port

Verify the port shown, with the default as either 1911 (non-SSL) or 4911 (SSL). If
you know the remote host is using a different (non-default) platform daemon port,
enter it here.

Click the OK button. If you chose Open Station (non-SSL), go to Step 4.
If you chose Open Station with SSL, different results are possible:

» If the Niagara station’s FoxService is not enabled for SSL, an error results with
“Cannot connect. Ensure server is running on specified port”. Retry from Step 1,
changing the Type to Station Connection.

+ If the Niagara station’s FoxService is enabled for SSL, but you have not yet installed
a certificate for it, a popup Identity Verification dialog with certificate details ap-
pears. In most cases, you click Accept to proceed to the next step.

+ An Authentication popup dialog appears. Go to the next step.

In the popup Authentication dialog, enter your station user credentials

NOTE: Be sure to use your station username and password — not credentials for the
platform.

» Username
Enter your station user name.
+ Password

Enter the password for this user.

If the “Remember these credentials option” is available, you can select it, so that Work-
bench “remembers” these user credentials. However, this can pose a future security
risk; thus this option may be disabled.

Click OK after entering credentials.

If the station user credentials were correct, the station is connected, and the Fox con-
nection icon appears in the side bar pane. Where Fox connection icons are:

» ' Station or

« & Station SSL
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The view pane shows the Station Summary view, listing primary components and de-
tails on the host.

If the station user credentials were not correct, you are prompted to enter them again.

For related details, refer to the “About Security” section “Users and security”.

To close a station

To close a station, do the following.

Step 1 In the nav side bar (refer to “Using the nav side bar (tree)”, if necessary) right—click on
the station icon and select the Close command from the popup menu.

The Close dialog box appears.
Step 2 In the Close dialog box, click OK to close the station.

The station is closed and the station icon is removed from the nav side bar.

To connect to a station

To connect to a station, do the following.

Prerequisites:

NOTE: You cannot connect to a station unless it is “open”. An open station may be visible
in your Workbench nav side bar, but appear dimmed (be disconnected). If there is no sta-
tion icon in the nav side bar, you need to open the station before connecting. See “To
open a station”.

To connect to a disconnected station, do the following:

Step 1 In the nav side bar (refer to “Using the nav side bar (tree)”) right—click the station icon
and select the Connect command from the popup menu. Or, simply double-click the
station icon.

The popup Authentication dialog box appears.

Step 2 Enter your station user credentials

NOTE: Be sure to use your station username and password — not credentials for the
platform.

+ Username
Enter your station user name.
» Password

Enter the password for this user.

If the “Remember these credentials option” is available, you can select it, so that Work-
bench “remembers” these user credentials. However, this can pose a future security
risk; thus this option may be disabled.

Step 3 Click OK after entering credentials.

If the station user credentials were correct, the station is connected, and the Fox con-
nection icon appears in the side bar pane. Where Fox connection icons are:

» ¥ Station or

» % Station SSL
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The view pane shows the Station Summary view, listing primary components and de-
tails on the host.

If the station user credentials were not correct, you are prompted to enter them again.

For related details, refer to the “About Security” section “Users and security”.

To disconnect from a station

To disconnect from a station, do the following:

Step 1 In the nav side bar (refer to “Using the nav side bar (tree)”) right—click the station icon
and select the Disconnect command from the popup menu.

The popup Disconnect confirmation dialog appears.
Step 2 In the Disconnect dialog box, click OK to disconnect.

The station is disconnected and the station icon is dimmed.

Using the side bar pane

The side bar pane displays all open side bars. The pane may be shown or hidden by selecting a
command from the Windows menu, as described in “To open the side bar pane”.

Following, are some facts about the behavior of side bars and the side bar pane:

+ Ifyou open a side bar, the side bar pane (if currently closed) will automatically open to dis-
play that pane.

+  When you open Workbench, the side bar pane returns to its last previous state (displayed
or hidden).

+  When you show the side bar after all side bar panes have been closed (causing the side bar
pane to hide) the side bar pane will be empty

+  When you close all side bars, the side bar pane will close

+  When you open Workbench, it will display the side bars that were open (if any) when the
last session was closed.

+  When more than one side bar is open in the side bar pane, side bars may be resized verti-
cally, maximized, or restored to their previous size using the title bar controls.

+ Side bars always expand to fill the side bar pane horizontally.

To open the side bar pane

To open the side bar pane, do the following:
Prerequisites:
¢ From the menu bar, select Window > Side Bars > Show Side Bar command.The side bar

will appear.

To open the bookmarks side bar

To open the bookmarks side bar, do the following:
Prerequisites:

¢ From the menu bar, select Window > Side Bars > Bookmarks.The bookmarks side bar ap-
pears in the side bar pane.

To open the help side bar
To open the help side bar, do the following:
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Prerequisites:
¢ From the menu bar, select Window > Side Bars > Help.The help side bar appears in the
side bar pane.

To open the nav side bar

To open the nav side bar, do the following:
Prerequisites:
o From the menu bar, select Window > Side Bars > Nav.The nav side bar appears in the side

bar pane.

To open the palette side bar

To open the palette side bar, do the following:
Prerequisites:
o From the menu bar, select Window > Side Bars > Palette.The palette side bar appears in

the side bar pane.

To close a side bar

To close the side bar pane, do the following:
Prerequisites:
o From the side bar title bar dropdown menu (left side), select the Close command.The side

bar pane closes.

To close the side bar pane

The side bar pane toggles on or off by selecting or deselecting the Show Side Bar command, as
described below. The side bar pane also closes when all palettes are closed.

Prerequisites:
To close the side bar pane, do the following:

o From the menu bar, select Window > Side Bars > Show Side Bar.The side bar pane closes.

To vertically resize a side bar

To vertically resize a side bar, do the following:
Prerequisites:
o Click on the title bar and drag vertically.The side bar will adjust to any size that fits in the

side bar pane.

To restore a side bar to a previous size

To restore a side bar to it’s previous size, do the following:
Prerequisites:

o Click on the restore icon on the title bar.The side bar will change to its previous state.

To maximize a side bar:

To maximize a side bar, do the following:

Prerequisites:
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¢ Click on the restore icon on the title bar.The side bar will expand to its maximum size in

the side bar pane.

Using bookmarks

Bookmarks are simply linked “shortcuts” or “favorites” to help you quickly find views in just a

couple of clicks. The bookmark side bar provides a convenient place in the side bar pane to
add, manage, edit, and remove bookmarks. You can also do these “bookmarking” tasks using

the Bookmarks menu on the menu bar. For an overview of the bookmark side bar, see “About

the bookmark side bar”.

This section describes the following tasks that are associated with the bookmark feature:
+ To add a bookmark

+ To manage bookmarks

+ To edit a bookmark

« Toremove a bookmark

To add a bookmark

To add a bookmark, do the following steps:

Step 1 Make sure that the view you want to bookmark is showing in the view pane, and then

do one of the following:
+ From the menu bar, select Bookmarks: Add to Bookmarks.

+ From the popup menu in the palette side bar, select Add to Bookmarks.

Step 2 In the Add to Bookmarks dialog box, type a name for the bookmark, in the Name

field.

Step 3 Optional: In the Add to Bookmarks dialog box, click the New Folder button to add a

new folder, if desired.

The New Folder dialog box appears. There you can name your new folder and click

OK to save it.

Step 4 Inthe Add to Bookmarks dialog box, select the folder where you want to locate the

bookmark and click OK.

The bookmark is added.

To manage bookmarks

To manage your bookmarks, do the following steps:
Step 1 Do one of the following:
+ From the menu bar, select Bookmarks: Manage Bookmarks.
+ From the popup menu in the palette side bar, select Manage Bookmarks.
Step 2 In the Manage Bookmarks dialog box, click on one of the following buttons:
+ New Folder buttons
To create new folders to organize your bookmarks
+ New Bookmark button
To create new bookmarks
+ Copy to button

To copy bookmarks to another location
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+ Move to button
To move bookmarks to another location
+ Remove button
To delete the selected bookmark
+ Edit button
To rename a selected bookmark
+ Move Up or Move Down button

To move bookmarks up or down in the bookmark tree view

To edit a bookmark

To edit a bookmark, do the following steps:

Step 1 In the bookmarks side bar, right-click the bookmark that you want to change and se-
lect Edit from the popup menu.

The bookmark Edit dialog box will appear.
Step 2 In the Edit dialog box, type the desired name for your bookmark in the Name field.
Step 3 In the Edit dialog box, type the ORD path or scroll Name field.

To remove a bookmark

To remove a bookmark, do the following:
Prerequisites:

o In the bookmarks side bar, right-click the bookmark that you want to change and select Re-
move from the popup menu.The bookmark is deleted from the bookmark list.

Using the help side bar

When you open the help side bar for the first time, the help side bar is empty except for the
Load Help button. The Load Help button will reappear any time any module's timestamp is
changed or when a new module is added or removed. When you click the Load Help button,
Workbench searches through all the available modules to create the help directory. The Help
Sidebar provides a view of the available Help.

To search for topics in the help side bar:

After you enter one or more words in the Find window, pressing the Search button creates a
list of documents that contain one or more occurrences of the words you have entered. The re-
sults show those document's containing any of the words, not all of the words. The ranking or-
der is based on how many times any of the words appear in a given document.

Prerequisites:
To search for topics in the help side bar, do the following steps:
Step 1 In help side bar, click on the Search tab. The search display appears.

Step 2 In the Find field, type the word or phrase that you are looking for and click the Search
button.

Topics that match your search word(s) will appear in side bar below the text field.

Step 3 Double-click on a topic to display the topic in the view pane.

138

NiagaraAX User Guide



Performing tasks

May 26, 2016

Using the nav side bar (tree)

The nav side bar provides a hierarchical view of the system in a nav—tree presentation. Com-
ponents that appear in the tree may be acted on in various ways depending the component

type:
The following sections describe how to use Nav side bar actions and the following procedures:
+ To refresh a nav side bar tree node
+ To refresh a nav side bar tree node
Nav side bar actions
+ Expand
Click the plus sign next to an icon to expand a branch of the tree and show any child nodes.
+ Collapse
Click the minus sign next to an icon to collapse a branch of the tree.
o Select
Click a node in the tree to select it.
+ View

Double—click the minus sign next to an icon to collapse a branch of the tree and hide its
child nodes.

+ Use popup menu
Right—click the desired node to use the context—sensitive popup menu.
+ Use file > menu

With a node selected, choose a menu item from the File menu.

To refresh a nav side bar tree node

Refreshing a nav side bar tree node, updates the view to reflect any changes to the files of that
node.

Prerequisites:
To refresh a nav side bar tree node, do the following steps:
Step 1 Click the node to select it.
Step 2 Do one of the following:
« From the File menu, select Refresh.
The tree node refreshes.
+ From the popup menu, select Refresh Tree Node.

The tree node refreshes.

To Go Into a nav side bar tree node

The Go Into command allows you to re-root the nav tree at any arbitrary node. This will make
that node the new root of the tree and give you a new tree in the nav side bar window. You can
get back to the original tree by selecting it from the All the nodes you have "gone into" are per-
sistently saved as a special type of Bookmark. Use the pulldown to switch between them. This
feature is quite handy when working with multiple Stations or deep File systems and
Databases.

Prerequisites:
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To refresh a nav side bar tree node, do the following steps:
Step 1 Click the node to select it.
Step 2 Do one of the following:
+ From the File menu, select Refresh.
The tree node refreshes.
+ From the popup menu, select Refresh Tree Node.

The tree node refreshes.

Using the jobs side bar

The Jobs side bar provides a place to view and manage current jobs. Once a job has completed
you are notified via the async notification feature. You can also view job details using the ">>"
button.

This section explains how to do the following:
+ To view job details
+ To cancel a job from the jobs side bar

o To dismiss a job

To view job details

To view job details from the jobs side bar, do the following:
Prerequisites:

+ On the desired job, click the details (">>") button.The job log details dialog box appears.

To cancel a job from the jobs side bar

To cancel a job from the jobs side bar, do the following:
Prerequisites:

o On the jobs side bar, click the cancel button.The job is cancelled.

To dismiss a job

Once a job has been completed, you are notified via the async notification feature. You may
then dismiss the job from the jobs side bar, if desired.

Prerequisites:
To dismiss a job, do the following:

o From the Jobs side bar click the close button on the job that you want to dismiss.The se-
lected job is closed.

Using the palette side bar

The palette side bar provides a place to open, view, and access components in modules. For an
overview of the palette side bar, see “About the palette side bar”.

This section explains how to do the following:
+ To open a palette
+ To close a palette

+ To create a palette

140

NiagaraAX User Guide



Performing tasks

May 26, 2016

+ To add a new component to a palette (PaletteFile.palette)
+ Toadd a new component to a palette (module.palette)

+ To copy a component to a palette

To open a palette

You can open one or more palettes in the palette side bar. Refer to “To open the palette side
bar” for details on how to open the palette side bar.

Prerequisites:
To open a new palette in the palette side bar, follow these steps:
Step 1 On the palette toolbar click the open palette button.

The Open Palette dialog box appears.

Step 2 In the Open Palette dialog box select one or more palettes from the list, as desired.
The text field at the top of the dialog box allows you to filter the displayed palettes by
typing in the name of the desired palette. Also, you can use the Browse button to lo-
cate palettes in alternate locations.

NOTE: Hold down the Ctrl or Shift key to make multiple selections.

Step 3 Click OK.
The palette(s) opens in the palette side bar pane.

To close a palette

You can close any of the palettes that are open in the palette side bar. When you close all the
palettes, the palette side bar closes.

Prerequisites:

To close a palette, follow these steps:

Step1 From the Drop-down palette selector, choose the palette that you want to close.
The selected palette displays in the side bar pane.

Step 2 Click the Close palette button.
The palette closes.

To create a palette

Palettes allow you to save copies of your work for future use. Palette files may reside under a
station file system or as part of a module. This procedure describes how to create a palette that
resides in a station file system. Refer to “Working with modules” for information about creating
a palette file that is part of a module (jar file).

Prerequisites:

NOTE: For convenience and good organization, it is a good idea to create a “palette” fold-
er on the file system to hold all your custom palette files.

To create a palette, follow these steps:

Step 1 In the nav tree, right-click on (or under) the station file system node, in the desired lo-
cation (see note, above).

The popup menu appears.

NiagaraAX User Guide

141



Performing tasks

May 26, 2016

Step 2 From the popup menu, select New > PaletteFile.palette.
The File Name dialog box appears with a default name.

Step 3 In the File Name dialog box, type the desired name for the new Palette file and click
OK.

The File Name dialog box disappears and the new Palette file appears in the nav tree.

For more information about palette files, refer to “About palettes”..

To add a new component to a palette (PaletteFile.palette)

You can add a new component to any of your own custom palettes, store the palette files on
your file system and view them in your palette side bar. The palette files must reside on the file
system, not in the station database. However, the components that you add to your palette file
may reside in the station database.

Prerequisites:

NOTE: For convenience and good organization, it is a good idea to create a “palette” fold-
er on the file system to hold all your custom palette files.

To add a new component to a palette using the wire sheet view, follow these steps:

NOTE: To add a new component using a view other than the wire sheet view, refer to the
information in “Working with components”.

Step 1 In the nav tree, double-click on the palette file that you want to open.
The default (Wire Sheet) view appears.
Step2 Add a component to the wire sheet view using one of the following methods.

+ Right click on the wire sheet view and select a new component from the New
menu.

+ Drag and drop a component from the nav side bar directly onto the wire sheet.
Step 3 Select File > SaveBog from the main menu.

The palette file is updated to contain the new component.

NOTE: If the updated palette is currently being viewed in the palette side bar, you
must close and reopen the palette after saving the station (SaveBog).

To add a new component to a palette (module.palette)

You can add new components to any of your palettes that have module.palette files associated
with them. A single module.palette file may be associated with each module that is stored in
the modules directory. You change a module.palette file by first making the desired changes to
a module.palette file that resides in a module “build” directory under your file system and then
using the build process to recreate the module that includes the changed palette file.

Prerequisites:
To add a new component to a palette (module.palette file), follow these steps:

Step 1 Double click on the desired module.palette file. It should be located in a module direc-
tory on your station file system.

The default (Wire Sheet) view appears.
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Step2 Add a component to the wire sheet view using one of the following methods:

+ Right click on the wire sheet view and select a new component from the New
menu.

+ Drag and drop a component or container from the nav side bar directly onto the
wire sheet.

Step 3 Select File > SaveBog from the main menu.

Step 4 From the console command line (press F3 to open console window) navigate to the
working directory and type the build command followed by a space and then the name
of the module folder. For example:

\workingDirectory> build moduleName

Press the Return key to initiate the build process. If the build is successful, the updated
jar file is built and overwrites the old jar file located in the modules folder. If the build
is not successful, no jar file is built and error messages are generated to help you trou-
bleshoot the problem.

Step 5 Refer to “To create a new (.jar) module” for more detailed instructions about creating
a module.

To copy a component to a palette

You can copy components to any of your own custom palettes, store the palette files on your
file system and view them in your palette side bar. The nav files must reside on the file system,
not in the station database. However, the components that you add to your palette file may re-
side in the station database. The components that you add to your palette are copies and not
connected to the original components that you are copying.

Prerequisites:

NOTE: For convenience and good organization, it is a good idea to create a “palette” fold-
er on the file system to hold all your custom palette files.

To copy a component to a palette, using the Wire Sheet view, follow these steps:
Step 1 In the nav tree, double-click on the file palette file that you want to open.
The default (Wire Sheet) view appears.

Step 2 From the nav side bar, palette side bar, or other source, drag and drop the desire com-
ponent to the wire sheet.

The copied component is added to the palette file.
Step 3 Select File > SaveBog from the main menu.

The palette file is updated to contain the new component.

NOTE: If the updated palette is currently being viewed in the palette side bar, you
must close and reopen the palette in the palette side bar in order to see the new items.

To add a side bar preview using the compPreviewWidget property

Palette previews display in the palette when components have images configured either as the
default image property or as the image assigned to the comPreviewWidget property. If no pre-
view is associated with a component, in AX-3.5 and later, you can add a compPreviewWidget

property to a widget in order to display an image in the preview pane of the palette side bar.

Prerequisites:
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To add a palette preview image to a component, do the following:

Step 1

Step 2

Step 3

Step 4
Step 5

Step 6

Step 7

Step 8

Step 9

Right-click the desired component in the palette side bar and select Views > Slot Sheet
from the popup menu. The Slot Sheet view displays.

In the slot sheet view, right-click in an empty area of the view and select Add Slot
from the popup menu. The Add Slot dialog box displays.

In the Add Slot dialog box, enter the following information:
+ Name
Type compPreviewWidget in this text field.
+ Type
Select bajaui and Label from the two option lists respectively.
Click the OK button. The compPreviewWidget slot is added to the component.

Right-click the desired component in the palette side bar and select Views > Property
Sheet from the popup menu. The Property Sheet view displays.

In the property sheet view, edit properties under the comPreviewWidget to add text
and an image, as desired and click the Save button.

Click the OK button. The preview is configured and should appear in the preview pane
the next time you select the component in the palette side bar.

Right-click the desired component in the palette side bar and select Views > Slot Sheet
from the popup menu. The Slot Sheet view displays.

In the Slot Sheet view, right-click on the compPreviewWidget slot and select Config
Flags from the popup menu. The Config Flags dialog box displays.

Step 10 In the Config Flags dialog box, select the Hidden and Remove on Clone options and

Using the view pane

click the OK button. The preview is now configured and should display in the preview
pane the next time you select the component in the palette side bar.

The view pane can display any component view that you choose (see “About views” for an in-
troduction to views). Different views of components can provide different editing options.
Most component editing is done in the view pane, however, many editing functions also in-
volve the nav tree pane as well. The following sections describe some of the basic tools pro-
vided in Workbench for editing components. These tools are context—sensitive and may be
used in several — but not all — views and with several — but not all — types of components.

For more details about viewing components, refer to “Viewing a component”

Editing components

Editing components in Workbench typically involves.

+ Selecting a component

+ Viewing a component

+  Working with components

+ Editing component data

The following sections describe these tasks.
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Selecting a component

By selecting an item, you are defining the scope of your actions. In other words, the only com-
ponents that are directly affected by your edits are those that are “selected” during your edits.
Of course, other components may be influenced by the change in a component that communi-
cates with it. It is also important to remember the hierarchical nature of the component tree. If
you delete or move a component that contains other components, then you are deleting or
moving all items that are contained in that container component.

When items are selected, they appear in one of the following ways:

+ In the nav tree view, the component text is changed to a white on purple highlight.
+ In the wire sheet view, selected components have a red border with red handles.

+ In the wire sheet view, selected links turn red.

For more information about views, refer to “About views”.

To select a component

To select a component, do one of the following:
Prerequisites:

+ In the nav tree view or the wire sheet view, left—click the desired component.The compo-
nent is selected.

o In the nav tree view or the wire sheet view, right-click the desired component.The compo-
nent (or link) is selected.

o In the wire sheet view, drag around the desired component.The component (or link) is
selected.

To select multiple components in the nav tree

To select more than one component in the nav tree do the following:
Step 1 Select a single component or link, as described in “To select a component”.
Step 2 Hold down the Shift key or Ctrl key and select additional items.

Multiple components (or links) are selected.

Step 3 Optional: In the wire sheet view, drag around the group of elements that you want to
select. Hold down the Shift key or Ctrl key and select additional items to select or dese-
lect them.

Multiple components (or links) are selected.

To select a multiple components in the wire sheet

To select more than one component in the wire sheet do the following:
Step 1 Select a single component or link, as described in “To select a component”.
Step 2 Hold down the Shift key or Ctrl key and select additional items.

Multiple components (or links) are selected.

Viewing a component

Each component that you select (in a view or in the nav tree) has a “default” view that appears
in the view pane. You can select a different view of the component using the view selector or
the popup (right—click) menu. The last view of an object becomes its default view during the
Workbench session. If the Workbench is closed and restarted, default views are reset to the
original default views.
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For details on selecting component views, see “To select a component view”.

In addition to having different views, you can edit the way views display information. For de-
tails about customizing a view, refer to the following procedures:

“To reorder components (in a component container)”

“To create a composite view”

To select a component view

To select a component view, do one of the following:
Prerequisites:

o Double-click on a component in the nav side bar.This will display the default view of the
component.

+ Right—click a component and choose a view from the Views submenu.

o With a component selected, choose a view from the view selector menu

To reorder components (in a component container)

You can reorder the components that are contained in a “container” component using the
property sheet view, the nav tree view, or the wire sheet view.

Prerequisites:

To reorder components, do the following:

Step 1 Right—click the desired component.
The popup menu appears.

Step 2 From the popup menu, select Reorder.
The Reorder dialog box appears.

Step 3 In the Reorder dialog box, use the sort buttons, as follows:
+ Move Up button

Select one or more items in the component list (use the Ctrl or Shift key to select
multiples) and click this button to move selected item(s) up (one position per click)
in the list.

+« Move Down button

Select one or more items in the component list (use the Ctrl or Shift key to select
multiples) and click this button to move selected item(s) down (one position per
click) in the list.

+ Sort by Name button

Click this button to sort all items in the list in alphabetical order, by name. Each
click toggles the sort order between ascending and descending sort order.

+ Sort by Type button

Click this button to sort all items in the list in order by component type. Each click
toggles the sort order between ascending and descending sort order.

+ Reset button

Click this button to set the components in the list back to the order that they were
in when the Reorder dialog box was opened.

The components are sorted according to button selected.
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To create a composite view

Composite views are available in the wire sheet view and in the property sheet view. Creating a
composite view of a component allows you to expose one or more child slots (that you desig-
nate) at the parent—view level. For more information about composite views, refer to “About
composites”.

Prerequisites:

To create a composite view, do the following:

NOTE: The component that you select in the following step must have a child component
to be a legitimate parent component. If no valid child component is available, then there
cannot be a composite.

Step 1 In the wire sheet view or in the property sheet view, right—click on the desired parent
object.

appears.
The popup menu appears.

Step 2 From the popup menu, select the Composite command.
The Composite Editor appears.

Step 3 In the Composite Editor, expand the tree to find and select the desired points to add
to the parent component. Select multiple points (if desired) by holding the Ctrl or Shift
keys when selecting.

Step 4 With the desired point(s) selected, click the Add button to add one or more points to
the right column of the Composite Editor.

Step 5 Optional: Use the Composite Editor control buttons to do the following, if desired:
+ Reverse
Reverse the chosen side (“in” or “out”) of a point that is being composited.
+ Rename
Provide a custom name for the new slot created by composited point.
+ Remove
Removes the composited item (slot) from right side of the Composite Editor.
+ Move Up

Sort all selected points by moving them up in the Composite Editor (list (one posi-
tion per click).

« Move Down

Sort all selected points by moving them down in the Composite Editor list (one po-
sition per click).

Step 6 Click the OK button.

The component composites are set.

Working with components

The following procedures describe basic tasks that are used when working with components:
+ To add a new component (property sheet, nav side bar, or wire sheet view)

+ To delete a component (property sheet, nav side bar, or wire sheet view)
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+ To rename a component (property sheet, nav side bar, or wire sheet view, slot sheet)

+ To duplicate a component (property sheet, nav side bar, or wire sheet view)

+ To paste a component (property sheet, nav side bar, or wire sheet view)

+ To drag a component to the property sheet, nav side bar, or wire sheet (left—click method)
+ To drag a component to the property sheet, nav side bar, or wire sheet (right—click

method)

To add a new component (property sheet, nav side bar, or wire sheet view)

You can add (create) a new component to a container using the property sheet view, the nav
tree view or the wire sheet view. To add a slot refer to “T'o add a new slot”.

Prerequisites:
To add a new component, do the following:

Step 1 Right—click in the container where you want to place the new component. This can be
a component in the nav tree view, the wire sheet view or the property sheet view.

A popup menu appears.

Step 2 From the popup menu, choose the New command and select the desired type of
component:

+ Folder

+ IconFolder

+ TextBlock

+ BooleanWritable

o NumericWritable

+ EnumWoritable

+ StringWritable

The Name dialog box appears.

Step 3 Type the desired name for the new component in the text field and click the OK
button.

The new component appears in the property sheet.

To delete a component (property sheet, nav side bar, or wire sheet view)

You can delete a component from a container, using the property sheet view, the nav tree view
or the wire sheet view. To delete a component using the slot sheet view, refer to To delete a slot
refer to “To delete a slot”.

Prerequisites:

To delete a component, do the following:

NOTE: If you delete a component that contains other components, all components in that
container component are deleted as well.

Step 1 Right—click the desired component.
A popup menu appears.
Step 2 From the popup menu, select the Delete command.

The component is deleted.
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To rename a component (property sheet, nav side bar, or wire sheet view, slot
sheet)

You can rename a component in the property sheet view, the nav tree view, the wire sheet view,
or the slot sheet view.

Prerequisites:

To rename a component, do of the following:

Step 1 In the desired view, right—click the component to rename.
The popup menu appears.

Step 2 From the popup menu, select the Rename command.
The Rename dialog box appears.

Step 3 In the Rename dialog box, type the desired name in the text field and click the OK
button.

The component is renamed.

To duplicate a component (property sheet, nav side bar, or wire sheet view)

You can duplicate a component from the property sheet view, the nav tree view, or the wire
sheet view.

Prerequisites:

To duplicate a component, do of the following:

Step 1 In the desired view, right—click the component to duplicate.
The popup menu appears.

Step 2 From the popup menu, select the Duplicate command.
The Name dialog box appears.

Step 3 In the Name dialog box, type the desired name in the text field (or use the default
name) and click the OK button.

The component is duplicated.

To paste a component (property sheet, nav side bar, or wire sheet view)

You can add a component to a container by pasting it to a container displayed the property
sheet view, the nav tree view, or the wire sheet view.

Prerequisites:
To add a component by pasting it, do the following:*

Step 1 In the desired view, select the desired component and use the Copy (to duplicate) or
Cut (to remove) command to copy the component to the clipboard.

Copy and Cut commands are available on the popup (right—click) menu, the Edit
menu, or from the toolbar.

Step 2 Right—click in the container where you want to place the new component. This can be
a component in the nav tree view, the wire sheet view or the property sheet view.

The popup menu appears.
Step 3 From the popup menu, select the paste command.
The Name dialog box appears.

Step 4 Type the desired name for the new component in the text field and click the OK
button.
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The new component is added to the targeted container.

To drag a component to the property sheet, nav side bar, or wire sheet (left—click
method)

You can drag a component to the displayed property sheet view, the nav tree view, or the wire
sheet view, by using a right—click drag or by using a normal, left—click drag.

Prerequisites:

NOTE: A left—click drag always creates a copy of the original.

To drag a component using the left—click drag method, do the following:

Step 1 In the desired view, left—click the component to copy and drag it to the target
container.

When you release the mouse button, the Name dialog box appears.

Step 2 Type the desired name for the new component in the text field and click the OK
button.

The new component is added to the targeted container.

To drag a component to the property sheet, nav side bar, or wire sheet (right—click
method)

You can drag a component to the displayed property sheet by using a right—click drag or by us-
ing a normal, left—click drag.

Prerequisites:

NOTE: A right—click drag always prompts you to choose a copy, move, or cancel
command.

To drag a component to a property sheet by using the right—click drag method, do the
following:

Step 1 In the desired view, right—click the component that you want to move (or copy) and
drag it to the property sheet.

When you release the right mouse button, a popup menu appears.
Step 2 From the popup menu, choose one of the following commands:

+ Copy - this command makes a duplicate of the component to paste onto the prop-
erty sheet.

The Name dialog box appears.

+ Move — this command removes the original component and prepares to paste in
onto the property sheet.

The Name dialog box appears.
+ Cancel - this command will stop the process, and the popup menu will disappear.

Step 3 Type the desired name for the new component in the text field and click the OK
button.

The new component appears in the property sheet.
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Editing component data

Many component editing functions in Workbench work the same, or similarly, in all compo-
nent views. However, some editing functions are restricted to particular component views. For
information about the standard edit commands (such as cut, copy, and paste, refer to “Types of
edit commands”. The following sections describe some of the basic component editing
procedures.

+ Using the property sheet
+ Using the wire sheet

+ Using the slot sheet

+ Using the link sheet

Using the property sheet

The property sheet view is displayed in the view pane by selecting Property Sheet from the
view selector menu (see “About the view selector”) or by using one of the other methods de-
scribed in “About the view pane”.

For information about creating new components, deleting components, duplicating compo-
nents, and so on, refer to “Editing components”.

To add an extension to a component property sheet view:

For more information about extensions, refer to “Extension process overview” or “About point
extensions”

Prerequisites:

NOTE: The following procedure may also be performed directly in the nav side bar tree
(refer to “Using the nav side bar (tree)”.

Step 1 Display the component property sheet view, as follows:
+ In the nav pane tree, select the desired component.

+ From the right—click popup menu (or from the view selector), select the compo-
nent property sheet view.

Step 2 Open the desired extensions palette from the palette side bar.

Step 3 Expand the extensions folder to find the extension that matches your data type and
collection method.

Step 4 Drag and drop or copy and paste the extension onto the bottom of the properties
sheet.

The extension is added. Refer to “Configure history extensions”

To add a component facet:

For more information about facets, refer to “About point facets”.

Step 1 In the property sheet view of a component, click the Edit Facet (>>) button.
The Edit Facets dialog box appears.

Step 2 In the Edit Facets dialog box, click the Add button.
The Add... dialog box appears.

Step 3 From the Key: options menu, select a parameter. Duplicates are not allowed.

Step 4 From the Type: options menu, select a parameter.
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Step 5 Click the OK button.

The Add... dialog box closes and the Edit Facets dialog box displays the new
information.

Step 6 From the Edit Facets dialog box, click the OK button.
The new facet is added.

Step 7 In the property sheet, click the Save button to your save changes.

To remove a component facet:

For more information about facets, refer to “About point facets”.

Step 1 In the property sheet view of a component, click the Edit Facet (>>) button.
The Edit Facets dialog box appears.

Step 2 In the Edit Facets dialog box, click the Remove button.
The Remove... dialog box appears.

Step 3 From the Remove... dialog box, choose a parameter(s) that you want to delete by se-
lecting the associated check box(es).

Step 4 Click the OK button.

The Edit Facets dialog box disappears and deleted parameter information does not
appear.

Step 5 From the Edit Facets dialog box, click the OK.
The new facet is removed.

Step 6 In the property sheet, click the Save button to save changes.

Using the wire sheet

The following are common tasks associated with the wire sheet
o To pin aslot

+ To paste a component onto the wire sheet

+ To drag a component to the wire sheet (left—click method)
+ To drag a component to the wire sheet (left—click method)

+ To drag a component to the wire sheet (right—click method)

To pin a slot

By default, some slots are visible in the wire sheet view of the slot. However, you can have any
— or all slots visible on the wire sheet by “pinning” open the slot(s).

Prerequisites:
To pin a slot:
Step 1 In the wire sheet view, right—click on the desired component.
The popup menu appears.
Step 2 From the popup menu, select the Pin Slots command.
The Pin Slots dialog box appears.
Step 3 In the Pin Slots dialog box, click to the left of all slots that you want to pin open.

A pin icon appears next to each icon you click.
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Step 4 Click the OK button.

The slots are pinned and appear on the wire sheet with a knob next to the slot name.

To paste a component onto the wire sheet

You can add a component to the displayed property sheet by pasting it onto the property sheet
or by dragging it onto the property sheet.

Prerequisites:

To add a component to a property sheet by pasting it to the property sheet, do the
following:

Step 1 Select the desired component and use the Copy (to duplicate) or Cut (to remove)
command to copy the component to the clipboard.

Copy and Cut commands are available on the popup (right—click) menu, the Edit
menu, or from the toolbar.

Step 2 Right—click on the property sheet.
The popup menu appears.

Step 3 From the popup menu, select the paste command.
The Name dialog box appears.

Step 4 Type the desired name for the new component in the text field and click the OK
button.

The new component appears in the property sheet.

To drag a component to the wire sheet (left-click method)

You can drag a component to the displayed property sheet by using a right—click drag or by us-
ing a normal, left—click drag.

Prerequisites:

To drag a component to a property sheet by using the left—click drag method, do the
following:

Step 1 Select the desired component using a left—click and drag it to the property sheet.
When you release the mouse button, the Name dialog box appears.

Step 2 Type the desired name for the new component in the text field and click the OK
button.

The new component appears in the property sheet.

To drag a component to the wire sheet (right-click method)

You can drag a component to the displayed property sheet by using a right—click drag or by us-
ing a normal, left—click drag.

Prerequisites:

To drag a component to a property sheet by using the right—click drag method, do the
following:

Step 1 Right—click the desired component and drag it to the property sheet.
When you release the right mouse button, a popup menu appears.
Step 2 From the popup menu, choose one of the following commands:

+ Copy - this command makes a duplicate of the component to paste onto the prop-
erty sheet.
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The Name dialog box appears.

+ Move - this command removes the original component and prepares to paste in
onto the property sheet.

The Name dialog box appears.
+ Cancel - this command will stop the process, and the popup menu will disappear.

Step 3 Type the desired name for the new component in the text field and click the OK
button.

The new component appears in the property sheet.

Using the slot sheet

The following are common tasks associated with the slot sheet
+ To add a new slot

+ To delete a slot

To add a new slot

To add a new slot, perform the following steps:
Step 1 In the slot sheet view, right—click in the pane.
The popup menu appears.
Step 2 From the popup menu, select the Add Slot command.
The Add Slot dialog box appears.
Step 3 In the Add Slot dialog box, enter the following information:
+ Name: type in a name for the slot.
+ Type: Select the component property type from the drop-down option lists.
+ Choose the desired slot options from the Flags field.
Step 4 Click the OK button.
The slot is added to the slot sheet.

To delete a slot

To delete a slot, perform the following steps:

Step 1 In the slot sheet view, right—click on the slot that you want to delete.
The popup menu appears.

Step 2 From the popup menu, select the Delete command.

The slot is deleted.

Using the link sheet

The following are common tasks associated with the link sheet
+ To delete a link using the link sheet view

o To edit a link using the link sheet view

To delete a link using the link sheet view

To delete a link using the link sheet view, perform the following steps:
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Using alarms

Step 1 In the link sheet view, right—click on the link that you want to delete.
The popup menu appears.
Step 2 From the popup menu, select the Delete command.

The link is deleted.

To edit a link using the link sheet view

To edit a link using the link sheet view, perform the following steps:
Step 1 In the link sheet view, right—click on the link that you want to edit.
The popup menu appears.
Step 2 From the popup menu, select the Edit command.
The edit dialog box appears.
Step 3 In the edit dialog box, edit the following fields, as desired
+ Source Ord
Type in (or browse to) the ORD for the desire source of the link.
+ Source Slot Name
Type in a name for the Source.
+ Target Slot Name
Type in a name for the Target Slot
+ Enabled

Choose True of False from the Enable option list. True enables the link and False
disables the link.

Step 4 In the edit dialog box, click the OK button.
The edit dialog box disappears and the edits are saved.

The following are common tasks associated with setting up and working with alarms in AX.
+ Creating alarms

+ Routing alarms

+ Managing alarms

Creating alarms

To create an “alarmable” control point, you must add an appropriate alarm extension to a con-
trol point and configure it to define your alarm condition requirements:

To set up alarm conditions for a control point

Prerequisites:

NOTE: Just as there are different types of control points (refer to “Types of control
points” on), there are different types of control point extensions (refer to “Types of point
extensions”). When adding an alarm extension to a control point, you must add the prop-
er type of extension to match the point, as described in “Types of alarm extensions”.
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To set up alarm conditions for a control point, do the following:

Step1 Add an alarm extension to the control point property sheet as described in “To add an
extension to a component property sheet view”. The alarm extension must match the
control point type (for example, BooleanChanegOfStateAlarmExt fits with a Boolean
Writable point — and a EnumChangeOfStateAlarmExt would not).

Step 2 Configure the alarm extension properties as desired. Refer to the “About alarm exten-
sion properties” for details about the alarm extensions properties.

NOTE: The Alarm Enable property options are not selected by default. You must se-
lect an AlarmEnable option in addition to setting your alarm extension properties.

Routing alarms

The alarm service handles the routing of alarms by using alarm classes to coordinate the trans-
fer of messages between alarm sources and alarm recipients. Refer to “Types of alarm recipi-
ents” for more information about alarm recipients.

To add an alarm class to the alarm service

For more information about alarm service, refer to “About the alarm service”. For more infor-
mation about alarm class, refer to “About alarm class”.

Prerequisites:

To add an alarm class to the alarm service, do the following:

Step 1 Right—click the AlarmService node in the nav side bar.
The popup menu appears.

Step 2 From the popup menu, select Views > WireSheet.
The alarm service Wire Sheet view appears.

Step 3 From the alarm palette, drag an AlarmClass component onto the wiresheet.
The Name dialog box appears.

Step4 Type the desired name for the new alarm class in the text field and click the OK
button.

The new alarm class appears in the wiresheet and is ready for configuration.

To add a console recipient to the alarm service

For more information about alarm service, refer to “About the alarm service”. For more infor-
mation about console recipient, refer to “About the console recipient”.

Prerequisites:
To add a console recipient to the alarm service, do the following:
Step 1 Right—click the AlarmService node in the nav side bar.
The popup menu appears.
Step 2 From the popup menu, select Views > WireSheet.
The alarm service Wiresheet view appears.
Step 3 From the alarm palette, drag a ConsoleRecipient component onto the wiresheet.

The Name dialog box appears.
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Step4 Type the desired name for the new console recipient in the text field and click the OK
button.

The new console recipient appears in the wiresheet and is ready for configuration.

To add a station recipient to the alarm service

For more information about alarm service, refer to “About the alarm service”. For more infor-
mation about station recipient, refer to “About the station recipient”.

Prerequisites:

To add a station recipient to the alarm service, do the following:

Step 1 Right—click the AlarmService node in the nav side bar.
The popup menu appears.

Step 2 From the popup menu, select Views > WireSheet.
The alarm service Wiresheet view appears.

Step 3 From the alarm palette, drag a StationRecipient component onto the wiresheet.
The Name dialog box appears.

Step 4 Type the desired name for the new station recipient in the text field and click the OK
button.

The new station recipient appears in the wiresheet and is ready for configuration.

To add an email recipient to the alarm service

For more information about alarm service, refer to “About the alarm service”. For more infor-
mation about email recipient, refer to “About the Email Recipient (email-EmailRecipient)”.

Prerequisites:

To add an email recipient to the alarm service, do the following:

Step 1 Right—click the AlarmService node in the nav side bar.
The popup menu appears.

Step 2 From the popup menu, select Views > WireSheet.
The alarm service Wiresheet view appears.

Step 3 From the email palette, drag an EmailRecipient component onto the wiresheet.
The Name dialog box appears.

Step 4 Type the desired name for the new email recipient in the text field and click the OK
button.

The new email recipient appears in the wiresheet and is ready for configuration.
Managing alarms

To acknowledge alarms from the alarm console view

Prerequisites:
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NOTE: Alarms are not removed from the alarm console until both the following condi-
tions exist:

+ alarm acknowledged

+ alarm source is in a normal (not alarm) state

You can acknowledge alarms from the alarm portal as well as from the alarm console. To
acknowledge alarms from the alarm portal, refer to “To acknowledge alarms from the
alarm portal”.

To acknowledge alarms from the alarm console view, do the following:
Step 1 Right—click on the ConsoleRecipient node in nav side bar pane.
The popup menu displays.
Step 2 From the popup menu, select Views > Alarm Console.
The alarm console view appears with all alarm sources displayed in a tabular view.

Step 3 In the alarm console view, select alarm sources that you want to acknowledge. Select
multiple alarms, if desired, using the Shift or Ctrl key.

NOTE: Each record that appears in the alarm console table represents one alarm
source and one or more alarms from that source. You may acknowledge either the lat-
est (most recent) alarm or acknowledge all alarms that are reported from that source
by choosing either the “Acknowledge” command or the “Acknowledge All” command,
as described in the following step.

Step 4 Acknowledge selected alarm(s) by doing one of the following:
+ From the Alarm menu, select Acknowledge (to acknowledge the latest alarm only)
The latest alarm from each selected choice is acknowledged.
OR

+ From the Alarm menu, select Acknowledge All (to acknowledge all alarms re-
ported from that source). Alternatively, you may click the Acknowledge All button
(located at the bottom of the dialog box).

All alarms from each selected alarm source are acknowledged.

To acknowledge alarms from the alarm portal

The alarm portal must be running and configured to include all desired alarm consoles before
it can be used to acknowledge alarms. Refer to “Alarm portal” for details about the alarm por-
tal. Refer to “Alarm Portal options” for details about alarm portal display options.

Prerequisites:

NOTE: Alarms are not removed from the alarm console (or portal) until both the follow-
ing conditions exist:

+ alarm acknowledged

+ alarm source is in a normal (not alarm) state
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You can acknowledge alarms from the alarm console as well as from the alarm portal. To
acknowledge alarms directly from the alarm console, refer to “To acknowledge alarms
from the alarm console view”.

To acknowledge alarms from the alarm portal, do the following:

Step 1

Step 2

Step 3

Step 4

Step 5

Step 6

Step 7

From the Tools menu, select Alarm Portal.
The Alarm Portal view displays in the view pane.

If the desired Alarm Console does not appear in the Alarm Console Monitor table (top
portion of the Alarm Portal view) right—click in the Alarm Console Monitor area.

The popup menu, appears.

Select Add Alarm Console.

The Add Alarm Console wizard appears.

Complete the Add Alarm Console wizard by entering the following information:
+ Host address information, as needed (IP or dialup)

+ Credentials information (username and password)

+ Choose the desired console, by Ord (if more than one is present at the host
address)

Click the Finish button to complete the Add Alarm Console wizard.

The alarm console appears in the Alarm Console Monitor table (top portion of the
Alarm Portal view). Any alarms will appear in the Open Alarm Sources table (bottom
portion of the Alarm Portal view).

In the Open Alarm Sources table, select alarm sources that you want to acknowledge.
Select multiple alarms, if desired, using the Shift or Ctrl key.

NOTE: Each record that appears in the Open Alarm Sources table represents one
alarm source and one or more alarms from that source. You may acknowledge either
the latest (most recent) alarm or acknowledge all alarms that are reported from that
source by choosing either the “Acknowledge” command or the “Acknowledge All”
command, as described in the following step.

Acknowledge selected alarm(s) by doing one of the following:

+ From the Alarm menu, select Acknowledge (to acknowledge the latest alarm only)
The latest alarm from each selected choice is acknowledged.
OR

+ From the Alarm menu, select Acknowledge All (to acknowledge all alarms re-
ported from that source). Alternatively, you may click the Acknowledge All button
(located at the bottom of the dialog box) or use the popup menu to acknowledge
the alarm(s).

All alarms from each selected alarm source are acknowledged.

To delete alarm records

The Alarm Database Maintenance view provides three ways to delete alarm records from the
alarm database. To delete old alarm records, do the following:

Step 1

In the Alarm Database Maintenance view, select one of the following three options:

+ Clear Old Records option
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to clear alarm records before a certain date and time. The Before field is provided
to allow you to set the date and time for removing old records. The Before field is
not available when you select either of the other options.

o Clear All Before Selected Record option

to delete all records that have a timestamp earlier than the timestamp of the record
that you select in the Alarm History pane table. The selected record is not deleted.

+ Clear All Records options

to delete all records that appear in the Alarm History pane table, regardless of the
date.

Step 2 Click the Run Maintenance button to initiate the delete action.

The Confirm Clear dialog box displays to clarify that you are about to delete records
and that the operation cannot be “undone”.

Step 3 If the information in the Confirm Clear dialog box confirms that you are deleting the
desired alarm records, click the Yes button (otherwise click the No button).

The alarm records are deleted and removed from the Alarm History table in the Alarm
History pane.

Creating a Live History Chart

The Live History Chart view is available directly from the history extension component and al-
so from a view on the HistoryPointList component. The history extension view displays the sin-
gle point in a live chart plot, while the HistoryPointList component, when configured, displays
all List Points that it contains.

The following procedures describe how to setup these views.
+ Live History Chart view from a History Extension

+ Live History Chart view from a HistoryPointsList Component

Live History Chart view from a History Extension

Prerequisites:

NOTE: Use this direct "history extension method" to display a single live charting point.
If you need to view several points plotted simultaneously, then use the HistoryPointList
component and the steps in the section, Live_Chart_view_from_a_HistoryPointsList_
Component.

To display a Live Chart view in Workbench using only a history extension, do the
following:

Step 1 Right-click the desired history extension component in the Workbench nav tree. The
popup menu displays.

Step 2 From the popup menu, select Views>Live History Chart. The Live History Chart view
displays.

Live History Chart view from a HistoryPointsList Component

To display a Live Chart view in Workbench using the HistoryPointsList component, do the
following:

Step 1 From the History palette, add a HistoryPointList component to your station in an ap-
propriate location (you can add the component anywhere in the station).
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Step 2 For each desired data plot, add a HistoryPointListItem to the HistoryPointList using
one of the following methods:

+ Drag and drop the component from the History palette, then link the history ex-
tension and configure the component using the property sheet view.

+ Right click on the HistoryPointList container, choose Actions>AddItem from the
popup menu. Using the List Item dialog box, link the history extension and config-
ure the component.

Step 3 Double-click on the HistoryPointList component to display the Live History Chart
view. When the Live History Chart view displays, select or clear selections in the Item
List View pane, as desired.

Working with modules

You can create and customize your own (.jar) modules so that you have access to individual
custom components or complete folders of components and applications that you have de-
signed and may use again.

NOTE: Starting in AX-3.7, non-developers can also create and customize “synthetic” (.sjar)
modules. With synthetic modules and types, there is no source code, no compiling. So, no de-
veloper experience is needed. For details, refer to the engineering notes document NiagaraAX
Synthetic Modules.

For basic information about modules, see “About modules”.
Creating a new (.jar) module

To create a new (.jar) module

You can create your own custom modules. This allows you to save copies of your work for fu-
ture use in the compressed (jar) module form. Palette and lexicon files may be customized and
included as part of the modules. Typically, if you choose to create a palette and a lexicon file,
you select these options in the New Module Wizard, which creates an empty “module.lexicon”
and “module.palette” file that you edit, as desired.

Prerequisites:

NOTE: For convenience, it is a good idea to create a “working” folder under the station
directory (as described in step 1, below) to hold all your custom files source material You
can leave this folder in your station and use it to hold source files for any modules that
you create.

To create a new module using Workbench, follow these steps:

Step 1 Connect to the station that you want to work with and, in the nav side bar, expand the
My File System > Sys Home nodes. The station installation directory appears under
this node.

Step 2 Right-click on the Sys Home node in the tree and select New > New Folder from the
popup menu to create a “working folder”. Give the folder a generic name, such as
“ModuleSource” or “workingModule”.

Step 3 Use the New Module Wizard to create the directory and files required for a new mod-
ule. Refer to “New Module wizard” for more information about using the New Module
Wizard. The wizard creates a new folder under a directory that you specify (typically,
you want to specify the “working directory” that you create in step 1, above).
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Step 4

Step 5

Step 6

Step 7

Step 8
Step 9

In the nav side bar, create a new folder named “src” under the newly created module
folder.

In the nav tree you should now have a folder structure similar to the following:
My File System/Sys Home/<workingDirectory>/<newModuleName>/src

Add items to the src folder, as desired. Copy and paste components or files from your
file system or from the station database. You can add subfolders under the src folder to
organize data, as desired, or you can put everything directly into the src folder.

In the <newModuleName> folder, double-click the “build.xml” file. It opens in Work-
bench text file editor.

In the “build.xml” file, after the last <dependency/> element, type in one or more
<resources/> elements to define the location of your source files.

For example, if you want to include all the “gif” files that are in an “images” folder
under your “src” folder, you type the following line in the “build.xml” file:

<resources name="/images/*.gif” />
The following listing is an example of how your “build.xml” file might look.

<!- Module Build File —>

<module

name = "newModuleName"
bajaVersion = "0"

preferredSymbol = "nM"
description = "My new graphic files"
vendor = "Acme"

>

<!- Dependencies —>

<dependency name="baja" vendor="Distech" vendorVersion="3.4" bajaVersion="0" />
<resources name="/images/*.*"/>

</module>
Save and close the “build.xml” file.

From the console command line in Workbench (press F3 to open console window)
navigate to the working directory and type the build command followed by a space and
then the name of the module folder. For example:

\workingDirectory> build moduleName

Press the Return key to initiate the build process. If the build is successful, the new jar
file is built and located in the modules folder. If the build is not successful, no jar file is
built and error messages are generated to help you troubleshoot the problem.

Step 10 You must restart Workbench to see the new module in the modules directory.

NOTE: If you chose to create a palette during the build process (using the New Mod-
ule Wizard) an empty palette is available with the new module. Refer to “To add a new
component to a palette (module.palette)” for instructions about adding components to
the palette.
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CHAPTER 6 COMPONENT (FUIDES

Torics COVERED IN THIS CHAPTER

Components in alarm module
Components in alarmRdb module
Components in backup module
Components in baja module
Components in chart module
Components in control module
Components in converters module
Components in crypto module
Components in email module
Components in file module
Components in flr module
Components in help module
Components in history module
Components in net module
Components in onCall module
Components in program module
Components in the Sms module
Components in schedule module
Components in timesync module
Components in web module
Components in workbench module

The Component Guides provide summary information on common components.

Summary information is provided on components in the following topics:

NOTE: For kitControl components, see the “Alphabetical list of kitControl components” sec-

tion in the NiagaraAX KitControl Guide.

Components in alarm module

+ AlarmClass

+ AlarmClassFolder

+ AlarmConsoleOptions

+ AlarmPortalOptions

+ AlarmService

+ AlarmSourceExt

+ AlarmSourcelnfo

+ BooleanChangeOfStateAlarmExt
+ BooleanCommandFailureAlarmExt
+ ConsoleRecipient

+ FaultAlgorithm

+  EnumChangeOfStateAlarmExt

o EnumCommandFailureAlarmExt

+ LinePrinterRecipient
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+  MemoryAlarmService

+ OffnormalAlgorithm

+ OutOfRangeAlarmExt

» PrinterRecipient

+ StationRecipient

+ StatusAlarmExt

+ StringChangeOfValueAlarmExt

alarm-AlarmClass

An AlarmClass object is used to group alarms that have the same routing and handling charac-
teristics. The AlarmClass is available in the alarm palette.

« Refer to “About alarm class”.

alarm-AlarmClassFolder

This is a container object provided for organizing groups of alarm class objects. The Alarm-
ClassFolder is available in the alarm palette.

« Refer to “About alarm class”.

alarm-AlarmConsoleOptions

The AlarmConsoleOptions component allows you to configure the parameters of the alarm
console. The Options dialog box displays when you select the Workbench Tools > Options
menu item.

+ Refer to “Alarm Console options” for details about the individual alarm console options.
+ Refer to About the alarm console for details about the alarm console.

The component is stored under the “/users/{user}/options” directory.

alarm-AlarmPortalOptions

This component allows you to configure the alarm portal parameters.

The Options dialog box displays when you select the Tools > Options from the main menu.
+ Refer to “Alarm Portal options” for details about the individual alarm console options.

+ Refer to About the alarm console for details about the alarm console.

The component is stored under the “/users/{user}/options” directory.

alarm-AlarmService

The AlarmService uses AlarmClasses to route all alarm messages between AlarmSources and
AlarmRecipients. Each station contains a single AlarmService. The AlarmService is available in
the alarm palette.

+ Refer to “About the alarm service” for more details.

alarm-AlarmSourceExt

AlarmSourceExt is the abstract superclass of all Baja control alarming algorithms. The Alarm-
SourceExt is available in the alarm module. Some common alarm source extensions include
OutOfRangeAlarmExt, BooleanChangeOfStateAlarmExt, BooleanCommandFailureAlarmExt,
EnumChangeOfStateAlarmExt and EnumCommandFailureAlarmExt.
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Refer to “About alarm extensions and components” for more details.

alarm-AlarmSourcelnfo

AlarmSourcelnfo is a container slot on any network component, and also on each child device
component. Properties under this slot are used to populate the alarm record when the network
or device does not respond to the network’s monitor ping. These properties work in the same
fashion as those in an alarm extension for any control point. See “About alarm extension
properties”.

For more details, refer to these topics in the Drivers Guide:
+ “About network Alarm Source Info”

« “Device Alarm Source Info”

alarm-BooleanChangeOfStateAlarmExt

BooleanChangeOfStateAlarmExt implements a change of state alarm detection algorithm for
Boolean objects as described in BACnet Clause 13.3.2. This alarm extension is available in the
Extensions folder of the alarm palette.

See the following links for more information:

+  “Types of alarm extensions”

+ “About alarm extensions and components”.5-3
+ “About alarm extension properties”.5-3

+ “About alarm extension manager”

alarm-BooleanCommandFailureAlarmExt

BooleanCommandFailureAlgorithm implements command failure alarm detection algorithm
for Boolean objects as described in BACnet. If feedback and output values of the point are not
equal for timeDelay duration, an offnormal alarm is generated. This alarm extension is avail-
able in the Extensions folder of the alarm palette.

See the following links for more information:

+  “Types of alarm extensions”

+ “About alarm extensions and components”.5-3
+ “About alarm extension properties”.5-3

+ “About alarm extension manager”

alarm-ConsoleRecipient

This component manages the transfer of alarms between the alarm history and the alarm con-
sole. The ConsoleRecipient is available in the alarm palette.

See the following links for more information:
« “About the console recipient”
+ “Types of alarm recipients”

o “About the alarm service”.5-7

alarm-FaultAlgorithm

FaultAlgorithm is the super-class of all Fault detection mechanisms defined by Niagara, and
contains properties that specify “fault” conditions. The default implementation does not gener-
ate any toFault alarms. A FaultAlgorithm is under each type of alarm extension, along with
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an OffnormalAlgorithm container. See “Types of alarm extensions” and also “About alarm ex-
tensions and components”.

alarm-EnumChangeOfStateAlarmExt

EnumChangeOfStateAlarmExt implements a change of state alarm detection algorithm for
Enum objects as described in BACnet Clause 13.3.2. Each algorithm instance defines a set of
enumerated values that should be considered “offnormal” conditions and therefore generate an
alarm. This alarm extension is available in the Extensions folder of the alarm palette.

See the following links for more information:

+  “Types of alarm extensions”

+ “About alarm extensions and components”.5-3
+ “About alarm extension properties”.5-3

+ “About alarm extension manager”

alarm-EnumCommandFailureAlarmExt

EnumCommandFailureAlarmExt implements command failure alarm detection algorithm for
enum objects as described in BACnet. If feedback and output values of the enum point are not
equal for more than timeDelay, an offnormal alarm is generated. This alarm extension is avail-
able in the Extensions folder of the alarm palette.

See the following links for more information:

+ “Types of alarm extensions”

+ “About alarm extensions and components”.5-3
+ “About alarm extension properties”.5-3

+ “About alarm extension manager”

alarm-LinePrinterRecipient

The LinePrinterRecipient component provides the capability to print alarms to line printers
that are attached to a station running on a Windows platform, or to such remote (networked)
printers known to its Windows OS. Alerts may be generated if the printing of an alarm fails,
but the lineprinter recipient does not print alarms that it generates itself.

See the following links for more information:
« “About the lineprinter recipient”
+ “Types of alarm recipients”

« “About the alarm service”.5-7

alarm-MemoryAlarmService

MemoryAlarmService provides an alternative to the standard file-based AlarmService. When
you use this service, alarms are not stored persistently on the station’s host as they are with the
standard file-based alarm service. The MemoryAlarmService is available in the alarm palette.

+ Refer to “About memory alarm service”.

alarm-OffnormalAlgorithm

OffnormalAlgorithm is a super-class for all algorithms that check for “off normal” conditions,
and contains properties that specify “alarm” conditions. An OffnormalAlgorithm is under each
type of alarm extension, along with a FaultAlgorithm container. See “T'ypes of alarm exten-
sions” and also “About alarm extensions and components”.
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alarm-OutOfRangeAlarmExt

OutOfRangeAlarmExt implements a standard out-of-range alarming algorithm, and applies to
points with a status numeric output. This alarm extension is available in the Extensions folder
of the alarm palette. See “Types of alarm extensions” and also “About alarm extensions and
components”.

alarm-PrinterRecipient

( (AX-3.7 and later) The PrinterRecipient component can be used to print alarms to most types
of printers (including laser printers) attached to a station running on a Windows platform, or
to remote (networked) printers known to its Windows OS. It differs from the older LinePrin-
terRecipient component, originally intended to work only with line printers—where alarms
print without a new page feed on each alarm, and the native font of the target printer is always
used.

The new PrinterRecipient provides additional font and style settings, and works well with the
“multi-line” alarm message text properties of alarm extension components, introduced starting
in AX-3.7.

Alerts may be generated if the printing of an alarm fails, but the printer recipient does not print
alarms that it generates itself.

See the following links for more information:
+ “About the printer recipient”
+ “Types of alarm recipients”

o “About the alarm service”.5-7

alarm-StationRecipient

Recipient for another station. This class receives alarms and formats them for another station.
The StationRecipient is available in the alarm palette.

See the following links for more information:
+ “About the station recipient”
+ “Types of alarm recipients”

« “About the alarm service”.5-7

alarm-StatusAlarmExt

StatusAlarmExt provides alarming based upon any combination of status flags, and applies to
all points/objects that accept extensions. This alarm extension is available in the Extensions
folder of the alarm palette. See “Types of alarm extensions” and “About alarm extensions and
components”.

alarm-StringChangeOfValueAlarmExt

StringChangeOfValueAlarmExt provides the ability to alarm upon inclusion or exclusion of a
particular string value, or more accurately, “regular expression” (regexp) of a point’s Out slot
(string type). By default, matching is case sensitive, but this is configurable using the “Case Sen-
sitive” property in the extension’s “Offnormal Algorithm” and “Fault Algorithm” container
slots.

By default, other configuration property values under Offnormal Algorithm and Fault Algo-
rithm are:

+ Expression — a value of: . *

This is the regexp value for “any text”.
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+ Normal On Match — true
Thus, by default status remains ok until an edit is made to one or both properties above.

This alarm extension is available in the “Extensions” folder of the AX-3.6 and later alarm
palette.

See the following sections for more StringChangeOfValueAlarmExt related details:
+ “Example”

+ “Regexp notes”

Also see these sections for general alarm extension information:

+ “Types of alarm extensions”

+ “About alarm extensions and components”.5-3

+ “About alarm extension properties”.5-3

+ “About alarm extension manager”

Example

(Simple string) A hospital emergency room desires an alarm created whenever the moon enters
a “full moon” phase. A StringWritable is created and given a StringChangeOfValueAlarmExt.
In this extension:

In the Offnormal Algorithm’s “Expression” property, the following string is entered: Full
Moon

The Offnormal Algorithm’s “Normal On Match” is set to false, and Case Sensitive is left at
true.

In the station’s WeatherService, a WeatherProvider has a MoonPosition component, which
serves as the link source. A link is made from the MoonPosition’s “Phase” property to the “In16
slot” of the StringWritable. On all phases of the moon but one, the StringWTritable has a normal
status. When MoonPosition’s phase changes to “Full Moon”, the StringWTritable has an alarm
status, and remains so until the next moon phase (“Waning Gibbous”).

Note that in this example, if the Expression string entry was simply: Moon, that alarms would
occur during both phases that include the string “Moon”, namely “Full Moon” and “New
Moon”.

Regexp notes

The “Expression” property in both the Offnormal Algorithm and Fault Algorithm containers of
a StringChangeOfValueExt can process a simple string value, as in the previous Example. The
Expression property also processes a value using “regular expression” (regexp) syntax. This pro-
vides even more flexibility, such as with use of “or” operators, among others.

Regexp syntax is beyond the scope of this document, but a few regexp examples are listed
below:

+ Contains the word “alarm”:
(.*) (alarm) (.*)

+ Contains the word “offnormal” or “fault”:
(.*) (offnormal) | (fault) (.*)

+ Eight “1” or “0” characters, with the fourth and eighth characters being 1:
(110) {3} (1) (110) {3} (1)

+ Empty text:
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~S
+ Any text:

*

This is the default Expression property value, that is in an extension copied from the alarm
palette.

Components in alarmRdb module

» rdbAlarmService

alarmRdb-RdbAlarmService

RdbAlarmService provides a means for using an RDBMS to store AX alarm records instead of
using the default alarm database (*\alarm\alarm.adb). This is different than exporting histories
to an RDBMS. When you use the rdbAlarmService, it replaces the use of the station’s default
alarm database.

+ Refer to the RdbmsNetwork Driver Guide for information about setting up the RdbAlarm-
Service component.

Components in backup module

+ BackupService

+ FoxBackupJob

backup-BackupService

NOTE: In the 2013 update releases of AX, including AX-3.7U1, password storage changes were
made to increase security. These changes affect the backup dist content, and more importantly
how backups can be restored. However, in AX-3.8 changes were made that simplify backup dist
usage, although there are considerations about JACE platform credentials (which are no longer
stored in a backup.dist file.) For details, refer to the AX 2013 Security Updates document.

The BackupService provides for complete configuration backups to Workbench PC or a brows-
er PC (user with Wb web profile). By default, the BackupService is included when you create a
new station using the New Station wizard. The target Niagara host (JACE, Supervisor) must
have the backup module installed.

The default view of a station’s BackupService is the BackupManager, which provides a Backup
button to manually initiate a backup. A backup automatically performs a local station save first,
and is run as a standard station Job. This means each backup provides a progress bar, and upon
completion, a popup notification. Under the station’s JobService, any backup appears as a “Fox
Backup.”

See the following for more details:
+ About a backup dist
+ Restoring a backup

+ BackupService configuration

About a backup dist

A backup is saved as a dist file (a zipped format) including minimally the station’s config.bog,
current station console output (.txt file), and backup.log file. If other station file types and
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subfolders are not excluded (in the BackupService configuration), the backup dist file contains
them too—for example, files of type: px, nav, html, jpg, png, and so forth.

Also, the backup dist contains the zipped “nre-config” for that host (including license and cer-
tificates files), as well as pointers to the installed “nre-core,” OS, and JVM, each by version. Es-
sentially, a backup dist provides a “configuration snapshot” of the entire JACE platform in
zipped “dist” file format. This allows for a complete image restoration.

CAUTION: Be careful to keep backup dist files in a secure location. They have always con-
tained sensitive information, for example a station’s config.bog file. They also may contain sen-
sitive host platform information. In update releases (AX-3.7ul), this includes unique “key ring”
files used for client password encryption.

Not included in a backup is runtime data that is actively managed by the station, such as the
alarm and history databases. This data should be “backed up” using standard alarm routing and
history archiving to a Supervisor host.

The default backup destination depends on your station connection, as either:
+  Workbench (Fox) — !backups

A subdirectory “backups” under your Niagara release directory. If you have not previously
made station backups, this directory is automatically created.

+ Browser access (Wb Web Profile) — !backups
A “ec-net\wbapplet\backups” folder under your Windows user profile location, e.g.:
Windows 7: C:\Users\John\ec-net\wbapplet\backups
Windows XP: C:\Documents and Settings\John\niagara\wbapplet\backups
If you have not previously made station backups, this directory is automatically created.

The default name for a backup file uses a format of: backup stationName YYMMDD
HHMM.dist

For example, “backup_demo_130412_1429.dist” for a backup made of station “demo” on April
12,2013 at 2:29 pm.

Restoring a backup

To restore a backup dist from Workbench, you open a platform connection to the JACE, then
use the platform Distribution File Installer to install a backup dist file.

+ Restoring from a backup may be necessary if the host failed in some manner, to allow re-
covery (to the same hardware, or to replacement hardware).

+ Another usage is to install the same backup dist file on multiple hosts, such that each host
(typically JACE) has the identical configuration, including station database. When perform-
ing these “replicated” host installations of a backup dist, the platform Distribution File In-
staller allows you to choose if TCP/IP settings from the backup dist should be restored (the
default is to not). Typically you do not, as TCP/IP settings must be unique on each host.

For related details, refer to “Restoring a backup dist” in the NiagaraAX Platform Guide.

NOTE: In update releases in this “replicated station” use case it is recommended that you
modify the original saved backup dist file, before installing it in multiple hosts. Otherwise,
station security is compromised. However in AX-3.8, improvements were made such that
edits to the AX-3.8 backup .dist file are unnecessary. For related details, see the sections
“Station archiving changes” and “Making modifications to archived station files” in the AX
2013 Security Updates document.
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Also see “Restoring a backup dist” in the NiagaraAX Platform Guide.

BackupService configuration

Configuration lets you define the file types and/or folders not included in a station backup. The
service’s property sheet provides the following properties for configuration:

.

Enabled

Either true (default) or false. Currently, this setting makes no difference (manual backup
still possible even if service has disabled status).

Exclude Files

Specifies file types to exclude from the backup dist, either by name or extension (each de-
limited by “;”). By default, the following files are excluded: *.hdb; *.adb; *.lock;
*backup*;console.*;config.bog.b*;config backup*

Exclude Directories

Specifies station subdirectories to exclude from the backup dist, using relative ORD syntax.
An ORD chooser control provides a Directory Chooser dialog in which you can select sta-
tion subfolders. By default, the following subfolders are excluded: file:~history,
file:"alarm

Offline Exclude Files

Specifies file types to exclude from the backup dist, when the station is stopped on the
source host. either by name or extension (each delimited by “;”). By default, the following
files are excluded: *.lock; *backup*;console.*;config.bog.b*;config

backup*

Note that history (*.hdb) and alarm (*.adb) files are backed up, unlike with a running
backup.

Offline Exclude Directories

Specifies station subdirectories to exclude from the backup dist, when the station is stopped
on the source host. Directories are specified using relative ORD syntax. An ORD chooser
control provides a Directory Chooser dialog in which you can select station subfolders. By
default, no directories are excluded, unlike with a running backup.

baja-FoxBackupJob

This component appears as a child of the JobService and displays the following properties rela-
tive to the save job:

.

Job State

Which of the following states the backup job is in currently: unknown, running, canceling,
canceled, success, failed.

Progress

A percentage 0) of progress toward completing the job.
Start Time

Displays the time that the job started.

Heart Beat Time

Displays the time of the last indication that the job is alive.
End Time

Displays the time that the job ends.

For related information, see:
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“backup-BackupService”
“baja-Job”.

“baja-JobService”

NOTE: All jobs in a station are cleared upon a station restart.

Components in baja module

Category
CategoryService
Component
DataFile

Directory
FileSystem

Folder

Format

IpHost

Job

JobService
LocalHost

Module
ModuleSpace
Permissions
PermissionsMap
PxView
ServiceContainer
Spy

Station
StationSaveJob
UnrestrictedFolder
User
UserPasswordConfiguration
UserPrototypes
UserService
UserServicePasswordConfiguration
Vector

Virtual Component
VirtualGateway
WsTextBlock
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« ZipFile
baja-Category

Each Category represents a custom logical grouping, and has a unique category index number.
You can assign components, files, and histories to one or more categories. All categorizable
components have a CategorySheet view, which shows you that component’s stored category
memberships (CategoryMask).

Categories reside under the station’s CategoryService, which has views CategoryBrowser and
CategoryManager. Categories play an integral role in station security, where you can give users
permissions for some (or all) categories. For a general review, see “Security model overview”.

baja-CategoryService

The CategoryService is the station container for all Category(ies), which represent logical
groupings to which you can assign components, files, and histories. The default view of this
service, the Category Browser, lets you centrally assign different objects to categories, using an
expandable tree view of the station.

The CategoryService also provides a Category Manager view, for you to create, edit and delete
categories. Categories play an integral role in station security, where you can give users permis-
sions for some (or all) categories. By default, the CategoryService is included when you create a
new station using the New Station wizard. For more CategoryService details, see
“CategoryService”.

baja-Component

Component is the required base class for all Baja component classes. The Component is avail-
able in the baja module.

Using Containers

Containers allow you to logically group components. The current container is the component
that contains components in the display window. A container may be selected as the current
container by one of the following methods:

+ Double-click the component in the Nav tree.

+ Right-click the component in the Nav tree (which brings up a menu) and select a view.
+ Right-click the component in a wire sheet (which brings up a menu) and select a view.
Container components include the following:

+  Component can be used as a general container for components. It allows you to place
components and links in a container.

+  DPage is a special component used to created a map of name/Ref pairs as dynamic slots.
baja-DataFile

DataFile represents a data file in the file system of a session.

baja-Directory

Directory is used to represent directories in File space implementations.
baja-FileSystem

FileSystem is a File space for the local machine's file system.
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baja-Folder

Folder is a special container designed to store components. The Folder is available in the baja
palette.

baja-Format

Format (or “BFormat”) is used to format objects into strings using a standardized formatting
pattern language. The format string is normal text with embedded scripts denoted by the %
percent character (use %% to insert a real %). A script is one or more calls chained together us-
ing the . dot operator. Calls are mapped to methods using reflections. Given call “foo”, the or-
der of reflection mapping is:

+ special call (see below)

+ getFoo(Context)

+ getFoo()

+ foo(Context)
+  foo()

o get("foo")

The following special functions are available to use in a script:

+ time() calls Clock.time() to get current time as an AbsTime

+ lexicon(module:key) gets the specified lexicon text

Examples of formats:

+ "hello world"

+ "my name is %displayName%"

+ "my parent's name is %parent.displayName%"

o "%value% {%status.flagsToString%} @ %status.priority%"

o "%time().toDateString%"

+  "%lexicon(bajaui:dialog.error)%"

For related details, see the engineering notes document BFormat (Baja Format) Property
Usage.

baja-lpHost

IpHost is used to represent a host machine that is identified with an IP address. The hostname
of an IpHost is either a a name resolvable via DNS or is a raw IP address.

+ A blue square indicates active connection(s) from Workbench, e.g. Fox (station) or
platform.

+ A red square indicates no active connections from Workbench.
baja-Job

A Job is used to manage a task that runs asynchronously in the background, but requires user
visibility. Some example jobs include:

+ StationSaveJob — From a station save, either initiated manually or from the auto-save
function (see “PlatformServiceContainer configuration parameters” in the NiagaraAX Plat-
form Guide).

+ FoxBackupJob — From a station backup (dist) to a remote PC, see BackupService.
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Many drivers also have various job types too. For example, the NiagaraDriver includes a Sta-
tionDiscoveryJob and NiagaraScheduleLearn]Job.

Every job finishes displaying one of the following status descriptors:
+ Success — Job completed successfully.

+ Canceled — Job canceled by user.

+ Failure — Job failed to complete.

+ Completed — Job completed.

Also, if you have the station open in Workbench, you see a momentary “notification popup” in
the lower-right corner of your display.

You can monitor and cancel a job from within the particular view where you initiated it, or
centrally from the JobServiceManager view of a station’s JobService. You can also open a Jobs
side bar to see all jobs in all opened stations (see “Using the jobs side bar”.

Regardless of how you access jobs, note the following:

+ To see details on a job, click the “” button next to its status descriptor. A popup Job Log di-
alog displays all the interim steps about the job, including timestamps and relevant
messages.

+ Todispose of a job, click the close (“X”) button to remove it from the station.

NOTE: All jobs in a station are cleared upon a station restart.

baja-JobService

The JobService contains Jobs that were executed by different processes in the station. Each job
appears as a child component. By default, the JobService is included when you create a new sta-
tion using the New Station wizard. The default view of the JobService is the
JobServiceManager.

NOTE: All jobs in a station are cleared upon a station restart.

baja-LocalHost

LocalHost represents the root of the Baja local Host namespace. The LocalHost is available in
the baja Module.

baja-Module

Module encapsulates a Baja software module which is packaged and delivered as a JAR file with
a "meta-inf/module.xml" description.

Modules are the basic unit of software deployment in the Baja architecture. Module names
must be one to 25 ASCII characters in length and globally unique. Modules are available in the
Workbench ModuleSpace (named “My Modules” under “My Host”).

For related details, see the section “About modules”.

baja-ModuleSpace

ModuleSpace is the container for modules which are keyed by their module name. In Work-
bench this is “My Modules” under “My Host”. Starting in AX-3.7, in addition to standard mod-
ules (jar files), “synthetic modules” (.sjar files) can be created in the ModuleSpace. See “About
modules”.
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baja-Permissions

Permissions are a property used to define the permissions given to a user’s PermissionsMap.

baja-PermissionsMap

Defines the security permissions to grant to a user. Permissions are added as dynamic proper-
ties with the name matching a Category and the value an instance of permissions. For more de-
tails, see “Permissions and security” and “About permission levels”. If a user has been
configured as a super user, then all permissions are automatically granted to all categories.
baja-PxView

PxView a dynamic view which may be added to components as a property or by overriding get-
Agents(). PxViews store the view contents in an XML file with a px extension. The view itself is
defined as a tree of bajaui:Widgets.

baja-ServiceContainer

ServiceContainer (Services) is the container used, by convention, to store a station’s services.
The Service Manager is its primary view. A ServiceContainer is included in any station created
using the New Station tool.

baja-Spy

Spy is an object wrapper for an instance of Spy, with an available “SpyViewer” interface to view
diagnostic information about the running station.

baja-Station

Station (Config) represents the component configuration of a station in the Baja framework.
See “Station” in the Niagara Developer Guide for developer information. The Station is avail-
able in a fox connection to AX host, along with its file space (Files) and histories (History).

Station Save

Save the current state of the system to persistent storage. You should regularly backup your
station or stations using the Save Action on the station.

baja-StationSaveJob

This component appears as a child of the job service and displays the following properties rela-
tive to the save job:

+ Job State

indicates which of the following states the save job is in currently: unknown, running, can-
celing, canceled, success, failed.

+ Progress
indicates a percentage 0) of progress toward completing the job.
» Start Time
displays the time that the job started.
+ Heart Beat Time
displays the time of the last indication that the job is alive.
+ End Time
displays the time that the job ends
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For related information, refer to:
+ “baja-Job”.

+ “baja-JobService”

NOTE: All jobs in a station are cleared upon a station restart.

baja-SyntheticModuleFile

(AX-3.7 and later) SyntheticModuleFile (synthetic module) is a synthetic Java archive (.sjar)
that allows the creation of memory-resident modules and types programmatically at station
runtime.

Synthetic modules differ from “standard” .jar (non-synthetic) modules in a number of ways,
and have a special default “Synthetic Module File View” for editing contents.

baja-UnrestrictedFolder

UnrestrictedFolder is a special container designed to store objects for use on a palette. Normal
isParentLegal() checks are not applied to UnrestrictedFolders. The UnrestrictedFolder is avail-
able in the baja palette.

baja-User

User is the component that represents a station connection, typically a specific person who
needs to access the system. Users are children of the station’s UserService. User components
are also children of the UserService’s UserPrototypes container, to allow “centralized user”
support.

For more details, see the following sections:
+ “Users and security”

+ “User”(all properties)

+ “UserService security notes”

Also, see “Security model overview”

baja-UserPasswordConfiguration

UserPasswordConfiguration (Password Configuration) is a child container under each User
component (and UserPrototype component) in an AX-3.7 or later station. It contains proper-
ties to specify periodic password expiration for the user and to require a password change (re-
set) upon the user’s next station login. For details see “About password expiration and
reset’and “Password reset”. The station’s UserService also has a related Password Configura-
tion child container.

NOTE: As a “mix-in”, these components are not available in a new station until it is started
and saved.

baja-UserPrototypes

UserPrototypes is a frozen container on a station’s UserService. It contains a single frozen “De-
fault Prototype” user, as well as any additional users needed for support of “centralized users”
in the station’s NiagaraNetwork. For more details, see “Network users”and “About User
prototypes”.
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baja-UserService

UserService is the service you use to add, edit, delete, and otherwise manage users of the sta-
tion. The UserManager is its primary view. Also available is a PermissionsBrowser view, in
which you can review and change permissions for any user’s assigned Category(ies). See “Users
and security”’and “UserService” for more details. The UserService is available in the baja mod-
ule. By default, the UserService is included when you create a new station using the New Sta-
tion wizard.

NOTE: To facilitate user management, the UserService component has a unique permissions
scheme. See “UserService security notes”.

baja-UserServicePasswordConfiguration

UserServicePasswordConfiguration (Password Configuration) is a child container under the
UserService in an AX-3.7 or later station. It contains “global” properties to define the periodic
password expiration for station users as well as the “unique password” history setting. For more

details see “About password expiration and reset”and “Password history (unique passwords)”.
Also note each station User has a related Password Configuration child container as well.

NOTE: As a “mix-in”, this component is not available in a new station until it is started and
saved.

baja-Vector

Vector is a dynamic Struct which allows properties to be added at runtime.

baja-VirtualComponent

A VirtualComponent is the Baja base class for implementations of transient (non-persisted)
components that reside in the station’s “virtual component space,” as defined by a VirtualGate-
way. Initial applications of virtual components are expected in various drivers for AX. For a
general explanation about Baja virtual components, see the NiagaraAX Drivers Guide section

“Virtual gateway and components”.

baja-VirtualGateway

A VirtualGateway is the Baja base class for a component that resides under the station’s com-
ponent space (Config), and acts as a gateway to the station’s “virtual component space.” Note
other object spaces are Files and History. Initial applications of virtual gateways are ex-
pected in NiagaraAX drivers. For a general explanation, see the NiagaraAX Drivers Guide sec-
tion “Virtual gateway and components”.

baja-WsTextBlock

WsTextBlock (Text Block) is a component you can drop onto a wire sheet (WireSheet) and
position to add text notes. Properties include “Text” (to display), Foreground and Background
colors, Font, Border, and whether the Text Block is directly “Selectable” in the wire sheet (by
default, Selectable is true). If Selectable is false, you must select this component via its node in
the Nav tree.

Text Block is available in the baja palette.
baja-ZipFile

ZipFile represents a zip file in the file system of a session.
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Components in chart module

.

BarChart
ChartCanvas
ChartHeader
ChartPane
DefaultChartLegend
LineChart

chart-BarChart

One of two chart types available (the other is LineChart).

chart-ChartCanvas

ChartCanvas is the canvas widget under a ChartPane.

chart-ChartHeader

ChartHeader is the header widget under a ChartPane.

chart-ChartPane

ChartPane is the container widget created when adding a Px chart.

chart-DefaultChartLegend
DefaultChartLegend is the legend widget under a ChartPane.

chart-LineChart

One of two chart types available (the other is BarChart).

Components in control module

.

BooleanPoint
BooleanWritable
DiscreteTotalizerExt
EnumPoint
EnumWTritable
NullProxyExt
NumericPoint
NumericTotalizerExt
NumericWritable
StringPoint
StringWritable
TimeTrigger
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control-BooleanPoint

BooleanPoint is a basic read-only control point, with default slots: Facets, Out, and ProxyExt.
See “About control points”for details. The BooleanPoint is available in the Points folder of the
control palette.

control-BooleanWritable

BooleanWritable extends BooleanPoint to include 16 levels of command priority control. The
highest priority active command is reflected in the out property. Commands at the emergency
and manual levels (1 and 8) are stored persistently. See “About control points” and “About
writable points”for more details.

The BooleanWritable is available in the Points folder of the control palette.

control-DiscreteTotalizerExt

DiscreteTotalizerExt is a control point extension for accumulating runtime and change of state
counts on binary or enum values. Two actions are available to clear (zero) accumulated totals,
ResetChangeOfStateCount and ResetElapsedActiveTime.

The DiscreteTotalizerExt is available in the Extensions folder of the control palette.

control-EnumPoint

EnumPoint is a basic read-only control point, with default slots: Facets, Out, and ProxyExt. See
“About control points”for details. The EnumPoint is available in the Points folder of the control
palette.

control-EnumWritable

WritableEnumPoint extends EnumPoint to include 16 levels of command priority control. The
highest priority active command is reflected in the out property. Commands at the emergency
and manual levels (1 and 8) are stored persistently. See “About control points” and “About
writable points”for more details.

The EnumWritable is available in the Points folder of the control palette.

control-NullProxyExt

NullProxyExt is the default implement AbstractProxyExt used to indicate that a point is not a
proxy point. The NullProxyExt is in the control palette’s Extensions folder, but is already
present by default on compatible point types. Presence indicates that you can add other types
of extensions to the parent component, for example alarm or history extensions.

control-NumericPoint

NumericPoint is a basic read-only control point, with default slots: Facets, Out, and ProxyExt.
See “About control points”for details. The NumericPoint is available in the Points folder of the
control palette.

control-NumericTotalizerExt

NumericTotalizerExt is a control point extension used for integrating a numeric point value
over time. For example, a totalizer with a minutely totalization interval can convert an instanta-
neous flow reading in cubic feet per minute (cfm) into a value representing total cubic feet con-
sumed. An available resetTotal action clears (zeroes) any accumulated total.

The NumericTotalizerExt is available in the Extensions folder of the control palette.
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control-NumericWritable

NumericWritable extends NumericPoint to include 16 levels of command priority control. The
highest priority active command is reflected in the Out property. Commands at the Manual
and manual levels (1 and 8) are stored persistently. See “About control points” and “About
writable points”for more details.

The NumericWritable is available in the Points folder of the control palette.

control-StringPoint

StringPoint is a basic read-only control point, with default slots: Facets, Out, and ProxyExt. See
“About control points”for details. The StringPoint is available in the Points folder of the control
palette.

control-StringWritable

StringWritable extends StringPoint to include 16 levels of command priority control. The high-
est priority active command is reflected in the Out property. Commands at the Manual and
manual levels (1 and 8) are stored persistently. See “About control points” and “About writable
points”for more details.

The StringWritable is available in the Points folder of the control palette.

control-TimeTrigger

TimeTrigger is a component that fires a topic at configured times. It is available configured as
both “Interval” or “Daily” in the Trigger folder of the control palette.

Components in converters module

+ EnumToSimpleMap

converters-EnumToSimpleMap

EnumToSimpleMap maps ordinals to Simple instances of the same type.

Components in crypto module

+ CryptoService

» SslProvider

crypto-CryptoService

CryptoService is a station service that can provide SSL features for earlier model QNX-based
JACEs (JACE-2/4/5 series, running the IBM J9 JVM) at any AX release level. It also applies to
any AX platform running a pre-AX-3.7 release that require SSL capablility. .

NOTE: Any AX-3.7 or later platform that runs the Oracle Hotspot JVM (most newer QNX-
based JACEs) and all Windows-based hosts) should be configured differently for SSL, and
should not use this station service or module. For related details, see the NiagaraAX SSL Con-
nectivity Guide.
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crypto-SsiProvider

Provides SSL configuration for the CryptoService in the AX host that cannot run the newer,
platform-based SSL introduced in AX-3.7 (such as JACE-2/4/5 series, running the IBM J9
JVM).

Components in email module

+ Email

+ EmailAlarmAcknowledger
+ EmailRecipient

+ EmailService

+ IncomingAccount

+ OutgoingAccount
email-Email

Email represents an email message.

email-EmailAlarmAcknowledger

The EmailAlarmAcknowledger component (AX-3.5 and later) provides a way for users to ac-
knowledge alarms by sending an email reply to an email alarm notification. This component is
available in the email palette and works with the On Call Service or directly with the Email
Service. Also see “About the Email Alarm Acknowledger”.

Actions

Actions include: Received, which opens the Received email dialog box.

email-EmailRecipient

The top-level email Messaging service. This service manages the routing of all email messages
from message sources to message recipients. The EmailRecipient is available in the email
palette.

Actions

Actions include RouteAlarm.

RouteAlarm

RouteAlarm routes the alarm.

email-EmailService

EmailService manages the life-cycle of Email. The EmailAccountManager is its primary view.
The EmailService is available in the email palette. EmailService may contain an IncomingAc-
count component and an OutgoingAccount component.

email-lIncomingAccount

IncomingAccount is a Email that receives mail. A number of properties specify the SMTP host,
port, and user credentials to use, as well as other parameters. The IncomingAccount is available
in the email palette.

IncomingAccount properties include the following:
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Hostname
This is the name of the mail server. For example mail.acme.com could be a Hostname.
Port

This is the port number associated with the email account. Typically email incoming ac-
count port numbers are port "110", however, if you leave the setting at its default value of
"-1" the IncomingAccount will search for and use a valid port.

CAUTION: With the default configuration (see “Delivery Policy” property, below) the in-
coming email account deletes all emails from the mail server when it checks the account to
retrieve new email, even if the emails are already marked as read by another email client. If
permanent retention of the emails is required then do one of the following: change the De-
livery Policy setting from Delete or configure a second service account which the mail serv-
er forwards emails to and configure the station's incoming account to check the second
service account.

Account

This is the name of the distinct account that is authorized for access to the "Hostname"
mail server. For example, if you are using an email account named "controls@acme.com”
on the host described above, the account name is simply "controls". The Hostname in this
case could be "mail.acme.com”.

Password
This is the login credential for the Account specified in the previous field.
Pollrate

This field allows you to specify how often the account connects to the mail server and
checks for unread mail messages. Increasing the pollrate value increases the time between
polls.

Enabled

This field allows you to activate or deactivate the account by choosing true or false,
respectively.

Status

This is a read-only display of the condition of service. The status displays {ok} if the account
is polling successfully. Other indications include:

+ {down} which means that the polling is unsuccessful, perhaps because of an incorrect
Hostname, Password, or Account name.

+ {disabled} because the Enable property is set to false
Last Poll Success, Last Poll Failure

These two properties display the time (in hours and minutes) of the last polling success and
failure.

Last Poll Failure Cause
This display-only field provides an error message to indicate a reason for polling failure.
Debug

This Boolean property turns Debug mode on true or off, as desired. When Debug is turned
on, you can see detailed debug information in a station's standard output view (Workbench
Platform > Application Director view) when the Station tries to send or receive email. This
can be used to troubleshoot the accounts and faults.

Use Ssl
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The Ssl (Secure Socket Layer) option list allows you to disable Ssl (false) or enable it (true).
Enable Ssl for communication with a host email server that requires it.

Store

This property allows you to choose between two standards of mail retrieval. You need to
choose the option that is in use by your host mail server: Imap or Pop3

Delivery Policy

This property provides an option list that allows you to select how the incoming email ac-
count handles incoming emails at the mail server.

The following options are available:
+ Delete

With this configuration the incoming email account deletes all emails from the mail
server when it checks the account to retrieve new email, even if the emails are already
marked as read by another email client.

o Mark As Read

This option marks all emails as read on the mail server when it checks the account to re-
trieve new email.

« Mark As Unread

This option marks all emails as unread on the mail server when it checks the account to
retrieve new email.

email-OutgoingAccount

OutgoingAccount is a Email that sends mail. A number of properties specify the SMTP host,
port, and user credentials to use, as well as other parameters. A “Max Sendable Per Day” prop-
erty can limit the number of station-generated emails, where the default value is 100. The Out-
goingAccount is available in the email palette.

OutgoingAccount properties include the following:

.

Hostname
This is the name of the mail server. For example mail.acme.com could be a Hostname.
Port

This is the port number associated with the email account. Typically email outgoing ac-
count port numbers are port "25", however, if you leave the setting at its default value of
"-1" the OutgoingAccount will search for and use a valid port.

Account

This is the name of the distinct account that is authorized for access to the "Hostname"
mail server. For example, if you are using an email account named "controls@acme.com”
on the host described above, the account name is simply "controls". The Hostname in this
case could be "mail.acme.com”.

Password

This is the login credential for the Account specified in the previous field. Increasing the
pollrate value increases the time between polls. During the time between polls, emails may
be queued (up to the max queue size) until the next poll time. At the next poll time all
queued emails are sent.

Pollrate
This field allows you to specify how often the account executes a send action.

Enabled
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This field allows you to activate or deactivate the account by choosing true or false,
respectively.

Status

This is a read-only display of the condition of service. The status displays {ok} if the account
is polling successfully. Other indications include:

+ {down} which means that the polling is unsuccessful, perhaps because of an incorrect
Hostname, Password, or Account name.

+ {disabled} because the Enable property is set to false
Last Poll Success, Last Poll Failure

These two properties display the time (in hours and minutes) of the last polling success and
failure.

Last Poll Failure Cause
This display-only field provides an error message to indicate a reason for polling failure.
Debug

This Boolean property turns Debug mode on true or off, as desired. When Debug is turned
on, you can see detailed debug information in a station's standard output view (Workbench
Platform > Application Director view) when the Station tries to send or receive email. This
can be used to troubleshoot the accounts and faults.

Use Ssl

The Ssl (Secure Socket Layer) option list allows you to disable Ssl (false) or enable it (true).
Enable Ssl for communication with a host email server that requires it.

Transport

This field allows you to select from available options for email communication. The default
setting and most common is SMTP.

Connection Timeout

This configurable field setting controls how long the station waits for a response from the
mail server before generating an exception and setting the fault cause. It waits for the next
scheduled poll and attempts to contact the mail server again at that frequency.

Use Authentication

This property allows you to specify that login credentials are required for sending any
email. Sometimes authentication is not required for emails routed to recipients in the same
domain. Setting this property to true makes the login credentials mandatory for any email.

Reply To
This field specifies the contents of the "From:" field in the email that is sent.
Persistent, Persistent Directory

Setting the Persistent property to true saves each queued email as an xml file in the desig-
nated persistence directory. Once the emails are actually sent, the xml files are deleted from
the directory. The purpose of this is to keep a copy of the emails in the queue which would
be lost if the station was stopped prior to the emails being sent. When the station restarts,
emails are loaded from the "Persistent Directory" back to the queue.

Email Queue Tracking Properties

"Queue” is where emails reside while they are waiting to be sent. Assuming that the Ac-
count Status is "ok", typically, the length of time that an email is in the queue depends on
the "Pollrate" setting. The following properties relate to the queue and mail management
properties
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Allow Disabled Queuing

This property (when set to true) allows emails to reside in the queue even when the En-
abled status is set to false.

Queue Size

This property refers to how many emails are currently in the queue (waiting to be sent).
You can clear the queue at any time by right-clicking on the appropriate outgoing ac-
count property and selecting Actions > Clear Queue from the popup menu.

Max Queue Size
This property allows you to specify how many emails are allowed to occupy the queue.
Number Sent

This property displays the number of emails that have been sent. You can reset this
number to zero at any time by right-clicking on the appropriate outgoing account prop-
erty and selecting Actions > Reset Number Sent from the popup menu.

Max Sendable Per Day
This property allows you to specify how many emails may be sent in one day.
Number Discarded

This read-only property displays a value to indicate how many emails did not success-
fully send.

Last Discard

This read-only property and later) displays a date and time value to indicate when the
last email did failed to send.

Last Discard Cause

This read-only property and later) displays an error message that indicates the cause of
the last email send failure.

Components in file module

ApplicationFile

AudioFile
BajadocFile
BogFile
BogScheme
BogSpace
CFile
CssFile
ExcelFile
GifFile
HtmlFile
ImageFile
JavaFile
JpegFile
NavFile
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+ DPaletteFile

» PdfFile

+ DPngFile

+ PowerPointFile

+ PrintFile

+ PxFile

+ TextFile

+ VideoFile

+ VisioFile

+ WordFile

+ XmlFile
file-ApplicationFile
ApplicationFile stores an application file.

file-AudioFile

AudioFile stores an audio file.

file-BajadocFile

BajadocFile represents Bajadoc documentation. Bajadoc is a special file that can describe com-
ponents in a database.

file-BogFile

BogFile represents a BogFile in the file system of a session. A Bog File is a special file that can
describe Components in a Database.

file-BogScheme

BogScheme represents a BogScheme in the file system of a session. A Bog File is a special file
that can describe Components in a Database.

file-BogSpace

BogSpace represents a BogSpace in the file system of a session. A Bog File is a special file that
can describe Components in a Database.

file-CFile
CFile stores a ¢ source file.

file-CssFile

CssFile stores a CSS cascading style sheet.

file-ExcelFile

ExcelFile stores a Microsoft Excel file.
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file-GifFile

GifFile stores a GIF image.
file-HtmlFile

HtmlFile stores HTML markup.
file-lmageFile

ImageFile stores an image.
file-JavaFile

JavaFile stores a java source file.
file-JpegFile

JpegFile stores a JPEG image.
file-NavFile

NavFile stores XML nav markup.

file-PaletteFile

Palette file is just a Bog file with a different extension and icon.

Many modules include a palette. For details on palettes see the “About palettes” topic.

file-PdfFile
PdfFile stores a Adobe PDF file.

file-PngFile
PngFile stores a PNG image.

file-PowerPointFile

PowerPointFile stores a Microsoft PowerPoint file.

file-PrintFile

PrintFile stores XML print markup.

file-PxFile

PxFile is just a Bog File file with a different extension and icon.

file-TextFile

TextFile stores plain text.

file-VideoFile

VideoFile stores an video file.
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file-VisioFile
VisioFile stores a Microsoft Visio file.

file-WordFile

WordFile stores a Microsoft Word file.

file-XmlFile

XmlFile stores an xml file.

Components in flr module

« FLR

flr-FIrService

The FloatingLicenseRepository (FLR) component provides the service for setting up a floating
license server in AX-3.5.

The component has one action: “Reload”. This action reloads or “reads” the license pack file
(LPF) into the FLR server application. This component is found in the flr palette.

Components in help module

» BajadocOptions

help-BajadocOptions

The BajadocOptions stores the options used by the BajadocViewer. The Bajadoc options allow
you to change the following:

+ Show Baja Only
» Flatten Inheritance

These are stored under /user/{user}/bajadoc.options.

Components in history module

+ AuditRecord

» AuditHistoryService

+ BooleanCovHistoryExt

+ BooleanIntervalHistoryExt
» ConfigRule

+ ConfigRules

+ CovAlgorithm

+ EnumCovHistoryExt

+ EnumlntervalHistoryExt
» FoxHistory

» FoxHistorySpace

+ HistoryConfig

NiagaraAX User Guide

189



Component Guides

May 26, 2016

» HistoryDevice

» HistoryEditorOptions

+ HistoryGroup

+ HistoryGroupings

+ Historyld

+ HistoryPointList

» HistoryPointListItem

+ HistoryService

» HistoryShortcut

+ IntervalAlgorithm

+ LocalDatabaseConfig

+ LogHistoryService

+  NumericCovAlgorithm

+  NumericCovHistoryExt
+ NumericIntervalHistoryExt
+ StringCovHistoryExt

« StringlntervalHistoryExt

history-AuditRecord

The AuditRecord keeps a History of changes made by users. If enabled, it registers itself as the
Auditor for the system when the service is started. The AuditRecord is available in the History
Module under the HistoryService.

history-AuditHistoryService

The AuditHistoryService keeps a history of changes made by users. If enabled, it registers itself
as the auditor for the station when the service is started. The AuditHistoryService is available
in the history palette.

One of the important aspects of security is the ability to analyze what has happened after the
fact. The Niagara component model is designed to audit all property modifications and all ac-
tion invocations. Auditable actions include:

+ Property changed

+ Property added

+ Property removed

+ Property renamed

+ DProperties reordered
+ Action invoked

Component modifications are only audited when the modification method is passed a non-null
context with a non-null user. The history module includes a standard implementation of an
audit trail stored to an AuditHistory history.

For more details, see “About user audits”.
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history-BooleanCovHistoryExt

BooleanCovHistoryExt is a history extension that is used for recording on change of value for
boolean point data. This extension is available in the history Module Extensions Directory. Re-
fer to “Types of history extensions” For more information about this extension.

history-BooleaniIntervalHistoryExt

BooleanIntervalHistoryExt is a history extension that is used for recording on intervals for boo-
lean point data. This extension is available in the history Module Extensions Directory. Refer to
“Types of history extensions” for more information about this extension.

history-ConfigRule

ConfigRule is used to determine the overrides for an existing history configuration. The Con-
figRule is available in the history Module.

history-ConfigRules

ConfigRules is the container for rules that determine the configuration of histories that are
pushed to the local device. Configuration rules are applied when a history is created. Changing
a rule has no effect on existing histories. The ConfigRules is available in the history Module.

history-CovAlgorithm
CovAlgorithm determines when to log a point's value according to change of value. The CovA-

lgorithm is available in the history Module Extensions Directory under some Change Of Value
extensions as Collector.

history-EnumCovHistoryExt

EnumCovHistoryExt is a history extension used to record on a change of value for Enum point
data. This extension is available in the history Module Extensions Directory. Refer to “Types of
history extensions” for more information about this extension.

history-EnumintervalHistoryExt

EnumlIntervalHistoryExt is a history extension used to record on intervals for Enum point data.
This extension is available in the history Module Extensions Directory. Refer to “Types of his-
tory extensions” for more information about this extension.

history-FoxHistory
FoxHistory is the implementation of BIHistory that works with the FoxHistorySpace.
history-FoxHistorySpace

FoxHistorySpace provides access to a History Database using the fox protocol.

history-HistoryConfig

HistoryConfig is the configuration for a History in the History Database.

history-HistoryDevice

HistoryDevice represents a source device for histories.
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history-HistoryEditorOptions

The HistoryEditorOptions stores the options used to configure history options.

These are stored under /user/{user}/textEditor.options.

history-HistoryGroup

The HistoryGroup component provides a way to organize alternate navigation presentations
for a station’s history space. Use the properties in this component to specify metadata proper-
ties for grouping histories. Add the HistoryGroup component to the HistoryGroupings con-
tainer-component by dragging and dropping it from the history palette or by clicking the New
button in the History Group Manager view.

Also see the following topics:

+ “About history grouping”

+ “About the History Group property sheet view”
+ “About the History Group Manager view”

history-HistoryGroupings

The HistoryGroupings component is available in AX-3.5 as a property of (frozen slot on) the
HistoryService component. This component serves as a container for HistoryGroup compo-
nents. The default view of the HistoryGroup component is the HistoryGroupManager view.
You can add HistoryGroup components under the HistoryGroupings component by dragging
and dropping a HistoryGroup from the History palette or by You can add HistoryGroup com-
ponents to this component by clicking the New button in the History Group Manager view.

Also see the following topics:

+ “About history grouping”

+ “About the History Group property sheet view”
+ “About the History Group Manager view”

history-Historyld

The Historyld comopnent is a container for History id.

history-HistoryPointList

This component is available in the history module. It is a container that holds the “history-His-
toryPointListIltem” components that you add to it. The default view of this component is the
Live History Chart view. The property sheet view is where you configure the HistoryPointList
properties.

The HistoryPointList component properties include the following;
+ Max Samples

Defines the maximum number of samples to store for each history extension displayed.
o Time Window

Defines the time range to display on the Time Axis while viewing the live chart. If the chart
is "zoomed" you will be able to pan and view all the collected data defined by Max Samples.

+ Background
Specifies the background color of the chart. The default setting is "null".

« Show Horizontal Grid Lines
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Shows (true) or hides (false) horizontal grid lines on the chart.
Show Vertical Grid Lines

Shows (true) or hides (false) vertical grid lines on the chart.

NOTE: If the Live History Chart view is invoked from a history extension, the following de-
fault property values are used to display the view:

+ Max Samples value = 5000
« Time Window value = 10 minutes
+ Start Time = 0 hours 0 minutes

+ Sample Rate = Auto

In addition to the HistoryPointList properties, the property sheet view displays all associated
HistoryPointListltem components below the properties. If the view is invoked from the History
Point List component the items in the list can be selected/unselected and the view will update
as needed.

Refer to “history-HistoryPointListItem” and “About the Live History Chart View” for more
information.

history-HistoryPointListitem

This component is available in the history module. Each HistoryPointListItem is linked to a
single history extension and is configured in the Add Item dialog box or in the HistoryPointLis-
tltem property sheet. HistoryPointListItem configurable properties include the following.

.

History Extension

The Ord to the History Extension of the Control Point you wish to view. This MUST be the
History Extension and NOT the Control Point or its corresponding History Component.

Display On Startup

Indicates whether or not to automatically display the chart for this item when the view first
comes up.

Start Time

Indicates how much of the collected history data you wish to view. The time that is entered
in this property will be subtracted from the current time to get the initial history data.

NOTE: The following conditions apply:If no data is found within the given Start Time the
LAST collected value is retrieved for the item.If the Start Time is 0 hours 0 minutes ALL
collected history values is retrieved for the item.

Sample Rate
The rate at which to sample the "live" data.
+ Auto
This value follows the interval defined in the history extension configuration
+ Fixed

This value follows a defined interval that is specified by the user in terms of hours, mi-
nutes, and seconds.

« Cov:
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This value specifies that updates are plotted whenever there is a change of value.
+ Min Value Range
The minimum value to display on the value axis.
+ Auto
This value uses the minimum value from the data collected.
» Fixed

This value uses the value specified by the user. This only applies to numeric points
(Booleans and Enums do not use this property).

+ Max Value Range
This value is the maximum value to display on the value axis.
+ Auto
This value uses the maximum value from the data collected.
+ Fixed

This value uses the value specified by the user. This only applies to numeric points
(Booleans and Enums do not use this property).

NOTE: If Min Value Range and Max Value Range are Fixed AND have the same values
charts may share the value axis. If these two conditions do not exist, additional value ax-
es may be added to the chart, as needed.

+ Line Color

This value specifies the desired color for the plot line.
+ Pen

This value specifies the line-weight and type to use for the plot line.
+ Item Name

This value specifies the name that is displayed on the view. This name must be unique with-
in the list of items.

Refer to “history-HistoryPointList” and “About the Live History Chart View” for more
information.

history-HistoryService

The History service provides http access to all histories in the Station. This service manages
the History lifecycle, including creation and deletion. Additionally, HistoryService maintains
the namespace for all Histories. As histories are created, they are added as slots to this service,
and removed upon deletion. When the service is started, all existing histories are added to the
service. Additionally, this service maintains global configuration for the histories. Each Station
contains a single HistoryService. The HistoryService is available in the history module.

See the “About the history service” for more information.

CloseUnusedHistories

Close all Unused Histories in this service.

FlushHistories

Flush all histories managed by this service.
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history-HistoryShortcut

The HistoryShortcut (History Nav Shortcut) component provides a way to include convenient
access to histories from various locations in a station nav tree hierarchy.

The HistoryShortcuts component is avaialable on the History palette. For details, see “About
history nav shortcuts”.

history-IntervalAlgorithm

IntervalAlgorithm logs a value periodically at a fixed interval. The IntervalAlgorithm is avail-
able in the history Module Extensions Directory under some Interval extensions as Collector.

history-LocalDatabaseConfig

LocalDatabaseConfig is the configuration for a LocalHistoryDatabase.

history-LogHistoryService

The LogHistoryService keeps a History of Niagara log records. If enabled, it registers itself as
the LogHandler for the system when the service is started. The LogHistoryService is available
in the History Module.

history-NumericCovAlgorithm

NumericCovAlgorithm determines when to log a numeric point's value according to change of
value. The NumericCovAlgorithm is available in the history Module Extensions Directory
under NumericChangeOfValue as Collector.

history-NumericCovHistoryExt

NumericCovHistoryExt is a history extension used to record on change of value for numeric
point data. This extension is available in the history Module Extensions Directory. Refer to
“Types of history extensions” for more information about this extension.

history-NumericintervalHistoryExt

NumericIntervalHistoryExt is a history extension used to record on interval for numeric point
data. This extension is available in the history Module Extensions Directory. Refer to “Types of
history extensions” for more information about this extension.

history-StringCovHistoryExt

StringCovHistoryExt is a history extension used for collecting a string control value on change
of value. This extension is available in the history Module Extensions Directory. Refer to
“Types of history extensions” for more information about this extension.

history-StringintervalHistoryExt

StringIntervalHistoryExt is a history extension for collecting a string control value at intervals.
This extension is available in the history Module Extensions Directory. Refer to “Types of his-
tory extensions” for more information about this extension.

Components in net module

The net module contains the components listed below.
+ InternetAddress

+ HttpProxyServer
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net-InternetAddress

InternetAddress models an Internet address which is a composite of a hostname (or raw IP ad-
dress) and a port number.

net-HttpProxyServer

HttpProxyService is used to support connections to the Internet through a non-transparent

proxy.

All services that make use of the bajax.baja.net.HttpConnection class will automati-
cally roll over to using the proxy server once the HttpProxyService has been configured and en-
abled. The Weather Service is one of the services that is affected by this feature.

To use this component you must:

+ add it to your station (under the Services node, for example)

+ configure the following properties in the Property Sheet view:

3

Status
This display-only property displays the status of the Http Proxy Service.
Fault Cause

This display-only property provides an error message that indicates the reason for a
fault.

Enabled
This property has a true (enabled) and false (disabled) option.
Server

This property provides a text field for entering the address of the proxy server you are
connecting to.

Port

This property is for specifying the port number for communicating with the proxy
server.

Exclusions

This text field allows you to designate addresses that are allowed to be contacted di-
rectly, therefore “excluding” them from having to be contacted through the proxy serv-
er. The default addresses in the field are typical addresses followed by a slash(/) and the
subnet mask designation.

Authentication Scheme

This property provides the following two options:

None

no authentication is required at the proxy server when this option is set.
Basic

basic authentication is required at the proxy server when this option is set.
User

This is the login name to be used when authentication is set to Basic.
Password

This is the password text that is to be used when authentication is set to Basic.
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Components in onCall module

« onCallService

+ onCallRecipient

« OnCallSchedule
onCall-OnCallService

Available in AX-3.5 and later, the On Call Service is a customization of the alarm service that
allows you to send alarm notifications to users based on a priority list (“Contact List”). This
service initiates an email (or text message) notification for designated alarms, sending the noti-
fication sequentially, as alarms escalate, to users based on their assigned priority. The OnCall-
Service component is available in the onCall module. Also see “About the On Call Service”.

Actions

Actions include Execute.

onCall-OnCallRecipient

The On Call Recipient (AX-3.5 and later) manages the transfer of alarms between the alarm
service and On Call Contacts. For example, a station may send alarm notifications by email or
cell phone to one or more contacts if they are specified in the currently assigned On Call Con-
tact List. The On Call Recipient component is linked to an Alarm Class component and pro-
vides a place to specify the scheduling details and other routing options. The OnCallRecipient
is available in the onCall module. Also see “About the On Call Recipient”.

Actions

Actions include Route Alarm.

onCall-OnCallSchedule

The OnCallSchedule (On Call List Schedule) is used to set times for making On Call Lists ac-
tive. The OnCallSchedule component is available in the onCall module.

Actions

Actions include Cleanup.

Components in program module

+ Program

+ ProgramModule

+ ProgramService
program-Program

Program uses an instance based classfile to implement user defined component logic. The Pro-
gram can be viewed and edited using the ProgramEditor. Program is available in the program
palette.

Actions

Actions include Execute.
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program-ProgramModule

ProgramModule provides a Program Module Builder view is used to build standard modules
from Program components. This provides a mechanism to version and provision Program
modules just like any other AX module.

ProgramModule is available in the program palette.

program-ProgramService

The ProgramService provides a (default) Batch Editor view to launch a batch operation on
multiple selected component slots. For more details, refer to the Batch Editor - Engineering
Notes document.

The ProgramService also provides a secondary RobotEditor view to create “Robots”, which are
similar to Program components (written using Java code), but are not persisted in the station
database.

The ProgramService is available in the program palette, but typically exists in most station’s
Services container, as it is included among default services when using the New Station tool
(wizard).

Actions

Actions include Run Robot.

Components in the Sms module

The Sms module contains components that allow you to set up a service for sending text mes-
sages. The following components are included in the Sms module:

+ SmsService
+ SmsRecipient
« Sms

+ SmsAlarmAcknowledger

sms-SmsService

The Sms Service is the main component used for sending text messages. The service consists
of a Transport object. The Transport object is used to send an Sms text message. The Trans-
port object can be changed via altering the "Transport Type' Property. All text messages are
queued under the Sms Service. If there are any text messages queued when the station shuts
down, they will be sent when the station next starts up. See also SmsService, in the Sms User
Guide.

Actions on this component include the following:
+ Ping

+ Send

+ Clear Queue

o Process Queue

+ Reset Number Sent Today

+ Read Meassages
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sms-SmsRecipient

This component acts as an alarm recipient for transmitting alarms via a text message. Its use is
similar to the EmailRecipient component. The user is able to format the text for the SMS mes-
sage within the body slot. Note the body of an SMS text message is limited to 140 characters.

Actions on this component include: Route Alarm

sms-Sms

This component is a general use Sms component to send text messages. The phone number
for the recipient must be in International format and is configured via the component's prop-
erty sheet.

Actions available on this component include:
+ Send Default Message
+ Send Message

sms-SmsAlarmAcknowledger

The SmsAlarmAcknowledger component (AX-3.5 and later) provides a way for users to ac-
knowledge alarms by sending a reply to a text message alarm notification. This component is
available in the Sms palette and works with the with the On Call Service or with the Sms
Service.

Actions available on this component include: Received

Components in schedule module

Schedules allow you to program commands to occur at specific times. Each schedule compo-
nent is designed to provide an output based on the current time. Components can receive this
command by linking to this output. See the “Weekly Scheduler view” for more information on
using schedules.

+ BooleanSchedule

+ CalendarSchedule

+ EnumSchedule

+ NumericSchedule

+ StringSchedule

+ TriggerSchedule

+ BooleanScheduleSelector
+ NumericScheduleSelector
«+ StringScheduleSelector

« EnumScheduleSelector

schedule-BooleanSchedule

A deployable weekly schedule that provides a continuous StatusBoolean output. Other weekly
schedule types include EnumSchedule, NumericSchedule, and StringSchedule. See “About
weekly schedules” for more details.

Input - If the “in” property is linked and its value is non-null, then this value overrides the
scheduled output. The BooleanSchedule is available in the schedule palette.
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schedule-CalendarSchedule

The CalendarSchedule provides a calendar for scheduling holidays or other schedule overrides.
The CalendarSchedule is available in the schedule palette.

schedule-EnumSchedule

A deployable weekly schedule that provides a continuous StatusEnum output. Other weekly
schedule types include BooleanSchedule, NumericSchedule, and StringSchedule. See “About
weekly schedules” for more details.

Input - If the “in” property is linked and its value is non-null, then this value overrides the
scheduled output. The EnumSchedule is available in the schedule palette.

schedule-NumericSchedule

A deployable weekly schedule that provides a continuous StatusNumeric output. Other weekly
schedule types include BooleanSchedule, EnumSchedule, and StringSchedule. See “About
weekly schedules” for more details.

Input - If the “in” property is linked and its value is non-null, then this value overrides the
scheduled output. The NumericSchedule is available in the schedule palette.

schedule-StringSchedule

A deployable weekly schedule that provides a continuous StatusString output. Other weekly
schedule types include BooleanSchedule, EnumSchedule, and NumericSchedule. See “About
weekly schedules” for more details.

Input - If the “in” property is linked and its value is non-null, then this value overrides the
scheduled output. The StringSchedule is available in the schedule palette.

schedule-TriggerSchedule

A schedule that fires topics - there is no continuous output. The TriggerSchedule is available in
the schedule palette.

schedule-BooleanScheduleSelector

ScheduleSelector components provide an easy way to select a preconfigured schedule of the
proper data type for controlling a particular component. BooleanScheduleSelector components
only link BooleanSchedule components to a control component of the Boolean data type.

See also,

+ About ScheduleSelector components

» Types of ScheduleSelector components

+ Types of ScheduleSelector component properties

» Example ScheduleSelector configurations

schedule-NumericScheduleSelector

ScheduleSelector components provide an easy way to select a preconfigured schedule of the
proper data type for controlling a particular component. NumericScheduleSelector compo-
nents only link NumericSchedule components to a control component of the Numeric data

type.
See also,

+ About ScheduleSelector components
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+ Types of ScheduleSelector components
+ Types of ScheduleSelector component properties

+ Example ScheduleSelector configurations

schedule-StringScheduleSelector

ScheduleSelector components provide an easy way to select a preconfigured schedule of the
proper data type for controlling a particular component. StringScheduleSelector components
only link StringSchedule components to a control component of the String data type.

See also,

+ About ScheduleSelector components

» Types of ScheduleSelector components

+ Types of ScheduleSelector component properties

» Example ScheduleSelector configurations

schedule-EnumScheduleSelector

ScheduleSelector components provide an easy way for to select a preconfigured schedule of the
proper data type for controlling a particular component. EnumScheduleSelector components
only link EnumSchedule components to a control component of the Enum data type.

See also,

+ About ScheduleSelector components

+ Types of ScheduleSelector components

+ Types of ScheduleSelector component properties

+ Example ScheduleSelector configurations

Components in timesync module

+ TimeSyncClient
+ TimeSyncService
timesync-TimeSyncClient

Slot of a TimeSyncService used to poll a time protocol server. The TimeSyncClient is available
in the timesync palette.

NOTE: The NtpPlatformService has largely replaced this older RFC 868-based timesync mod-
ule and components, since AX-3.4. For detalils, refer to “About the NtpPlatformService” in the
Platform Guide.

timesync-TimeSyncService

NOTE: The NtpPlatformService has largely replaced this older RFC 868-based timesync mod-
ule and components, since AX-3.4. For details, refer to “About the NtpPlatformService” in the
Platform Guide.

A time protocol (RFC 868) client and server. To synchronize with other servers, TimeSyn-
Clients must be added to the service. As a convenience, a disabled default client has already
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been added (it will need configuring). The service uses the clients to poll their configured serv-
ers, and if the service detects a drift greater than the tolerance property, the service will reset
the system time. The module palette contains clients preconfigured for well known time proto-
col servers. The primary view of this Component is TimeSyncManager.

From the PropertySheet, you can set Enabled and Server Enabled.Enabled (to false) to disable
the time sync client. Server Enabled enables the time sync server. In order to sync between sta-
tions, enable master TimeSync service to be a server, then add a TimeSyncClient in the station,
configured for the server Station. The TimeSyncService is available in the timesync palette.

ForceSync
Force Time Synchronization.
Sync

Time Synchronization.

Components in web module

+ WebService

web-MobileClientEnvironment

MobileClientEnvironment (mobile) is a child of the ClientEnvironments container of a station’s
WebService, and present only if the host is licensed with the mobi le feature. It is used in the
automatic selection of the appropriate webProfile type for a user, based on the detection of the
incoming browser client type (e.g. desktop or mobile). For details, refer to “About the Mobile
Client Environment (mobile) property ” in the NiagaraAX Mobile Guide.

web-WebService

WebService encapsulates access to the HTTP server as well as the servlet infrastructure used
to expose custom applications over HT'TP. The WebService is available in the web palette. It is
also one of the default services in a station created by using the New Station tool. Only one
WebService is supported in a station.

NOTE: In AX-3.8U1, the Web Start feature offers an alternative to running the Workbench
applet in a web browser by providing an applet-like Workbench environment that runs com-
pletely outside of the browser in a separate window. Web Start is configurable via the Web
Start Config property, an added slot in the Web Services Property Sheet view.

NOTE: In AX-3.8, several WebService properties in a new station (via New Station tool in
Workbench) have different defaults than in previous NiagaraAX releases. See the “New station
WebService defaults in AX-3.8” topic. In addition, any AX-3.8 station that provides “Web
Workbench” to browser clients requires those browser client PCs to have Java configured with
“Unlimited Strength Policy Files”.

Properties of the WebService determine the port usage and authentication methods of the sta-
tion’s web server, among other things. Properties include:

» Status
Read-only property that displays the status of the WebService.
+ Fault Cause

If status is fault, provides an error message that indicates the reason.
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Enabled
By default true (enabled); if necessary it can be set to false (disabled).

NOTE: To increase security in a scenario where the WebService is not used, for example in
the JACE station where browser access is not needed, set this to false to disable this
service.

Http Port
TCP port the service listens on for HTTP client connections, where port 80 is the default.
Http Enabled

Boolean to determine if HTTP client requests are processed, it is t rue by default (before
AX-3.8).If false, and HTTPS is enabled, HTTP requests are redirected to HTTPS. See
“New station WebService defaults in AX-3.8".

Https Port

TCP port the service listens on for HTTPS (secure) client connections, where port 443 is
the default.

Https Enabled

Boolean to determine if HTTPS client requests are processed, it is false by default (before
AX-3.8). See “New station WebService defaults in AX-3.8".

+ Starting in AX-3.7, any “Hotspot JVM” NiagaraAX host can be configured for secure
(SSL/TLS) connections for browser (HTTPS) access, as well as secure Fox connections
(Foxs) and platform connections (platformssl). Complete details are in the NiagaraAX
SSL Connectivity Guide.

+ Any “IBM J9” host (earlier JACE models) can provide SSL connections to the station via
browser access , regardless of NiagaraAX release level. The inital station login screen is
always encrypted (secure), as well as all Hx access of the station. However, if browser ac-
cess uses a “Workbench” (WbApplet) profile , data transmitted over Fox is not secured
with an SSL socket. A different architecture is used, where station requires the Crypto-
Service, with the crypto module installed.

Https Only

If both HTTP and HTTPS are enabled, all HTTP requests are redirected to the HTTPS
port. See “New station WebService defaults in AX-3.8”.

Https Min Protocol

For “Hotspot JVM” SSL only. Specifies the security protocol to use, where the default is ei-
ther standard protocols (SSLv3+TLSv1). Other choices are one or the other: SSLv3 or
TLSv1.

Https Cert

For “Hotspot JVM” SSL only. Specifies the server certificate to use for HTTPS connections,
which may be different (or the same) as the one used for secure platform and secure fox
connections.

Authentication Scheme
The authentication scheme used for HTTP requests, where choices are:

+ Cookie Digest — (default) The most secure (and recommended) authentication method.
However, in some scenarios another authentication method may be necessary.

+ Cookie — Applies if the station uses the LdapUserService or ActiveDirectoryService
instead of the standard UserService.
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Also applies if using “domain-wide cookies authentication”, in which case the WebSer-
vice’s property Single Sign On Enabled (new in AX-3.7U1) also should be set to true.
For related details, see “Domain-wide cookies authentication”.

» Basic — Typically not used, except if the client did not support one of the other (pre-
ferred) authentication schemes.

Gzip Enabled

Default is true, to enable gzip compression for basic text types: html, xml, css, js, and so
on. Gzip support is new starting in AX-3.7. If set to false, gzip compression is not used.

Log File Enabled

Default is false. If set to true, a log file of HTTP transactional messages from client con-
nections is created in the station’s specified log file directory.

Log File Format

File format for log files (if enabled). Choices include:
+ NCSA Common Log Format (default)

+ NCSA Extended Log Format

+  W3C Extended Log Format

Log File Directory

Default is file: httpd. The folder in the station’s file space in which log files are stored. Log
file names use a YYMMDD . 1og (date) convention, such as 130501 . 1og for a file created
May 1, 2013.

Log File Policy

Determines when a new log file is started, whether Daily (the default) or else Weekly,
Monthly, or Limited Size.

Log Maximum Size
Specifies the maximum size of a log file, in MB, where 100MB is the default.
Auto Login Enabled

Boolean to determine if auto-login can occur using cookies, it is false by default. Only
valid if the authentication scheme is set to Cookie.

Single Sign On Enabled

Boolean to determine if “domain-wide cookies authentication” can occur using cookies, it is
false by default. Only valid if the authentication scheme is set to Cookie. Other WebSer-
vice modification is necessary for this feature, see “Domain-wide cookies authentication”.

Login Template

Specifies the template for the browser login page. If null (default), the default login template
is used.

Tunneling Enabled

Boolean to specify if this station provides HTTP tunneling to other stations (default is
false). If set to true (and the host is licensed for tunneling), the station can act as a
proxy and redirect HT'TP requests/responses where appropriate. Note you may also need
to enable Fox tunneling for full support. For more details, refer to the Fox Tunneling and
HTTP Tunneling engineering notes document

Proxy Authentication When Tunneling

Boolean to specify if authentication is required at this (proxy) station before rerouting
HTTP tunnel requests to other stations (default is false). If set to true authentication is
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required, otherwise this proxy station simply reroutes all HTTP tunel requests without re-
quiring additional authentication.

NOTE: This is required only when using Cookie Digest on the target station when:
+ A non-default Fox port is used on the target station, or
+ The target station has not been upgraded to AX-3.7U1 or later.

+ The target station has a different password.

» Cookie Digest Session Timeout

Applicable only if authentication type is Cookie Digest. Specifes the maximum amount of
time, in minutes, without activity during a browser session, whereafter the session is con-
sidered timed out—the user must log in again).

The default is 5 minutes. If set to 0, there is no timeout (but typically not recommended, as
this could be a security risk).

« Client Environments

In AX-3.7 and later, a container for Mobile Client Enviroment (mobile) entries, available if
the station’s host is licensed with the mobile feature. It is used in detection of a user’s
browser type (e.g. desktop or mobile) and the selection of the appropriate webProfile for
that user. For details, refer to “About the Mobile Client Environment (mobile) property ” in
the NiagaraAX Mobile Guide.

+  Web Start Config

In AX-3.8U1, Web Start Config properties allow you enable/disable Web Start functionality
which launches the application in an applet-like Workbench environment that runs com-
pletely outside of the browser. Also you can configure shortcuts (for the desktop and /or
the Windows Start menu) for launching the application. For details, see NiagaraAX Web
Start Guide.

New station WebService defaults in AX-3.8

By default in AX-3.8, any new station created in Workbench using the New Station tool (wiz-
ard) is created for SSL access only, including both its WebService and FoxService (the latter a
container under its NiagaraNetwork component).

A “Use secure connections (recommended)” checkbox in the New Station wizard enables this.
If left checked, the station’s WebService has these properties set as follows:

+ Http Enabled: false

« Hittps Port: 443 (or whatever Https Port was specified in the New Station wizard).
» Https Enabled: true

+ Https Only: true

Sometimes when using the AX-3.8 New Station wizard you may wish to uncheck secure con-
nections, which makes a WebService (and FoxService) with different values for the properties
above. You might do this when making a station to be installed in a “J9 JVM” JACE (JACE-2/4/
5 series), which cannot use Foxs (Fox SSL), but could use SSL for the WebService, if you also
configured it with the station-based CryptoService.

In any case, after creating a new station, you can always re-edit its WebService (and FoxSer-
vice) properties offline if needed—before installing it in the target host platform. For related
details “New Station wizard”.

NiagaraAX User Guide

205



Component Guides May 26, 2016

Components in workbench module

+ ComponentFinder

+ KioskService

+ WbFieldEditorBinding

+  WbViewBinding

+  WsOptions
workbench-ComponentFinder

The ComponentFinder dialog provides a means of finding Components.

Figure 136. Sample Window

X
q Component Finder
tame | ]
Type [ baia [#]] component [v] @ -
Results 0 objects
[ ox][concer |

workbench-KioskService

#& workbench-KioskService is used to enable the Kiosk mode. Kiosk mode provides a way to
run a Workbench station so that it fulfills many of the needs of a stand-alone operator worksta-
tion as well as many needs of a touchscreen interface. In order to automatically start Kiosk
mode, you must have a locally connected display.

NOTE: The Kiosk profile is not invoked or displayed by remote browser clients. You cannot
use a remote computer with a touchscreen and expect to get the same Kiosk interface.

This component is located in the workbench palette. To set a station to Kiosk mode, add the
service to the station's "Services" folder (Config > Services) and set the enabled property to
"true". While Kiosk mode is not limited to touchscreen applications, it does provide advantages
that make it well suited for use in a touchscreen application.

workbench-WbFieldEditorBinding
&

WhbFieldEditorBinding is used to bind WbFieldEditors to an object. It allows any existing
WhFieldEditor (BooleanFE, EnumFE, AbsTimeFE,etc) to be used in a PX presentation.

workbench-WbViewBinding
&

WbViewBinding is used to bind WbViews to an object. It allows any existing WbView (Proper-
tySheet, WireSheet, manager view, etc.) to be used in a PX presentation.
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workbench-WsOptions

&

The WireSheet options allow you to view and change the following:
+ Show Thumbnail

+ Show Grid

+ Show Status Colors

These are stored under /user/{user}/wiresheet.options.
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CHAPTER 7 PLUGIN GUIDES

Torics COVERED IN THIS CHAPTER

Plugins in alarm module
Plugins in backup module
Plugins in chart module
Plugins in email module
Plugins in help module
Plugins in history module
Plugins in html module
Plugins in onCall module
Plugins in program module
Plugins in raster module
Plugins in schedule module
Plugins in timesync module
Plugins in wiresheet module
Plugins in wbutil module
Plugins in workbench module
References

In this appendix (introduction)
About keyboard shortcuts
Types of menu bar items
Types of popup menu items
Types of edit commands
Types of toolbar icons
Types of console commands

Plugins provide views of components.

There are many ways to view plugins (views). One way is directly in the nav tree. Another way
is to right-click on the component and select one of its views from the popup menu.

Access the following summary descriptions on any plugin by selecting Help > On View (F1)
from the menu, or pressing F1 while the view is open.

Following, is a list of the types of plugin modules:

Plugins in alarm module

+ alarm-AlarmConsole

+ alarm-AlarmDbMaintenance

+ alarm-AlarmDbView

+ alarm-AlarmClassSummary

+ alarm-AlarmExtManager

+ alarm-AlarmInstructionsManager

o alarm-AlarmPortal

alarm-AlarmConsole

o

The Alarm Console allows you to view and acknowledge Alarms. It can be started by Right-
clicking the alarmRecipient in the AlarmService and selecting Views > Alarm Console.
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Viewing Alarms

Multiple Alarms from a single source are visualized as a single row in the alarm console. Color
coded icons provide a visual indication for unacknowledged/inAlarm, acknowledged/inAlarm,
and unacknowledged/not inAlarm.

+ alarm

+ 2 redAlarm

+ % greenAlarm
o % orangeAlarm

Double-clicking a row in the Table shows the history of the alarms associated with that point.
You can sort the Alarms in order of any column by pressing the column bar (once for ascend-
ing, twice for descending). Available commands include:

« & Acknowledge
« & Hyperlink

L

3

Notes
+ @& Silence
+ ¥ Filter
Acknowledging Alarms

Select an Alarm by Left-clicking it. In order to acknowledge an Alarm, press the £Alarm Ac-
knowledge toolbar button or select Alarm > Acknowledge from the Menu. You can select
multiple Alarms and acknowledge them simultaneously. In order to silence Alarms, press the
@Alarm Silence toolbar button or select Alarm > Silence from the Menu.

Acknowledge

& Acknowledge allows you to acknowledge the currently selected Alarm(s).

Hyperlink
& Hyperlink allows you to hyperlink to Alarm URL.

Silence

&Silence allows you to silence the currently selected Alarm(s).

Filter

¥Filter allows you to filter alarms.

Alarm Report Dialog

From the Alarm console, you can view the Alarm Report to see all alarms on the point. Select
an Alarm and Double-click it to see the Alarm Report.

You can sort the Alarms in order of any column by pressing the column bar (once for ascend-
ing, twice for descending). Available commands include:

« & Acknowledge
+ & Hyperlink

L

3

Notes

+ ¥ Filter
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Viewing Alarm Record

From the Alarm Report Dialog, you can view the Alarm record to see all information on the
Alarm. Select an Alarm and Double-click it to see the Alarm record.

Available commands include:
o & Acknowledge

+ & Hyperlink

Notes

L

.

o & Filter
Notes
Notes allows you to add user notes to Alarm records.

alarm-AlarmDbMaintenance

q

AlarmDbMaintenance is a view of the alarm service. It allows you view and manage alarm
records.

For more information refer to:
« “About the alarm database maintenance view”

« “About the alarm service”

alarm-AlarmDbView

o
AlarmDb is a view of the alarm service. It allows you view and sort alarm records.
For more information refer to:

+ “About the alarm service”

alarm-AlarmClassSummary

q

AlarmClassSummary is a view of the alarm service. It presents a table of information about all
alarm classes that are assigned to the alarm service.

For more information refer to:

+ “About the alarm class summary view”

+ “About the alarm service”
alarm-AlarmExtManager

a

AlarmExtManager allows you to manage Alarm extensions.
alarm-AlarminstructionsManager

q
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AlarmlInstructionsManager view displays a standard table-type report that provides a way to
view, assign, and edit alarm instructions.. For details, refer to “About the Instructions Manager
view”.

alarm-AlarmPortal

q

The Alarm Portal allows you to view and acknowledge Alarms from multiple Stations. It can be
started from the main Menu by selecting Tools > AlarmPortal.

From the Alarm Portal, you can view the Alarm record to see all information on the Alarm. Se-
lect an Alarm and Double-click it to see the Viewing Alarm Record. Available commands
include:

+ & Acknowledge
+ @ Silence
+ & Hyperlink

L

3

Notes

+ ¥ Filter

Plugins in backup module

+ backup-BackupManager

backup-BackupManager

o'}

The BackupManager is the default view for a station’s BackupService. From this view you can
issue a backup command, to back up the station’s configuration to your local PC, in dist file for-
mat. When you issue a Backup command, a File Chooser dialog appears to select the destina-
tion directory on your PC (see File Ord Chooser) and the file name for the backup dist file.

The default backup destination depends on your station connection, as either:
+  Workbench (Fox) — !backups

A subdirectory “backups” under your Niagara release directory. If you have not previously
made station backups, this directory is automatically created.

+ Browser access (Wb Web Profile) — !backups

A subdirectory “backups” under the Niagara subfolder of your installed Java 2 runtime envi-
ronment (Java plugin).

For example: C:\Program Files\Java\j2rel1.4.2_05\niagara\backups.
If you have not previously made station backups, this directory is automatically created.

The default name for a backup file uses a format of: backup stationName YYMMDD
HHMM.dist

For example, “backup_J4031P98c_050618_1429.dist” for a backup made of station “J403IP98c”
on June 18, 2005 at 2:29 pm.

In the BackupManager, a progress bar and Job Log (>> control) is provided for an initiated
backup.

The BackupManager displays a table of the 10 most recent backups, with the following data
columns:

+ Timestamp

Station date and time when the backup was initiated.
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+ Host
IP address of the requesting (remote) PC for the backup.
+ Path

File path used on the requesting (remote) PC for saving the backup. Typically, this is rela-
tive to the default Niagara directory (!), however, it may be an absolute file path.

¢ User

The station user that initiated the backup.

Plugins in chart module

+ chart-ResourceManager

chart-ResourceManager

D

The Resource Manager is an available view on any running station. It provides a line chart of
both CPU and memory usage of the host platform, and updates in real time. In addition, indi-
vidual resource statistics are provided in a table, which you can refresh by clicking the Update
button.

Plugins in email module

+ email-EmailAccountManager

email-EmailAccountManager

EEmail Account Manager allows you to view email accounts. It is the default view of the
EmailService.

Plugins in help module

+ help-BajadocViewer

help-BajadocViewer

@The BajadocViewer Plugin provides the ability to navigate and browse Baja reference docu-
mentation. Baja reference documentation includes both Java API details as well as Baja slot
documentation. It shows documentation for the following:

« Subclasses

+ Properties

+ Actions

+ Topics

+ Constructors
o Methods

+ Fields

In order to view Bajadoc, either right-click on a # ' Bajadoc file and select Views > Bajadoc
Viewer or select @Bajadoc On Target from the main Help Menu or popup Menu.

See Object Model in the Developer Guide for more information.
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BajadocViewer Menus
The BajadocViewer menu functions include:
+ Show Baja Only

» Flatten Inheritance

Show Baja Only

This option allows you to view only the documentation for slots (Properties, Actions, and
Topics). When it is set to false, documentation on the Java constructors, methods and fields is
also displayed.

Flatten Inheritance

This option allows you to flatten the inheritance hierarchy into a single set of documentation.
When it is false only the Java members and Baja slots declared in the specified class are dis-
played. When it is set to true all the Java members and Baja slots inherited from super classes
are also shown.

Subclasses

Subclasses provides a subclass tree of all that are subclassed from this item.

Properties

Properties represent a storage location of another Niagara object. Flags are boolean values
which are stored as a bitmask on each slot in a Baja Object. Some flags apply to all slot types,
while some only have meaning for certain slot types.

Flags

Flag Char Applies Description

readonly r P The readonly flag
is used to indicate
slots which are not
accessible to users.

transient t P Transient properties
do not get persisted
when saving a object
graph to the file sys-
tem. Transient prop-
erties are usually also
readonly, unless they
are designed to be a
linkable input slot.

hidden h P,A,T Hidden slots are de-
signed to be invisible
to the user, and exist
only for Java devel-
opers. User interfa-
ces should rarely
display hidden slots.

summary s P Summary properties

are the focal points
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Flag

Char

Applies

Description

of any given BCom-
ponent. This flag is
used by user inter-
face tools to indicate
primary properties
for display. This
might be as a col-
umns in a Table, or
as a glyph in a graph-
ical programming
tool.

async

By default Action are
invoked synchro-
nously on the callers
thread. By using the
async flag on an
Action, invocations
are coalesced and
executed asynchro-
nously at some point
in the near future on
the engine's thread.

noExecute

No execute proper-
ties prevents start/
stop from recursing
on properties with
this flag set.

defaultOnClone

Specifies that when
an object is cloned
via the newCopy()
method these prop-
erties retain their de-
fault value, not the
clone source's value.

confirmRequired

When the Action is
invoked by a user, a
confirmation dialog
must be acknowl-
edged before
proceeding.

operator

P,AT

This makes a slot as
operator security lev-
el. By default when
this flag is clear, the
slot is an admin se-
curity level.

userDefined1

P,AT

User defined.
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Flag Char Applies Description
userDefined2 2 P,AT User defined.
userDefined3 3 P,AT User defined.
userDefined4 4 P,A, T User defined.

See Config Flags for information on configuring flags on properties.

Actions

An Action is a slot that specifies behavior which may be invoked either through a user com-
mand or by an event. Actions provide the capability to provide direction to Components. They
may be issued manually by the operator or automatically through links. Actions can be issued
by Right-clicking on the Component. The Component bajadoc provides a complete list of Ac-

tions available for each Component. Typical Actions include:

+ Manual actions are available based on Component type. The following are commonly

available:

+ Auto (BooleanWritable, NumericWritable and EnumWTritable)
+ Active (BooleanWritable)

+ Inactive (BooleanWritable)

+ Override (NumericWritable and EnumWTritable)

Each of the above actions is issued to the priorityArray of the Component at level 8
(Manual Operator).

+ Many other Actions are available on other Components. Each Action available for a Com-

ponent is listed in the Actions sect2 of the Component bajadoc.

Topics

Topics represent the subject of an event. Topics contain neither a storage location, nor a be-

havior. Rather a topic serves as a place holder for a event source.

Plugins in history module

+ history-DatabaseMaintenance

+ history-DeviceHistoriesView

+ history-GroupManager

+ history-HistoryChart
+ history-HistoryChartBuilder

+ history-HistoryEditor

+ history-HistoryExtManager
+ history-HistorySummaryView

+ history-HistoryTable

+ history-LiveHistoryChart
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history-DatabaseMaintenance

aThe DatabaseMaintenance view allows you to maintain the histories in a station from
Workbench.

This view allows you to Clear Old Records, Clear All Records or Delete Histories.

history-DeviceHistoriesView

q

The Device Histories View is available on any device that supports import and export of histor-
ies (for example, Niagara devices, BACnet devices, and others). The view shows a filtered list of
history shortcuts for that particular device. This view displays all the related shortcuts in a ta-
ble. You can double-click on any single entry in the table to open that history in the History
Chart view.

history-GroupManager

q

The HistoryGroupManager provides a tabular view of all history groups. It is the default view
of the HistoryGroupings component and provides information about the groups contained in
the HistoryGroup component.

Refer to the following sections for related information:
+ “About history grouping”

+ “About the History Group property sheet view”

+ “About the History Group Manager view”

history-HistoryChart

o'}

The HistoryChart is a view that allows you to display and configure charts of history records.
Any point History can be charted by double-clicking directly on it under the History node in
the nav tree.

The HistoryChart properties are configurable when editing the HistorChart view in a Px page.

Figure 137. History Chart display properties are configurable in the Px page view

2 History Chart
Choose how to display these dEFaU|tD_E|ta fils L=
ey -
chart features on initial view defaultlivellpdates  |False =
defaultTimeRange timeR.ange:start Tir (==
enabled true E‘
ayout 0,0,450,350 =]
. showDeltaEditor true =]
Choose to show or hide these - =
P showlivellpdates true d
chart features individually - - —
showTimeRangeEditar  |true hd
wvisible true [=]

» defaultDelta

When set to true, this property causes the history chart view to plot delta values on initial
display and any time the view is refreshed.

+ defaultLiveUpdates

When set to true this property sets the chart view to Live Update mode on initial display
and whenever the view is refreshed.

+ defaultTimeRange
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This property allows you to choose a specific time range option that appears on initial dis-
play and whenever the history chart view is refreshed.

+ enabled
This property allows you to disable (false) or enable (true) the history chart view.
+ layout

This property provides four values that define the size of the history chart view display
area.

« showDeltaEditor

This property allows you to hide (false) or show (true) the delta mode button [Al on the his-
tory chart view.

+ showLiveUpdates

This property allows you to hide (false) or show (true) the live update button [ on the his-
tory chart view.

» showTimeRangeEditor

This property allows you to hide (false) or show (true) the Time Range Editor option list on
the history chart view.

+ visibility
This property allows you to hide (false) or show (true) the history chart view.

history-HistoryChartBuilder

q

The HistoryChartBuilder is a view that allows you to view and configure charts of one or more
histories. Add a history by double-clicking or dragging into the configuration area. For any
chart, you can specify a Time Range, Title, and whether to show grid lines. Each history has a
selectable Chart Type of either Line or Discrete Line. After you Build a chart, you can Save it.

history-HistoryEditor

a
The HistoryEditor allows you to view and query a History in a Station.

The HistoryEditor allows you to #Hide or Unhide selected records.

history-HistoryExtManager

o'}

The HistoryExtManager provides a tabular view of all history extensions. It is the default view
of the HistoryService and provides information about the control point, extension type, name
and status of each entry. Refer to the following references for information about the history ex-
tension manager, its associated menus, toolbar icons, and other details.

Refer to the following sections for related information:
+ “About the History Ext Manager menu”
+ “About the history extension manager view”

+ “About the history extension manager popup menu items”

history-HistorySummaryView

aThe HistorySummaryView allows you to view the general information about a History.
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history-HistoryTable

o'}

The HistoryTable is a view that allows you to view tables of histories. The selected entries are
shown as timestamp, trendFlags, status and value in each row of the Table.

You can resize columns in the HistoryTable. If you move the cursor over the line between col-
umns, it will change to a resize cursor. You can then drag the line to the desired size.

If want to reorder the columns in the HistoryTable, drag the column header to a new location.

Query

Query lets you select the period for the query. Selections include:
» Time Range

+ Today

+ Yesterday

o Last Week

+ Last 7 Days

+ Last Month

» Last Year

+ Month-to-date

+ Year-to-date

Filter

Ry

Filter lets you use the filter you have configured for the data in the Table.
Filter Config
4

Filter lets you configure the filter for the data in the Table.

history-LiveHistoryChart

o'}

Background and live history charting is available for history data. This feature includes the abil-
ity to display historical data (trend data) in a Live History Chart view that plots a range of data
from a configurable start time to the current time and continues plotting as new data is gener-
ated by the source. Refer to “About the Live History Chart View” for more details.

Plugins in html module

o html-WbHtmlView
+ html-SpyViewer

html-WbHtmlView

a The WbHtmlView allows you to view HTML files.
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WbHtmlView Menus

Main menu functions are available from this view.

WbHtmlView Toolbar

In the WbHtmlView, the toolbar contains navigation and editing buttons as described in
“About the toolbar”. In addition, Find, FindNext and FindPrev toolbar buttons are available.

HTML Support
HTML Tags

The WbHtmlView attempts to ignore mismatched or missing Tags. It can parse any HTML,
no matter how badly messed up the Tags are, although it might do a pretty bad job of rendering
the results. It does simplistically attempt to repair missing <p>, but other problems are solved
by ignoring Tags. Warnings will appear on the command line showing its best guess as to what
the problem was. Valid tags include:

+ a-anchor Ex:<a href="#fragment">Title<a> and <a name="fragment">Title<a> (Attributes
href and name)

+ applet - not supported

+ b - bold text style Ex: <b>bold text<b>

+ body - document body

+ br - forced line break

+ code - computer code fragment

+ col - not supported

+ colgroup - not supported

+ dd - definition description

+ div - not supported

+ dl - definition list

+ dt - definition term

+ em - emphasis Ex: <em>emphasis text<em>
« font - local change to font (Attributes Color, name and size)
+ hl - heading Ex:<h1 class="title'>Title<h1>
+ h2 - heading

+ h3 - heading

+ h4 - heading

+ h5 - heading

+ h6 - not supported

+ head - document head

+ hr - horizontal rule

+ html - document root element

+ i-italic text style

+ img - embedded image Ex: <img src="../doc/icons/x16/home.png"> An <img> without an
align attribute is treated as an 'inline' image. An align of left or right causes text to
flow around the image.
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o li-list item

+ link - a media-independent link Ex:<link rel='StyleSheet' href="module://bajaui/doc/style.
css' type="text/css'/>

+ meta - not supported

+ object - not supported

+ ol - ordered list

+ p - paragraph Ex:<p class="note'>Note<p>

+ pre - preformatted text

+ span - not supported

+ style - not supported

« table - table (Attributes align, border, bordercolor, cellpadding, cellspacing and width)
+ tbody - not supported

+ td - table data cell supports ALIGN (left, right, and center), BGCOLOR, COLSPAN, ROW-
SPAN and WIDTH

«+ tfoot - not supported

+ th - table header cell supports ALIGN (left, right, and center), BGCOLOR, COLSPAN,
ROWSPAN and WIDTH

«+ thead - not supported

« title - document title

+ tr - table row supports ALIGN (left, right, and center) and BGCOLOR
+ tt - teletype or monospaced text style

o ul - unordered list

HTML Attributes

HTML Elements have associated properties, called attributes, which may have values. Attrib-
ute/value pairs appear before the final ">" of an element's start tag. Valid attributes include:

« align - vertical or horizontal alignment Deprecated; elements: img, object? values: bottom,
left,middle, right or top.

« align - table position relative to window Deprecated; elements: table; values: center, left
or right

« align - align, text alignment Deprecated; elements: div?, h1?, h2?, h3?, h4?, h5?, h6?, p; val-
ues: center, justify, left or right

« align - alignment; elements: col?, colgroup?, tbody?, td, tfoot?, th, thead?, tr; values: cen-
ter, char, justify, left or right

+ bgcolor - background Color Deprecated; elements: h1, h2, h3, h4, h5, h6?, p, td, th, tr

+ border - controls frame width around table; elements: table

+ cellpadding - spacing within cells; elements: table

+ cellspacing - spacing between cells; elements: table

« class - class name or set of class names for stylesheets; elements: most elements

+ color - text Color Deprecated; elements: font, h1, h2, h3, h4, h5, h6?, p, pre, td?, th?, tr?

+ colspan - number of cols spanned by cell; elements: td, th
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+ content - associated information; elements: meta?

o href - URI for linked resource; elements: a, link

« id - name to an element; elements: most elements

+ lang - Language Code; elements: most elements not supported

« name - named link end; elements: a

+ name - meta information name; elements: meta?

+ rel - forward link types; elements: link; values: stylesheet

+ rowspan - number of rows spanned by cell; elements: td, th

+ size - size of font; elements: font; value: fixed 1-7 or relative -7 to +7
+ summary - purpose/structure for speech output; elements: table
+ type - advisory content type; elements: link; values: text/css

« width - table width; elements: table

Character Entity References

Character Entity References are supported including the following:
o & -ampersand &

+ &apos; - apostrophe '’

+  &copy; - copyright ©

o &gt; - greater than >

+ &ldquo; - double quotation, left “

+ &lsquo; - single quotation, left *

o &lt; - less than <

o &mdash; - em dash —

+ &nbsp; - non breaking space " "

« &ndash; - en dash —

+ &rdquo; - double quotation, right”
+ &rsquo; - single quotation, right’

+ &quot; - quotation mark "

o &reg; - registered trademark °

o &trade; - trademark ™
Stylesheet Support

Introduction

Stylesheets are supported using a link in the header as follows:

<head>

<title>Sample<title>

<link rel='StyleSheet' href='module://bajaui/doc/style.css' type='text/css'
<head>

See the default stylesheet used for Niagara developer documentation: module://bajaui/doc/
style.css or the CSS stylesheet used for this document at docbook.css.
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Pseudo-classes and Pseudo-elements

Anchor pseudo-classes include:

.

.

.

A:link unvisited links unsupported
A:visited visited links unsupported

A:active active links unsupported

CSS1 Properties

Stylesheet elements supported include:

.

background - The 'background’ property is a shorthand property for setting the individual
background properties (i.e., 'background-color’, 'background-image', 'background-repeat’,
'background-attachment’ and 'background-position’) at the same place in the style sheet.

background-attachment unsupported
background-color - This property sets the background Color of an element.
background-image unsupported
background-position unsupported
background-repeat unsupported
border unsupported

border-bottom unsupported
border-bottom-width unsupported
border-color unsupported
border-left unsupported
border-left-width unsupported
border-right unsupported
border-right-width unsupported
border-style unsupported

border-top unsupported
border-top-width unsupported
border-width unsupported

clear unsupported

color - This property describes the text Color of an element (often referred to as the fore-
ground Color).

display unsupported
float unsupported

font unsupported
font-family unsupported
font-size unsupported
font-style unsupported
font-variant unsupported
font-weight unsupported
height unsupported
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+ letter-spacing unsupported

+ line-height unsupported

+ list-style-image unsupported
+ list-style-position unsupported
+ list-style-type unsupported

+ margin unsupported

+ margin-bottom unsupported
+ margin-left unsupported

» margin-right unsupported

+ margin-top unsupported

+ padding unsupported

+ padding-bottom unsupported
+ padding-left unsupported

+ padding-right unsupported

+ padding-top unsupported

+ text-align

+ text-decoration unsupported
+ text-indent unsupported

+ text-transform unsupported
+ white-space unsupported

+ width unsupported

» word-spacing unsupported
html-SpyViewer
&

SpyViewer allows you to view diagnostic information about the system. It contains the
following:

+ sysinfo - sysinfo provides system information.
+ stdout - stdout provides access to standard output.
» systemProperties - systemProperties provides access to system properties.

+ logSetup - logSetup allows you to config your log severities dynamically. There is also an
option to flush the current settings to log.properties.

» sysManagers - sysManagers provides information on managers. These include:
» registryManager
+ schemaManager
» componentNavEventManager
+ moduleManager
+ engineManager

+ leaseManager
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» serviceManager
+ licenseManager
» stationManager
+ navSpace - provides information on the navSpace.

+ userinterface - if System - userInterface provides information on the user interface
framework.

+ fox - fox provides information on fox client and server sessions.

Plugins in onCall module

+ onCall-OnCallListManager
+ onCall-OnCallContactManager
« onCall-OnCallUserReportView

onCall-OnCaliListManager

o'}

The On Call List Manager view (AX-3.5 and later) is the default view of the On Call Service.
This view displays a table listing of all existing On Call lists and allows you to add, delete, and
edit On Call Contacts. See also, “About the On Call List Manager view”.

onCall-OnCallContactManager

q

The On Call Contact Manager view (AX-3.5 and later) is the default view of the On Call List
component. This view displays a table listing of all contacts in the selected On Call list and al-
lows you to add, delete, and edit On Call Contacts. See also, “About the On Call Contact Man-
ager view”.

onCall-OnCallUserReportView

q

The On Call user Report view (AX-3.5 and later) is the default view of the On Call Contact
component. This view provides a tabular presentation of the details associated with any On
Call List that the selected user is assigned to. The purpose of this view is to provide each On
Call Contact with a configurable table of information that shows scheduled times and priorities
associated with all of On Call Contact Lists that they are assigned to. See also, “About the On
Call User Report view”.

Plugins in program module

+ BatchEditor

+ ProgramEditor

+ ProgramModuleBuilder
+ RobotEditor

program-BatchEditor

E|
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The Batch Editor is the default view on the ProgramService. It allows you to perform a variety
of operations on slots of multiple components by issuing a single “batch” command. You can
add (specify) components using drag and drop from the Nav tree, or copy and paste into the
view, or by using the “Find objects” (Bql Query Builder) function—or any combination of the
three methods.

As needed, use the @ Clear Selected Items control to remove any items before running the
operation.

The Batch Editor can be a real time saver when the same configuration change needs to be re-
plicated among multiple component slots. For complete details, refer to the Batch Editor - En-
gineering Notes document.

program-ProgramEditor

a The ProgramEditor Plugin provides the ability to view and edit Program Components.

To view, Right-click a Program and select ProgramEditor. It shows EProgramEditor Edit, 8
ProgramkEditor Slots, OProgramEditor Imports and ¥ProgramEditor Source tabs.

ProgramEditor Edit

Edit allows you to edit the onExecute, onStart, onStop and freeForm methods. An example
from the demo Database follows:

BStatusNumeric inA = getInA();
BStatusNumeric inB = getInB();
BStatusNumeric out = getOut();

out.setValue( inA.getValue() + inB.getValue() );

ProgramEditor Slots

g

Slots allows you to view and change the slots of the program component. It includes Slot, #,
Name, Display Name, Definition, Flags and Type for each slot. See SlotSheet for more infor-
mation on slots.

ProgramEditor Imports

O

Imports allows you to view the Modules that have been imported.
It also allows the following:

o © ProgramEditor ImportType

+ © ProgramEditor ImportPackage

+ © ProgramEditor Remove
ProgramEditor ImportType
&)

ImportType allows you to import a new type.

226

NiagaraAX User Guide



Plugin Guides May 26, 2016

ProgramEditor ImportPackage

)

ImportPackage allows you to import a new type.
ProgramEditor Remove

@

Remove allows you to import a new type.
ProgramEditor Source

&

Source allows you to view and edit the source of the program component. The editor supports
special Color coding for Java Files. An example from the demo Database follows:

/* Auto-generated ProgramImpl Code */

import java.util.*; /* Java Predefined*/
import javax.baja.sys.*; /* baja Predefined*/
import javax.baja.status.*; /* baja Predefined*/
import javax.baja.util.*; /* baja Predefined*/
import com.tridium.program.*; /* program Predefined*/

public class ProgramImpl
extends com.tridium.program.ProgramBase

{

L1777 77777777777777777777777777777777777777777777777777777777777
// Getters
[1777777777777777777777777777777777/7777777777777777777777/7777777

public BStatusNumeric getOut () { return (BStatusNumeric)get ("out"); }
public BStatusNumeric getInA() { return (BStatusNumeric)get ("inA"); }
public BStatusNumeric getInB() { return (BStatusNumeric)get ("inB"); }

[1777777777777777777777777777777777/77777777777777777777777777777
// Setters
L1777 77777777777777777777777777777777777777777777777777777777777

public void setOut (javax.baja.status.BStatusNumeric v) { set("out", wv);
public void setInA(javax.baja.status.BStatusNumeric v) { set("inA", v); }
public void setInB(javax.baja.status.BStatusNumeric v) { set("inB", v); }

L1117 0777777007777 0077777077777 70777777777 77777777777777777777

// onExecute

[177777777777777777777777777777777777777777777777777777777777777

public void onExecute ()
throws Throwable

{

BStatusNumeric inA = getInA();
BStatusNumeric inB = getInB();
BStatusNumeric out = getOut();

out.setValue( inA.getValue() + inB.getValue() );
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}

ProgramEditor Menus

The Workbench main menu functions are available. When the ProgramEditor is visible, the
following ProgramEditor menu function is also available:

o @ ProgramEditor ImportType

o © ProgramEditor ImportPackage
+ © ProgramEditor Remove

© Add Slot Ctrl + A

@ Delete

+ © Rename Slot Ctrl + R

+ & Reorder

« % ProgramEditor Compile & Save F9

+ 4 ProgramEditor Compile Ctrl + F9

ProgramEditor Toolbar

The Workbench toolbar contains navigation and editing buttons as described in “About the
toolbar”. When the ProgramEditor is visible, additional toolbar buttons include:

+ 2% Find F5

+ [# Replace F6

« T ProgramEditor Compile & Save F9
+ 4 ProgramEditor Compile Ctrl + F9
+ % Console Prev

+ Ik Console Next
ProgramEditor Compile & Save

4

CompileSave allows you to compile and save the source of the program component. The short-
cut is F9.

ProgramEditor Compile

4

Compile allows you to compile the source of the program component. The shortcut is Ctrl +
Fo.

program-ProgramModuleBuilder

q

The Program Module Builder is the default view on the ProgramModule. It lets you create a
module from one or more Program components, such that they may be versioned and provi-
sioned just like other AX modules.
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program-RobotEditor

(o)

The RobotEditor is used to write Robots that can be run via the ProgramService.
RobotEditor Menus

The Workbench main menu functions are available. When the RobotEditor is visible, the fol-
lowing RobotEditor menu function is also available:

+ % RobotEditor Compile Ctrl + F9
+ ' RobotEditor Compile & Run F9

RobotEditor Toolbar

The Workbench toolbar contains navigation and editing buttons as described in “About the
toolbar”. When the RobotEditor is visible, additional toolbar buttons include:

+ @& Find F5

o [# Replace F6

+ % RobotEditor Compile Ctrl + F9

+ * RobotEditor Compile & Run F9

+ % Console Prev (?need to find SearchConsolePrev.html source?)

+ B Console Next (?need to find SearchConsoleNext.html source?)

RobotEditor Compile

K

Compile allows you to compile the source of the Robot component. The shortcut is Ctrl + F9.

RobotEditor Compile & Run

»

Compile& Run allows you to compile and run the source of the Robot component. The short-
cut is F9.

Plugins in raster module

+ raster-RasterViewer

raster-RasterViewer

1

The RasterViewer is used to display bitmapped image files: GIF, JPEG, PNG. It displays the im-
age in the main window with Format and image Size at the bottom.

Plugins in schedule module

+ schedule-CalendarScheduler

+ schedule-CurrentDaySummary
+ schedule-Scheduler

+ schedule-TriggerScheduler
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schedule-CalendarScheduler

o'}

The CalendarSchedule view is used to define calendar days in a CalendarSchedule. Typically,
calendar days represent holidays.

Use the Add button to add a calendar day (or range of days). Each entry requires a unique
name, a date type, and other specific calendar data criteria. Other controls in the Calendar-
Schedule allow you to edit priority, rename, or delete calendar date entries.

For more details, see “Calendar Scheduler view”.

schedule-CurrentDaySummary

o'}

The CurrentDaySummary view is available on BooleanSchedule, EnumSchedule, Numeric-
Schedule, and StringSchedule components. It provides a simple linear listing of all schedule
events for the current day, moving left-to-right from 0-to-24 hours.

For more details, see “Summary”.

schedule-Scheduler

o'}

The Scheduler allows you to view and edit schedule components, namely BooleanSchedule,
EnumSchedule, NumericSchedule, and StringSchedule. Each of these components has a Sched-
uler view. The only difference between these different schedules is the output type.

NOTE: For more details, see “Weekly Scheduler view”.

There are four major elements in the Scheduler interface, separated by tabs in the view:
+  Weekly Schedule

+ Special Events

+ Properties

+ Summary

Weekly Schedule

Defines the regular (repeating) day-of-week schedule events for each day of the week.
Creating A Time Range Right-click and drag down in the slider column for desired the day.
Deleting A Time Range Click on a time range and press the delete or backspace key.

Editing A Time Range Time can be adjusted four ways: Dragging the top, bottom or center of a
time range, or using the fine grained start and finish editors. To fine-tune a time range click on
a time range then adjust the times in the editors to the left.

NOTE: IMPORTANT: The finish time is exclusive; it is the first non-effective time after the ef-
fective period. The start time is inclusive.

Output is assigned to each time range and can be edited just below the time editors on the left.

Special Events

Special events override (yet intermingle with) events in the normal weekly schedule.
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Adding, Prioritizing, Renaming, and Deleting. Use the controls at the bottom for this purpose.

Editing At least one time range must be present for an exception to work. Output is assigned to
the time ranges. The slider operates exactly like the normal weekly sliders.

Properties

Define the schedule’s effective period, default output, facets, and whether automatic special-
event cleanup occurs.

Default Output

This is the value of the schedule's output when no normal or exceptional schedule is effective.

Cleanup Special Events

If set to true (default), special events that have expired are automatically removed from the
view. This occurs on the day following the scheduled special event.

Summary

Shows months with selectable days, including all schedule event activity for any day selected.

schedule-TriggerScheduler

q

The TriggerSchedule view is used to define schedule events in a TriggerSchedule. Trigger
schedules are defined by combination of calendar day (or days) and trigger event time(s), in-
cluding time ranges, each with a repeating interval.

Use the bottom-left Add button to add a scheduled day (or range of days). Each entry requires
a unique name, a date type, and other specific calendar data criteria. Other controls in the Trig-
gerSchedule allow you to edit priority, rename, or delete calendar day entries.

Use the bottom-right Add button to add trigger events to any selected scheduled day(s). Use
the time selector to specify the individual trigger event. Use the Range controls to define a time
range with repeating interval for trigger events to occur.

For more details, see “About trigger schedules”.

Plugins in timesync module

+ timesync-TimeSyncManager

timesync-TimeSyncManager

q

The TimeSyncManager is used to display the status of TimeSyncClients, as well as add new or
edit existing TimeSyncClients. By default, it displays Server Name, Status, Poll Delta, Poll Local
Time, and Poll Server Time for each TimeSyncClient.

NOTE: The NtpPlatformService has largely replaced this older RFC 868-based timesync mod-
ule and components, since AX-3.4. For details, refer to “About the NtpPlatformService” in the
Platform Guide.

Plugins in wiresheet module

« wiresheet-WireSheet
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wiresheet-WireSheet

The WireSheet view shows the contents of this component. It can be used on a component
of a running station or a component in a Bog File.

If in a running station, it is active and real-time updates are provided. In order to command or
select a different view of the item, you may right-click to get the popup menu.

WireSheet Menus

The WireSheet includes the following menus:
+  WireSheet Main Menu

+  WireSheet Component Menu

+ WireSheet Background Menu

+  WireSheet Link Menu

WireSheet Main Menu

The WireSheet main menu functions are available. When the *wiresheet; is visible, the follow-
ing WireSheet menu functions are also available:

+ e Delete Links

+ & Arrange

o B Select All

o Show Thumbnail
+ Show Grid

+ Show Status Colors

WireSheet Component Menu

If you Right-click any Component in the WireSheet, you can choose from the following:
+ views - Go to any of the views of the Component.
+ Actions - Perform any of the Actions on the Component.
o s CutCtrl + X
o+ [ CopyCtrl+C
® Paste Ctrl + V
+ [ Duplicate Ctrl + D
© Delete Delete

-
(2]

CompositeEditor

Rename
+ E! Reorder

« # Pin Slots

WireSheet Background Menu

If you Right-click the Background of the WireSheet, you can choose from the following:
o oo CutCtrl +X

+ [ CopyCtrl + C
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« [ Paste Ctrl + V

+ [ Duplicate Ctrl + D
o @ Delete Delete

+ @ Delete Links

+ & Arrange

+ Select All

. workbench-CompositeEditor

WireSheet Link Menu

If you Right-click any link in the WireSheet, you can choose from the following:
o oo CutCtrl+X

o+ [ CopyCtrl+C

o [ Paste Ctrl + V

+ [ Duplicate Ctrl + D

+ © Delete Delete

+ & Delete Links

+ & Arrange

o Select All

. CompositeEditor

WireSheet Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”. When
the WireSheet is visible, additional toolbar buttons include:

« aa Delete Links

Delete Links

Delete Links may be accessed from the Menu under Edit or from the toolbar. It allows you to
eliminate the selected link(s). You can Delete Links only in the WireSheet.

Pin Slots

-

Pin Slots provides the capability to make Properties of a Component visible in the WireSheet
view of the Component. Right-click on the Component and select Pin Slots. This will bring up
the Pin Slots Dialog.

The selected Properties are now visible in the WireSheet.
Arrange
=

Arrange allows you to arrange the items in the WireSheet. You can Arrange All or Arrange
Selection.
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Select All

Select All allows you to select all items in the WireSheet.

Show Thumbnail

Show the thumbnail view in the upper right corner of the WireSheet. This allows you to toggle
whether this function is enabled. This function may be accessed from the Menu under Wire-
Sheet. It allows you to display a thumbnail of the WireSheet view in the corner of the Wire-
Sheet. You can use the thumbnail to move around the WireSheet by Dragging the shaded area
in the thumbnail. You can also hold down the Ctrl key and move the thumbnail around the
WireSheet to keep it out of your way.

Show Grid

When enabled, the Grid is displayed in the background of the WireSheet. This helps you to
align Components when you move them. You may control whether the Grid layer is enabled or
visible from the WireSheet Menu or the Tools > > Options Menu. This allows you to toggle
whether this function is enabled.

Show Status Colors

Show the Status Colors. This allows you to toggle whether this function is enabled. This func-
tion may be accessed from the Menu under WireSheet. It allows you to display StatusColors in
the WireSheet.

workbench-PrintDialog

53

Print provides the capability to print the WireSheet. The WireSheet will remain fixed at logical
size of 100 x 100 "blocks". Printing will scale the WireSheet drawing to fit the page size (minus
header and footer). Thus if you build your WireSheet logic in the top left corner, you will get a
large scale for your print out. If you use the entire WireSheet down to the bottom right corner,
you will get a much smaller scale for your print out. Margins are 1" for left and 1/2" for top,
bottom, and right. A standard header is included which displays container's reference and cur-
rent date. A future version will create a footer listing external links and knobs.

workbench-CompositeEditor

Composite Editor provides the capability to expose child slots of a Component as slots on the
parent. Right-click on the Component and select Composite Editor. This will bring up the
Composite Editor Dialog. The selected Properties are now visible in the WireSheet.

workbench-ExportDialog

=

Export provides the capability to Export views. You can Export any Table found in the Work-
bench (anything built with bajaui:Table). The Table options menu (that little button to the
right of the header), includes a Print and Export command. These commands allow you to Ex-
port the Table to PDF, HTML, or CSV (ExcelFile). The Export uses the current sort order and
visible columns you have displayed.

Plugins in wbutil module

+ wbutil-CategoryBrowser
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+ wbutil-CategoryManager

+ wbutil-CategorySheet

+ whbutil-PermissionsBrowser
+ wbutil-ResourceEstimator
+ whbutil-TodoList

+ wbutil-UserManager

wbutil-CategoryBrowser
)

CategoryBrowser is the default view of a station’s CategoryService. Use it to assign objects in
the station into categories. This view presents an expandable tree table where the table col-
umns are the available categories, and rows are the categorizable objects.

+ Yellow rows are objects explicitly assigned into a category.

+ Dimmed rows represent objects inheriting their parent’s categories.

NOTE: For any object except the three root objects: station (components), file, and history,
you can check to inherit its parent’s categories. For root objects, you must select at least
one category.

For any component, you can alternately use its CategorySheet view to assign it categories. See
“Categories and security” for details on how categories affect security, and “Category Browser”
for more details on this CategoryService view.

wbutil-CategoryManager
@

CategoryManager is a view on the CategoryService that allows you to create, enable and delete
categories. Categories are used by the security model, as well as for future features. You can
then use the CategoryBrowser view to centrally assign objects to categories. Or, at the individu-
al component level, use a component’s CategorySheet view to assign it to categories.

You can assign an object to many categories at the same time. Each object stores its own cate-
gories. See “Categories and security” for details on how categories affect security, and “Category
Manager” for more details on this CategoryService view.

wbutil-CategorySheet
@

CatgegorySheet is used to assign a component into one or more categories (or configure it to
inherit categories). Every component has a CategorySheet view. See “Categories and security”
for details on how categories affect security, and “Category Sheet” for more details on this com-
ponent view.

wbutil-PermissionsBrowser

q

PermissionsBrowser is an available view on the UserService, for reviewing the permissions any
user has on each object. It provides an expandable tree table (similar to the CategoryBrowser
view of the CategoryService). In the PermissionsBrowser, columns represent station user ac-
counts, and rows are the objects in the station, with each table cell showing user permissions.

+ Yellow rows are objects explicitly assigned with permissions.
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+ Dimmed rows represent objects inheriting their permissions.

Double-click a cell to bring up the permissions dialog for that user (unless user has super user
rights). This allows you to globally change that user’s permission levels for any category in the
station.

See “Permissions and security” for details on how permissions affect security, and “Permissions
Browser” for more details on this UserService view.

wbutil-ResourceEstimator

5.

The Resource Estimator tool allows you to estimate station resources based a number of varia-
bles, which you enter in various fields. It is one of several tools in the Workbench Tools menu.

For more information, refer to “Resource Estimator”.

wbutil-TodoList

The Todo List tool allows you to enter, summarize, group, and prioritize pending tasks. It is
one of several tools in Workbench’s Tools menu.

For more information, refer to “Todo List”.

wbutil-UserManager
-3

The UserManager is the primary view of the UserService. You use it to add, edit, and delete
users for accessing the station. See “Users and security” for details on how users affect security,
and “User Manager” for more details on this UserService view.

For an overview on the station security model, see “Security model overview”.

Plugins in workbench module

« workbench-CollectionTable

+ workbench-DirectoryList

+ workbench-HexFileEditor

» workbench-JobServiceManager
+ workbench-LinkSheet

+ workbench-ModuleSpaceView
+ workbench-NavContainerView
« workbench-NavFileEditor

+ workbench-PropertySheet

+ workbench-SlotSheet

» workbench-StationSummary

+ workbench-TextFileEditor

+ workbench-ServiceManager

+ workbench-WbPxView

+ workbench-WhbServiceManagerView
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workbench-CollectionTable

The CollectionTable allows you to view tables. One way to create a Table is through a BQL col-
lection like:

local:|fox:|station:|slot:/ControlObjects|bgl:select displayName, type,
The Table options menu (see “Table controls and options” for more details about the table op-
tions), allows you to Reset Column Widths, Print and Export.

workbench-DirectoryList

The DirectoryList Plugin provides a listing of the subdirectories and files found in a given
Directory. If you Double-click an item, you will go to its default view.

Files will be displayed with an icon based on file type.

DirectoryList Menus

Main menu functions are available. When the DirectoryList is visible, the following popup
menu functions are also available:

+ Views - show the view menus for the Component.

+ Actions - Perform any of the Actions on the Component.
+ New - Create a new file of standard types (if a Directory).
o v CutCtrl + X

+ [ CopyCtrl + C

o [® Paste Ctrl + V

+ [ Duplicate Ctrl + D

+ © Delete Delete

+ © Rename

=

« &! Reorder

DirectoryList Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”.

Refresh

Refresh allows you to synchronize the cached components with the actual file system.

New

New allows you to make a new Folder or File in the selected Folder of these types:
+ O New Folder allows you to make a new Folder in the selected Folder.

+ o BogrFile.bog

+ @ HtmlFile.html

. JavaFile.java

+ & NavFile.nav

+ & PrintFile.print

. TextFile.txt
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workbench-HexFileEditor
The HexFileEditor allows you to view hexadecimal files. It provides a binary view of a file's

contents.

workbench-JobServiceManager
&

The JobServiceManager is the default view on a station’s JobService. It provides a table listing
of up to the last 10 Jobs executed by the station since the last station start. Order is oldest job
at top, most recent job at bottom.

To see details on any job, click the “” button next to its status descriptor. A popup Job Log dia-
log displays all the interim steps about the job, including timestamps and relevant messages.

To dispose of any job, click the close (“X”) button to remove it from the station.

NOTE: Only the last ten jobs are saved. All jobs in a station are cleared upon a station restart.

workbench-LinkSheet

The LinkSheet allows you to view and delete links. It provides a view of the links on a
Component.

LinkSheet Main Menu

The main menu functions are available. When the LinkSheet is visible, the following LinkSheet
menu functions are also available:

+ e Delete Links

¢ = GoTo

LinkSheet Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”. When
the LinkSheet is visible, additional toolbar buttons include:

+ & Delete Links

GoTo

=

Go To goes to the selected item.

workbench-ModuleSpaceView

The ModuleSpaceView allows you to view Modules.
OptionsButton

The Options Button provides the ability to toggle columns on and off like Mozilla does.

workbench-NavContainerView
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NavContainerView is a default listing of nav children.

workbench-NavFileEditor

The NavFileEditor allows you to view and edit Nav Files. It provides a view of the Pages in the
station and a view of the Nav Tree. You can drag Pages to the Nav Tree to add them to the Nav
File. The name and Ord are shown at the bottom of the window.

In order to use the Nav File, you must place the filename in the Default Nav File property of
the WebService.

workbench-PropertySheet

The Property Sheet shows all the user visible Properties of the Component.

This view also lets you change any Properties that you have authority to change. It can be used
on a Component of a running Station or a Component in a Bog File.

In order to see Properties of Components in the PropertySheet, press the + sign to expand the
Component.

When you want to enter a URL, you can Copy the Component or URL and Paste it into the
PropertySheet using the Paste shortcut Ctrl + V.

When a Property has been changed, its symbol will become red until you press ESave.

PropertySheet Menus

The main menu functions are available. If you Right-click any Component in the Property-
Sheet, you can choose from the following:

+ Views - show the view menu for the Component.
+ Actions - Perform any of the Actions on the Component.

04 (2]

o CutCtrl+X

. [

+ CopyCtrl + C
. @

o PasteCtrl +V
. M

+  Duplicate Ctrl + D
. ©

«  Delete Delete

. Rename

«  Reorder

. ¥

+  Config Flags
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PropertySheet Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”.
Config Flags
\"

Configure Flags on a component. This is available on Properties. Right-click a Property to
view the Config Flags Dialog.

Links
&

Links provide the mechanism to dynamically attach Components. They allow you to attach an
output Property of one Component to an input Property of another Component. The links are
visible in the Property Sheet of the Component. Links show whether they are direct or indirect
and their source Property.

In order to view the Properties of the link, Left-click the + plus sign on the Component to ex-
pand it.

Each link shows the following:

+ Link Type and source

+ Source Ref - This is the linked Component.

+ Source Slot Name - This is the linked Component's property.
+ Target Slot Name - This is the current Component's property.
+ Enabled - This shows whether the link is currently enabled.

See for more information on creating links.

OrdChooser

In order to select an Ord instead of typing it, you can use one of the Ord editors. They include:
+ Bql Builder

+ Directory Ord Chooser

+ File Ord Chooser

+ History Ord Chooser

+ Ref Chooser

Once you have selected an editor, you can use the » button to the right of the selection box. It
will present the selected editor.

workbench:FileOrdChooser

In order to select a file Ord instead of typing it, you can use the FileOrdChooser.

You can select FileSpaces, Bookmarks and directories and files. In addition toolbar functions
are provided including:

Back
&

Back moves back to the previous view.
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Uplevel

&

Uplevel moves up one level in tree.

Home

&

Home moves up one level in tree.

New Folder

&

New Folder creates a new Directory.

ListView

ListView allows you to use the list view.

DetailsView

DetailsView allows you to use the details view.

Bookmarks

You can press the &Bookmarks button to add the selection to Bookmarks.
Show/Hide Preview

&

Show/Hide Preview toggles whether the preview pane is visible.

workbench:DirectoryOrdChooser

In order to select a Directory Ord instead of typing it, you can use the DirectoryOrdChooser.

You can select FileSpaces, Bookmarks and directories. In addition toolbar functions are pro-
vided including:

New Folder
&
New Folder creates a new Directory.

Bookmarks

You can press the Bookmarks button to add the selection to Bookmarks.

workbench:HistoryOrdChooser

In order to select a reference Ord instead of typing it, you can use the HistoryOrdChooser.
You can select items from the tree by type slot or Handle.

workbench:RefChooser

In order to select a reference Ord instead of typing it, you can use the RefChooser.
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You can select items from the tree by type slot or Handle.

workbench:BqlQueryBuilder

In order to select a BQL query instead of typing it, you can use the BqlQueryBuilder.

BQL is one Scheme used to Query in the Niagara Framework. An Ord is made up of one or
more Queries. A Query includes a Scheme and a body. The bql Scheme has a body with one of
the following formats:

+ BQL expression
+ Select projection FROM extent Where predicate
You can create the Ord Qualifier, Select, FROM and Where portions of a Query.

Ord Qualifier

In the left window, you can select an Ord to use as the qualifier. It will immediately be placed
in the BQL statement at the top when you select it.

If you select the history Scheme, your options will vary from those shown here.

workbench:ProjectionBuilder

In order to build the projection for a BQL request instead of typing it, you can use the Projec-
tionBuilder in Bql Builder. You can select an item from the center window to use with the se-
lect statement. Press the =right arrow to add each one to the projection.

Bql Expressions"

An expression can be one of the following:

« field like displayName

o Xyz

+ any method that returns non-void and takes zero parameters

After you build the BQL statement, you can remove the "Select" to provide a BQL expression

instead of a Select statement.

workbench:ExtentBuilder

An extent can be one or more of the following:

« ""all available from the target
+ all property slots
«+ all methods that return non-void and take zero parameters

In order to build the Extent for a BQL request instead of typing it, you can use the ExtentBuild-
er in Bql Builder. You can select the Restrict Type and choose the module and item to use with
the FROM clause. It will immediately appear in the BQL statement at the top.

This also changes the items that are available in the projection.

If you choose a history Scheme, the ExtendBuilder will provide different selections. The extent
for a History typically can be one of the following:

o "from /demo/Float" where demo is the station name

mn

+ "from !Float" where "!" signifies the current station
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workbench:QualifierBuilder

In order to build the Qualifier for a BQL request, you can type it in the QualifierBuilder in Bql
Builder. As you type, it will immediately appear in the BQL statement at the top.

Edit Facets

Edit Facets allows viewing and editing of facets. In order to change facets, you use the » button
to the right of the facets. It will present the Edit Facets dialog box.

From here you can Add, Remove or select the Enum Range Dialog.

Add
Add allows you to add a Key and Type.

Remove

Remove allows you to remove facets.

Enum Range Dialog

In order to view or set the range of values for a Enum, you can use the ». It will present the
Enum Range Dialog:

You can enter one of the standard Enumerations in the field under the Use Enum Type in
Range (module:name).

Press Use Enum Type in Range (module:name) to use the Enumeration that you entered. In
order to enter or change an Enumeration, enter the Ordinal in the field above the Add button.
Next enter the new value for the Tag and press Modify. Press OK to complete the dialog.

workbench-ServiceManager

&

Service Manager allows you to view services. It is available on the ServiceContainer.
workbench-SlotSheet

B The Slot Sheet shows all the user visible slots of the Component.
This includes @Properties, @ Actions, and ©Topics.
The SlotSheet is a Table that shows the following for each slot:

« Slot
. #
+« Name

+ Display Name
+ Definition

+ flags

+ Type

The SlotSheet also optionally shows any Name Maps. The SlotSheet includes the following
menus:

+ SlotSheet Main Menu
+ SlotSheet Component Menu

NiagaraAX User Guide

243



Plugin Guides

May 26, 2016

SlotSheet Main Menu

The main menu functions are available. When the SlotSheet is visible, the following SlotSheet
menu functions are also available:

+ © AddSlot Ctrl + A

+ @ Rename Slot Ctrl + R
+ ¥ Config Flags

+ [E Config Facets

+ & Reorder

+ Add Name Map

SlotSheet Component Menu

If you Right-click any Component in the SlotSheet or the background, you can choose from
the following:

« © AddSlotCtrl + A
o [ CopyCtrl+C
« @ Delete Delete

+ © Rename Slot Ctrl + R
+ ¥ Config Flags
+ [& Config Facets

+ Add Name Map

SlotSheet Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”. When
the SlotSheet is visible, additional toolbar buttons include:

« © AddSlot
+ O Rename Slot
. v

+  Config Flags

+  Reorder

Add Slot

)

Add Slot allows you to add a slot to the Component.
Rename Slot

Rename Slot allows you to rename a slot in the Component.
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Add Name Map

Add Name Map allows you to add a Name Map to the Component. You Right-click on the
Property displayNames to delete or rename Name Map and displayNames_xx to delete or re-
name Name Map (xx) where xx is the Language Code.

Config Facets
&

Configure Facets on the Component. This is available on Properties. Right-click a Property to
view the Config Facets Dialog.

workbench-StationSummary
oy

StationSummary is the default view on a Station. It holds primary components (e.g. Config,
Files, History) and shows specific configuration information about the station’s host platform,
including:

+ Station Name

¢« Host
+ Host Model
« HostId

» Niagara Version
+ Java Version

+ OS Version

+ Locale

¢ Current Time

workbench-Synthetic Module File View

a The Synthetic Module File View is the default view on a @ synthetic module.

This module is available starting in AX-3.7 and later. Refer to the engineering notes document
for details.

workbench-TextFileEditor

O

The TextFileEditor Plugin provides a powerful Color coded text editor. It supports Color cod-
ing of C, java and xml file types. See File Types for more information on Color coding of spe-
cific file types. See Text Editor Options to change editor options including Color coding.

TextFileEditor Menus

The main menu functions are available.

TextFileEditor Toolbar

The toolbar contains navigation and editing buttons as described in “About the toolbar”.
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File Types

The TextFileEditor Plugin provides a powerful Color coded text editor. It supports Color cod-
ing of C, java, properties, Python and xml file types. See Text Editor Options to change
editor options including Color coding.

C Files

The TextFileEditor supports special Color coding for C files including:
+ Preprocessor - #include

+ Line Comment - / comment /

o Multiline Comment - /* comment */

o String literal - "string" and 'string’

o Number literal - '0' and 'F"'

+ Keyword - blue - i f

CSS Files
The TextFileEditor supports special Color coding for CSS files including:

+ Identifier - HTML element or CSS identifier
+ Line Comment - / comment /

+ Multiline Comment - /* comment */

+ String literal - "string" and 'string’

+ Number literal - '0' and 'F'

+ Keyword - blue - i f
HTML Files

The TextFileEditor supports special Color coding for HTML files including:
+ Identifier - HTML element

o Multiline Comment - <! - Comments here —>

+ String literal - "string" and 'string’'

+ Number literal - '0' and 'F''

+ Keyword - blue - i f
Java Files

The TextFileEditor supports special Color coding for Java files including:
e« Bracket- ( { [

o Keyword - if

+ Line Comment - / comment /

o Multiline Comment - /* comment */

+ String literal - "string" and 'string’

o Number literal - '0"' and 'F’
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JavaScript Files

The TextFileEditor supports special Color coding for JavaScript files including:
o Bracket- ( { [

o Keyword - if

+ Line Comment - / comment /

o Multiline Comment - /* comment */

o String literal - "string" and 'string’

o Number literal - '0"' and 'F’

Properties Files

The TextFileEditor supports special Color coding for properties files including:
+ Line Comment - #

« Bracket - =

Python Files

The TextFileEditor supports special Color coding for Python files including:
e Bracket- {} () []

o Keyword - if

+ Line Comment - #

 String literal - "string" and 'string’

o Number literal - '0' and 'F'

Xml Files

The TextFileEditor supports special Color coding for Xml files including:
o Multiline Comment - <!~ comment —>>
o Bracket-<><>

o String literal - "string" and 'string’
workbench-WbPxView

PxView is a dynamic view which may be added to Components as a property. PxViews store
the view contents in a PxFile which is an XML file with a PX extension.

This view is defined as a tree of bajaui:Widgets.

For more information about Px views, refer to the NiagaraAX Graphics Guide sections “About
Px views” and “About the Px Editor menu”. Other related Px information is available in that
document as follows:

o “About Px files”
« “About Px viewer”

« “About Px Editor”

WbPxView Menus

The main menu functions are available. When the Px Viewer is visible, the following menu
functions are also available:
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References

3

PxViewer View Source Xml

PxViewer View Source Xml

You can view the source XML of a PX Page by selecting View Source Xml from the main
menu.

workbench-WbServiceManagerView

&

Workbench Service Manager allows you to view services. It is available from the Tools menu.

In this appendix (introduction)

This appendix contains the following reference information:

.

About keyboard shortcuts

Explains how to use the keyboard to enter menu bar and popup menu commands — without

using the mouse.

Types of menu bar items

Describes the different menu items available from the menu bar. Refer to “About the menu

bar” for an overview of the menu bar.
Types of popup menu items

Describes the popup menus that appear in different views and contexts.

Types of toolbar icons

Describes the types of icons that are in the toolbar. For an overview of the toolbar, refer to

“About the toolbar”.

About keyboard shortcuts

Workbench provides a number of keyboard shortcuts for common actions.

Shortcut actions are performed by holding down the combination of keys listed. They include:

3

.

3

F1 - Help On View

F3 - Console

F4 - Hide Console

F5 - Find

F6 - searchReplace;

F7 - Goto File

F8 - searchConsoleNext
F9 - Save amp; Compile
Alt + Left - Back

Alt + Right - Forward
Alt + Up - Up Level

Alt + Home - Home
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.

Alt + Space - Recent Ords
Ctrl + A - Add Slot

Ctrl + C - Copy

Ctrl + D - Duplicate
Ctrl + F - Find Next
Ctrl + G - Goto Line
Ctrl + L - Open Ord
Ctrl + N - New Window
Ctrl + O - Open File...
Ctrl + P - Print

Ctrl + R - Rename Slot
Ctrl + S - Save

Ctrl + T - New Tab

Ctrl + V - Paste

Ctrl + W - Word Wrap
Ctrl + X - Cut;

Ctrl + Z - Undo

Ctrl + F1 - Find Bajadoc
Ctrl + F4 - Active Plugin
Ctrl + F5 - Find Files
Ctrl + F6 - Replace Files
Ctrl + F9 - Compile

Ctrl + PageUp - Next Tab

Ctrl + PageDown - Previous Tab
Shift + F8 - searchConsolePrev
Ctrl + Shift + F - Find Prev

Ctrl + Alt + Z - Redo

Types of menu bar items

This section describes the menu items that appear in the Workbench menu bar:

.

File menu
See “About the File menu”

Edit menu

See “About the Edit menu”

Search menu

See “About the Search menu”

Bookmarks menu

See “About the Bookmarks menu”
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Tools menu

See “About the Tools menu”

Window menu

See “About the Window menu”

Px Editor menu

See “About the Px Editor menu”

History Ext Manager menu

See “About the History Ext Manager menu”
Help menu

See “About the Help menu”

About the File menu

The File menu in the menu bar has the following options:

The File menu in the menu bar provides the following options:

.

& Open Ord

You may open a ORD by selecting File > Open > Open Ord from the main menu or from
the toolbar open button.

The Ord Chooser also allows you to directly type the Ord of a location in order to go there.
If no view is specified, the default view for the item will be presented. You may also paste
an Ord instead of typing it by pressing the paste shortcut Ctrl + V after you have copied a
node or Ord into the clipboard.

Open File
You may open a file by selecting File > Open > Open File... from the main menu.
© Open Directory

You may open a Directory by selecting File > Open Open Directory... from the main
menu.

% Open Station (Fox)

You may open a Station by selecting File > Open > Open Station (Fox)... from the main
menu. This will cause the following popup window to be presented so that you can com-
plete each field.

Address - This is the address of the computer running the Station that you wish to access.
User name - This is the user name given to you by your system administrator.

Password - This is the password given to you by your system administrator.

Remember these credentials - This will save this connection in your connection list.

Once you successfully connect to the Station, it will appear in the tree and your home page
will be displayed.

If you will be away from the system, you should close the Station to prevent unauthorized
access.

& Open Platform

You may open a Platform by selecting File > Open > Open Platform... from the main
menu. This will cause the following popup window to be presented so that you can com-
plete each field.
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Host - This is the address of the computer running the Platform that you wish to access.
Port - This is the port used.

Password - This is the password given to you by your system administrator.

Remember these credentials - This will save this connection in your connection list.

Once you successfully connect to the Platform, it will appear in the tree and the available
tools will be displayed.

8% Find Stations

You may find Stations by selecting File > Open > Find Stations... from the main menu.
This command finds all the stations running on the network. It will search for 5 seconds,
then display a Table of all the stations found. You may display additional columns about
each station using the options button (on the right of the header). Double-click a Station to
open a Fox connection to it.

= Back
Back allows you to go to the previous view. The shortcut is Alt + Left.
= Forward

Forward allows you to go to the next view. You must have used the Back command previ-
ously. The shortcut is Alt + Right.

& Up Level

Up Level allows you to go to the next level up. The shortcut is Alt + Up.
E Save

Saves the value of the Component.

[ Save Bog

Save the Component changes to the Bog File file.

& Save All

Save all open views. This saves all Tabs when browsing with multiple Tabs.
& Recent Ords

Recent Ords allows you to see recent Ords. The shortcut is Alt + Space.
Refresh

Refresh allows you to refresh the current view.

fr Home

Home allows you to go to the home view. The shortcut is Alt + Home.
& Printing

Printing provides the capability to print the current view. When it appears dimmed, print-
ing is not available.

= Export

Export provides the capability to Export the current view. When it appears dimmed, Ex-
port is not available.

Logging off the System

You may exit the system by a number of means. You may Close the session, Close All ses-
sions, Exit, or Close the current window. Each of these causes different actions and should
be understood.

Close Session
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You may logoff the Station at any time by selecting File > Close from the main menu.

Once you successfully close a session, it will be removed from the tree. This could leave a
user interface running without an open session.

+ Disconnect

You may logoff the system at any time by Right-clicking the connected system in the tree
and select Disconnect. This allows you to close a session with a Station without removing
it from the tree.

+ Dismiss

You may logoff a connected system at any time by Right-clicking the connected system in
the tree and select Dismiss. This allows you to close a session with a Station and remove it
from the tree.

+ Exiting the System

You may exit the system at any time by selecting File > Exit from the main menu. This dif-
fers from logoff in that it also causes the user interface to stop.

« Close the Current Window

You may close the current window at any time, if it is not the primary window, by any of
the following methods:

+ selecting File > Close from the main menu
+ pressing the box in the top left corner and selecting Close from the menu
+ pressing the Xl close icon in the top right corner of the window

+ New Window

New Window requests that a new window be created identical to the current one. This al-
lows you to view multiple views concurrently.

« [ New Tab

New Tab requests that a new tab be created identical to the current one. This allows you
to view multiple views in the same Window. You can hold down the Ctrl key during a Dou-
ble-click to hyperlink into a new tab. You can also Right-click to get a popup menu on tabs
to close the tab, or close all other tabs.

. Close Tab
Close Tab requests that a tab be closed.
+ Close Other Tabs
Close Other Tabs requests that all other tabs be closed.
o Next Tab
Next Tab selects the next tab. The shortcut is Ctrl + PageUp.
+ Previous Tab

Previous Tab selects the previous tab. The shortcut is Ctrl + PageDown.

About the Edit menu

+ oo Cut
Cut copies the current Selection to the clipboard and changes its Color to gray until a Paste
is performed to delete it. If the Selection is a string, Cut makes a Copy of the current text

selection and places it in the clipboard and removes it from the current string. It is may be
accessed by selecting an item and:
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.

+ Right-clicking the item(s) and choosing Cut.

+ Right-click in the tree and choosing Cut.

+ In the Wire Sheet press the #a Cut toolbar icon.

o Inthe Wire Sheet select Edit > Cut from the main menu.

+ pressing the shortcut key Ctrl + X (hold down Ctrl and press X) when in a window oth-
er than the main browser window.

You can use Drag to Cut and Paste in one operation.
@ Copy

Copy copies the current contents of the clipboard to the destination component as a set of
new dynamic properties. If the Selection is a string, Copy makes a copy of the current text
Selection and places it in the clipboard. To Copy a Component, do any of the following:

+ Right-click a Component in a view or tree and choose Copy
+ Right-click the background in the Wire Sheet choosing Copy
+ Inthe Wire Sheet press the T3 Copy toolbar button.

+ Inthe Wire Sheet select Edit > Copy from the main menu

+ pressing the shortcut key Ctrl + C (hold down Ctrl and press C) when in a window other
than the main browser window.

You can copy a selected group of Components in the Wire Sheet.
You can use Drag to Copy also.

In order to Copy a Component, you must Copy it from the Palette or an existing Data-
base. You can follow one the following steps:

+ In the Palette Sidebar, expand a module (like control) and sub-directory (like Points),
Right-click on a Component (like BooleanWritable) and select Copy.

+ In the namespaces sidebar (tree), expand System, Modules, a module (like control),
Files, module.palette, and sub-directory (like Points), Right-click on a Component (like
BooleanWritable) and select Copy.

+ OR Right-click on a Component that you want to Copy from a Wire Sheet, Property
Sheet or the tree and select Copy.

[® Paste

Paste copies the contents of the clipboard to the destination Component as a set of new dy-
namic properties. If the target is a string, Paste places a reference to the source that was cut
or copied into clipboard. It may be accessed by cutting or copying item(s) and:

+ Right-clicking the item and choosing Paste

» Right-click in the tree and choosing Paste

+ Inthe Wire Sheet press the Paste toolbar icon.

+ Inthe Wire Sheet select Edit > Paste from the main menu

+ pressing the shortcut key Ctrl + V (hold down Ctrl and press V) when in a window oth-
er than the main browser window.

You can use Drag to Cut and Paste in one operation.

You can add a Component to a running Station or an offline Bog File file. You can do
this using any of the following:

+ Inthe Wire Sheet, Right-click on the background and select Paste to add the new Com-
ponent. The new Component is created and is selected.
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+ In the tree, Right-click on a Container and select Paste to add the new Component in-
side the Container.

See the Bajadoc Index for reference information. If you select Help > Guide On Target
with a Component selected, you will get the Guide for that Component. If you select
Help > Bajadoc On Target with a Component selected, you will get the bajadoc for
that Component. The BooleanWritable bajadoc is at module://control/doc/javax/baja/
control/BBooleanWTritable.bajadoc.

[ Paste Special

Paste Special copies the contents of the clipboard to the destination Component when it is
a Special Transferable.

[ Duplicate

Duplicate copies the current Selection and places a duplicate in the same Container. This
function may be access from the menu under Edit (shortcut Ctrl + D) or from the toolbar.

@ Delete

Delete removes the current Selection from its parent Container. It may be accessed by se-
lecting an item and:

+ Right-clicking the item(s) and choosing Delete

+ Right-click in the tree and choosing Delete

+ Inthe Wire Sheet press the @ Delete toolbar button.

+ Inthe Wire Sheet select Edit > Delete from the main menu
> Undo

This reverses the last Action as if it had not been performed. It is only available for certain
actions such as:

+ DPaste Component
+ Cut Component

o link

o Delete Links

© Redo

This restores an Action after Undo has removed it. It is only available after a successful
Undo.

About the Search menu

The Search menu in the menu bar has the following options:

.

8% Find

Find allows you to search in the file for the selected string. You can Match Case or Match
Word. The shortcut is F5.

= Find Next

Find Next allows you to find the next occurrence of the selected string. The shortcut is Ctrl
+ F (hold down Ctrl and press F).

<& Find Prev

Find Prev allows you to find the previous occurrence of the selected string. The shortcut is
Ctrl + Shift + F (hold down Ctrl and Shift and press F).

# Replace
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016

Replace allows you to replace the next occurrence in the file. The shortcut is Ctrl + R (hold

down Ctrl and press R).

+ Goto Line

Goto Line allows you to go to a line number in the file. The shortcut is Ctrl + G (hold down

Ctrl and press G).
. Goto File

Goto File allows you to go to a file. The shortcut is Ctrl + F3 (hold down Ctrl and press
F3).

« B& Find Files

Find In Files allows you to find the all occurrences of a string in files. You can Match Case

or Match Word. You can choose Files to Find. You can select a Folder. You can choose
whether to Search subfolders.

» 8 Replace Files

Replace Files allows you to replace the all occurrences in the files.
+ % Console Prev

Console Prev allows you to go to the previous console error. The shortcut is F7.
« b Console Next

Console Next allows you to go to the next console error. The shortcut is F8.

About the Bookmarks menu

The Bookmarks menu in the menu bar has the following options:
+ AddTo Bookmarks

You may add a Bookmark by selecting Bookmarks > Add to Bookmarks from the main
menu.

+ Manage Bookmarks

You may manage Bookmarks by selecting Bookmarks > Manage Bookmarks from the
main menu.

+ Bookmarks Go Into
You may select Bookmarks by selecting Bookmarks > Go Into from the main menu.
+ Bookmarks File

You may select Bookmarks by selecting Bookmarks > File from the main menu.

About the Tools menu

The Tools menu in the menu bar has the following options:
+ Viewing and Changing the Options

The Options allow you to customize the framework for the way you use it. It can be se-
lected from the main Menu by selecting Tools > Options. It includes the following:

+ General
+ Lexicon
+ Text Editor
+  Wire sheet

+ ColorChooser
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The ColorChooser allows you to choose Colors.
+ New Module Wizard

@ The New Module Wizard allows you to build a new Module. It can be selected from the
main Menu by selecting Tools > New Module.

« New Station Wizard

The New Station Wizard allows you to build a new station Database. It can be selected
from the main Menu by selecting Tools > New Station.

You must enter a Station Name. You can also choose whether this is a Controller Station
or a Supervisor Station. Press = Next to proceed. Next you should enter an Admin Pass-
word. You can also change the Fox Port and HTTP Port. Press » Finish to proceed. You
are then presented a view of your newly created Station at local:|file:!stations/stationname/
config.bog|bog:|slot:/.

+ Manage Credentials

.

Manage Credentials is available in the main Tools menu by selecting Manage Creden-
tials.... You can Reset or Remove selected Credentials or Remove All Credentials. You can
also Open selected Credentials.

+ Request License
Request License is available in the main Tools menu by selecting Request License.... You

can request a license by submitting the form.

About the Window menu

The Window menu in the menu bar has the following options:
+ Side Bars
+ v Show Side Bar

You can choose whether to have Side Bars by selecting Window > Side Bars > Show
Side Bar from the main menu.

For more information about the side bar refer to “About the side bar panes”.
+ Bookmarks

You can choose to show the Bookmarks Side Bar by selecting Window > Side Bars >
Bookmarks from the main menu.

For more information about the Bookmarks side bar refer to “About the bookmark side
bar”.

« ? Help Sidebar

The typical configuration provides a Help Sidebar frame in the left side of the main
window. If it is not open, you can choose to display the Help Side Bar by selecting Win-
dow > Side Bars > Help from the main menu.

Initially, the Help Sidebar is empty until you press Load Help.

Load Help will reappear any time any Module's timestamp is changed or a new Module
is added or removed. Load Help searches through all the available Modules to create
the help Directory. The Help Sidebar provides a view of the available Help.

For more information about the Help Sidebar refer to “About the help side bar”.
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« % Jobs Sidebar

The Jobs SideBar shows all the current jobs in all the stations with which you have a
connection. Controls are provided to allow you to view a job log or dismiss a completed
job.

For more information about the Jobs side bar refer to “About the jobs side bar”.
+ Nav

You can choose to show the Nav side bar by selecting Window > Side Bars > Nav from
the main menu.

For more information about the Nav side bar refer to “About the nav side bar”.
» DPalette

You can choose to show the Palette Side Bar by selecting Window > Side Bars > Pa-
lette from the main menu.

For more information about the Palette side bar refer to “About the palette side bar”.
PathBar Uses NavFile

You can toggle this option ON or OFF by selecting Window > Side Bars > PathBar Uses
NavFile. When ON, the PathBar (located at the top of the main window) displays your cur-
rent path, as defined by the NavFile (logical path). When OFF (not selected) the PathBar
displays your absolute path regardless of whether it is mapped to the NavFile or not. You
must refresh the view after changing this setting in order to see the PathBar change.

Active Plugin

The Active Plugin function gives focus to the current view. From the main menu you can
select Window > Active Plugin or use the shortcut Ctrl + F4. It is very useful to use F3/
Ctrl + F4 to toggle between the Console and the Text File Editor.

Hide Console

You can hide the console by selecting Window > Hide Console from the main menu or us-
ing the shortcut Ctrl + F2.

Console

The Console provides the capability to issue console commands directly. From the main
menu you can select Window and Console (F3) or Hide Console (F4) to determine if the
console is visible.

Refer to “Types of console commands”6 for information about console commands.

About the Px Editor menu

The Px Editor menu appears in the menu bar when Px Editor is the active view. The Px Editor
has the following context—sensitive options:

.

Toggle View/Edit Mode

This command toggles the active view between Px Editor (for editing) and Px View (view
only). If there are unsaved changes in your Px file, you are prompted to save before switch-
ing from Px Editor to Px View.

View Source Xml
Selecting this command displays the Px source file in a separate read—only window.
Go to Source Xml

Selecting this opens the Px source (xml) file directly in the text file editor. Files can be
edited and saved using the editor.

Grid
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This command toggles the grid display on and off.

Snap

This command toggles the snap—to—grid feature on and off.
Show Hatch

This command toggles the hatching pattern visibility on and off. When hatching is on, dim
angular lines (hatching pattern) displays on objects to make them more visibly distinct.

Set Target Media

This command is available when you are editing a Px file directly in the Px Editor—not when
you are editing the Px file as a view of a component. When selected, this command displays
the Set Target Media dialog box to allow you to choose your expected media viewer
(HTML Px Media or Workbench Px Media). See “About presentation media” for more de-
tails about media types.

About the History Ext Manager menu

The History Ext Manager menu appears in the menu bar when History Extension Manager is
the active view. The History Ext Manager menu has the following options:

3

.

* Enable Collection

Select this menu item to enable (start the collection process) for the selected entries.
= Disable Collection

Select this menu item to disable (stop the collection process) for the selected entries.
= Rename History

Select this menu item to rename the selected history. This menu item displays the Set His-
tory Name dialog box.

# Edit System Tags

Select this menu item to open the Set System Tags For Selected History Extensions dia-
log box. Use this dialog box to edit system tags associated with a single history extension or
perform batch edits when you have more than one history extension selected.

About the Help menu

The Help menu in the menu bar has the following options:

.

? Help Contents Index

The help contents provides a common point of access to all system documentation. It is ac-
cessed by selecting Help > Contents Index from the menu or pressing the 2 Help button
on the toolbar to see the Help Index.

Help On View

This provides help for the current Plugin. It is accessed by selecting Help > On View from
the menu with the Plugin in use.

@ Help Guide On Target

This provides context sensitive help for Components. It is accessed by selecting Help >
Guide On Target from the menu when the current view is a view of a Component. It is also
available by Right-clicking a Component and choosing Views > Guide Help.

© Help Bajadoc On Target

This provides context sensitive Bajadoc help for Components. It is accessed by selecting
Help > Bajadoc On Target from the menu when the current view is a view of a
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Component. It is also available by Right-clicking a Component and choosing Views > Baja-
doc Help.

88 Help Find Bajadoc

This is accessed by selecting Help > Find Bajadoc from the menu. It searches for the re-
quested bajadoc.

#& Help About

This is accessed by selecting Help > About from the menu. It provides the software release
and license information.

Types of popup menu items

Workbench provides view—specific, or context—specific commands for editing components in
many of the views. Following, is a list of the standard popup (right—click) menus.

.

Nav side bar

For descriptions of the popup menu items that are available in the nav side bar refer to
“About the nav side bar popup menu items”.

Wire sheet

For descriptions of the wire sheet popup menu items, refer to “About the wire sheet popup
menu items”.

Property sheet

For descriptions of the property sheet popup menu items, refer to “About the property
sheet popup menu items”..

Px Editor

For descriptions of the Px Editor popup menu items, refer to “About the Px Editor popup
menu items”..

History extension manager

For descriptions of the History extension manager popup menu items, refer to “About the
history extension manager popup menu items”..

Todo list

For descriptions of the Todo list popup menu items, refer to “About the Todo list popup
menu items”..

Point Manager

For descriptions of the Point Manager popup menu items, refer to “About the point manag-
er popup menu items”.

About the nav side bar popup menu items

i

The nav sidebar provides a tree—type hierarchical view of the system. For an overview of the
nav side bar, refer to “About the nav side bar”.

The nav side bar menu is the popup menu that displays command options when you right—
click on a component item in the nav side bar. The nav side bar menu has the following
options:

.

Views

Goes to any of the views of the selected component.
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Actions

Perform any available actions on the component.
New

Create a new item of standard types.

se Cut

See “Types of edit commands”.

[ Copy

See “Types of edit commands”.

[ Paste

See “Types of edit commands”.

[ Duplicate

See “Types of edit commands”.

@ Delete

See “Types of edit commands”.

2@ Find

This menu item displays the Component Finder dialog box.
Link Mark

This menu item sets a selected point to your popup menu, making it temporarily available
for “Linking From” or Linking To” other points.

Link From

This menu item allows you to link a selected point to another point that has been marked,
using Link Mark from the popup menu.

Link To

This menu item allows you to link a selected point to another point that has been marked,
using Link Mark from the popup menu.

™ Rename

Select this menu item to rename the selected point. This menu item displays the Set Point
Name dialog box. You can only rename one point at a time.

£! Reorder

This menu item displays the Reorder Points dialog box, which provides the following com-
mands for reordering points within the selected parent component.

+ Move Up

+ Move Down

+ Sort by Name

+ Sort by Type

+ Reset

Composite

This menu item displays the Composite Editor dialog box.
Refresh

This menu item updates the display of the currently active view.
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« % Golnto

Go Into allows you to re-root the nav tree at any arbitrary node. Right-click the node and
select the "Go Into" command. This will make that node the new root of the tree. All the
nodes you have "gone into" are persistently saved as a special type of Bookmark. Use the
pulldown to switch between them. This feature is quite handy when working with multiple
Stations or deep File systems and Databases.

About the wire sheet popup menu items

Most of the wire sheet menu commands are described in “About the nav side bar popup menu
items”. Following are wire sheet specific popup menu options:

+ Arrange

Provides options for aligning components on the wire sheet in order to make them easier to
view:

+ Arrange All
Redistributes the layout of all components on the wire sheet.
+ Arrange Selection
Redistributes the layout of all selected components on the wire sheet.
o Selectall

Selects all components on the active wire sheet.

About the property sheet popup menu items

Most of the property sheet menu commands are described in “About the nav side bar popup
menu items”. Following are wire sheet specific popup menu options:

+ Config flags
Opens the Config dialog box which you can use to add configuration flags on individual

slots.

About the Px Editor popup menu items

The Px Editor popup menu displays when you right-click on an object in the Px Editor view.
The menu commands are dimmed or available, depending on the type of object that you select.

The following menu commands are on the Px Editor popup menu:
+ New (refer to “About the Edit menu”)

+ e Cut Ctrl + X (refer to “About the Edit menu”)

+ [ Copy Ctrl + C (refer to “About the Edit menu”)

+ [® Paste Ctrl + V (refer to “About the Edit menu”)

+ [ Duplicate Ctrl + D (refer to “About the Edit menu”)

+ @ Delete Delete (refer to “About the Edit menu”)

. Edit Properties... (refer to “About the properties side bar”)

4,

+ [E Align > Left
This command is available when you select two or more objects in the Px Editor. Choose
the Left command to align the left edges of two or more objects along a vertical line.

=

. = Align > Right
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This command is available when you select two or more objects in the Px Editor. Choose
the Right command to align the right edges of two or more objects along a vertical line.

MW Align > Top

This command is available when you select two or more objects in the Px Editor. Choose
the Top command to align the top edges of two or more objects along a horizontal line.

i Align > Bottom

This command is available when you select two or more objects in the Px Editor. Choose
the Bottom command to align the bottom edges of two or more objects along a horizontal
line.

% Reorder > To Top

This command is available when you select one or more objects in the Px Editor. Choose
the To Top command to move the selected object to the top position (inside its parent ob-
ject) in the Widget Tree. This command will place the object in front (with respect to the
view pane, or z-axis) of all other objects in the parent object, but will not move the object
out of its parent object.

Reorder > Up

This command is available when you select one or more objects in the Px Editor. Choose

the Up command to move the selected object one position higher in the Widget Tree and
forward one position in the view pane. This command will not move the object out of its

parent object.

Reorder > Down

This command is available when you select one or more objects in the Px Editor. Choose
the Down command to move the selected object one position lower in the Widget Tree and
back one position in the view pane. This command will not move the object out of its pa-
rent object.

% Reorder > To Bottom

This command is available when you select one or more objects in the Px Editor. Choose
the To Bottom command to move the selected object to the bottom position (inside its pa-
rent object) in the Widget Tree. This command will place the object behind (with respect
to the view pane, or z-axis) all other objects in the parent object, but will not move the ob-
ject out of its parent object.

Border > Add Border

This command is available when you select one or more objects in the Px Editor. Choose
the Add Border command to wrap selected object(s) with a border pane. Each selection is
wrapped in a separate border pane.

Border > Remove Border

This command is available when you select one or more border panes in the Px Editor.
Choose the Remove Border command to delete selected border pane(s).

About the history extension manager popup menu items

The history extension manager popup menu has the following items:

.

.

Views

This menu item provides a submenu that lists all the available views of the history extension
manager.

Actions > Update History Id

This menu item provides a way to refresh the History Id after a rename. It applies the for-
matting property (as designated by the enclosing % signs) of the Name Format field to the
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Id of the History Config Id. For example, if the History Name property under a history ex-
tension is set to $parent . name%, then the History Config Id is initially named based on
this parent display name. However, if you rename the parent component, the History Con-
fig Id property does not automatically or immediately change. The Update History Id action
invokes a renaming of the History Config Id based on the formatting property, so if the pa-
rent component (in this example case) is changed, the the Update History Id action changes
the Id property and, if different from the history name, it results in a change in the history
name as well. See “About history names” for more information about history naming.

+ Go To Point

This menu item displays the property sheet view of the point associated with the selected
entry.

+ Go To History
This menu item displays the default view of the history associated with the selected entry.
+ ' Enable Collection
Select this menu item to enable (start the collection process) for the selected entries.
+ ® Disable Collection
Select this menu item to disable (stop the collection process) for the selected entries.
+ @ Rename History

Select this menu item to rename the selected history. This menu item displays the Set His-
tory Name dialog box. You can only rename one history at a time.

+ [ Edit System Tags

Select this menu item to open the Set System Tags For Selected History Extensions dia-
log box. Use this dialog box to edit system tags associated with a single history extension or
perform batch edits when you have more than one history extension selected.

Refer to “About the History Ext Manager menu” for information about the History Ext Manag-
er menu. Refer to “About the history extension manager view” for general information about
the history extension manager view.

About the Todo list popup menu items

The Todo list popup menu has the following items:
+ © Add

This menu item opens the Add dialog box, when clicked. Use this menu item to add a new
item to your Todo checklist and assign a Summary and Group to the item. This menu item
is available even if no items are selected.

+ v Mark Complete

This menu item, when clicked, dims and lines-through the selected item(s) in the Todo list
so that the item(s) appears to be “crossed off” the list. If an item is already marked complete
and this menu item is selected, the item will be restored to its “unmarked” state. With no
items selected, this menu item is dimmed (unavailable).

o = Edit

Displays the Edit dialog box, when clicked, allowing you to change the Summary and the
Group fields associated with the item.

« = Moveto Top
Moves the selected item to the top of the list.
« * Move Up
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Moves the selected item up in the list, one increment per click.

~ Move Down

Moves the selected item down in the list, one increment per click.
= Move to Bottom

Moves the selected item to the bottom of the list.

© Remove

Displays a “Remove selected items?” prompt, when clicked; deletes selected items when the
prompt is affirmed.

Refer to “Todo List” for general information about the Todo list view.

About the point manager popup menu items

The point manager popup menu has the following items:

.

Views

This menu item provides a submenu that lists all the available views of the point manager.
These same views are available from the view selector menu (see “About the view selector”)
when the point extension manager is the active view.

Actions

This menu item allows you to perform any available actions on the component. For exam-
ple, write to a “writable” point.

New

This menu item allows you to add a new component to the points manager. Valid options
are presented in the submenu.

Cut

See “Types of edit commands”.
Copy

See “Types of edit commands”.
Paste

See “Types of edit commands”.
Duplicate

See “Types of edit commands”.
Delete

See “Types of edit commands”.
Find

This menu item displays the Component Finder dialog box.
Link Mark

This menu item sets a selected point to your popup menu, making it temporarily available
for “Linking From” or Linking To” other points.

Link From

This menu item allows you to link a selected point to another point that has been marked,
using Link Mark from the popup menu.

Link To
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This menu item allows you to link a selected point to another point that has been marked,
using Link Mark from the popup menu.

+ Rename

Select this menu item to rename the selected point. This menu item displays the Set Point
Name dialog box. You can only rename one point at a time.

+ Reorder

This menu item displays the Reorder Points dialog box, which provides the following com-
mands for reordering points within the selected parent component.

+ Move Up

+ Move Down

+ Sort by Name

+ Sort by Type

+ Reset
+ Composite

This menu item displays the Composite Editor dialog box.
+ New Folder

This menu item allows you to add and name a new points folder.
+ New

This menu item allows you to add and name a new point.
. Edit

This menu item displays the Point Editor dialog box.

Types of edit commands

In addition to view—specific editing tools, Workbench provides commands for editing compo-
nents in many of the views.

Following, is a list of descriptions of the standard commands that are available in Workbench
views for editing components.

o Drag

Dragging files or components only works within a single Workbench application. However,
it is possible to drag files from Windows Explorer into Workbench to see the default view.
Dragging a component or file using the left mouse button performs a Copy operation.
Dragging a component or file using the right mouse button always prompts you for a Copy,
Move, or Cancel command selection.

+ Cut

Use the Cut command to delete the selected object and send it to the clipboard.
+ Copy

Use the Copy to send the selected object to the clipboard without deleting it.
+ Paste

Use the Paste command to copy the current contents of the clipboard to the destination as
a set of new dynamic properties.

+ Duplicate
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Use duplicate to create a copy of the current selection in the same container as the
selection.

Delete
Use the Delete command to remove a selected item from its parent container.
Undo

Use the Undo command to reverse the previous command. Undo is only available for cer-
tain commands, such as, Paste, Cut, Delete, and the Link action.

Redo

Use the Redo command to restore a command-—action after the Undo command has re-
moved it.

Rename

Use Rename to change the name of a Component.

Types of toolbar icons

For an overview of the Workbench toolbar, refer to “About the toolbar”.

Some icons are always visible as you navigate through the system. Additional icons may be
added and removed from view when different views are active. When icons appear dimmed,
their functions are unavailable. Icons that appear on the toolbar are grouped in the following
categories:

3

Standard toolbar icons

These icons may be dimmed (or unavailable in certain views) but they are always present
on the toolbar. Refer to “Standard toolbar icons” for the listing of Standard toolbar icons.

Slot sheet toolbar icons

These icons appear only when the Slot Sheet is active. Refer to “Slot Sheet toolbar icons”
for the listing of Slot Sheet toolbar icons.

Px Editor toolbar icons

These icons appear only when the Px Editor or Px Viewer is active. Refer to “Px Editor tool-
bar icons” for the listing of Px Editor toolbar icons.

History extension manager toolbar icons

These icons appear when the History Editor view is active. Refer to “About the history ex-
tension manager toolbar icons” for the listing of History Editor toolbar icons.

History Editor toolbar icons

These icons appear when the History Editor view is active. Refer to “About the history edi-
tor toolbar icons” for the listing of History Editor toolbar icons.

Todo list toolbar icons

These icons appear when the Todo list view is active. Refer to “About the Todo list toolbar
icons” for the listing of Todo list toolbar icons.

Standard toolbar icons

For an overview description of the toolbar, refer to “About the toolbar”. Following are the icons
that appear in all views:

3

.

<= Back. See “Back” for details about the Back function.

= Forward. See “Forward” for details about the Forward function.

266

NiagaraAX User Guide



Plugin Guides

May 26, 2016

.

B BB B &

& b @I W

@ 5 B 2

5

(%]

Up Level. See “Up Level” for details about the Up Level function.

Recent Ords. See “Recent Ords” for details about the Recent Ords function.

Home. See “Home” for details about the Home function.

Refresh. See “Refresh” for details about the Refresh function.

Left Side Bar. See “Side Bars” for details about the Side Bars function.
Open. See “About the File menu” for details about all the Open functions.
Save Ctrl + S. See “Save” for details on the Save function.

Save Bog. See “Save Bog” for details on the Save Bog function.

Printing Ctrl + P. See “Printing” for details on the Printing function.

Cut Ctrl + X. See “Cut” for details on the Cut function.

Copy Ctrl + C. See “Copy” for details on the Copy function.

Paste Ctrl + V. See “Paste” for details on the Paste function.

Duplicate Ctrl + D. See “Duplicate” for details on the Duplicate function.
Delete Delete. See “Delete” for details on the Delete function.

Undo Ctrl + Z. See “Undo” for details on the Undo function.

Redo Ctrl + Alt + Z. See “Redo” for details on the Printing function.

Slot Sheet toolbar icons

For an overview description of the toolbar, refer to “About the toolbar”. Following are the icons
that appear when the Slot Sheet view is active:

3

.

©

Add Slot

Creates a new slot (appearing as a row) on the slot sheet.

uJ Rename Slot

Displays the Rename Slot dialog box, when clicked. This icon is dimmed when no slot, or
more than one slot is selected in the slot sheet editor view.

\"

Config Flags

Displays the Config Flags dialog box, when clicked. This icon is dimmed unless one or
more slots are selected in the slot sheet editor view.

=+
=

Reorder

Displays the Reorder dialog box, when clicked.

Px Editor toolbar icons

For an overview description of the toolbar, refer to “About the toolbar”. Following are the icons
that appear when the Px Editor is the active view:

.

.

e

Toggle View/Edit Mode.

Displays, alternately, the Px Editor or the Px Viewer in the view pane. This icon appears in-
set when the Px Editor view is active and it appears normal when the Px Viewer is active.

See the NiagaraAX Graphics Guide section “About Px views” for more details about the Px
Editor and Px Viewer.

I Right (Px Editor) side bar menu
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Displays a dropdown menu of side bar options for the Px Editor. The following options are
available:

+ Bound Ords
Shows or hides the Bound Ords side bar (refer to “About the bound ords side bar”).
+  Widget Tree
Shows or hides the Widget Tree side bar (refer to “About the widget tree side bar”).
+ Properties
Shows or hides the Properties side bar (refer to “About the properties side bar”).
& Left align
Aligns left edges of selected objects along a vertical line.
2 Right align.
Aligns right edges of selected objects along a vertical line.
MW Top align
Aligns top edges of selected objects along a horizontal line.
il Bottom align
Aligns bottom edges of selected objects along a horizontal line.
& To Top
Moves selected objects to the highest position (with regard to z-order) in the parent object.
% To Bottom
Moves selected objects to the lowest position (with regard to z-order) in the parent object.
& Select
Activates the pointer tool used to select objects in the Px Editor view using the mouse.
Add Polygon
Activates the polygon tool for drawing polygons.
Add Path
Activates the path tool that allows you to draw bezier curves in the Px Editor view.
© Add Point

Activates the Add Point tool that allows you to add a point to a path or a polygon in the Px
Editor view.

Delete Point

Activates the Delete Point tool that allows you to remove a point from a path or a polygon
in the Px Editor view.

About the history extension manager toolbar icons

The Workbench toolbar contains navigation and editing buttons as described in About the
toolbar.

For an overview description of the history editor view, refer to “About the history extension
manager view”. Following, are the icons that appear when the history extension manager view
is active:

» HistoryExtManager Enable Collection

Click this icon to enable (start the collection process) for the selected entries.
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3

3

® HistoryExtManager Disable Collection
Click this icon to disable (stop the collection process) for the selected entries.
= HistoryExtManager Rename History

Click this icon to rename the selected history. When clicked, the Set History Name dialog
box appears.

5 HistoryExtManager Edit System Tags

Click this icon to open the Set System Tags For Selected History Extensions dialog box.
Use this dialog box to edit system tags associated with a single history extension or perform
batch edits when you have more than one history extension selected.

About the history editor toolbar icons

For an overview description of the history editor view, refer to “About the history editor view”.
Following are the icons that appear when the history editor view is active:

.

.

# Hide

With one or more records selected, this icon is available to set the trend flag of all selected
records to “hidden”. With no records selected, the icon is dimmed (unavailable).

& Unhide

With one or more records selected, this icon is available to set the trend flag of all selected
records to “hidden”. With no records selected, the icon is dimmed (unavailable).

¥ Filter

Displays the Configure Flags dialog box, when clicked. This icon is available even if no re-
cords are selected.

A Configure Outliers

Displays the Configure Outliers dialog box, when clicked.

About the Todo list toolbar icons

For an overview description of the Todo list view, refer to “Todo List”. Following are the icons
that appear when the Todo list view is active:

3

9 Add

This icon opens the Add dialog box, when clicked. Use this icon to add a new item to your
Todo checklist and assign a Summary and Group to the item. This icon is available even if
no items are selected.

» Mark Complete

This icon, when clicked, dims and lines-through the selected item(s) in the Todo list so that
the item(s) appears to be “crossed off” the list. If the item is already marked as completed
and this icon is selected, the item will be restored to its “unmarked” state. With no items se-
lected, this toolbar icon is dimmed (unavailable).

# Edit

Displays the Edit dialog box, when clicked, allowing you to change the Summary and the
Group fields associated with the item.

= Move to Top
Moves the selected item to the top of the list.
~ Move Up

Moves the selected item up in the list, one increment per click.
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~ Move Down

Moves the selected item down in the list, one increment per click.
= Move to Bottom

Moves the selected item to the bottom of the list.

© Remove

Displays a “Remove selected items?” prompt, when clicked; deletes selected items when the
prompt is affirmed.

Types of console commands

The following sections provide descriptions of how to use the Workbench console in terms of:

The following types of commands may be typed in from the Workbench console.

.

Niagara shell commands

These commands are used at the command line and may be typed in directly. See “Niagara
shell commands”:

nre commands

These commands are used at the command line and may be typed in using the “nre” prefix.
See “nre (station) commands”.

wb commands

These commands are used at the command line and may be typed in using the “wb” prefix.
See “wb (Workbench) commands”.

plat commands

These commands are used at the command line and may be typed in using the “plat” prefix.
See “plat (platform) commands”:

Niagara shell commands

.

cd

This command displays and changes the current directory. Type cd <directory name> to
change to a specific directory. Type cd to display the current directory.

debug

This command turns debug tracing on and off. Type debug on to turn on debug. Type de-
bug off to turn off debug.

print

This command prints a message to the output stream. Type print <message> to print the
literal message to the console.

reset

This command resets the environment to its default state. Type reset to set the environ-
ment to its default state.

set
This command displays and modifies environment variables.
+ Type to set to display all the environment variables.

+ Type set <prefix> to display all the environment variables that start with the specified
prefix.
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+ Type to set <name>= to remove the “named” variable.
+ Type to set <name>=<value> to set the “named” variable to the “value” specified.
+ which
This command resolves a filename in a path. Type to which <filename> to find the first oc-

currence of the specified “filename”.

nre (station) commands

Use the following syntax with the nre command:
nre [options] <class> [args]*
The following parameters may be used with the nre command.
o class
This is a class name or a module:classname to execute.
o args
This is the name of one or more arguments to pass through to main.
The following options may be used with the nre command.
e -version
This option displays the nre version.
+ -modules:<x>
This option displays the modules that match the pattern defined by “x”.
+ -hosted
This option displays the id for the system host.
+ -licenses
This option displays a summary of the license information.
e -props
This option displays a list of the system properties.
o -locale:<x>

This option allows you to set the default locale. For example, to set the default locale to US
English, type: -locale:en_US

+ -@option

This option allows you to pass the specified option to the Java VM.
o -testheap

This option tests and displays the max heap size.
o -buildreg

This option causes a rebuild of the registry.

wb (Workbench) commands

The wb command starts up an instance of Workbench. Use the following syntax with the wb
command:

wb [options] <ord>

The following parameter may be used with the wb command.
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ORD

This option specifies the ORD of the initial view that you want display when Workbench
starts up.

The following options may be used with the wb command.

3

-profile

This option specifies the workbench profile to assign when Workbench starts up.
-file:ord

This option specifies the initial file to display when Workbench starts up.
-locale<x>

This option sets the locale on startup.

-@<option>

This options allows you to pass the specified option to the Java VM.

plat (platform) commands

Use the following syntax with the plat command:

plat <command> <flags> <command-flags>

The following commands may be used with plat.

3

details

This command displays a configuration summary for a remote host.

fget

This command gets one or more files from a remote host.

flist

This command provides file details for a single file, or for all files in a directory.
ipconfig

This command displays the TCP/IP configuration for a remote host.

jacejar

This command creates module files that can be run on embedded hosts.
liststations

This command lists stations that are managed by the Niagara platform daemon.
moduleinstall

This command installs modules to a remote host.

reboothost

This command requests that a remote Niagara platform daemon reboot its host.
script

This command runs one or more platform commands in a script.

startstation

This command requests that a Niagara platform daemon start a station.
stopstation

This command requests that a Niagara platform daemon stop a station.
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tellstation

This command sends text to the console of a running station.
watchstation

This command monitors the output of a station.
installdaemon

This command installs the platform service (Win32 only).
uninstalldaemon

This command removes the Niagara platform service (Win32 only).
installdialup

This command installs the dialup service (Win32 only).
unistalldialup

This command removes the dialup service (Win32 only).

The following options may be used with the plat command.

3

-usage

plat -usage prints the help listing in the console

plat <command> -usage prints the command specific usage in the console
-?

+ plat -? prints the help listing in the console

+ plat <command> -? prints the command specific usage in the console
-help

« plat -help prints the help listing in the console

+ plat <command> -help prints the command specific usage in the console
-locale:<x>

This option sets the default locale (en_US).

-@<option>

This option passes the option to the Java VM.

-buildreg

This option forces a rebuild of the registry.
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